No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 12800 and 12800E V200R002C50

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Association Between a VRRP Group and a Direct Route

Example for Configuring Association Between a VRRP Group and a Direct Route

Networking Requirements

In Figure 3-28, the VRRP group consisting of NPE1 and NPE2 functions as the gateway and uplink traffic is sent to the master NPE1. OSPF runs between NPE1, NPE2, and NPE3 to ensure connectivity. The path that downlink traffic passes depends on OSPF route selection. On NPE3, there are two equal-cost OSPF routes to network segment 10.1.1.0/24, so downlink traffic may be load balanced. In this case, uplink and downlink traffic are transmitted along different paths, so data is blocked by the firewall. It is required that uplink and downlink traffic be transmitted along the same path so that data can pass the firewall.

Figure 3-28 Networking diagram for configuring association between a VRRP group and a direct route

Configuration Roadmap

The configuration roadmap is as follows:

  • Configure a VRRP group on NPE1 and NPE2 to improve link reliability.

  • Configure OSPF on NPE1, NPE2, and NPE3 to ensure connectivity at the network layer.

  • Configure association between a direct route and a VRRP group on NPE1 and NPE2.

  • Configure OSPF to import direct routes and retain the cost of the imported route on NPE1 and NPE2 so that VRRP can be associated with direct routes.

Procedure

  1. Configure devices to ensure network connectivity.

    # Assign an IP address to each interface. NPE1 is used as an example. The configurations of NPE2 and NPE3 are similar to the configuration of NPE1.

    <HUAWEI> system-view
    [~HUAWEI] sysname NPE1
    [*HUAWEI] commit
    [~NPE1] vlan batch 100 300
    [*NPE1] interface 10ge 1/0/1
    [*NPE1-10GE1/0/1] port link-type trunk
    [*NPE1-10GE1/0/1] port trunk allow-pass vlan 300
    [*NPE1-10GE1/0/1] quit
    [*NPE1] interface 10ge 1/0/2
    [*NPE1-10GE1/0/2] port link-type trunk
    [*NPE1-10GE1/0/2] port trunk allow-pass vlan 100
    [*NPE1-10GE1/0/2] port trunk pvid vlan 100
    [*NPE1-10GE1/0/2] undo port trunk allow-pass vlan 1
    [*NPE1-10GE1/0/2] quit
    [*NPE1] interface vlanif 100
    [*NPE1-Vlanif100] ip address 10.1.1.1 24
    [*NPE1-Vlanif100] quit
    [*NPE1] interface vlanif 300
    [*NPE1-Vlanif300] ip address 10.1.3.1 24
    [*NPE1-Vlanif300] quit
    [*NPE1] commit

  2. Configure VRRP groups.

    # Create VLAN 100 on the UPE, and add 10GE1/0/1 and 10GE1/0/2 to VLAN 10 so that VRRP Advertisement packets from NPE1 and NPE2 can be transparently transmitted.

    <UPE> system-view
    [~UPE] vlan 100
    [~UPE-vlan100] port 10ge 1/0/1
    [*UPE-vlan100] port 10ge 1/0/2
    [*UPE-vlan100] commit
    [~UPE-vlan100] quit

    # Create VRRP group 1 on NPE1 and set the priority of NPE1 in the group to 120 so that NPE1 functions as the master.

    <NPE1> system-view
    [~NPE1] interface vlanif 100
    [~NPE1-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111
    [*NPE1-Vlanif100] vrrp vrid 1 priority 120
    [*NPE1-Vlanif100] vrrp vrid 1 preempt timer delay 60
    [*NPE1-Vlanif100] commit
    [~NPE1-Vlanif100] quit

    # Create VRRP group 1 on NPE2 and set the priority of NPE2 to 100 so that NPE2 functions as the backup.

    <NPE2> system-view
    [~NPE2] interface vlanif 100
    [~NPE2-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111
    [*NPE2-Vlanif100] commit
    [~NPE2-Vlanif100] quit

  3. Configure OSPF.

    # Configure OSPF on NPE1.

    [~NPE1] ospf 1
    [*NPE1-ospf-1] area 0
    [*NPE1-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [*NPE1-ospf-1-area-0.0.0.0] commit
    [~NPE1-ospf-1-area-0.0.0.0] quit
    [~NPE1-ospf-1] quit

    # Configure OSPF on NPE2.

    [~NPE2] ospf 1
    [*NPE2-ospf-1] area 0
    [*NPE2-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [*NPE2-ospf-1-area-0.0.0.0] commit
    [~NPE2-ospf-1-area-0.0.0.0] quit
    [~NPE2-ospf-1] quit

    # Configure OSPF on NPE3.

    <NPE3> system-view
    [~NPE3] ospf 1
    [*NPE3-ospf-1] area 0
    [*NPE3-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [*NPE3-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [*NPE3-ospf-1-area-0.0.0.0] commit
    [~NPE3-ospf-1-area-0.0.0.0] quit
    [~NPE3-ospf-1] quit

  4. Configure association between a direct route and a VRRP group.

    # Configure NPE1.

    [~NPE1] interface vlanif 100
    [~NPE1-Vlanif100] direct-route track vrrp vrid 1 degrade-cost 300
    [*NPE1-Vlanif100] commit
    [~NPE1-Vlanif100] quit

    # Configure NPE2.

    [~NPE2] interface vlanif 100
    [~NPE2-Vlanif100] direct-route track vrrp vrid 1 degrade-cost 300
    [*NPE2-Vlanif100] commit
    [~NPE2-Vlanif100] quit

  5. Configure OSPF to import direct routes.

    # Configure NPE1.

    [~NPE1] ospf 1
    [~NPE1-ospf-1] import-route direct
    [*NPE1-ospf-1] default cost inherit-metric
    [*NPE1-ospf-1] commit
    [~NPE1-ospf-1] quit

    # Configure NPE2.

    [~NPE2] ospf 1
    [~NPE2-ospf-1] import-route direct
    [*NPE2-ospf-1] default cost inherit-metric
    [*NPE2-ospf-1] commit
    [~NPE2-ospf-1] quit

  6. Verify the configuration.

    # Run the display ip routing-table command on NPE2 to view the IP routing table. You can see that the cost of the direct route on the network segment where the VRRP-enabled interface is located is 300.

    [~NPE2] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Table : _public_
             Destinations : 12       Routes : 12        
    
    Destination/Mask    Proto  Pre  Cost        Flags NextHop         Interface
    
           10.1.1.0/24  Direct 0    300           D  10.1.1.2        Vlanif100
           10.1.1.2/32  Direct 0    0             D  127.0.0.1       Vlanif100
         10.1.1.111/32  O_ASE  150  0             D  10.1.2.2        Vlanif200
         10.1.1.255/32  Direct 0    0             D  127.0.0.1       Vlanif100
           10.1.2.0/24  Direct 0    0             D  10.1.2.1        Vlanif200
           10.1.2.1/32  Direct 0    0             D  127.0.0.1       Vlanif200
         10.1.2.255/32  Direct 0    0             D  127.0.0.1       Vlanif200
           10.1.3.0/24  OSPF   10   2             D  10.1.2.2        Vlanif200
          127.0.0.0/8   Direct 0    0             D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct 0    0             D  127.0.0.1       InLoopBack0

    # Run the display ip routing-table 10.1.1.0 command on NPE3 to view the route to the user network segment. You can see that NPE3 sends downlink traffic through the route with the next hop address of 10.1.3.1.

    [~NPE3] display ip routing-table 10.1.1.0
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Table : _public_
    Summary Count : 1
    
    Destination/Mask    Proto  Pre  Cost        Flags NextHop         Interface
    
           10.1.1.0/24  O_ASE  150  0             D  10.1.3.1        Vlanif300

Configuration Files

  • UPE configuration file

    #
    sysname UPE
    #
    vlan batch 100
    #               
    interface 10GE1/0/1
     port default vlan 100
    #               
    interface 10GE1/0/2
     port default vlan 100
    #
    return
  • NPE1 configuration file

    #
    sysname NPE1
    #
    vlan batch 100 300
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt timer delay 60
     direct-route track vrrp vrid 1 degrade-cost 300
    #
    interface Vlanif300
     ip address 10.1.3.1 255.255.255.0
    #
    interface 10GE1/0/1
     port default vlan 300
    #
    interface 10GE1/0/2
     port default vlan 100
    #               
    ospf 1          
     default cost inherit-metric
     import-route direct
     area 0.0.0.0   
      network 10.1.3.0 0.0.0.255
    #
    return
  • NPE2 configuration file

    #
    sysname NPE2
    #
    vlan batch 100 200
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
     direct-route track vrrp vrid 1 degrade-cost 300
    #
    interface Vlanif200
     ip address 10.1.2.1 255.255.255.0
    #
    interface 10GE1/0/1
     port default vlan 200
    #
    interface 10GE1/0/2
     port default vlan 100
    #               
    ospf 1          
     default cost inherit-metric
     import-route direct
     area 0.0.0.0   
      network 10.1.2.0 0.0.0.255
    #
    return
  • NPE3 configuration file

    #
    sysname NPE3
    #
    vlan batch 200 300
    #
    interface Vlanif200
     ip address 10.1.2.2 255.255.255.0
    # 
    interface Vlanif300
     ip address 10.1.3.2 255.255.255.0
    #
    interface 10GE1/0/1
     port default vlan 200
    #
    interface 10GE1/0/2
     port default vlan 300
    #              
    ospf 1          
     area 0.0.0.0   
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-03-21

Document ID: EDOC1000166606

Views: 90672

Downloads: 84

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next