No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 12800 and 12800E V200R002C50

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Single-Hop BFD on a VLANIF Interface

Example for Configuring Single-Hop BFD on a VLANIF Interface

Networking Requirements

In Figure 2-23, SwitchA connects to SwitchB through the VLANIF interface and Layer 2 transmission devices, SwitchC and SwitchD, are deployed between them. Faults on the link between SwitchA and SwitchB need to be quickly detected.

Figure 2-23 Networking diagram for configuring single-hop BFD on a VLANIF interface

Configuration Roadmap

The configuration roadmap is as follows:

Configure BFD sessions on SwitchA and SwitchB.

Procedure

  1. Configure devices to ensure network connectivity.

    # Assign an IP address to each interface. SwitchA is used as an example. The configuration of SwitchB is similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.5 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] commit

  2. Configure single-hop BFD.

    # Enable BFD and create a BFD session on SwitchA.

    [~SwitchA] bfd
    [*SwitchA-bfd] quit
    [*SwitchA] bfd atob bind peer-ip 10.1.1.6 interface vlanif 100
    [*SwitchA-bfd-session-atob] discriminator local 1
    [*SwitchA-bfd-session-atob] discriminator remote 2
    [*SwitchA-bfd-session-atob] commit
    [~SwitchA-bfd-session-atob] quit
    

    # Enable BFD and create a BFD session on SwitchB.

    [~SwitchB] bfd
    [*SwitchB-bfd] quit
    [*SwitchB] bfd btoa bind peer-ip 10.1.1.5 interface vlanif 100
    [*SwitchB-bfd-session-btoa] discriminator local 2
    [*SwitchB-bfd-session-btoa] discriminator remote 1
    [*SwitchB-bfd-session-btoa] commit
    [~SwitchB-bfd-session-btoa] quit
    

  3. Verify the configuration.

    # Run the display bfd session all verbose command on SwitchA and SwitchB. The output on SwitchA is used as an example and shows that a single-hop BFD session is set up and is in Up state.

    [~SwitchA] display bfd session all verbose
    Total UP/DOWN Session Number : 1/0
    --------------------------------------------------------------------------------
      Name : atob                  (Single Hops)   State : Up
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Interface(Vlanif100)  
      Bind Session Type      : Static 
      Bind Peer IP Address   : 10.1.1.6         
      Bind Interface         : Vlanif100
      FSM Board ID           : 1                ToS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000       
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000       
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : No Application Bind                                  
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    

    # Run the shutdown command on the 10GE1/0/1 interface of SwitchA to simulate a link fault.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] shutdown
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit

    # Run the display bfd session all verbose command on SwitchA and SwitchB. The output on SwitchA is used as an example and shows that a single-hop BFD session is set up and is in Down state.

    [~SwitchA] display bfd session all verbose
    Total UP/DOWN Session Number : 0/1
    --------------------------------------------------------------------------------
      Name : atob                  (Single Hops)   State : Down
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Interface(Vlanif100)  
      Bind Session Type      : Static 
      Bind Peer IP Address   : 10.1.1.6         
      Bind Interface         : Vlanif100
      FSM Board ID           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 10093            Actual Rx Interval (ms): 10093      
      WTR Interval (ms)      : -                Detect Interval (ms)   : -          
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : No Application Bind                                  
      Session Not Up Reason  : In negotiation                                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ip address 10.1.1.5 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    bfd atob bind peer-ip 10.1.1.6 interface Vlanif100
     discriminator local 1
     discriminator remote 2
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ip address 10.1.1.6 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    bfd btoa bind peer-ip 10.1.1.5 interface Vlanif100
     discriminator local 2
     discriminator remote 1
    #
    return
Translation
Download
Updated: 2019-03-21

Document ID: EDOC1000166606

Views: 104097

Downloads: 85

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next