No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 12800 and 12800E V200R002C50

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a VRRP6 Group in Active/Standby Mode

Example for Configuring a VRRP6 Group in Active/Standby Mode

Networking Requirements

In Figure 3-29, HostA is dual-homed to SwitchA and SwitchB through the switch on the IPv6 network. The requirements are as follows:
  • The host uses SwitchA as the default gateway to connect to the Internet. When SwitchA becomes faulty, SwitchB functions as the gateway. This implements gateway backup.

  • After SwitchA recovers, it resumes control within 20s.

Figure 3-29 Networking diagram for configuring a VRRP6 group in active/standby mode

Device

Interface

VLANIF Interface

IP Address

SwitchA

10GE1/0/1

VLANIF 300

2002::1/64

10GE1/0/2

VLANIF 100

FC00::1/64

SwitchB

10GE1/0/1

VLANIF 200

2001::1/64

10GE1/0/2

VLANIF 100

FC00::2/64

SwitchC

10GE1/0/1

VLANIF 300

2002::2/64

10GE1/0/2

VLANIF 200

2001::2/64

10GE1/0/3

VLANIF 400

2003::2/64

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface and configure a routing protocol to ensure network connectivity.
  2. Configure a VRRP6 group on SwitchA and SwitchB, set the preemption delay to 20s and a higher priority for SwitchA so that SwitchA functions as the master to forward traffic, and set a lower priority for SwitchB so that SwitchB functions as the backup.

Procedure

  1. Configure devices to ensure network connectivity.

    # Assign an IP address to each interface. SwitchA is used as an example. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100 300
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 300
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 300
    [*SwitchA-10GE1/0/1] undo port trunk allow-pass vlan 1
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/2] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/2] undo port trunk allow-pass vlan 1
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ipv6 enable
    [*SwitchA-Vlanif100] ipv6 address FC00::1 64
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit
    [~SwitchA] interface vlanif 300
    [*SwitchA-Vlanif300] ipv6 enable
    [*SwitchA-Vlanif300] ipv6 address 2002::1 64
    [*SwitchA-Vlanif300] commit
    [~SwitchA-Vlanif300] quit

    # Configure OSPFv3 between SwitchA, SwitchB, and SwitchC. SwitchA is used as an example. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    [~SwitchA] ospfv3
    [*SwitchA-ospfv3-1] router-id 1.1.1.1
    [*SwitchA-ospfv3-1] commit
    [~SwitchA-ospfv3-1] quit
    [~SwitchA] interface vlanif 100
    [~SwitchA-Vlanif100] ospfv3 1 area 0
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit
    [~SwitchA] interface vlanif 300
    [~SwitchA-Vlanif300] ospfv3 1 area 0
    [*SwitchA-Vlanif300] commit
    [~SwitchA-Vlanif300] quit

  2. Configure VRRP6 groups.

    # Configure VRRP6 group 1 on SwitchA, and set the priority of SwitchA to 120 and the preemption delay to 20s.

    [~SwitchA] interface vlanif 100
    [~SwitchA-Vlanif100] vrrp6 vrid 1 virtual-ip FE80::1 link-local
    [*SwitchA-Vlanif100] vrrp6 vrid 1 virtual-ip FC00::100
    [*SwitchA-Vlanif100] vrrp6 vrid 1 priority 120
    [*SwitchA-Vlanif100] vrrp6 vrid 1 preempt timer delay 20
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit
    

    # Configure VRRP6 group 1 on SwitchB, and set the default priority of 100 for SwitchB.

    [~SwitchB] interface vlanif 100
    [~SwitchB-Vlanif100] vrrp6 vrid 1 virtual-ip FE80::1 link-local
    [*SwitchB-Vlanif100] vrrp6 vrid 1 virtual-ip FC00::100
    [*SwitchB-Vlanif100] commit
    [~SwitchB-Vlanif100] quit

  3. Verify the configuration.

    # Run the display vrrp6 verbose command on SwitchA and SwitchB. You can see that SwitchA is in Master state and SwitchB is in Backup state.

    [~SwitchA] display vrrp6 verbose
    Vlanif100 | Virtual Router 1
    State           : Master
    Virtual IP      : FE80::1
                      FC00::100
    Master IP       : FE80::26D:88FF:FE35:5804
    PriorityRun     : 120
    PriorityConfig  : 120
    MasterPriority  : 120
    Preempt         : YES   Delay Time : 20s   Remain : --
    TimerRun        : 100cs
    TimerConfig     : 100cs
    Virtual MAC     : 0000-5e00-0201 
    Check Hop Limit : YES
    Config Type     : Normal
    Create Time      : 2013-01-12 20:15:46
    Last Change Time : 2013-01-12 20:15:46
    
    [~SwitchB] display vrrp6 verbose
    Vlanif100 | Virtual Router 1
    State           : Backup
    Virtual IP      : FE80::1
                      FC00::100
    Master IP       : FE80::26D:88FF:FE35:5804
    PriorityRun     : 100
    PriorityConfig  : 100
    MasterPriority  : 120
    Preempt         : YES   Delay Time : 0s   Remain : --
    TimerRun        : 100cs
    TimerConfig     : 100cs
    Virtual MAC     : 0000-5e00-0201
    Check Hop Limit : YES
    Config Type     : Normal
    Create Time      : 2013-01-12 20:15:46
    Last Change Time : 2013-01-12 20:15:46
    

    # Run the shutdown command on 10GE1/0/2 of SwitchA to simulate a link fault.

    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] shutdown
    [*SwitchA-10GE1/0/2] commit
    [~SwitchA-10GE1/0/2] quit
    

    # Run the display vrrp6 command on SwitchA and SwitchB. You can see that SwitchA is in Initialize state and SwitchB is in Master state.

    [~SwitchA] display vrrp6 verbose
    Vlanif100 | Virtual Router 1
    State           : Initialize
    Virtual IP      : FE80::1
                      FC00::100
    Master IP       : ::
    PriorityRun     : 120
    PriorityConfig  : 120
    MasterPriority  : 0
    Preempt         : YES   Delay Time : 20s   Remain : --
    TimerRun        : 100cs
    TimerConfig     : 100cs
    Virtual MAC     : 0000-5e00-0201 
    Check Hop Limit : YES
    Config Type     : Normal
    Create Time      : 2013-01-12 20:15:46
    Last Change Time : 2013-01-12 20:15:46
    
    [~SwitchB] display vrrp6 verbose
    Vlanif100 | Virtual Router 1
    State           : Master
    Virtual IP      : FE80::1
                      FC00::100
    Master IP       : FE80::26D:88FF:FE34:5B04
    PriorityRun     : 100
    PriorityConfig  : 100
    MasterPriority  : 100
    Preempt         : YES   Delay Time : 0s   Remain : --
    TimerRun        : 100cs
    TimerConfig     : 100cs
    Virtual MAC     : 0000-5e00-0201 
    Check Hop Limit : YES
    Config Type     : Normal
    Create Time      : 2013-01-12 20:15:46
    Last Change Time : 2013-01-12 20:15:46
    

    # Run the undo shutdown command on 10GE1/0/2 of SwitchA. After 20s, run the display vrrp6 command on SwitchA and SwitchB. You can see that SwitchA is in Master state and SwitchB is in Backup state.

    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] undo shutdown
    [*SwitchA-10GE1/0/2] commit
    [~SwitchA-10GE1/0/2] quit
    
    [~SwitchA] display vrrp6 verbose
    Vlanif100 | Virtual Router 1
    State           : Master
    Virtual IP      : FE80::1
                      FC00::100
    Master IP       : FE80::26D:88FF:FE35:5804
    PriorityRun     : 120
    PriorityConfig  : 120
    MasterPriority  : 120
    Preempt         : YES   Delay Time : 20s   Remain : --
    TimerRun        : 100cs
    TimerConfig     : 100cs
    Virtual MAC     : 0000-5e00-0201 
    Check Hop Limit : YES
    Config Type     : Normal
    Create Time      : 2013-01-12 20:15:46
    Last Change Time : 2013-01-12 20:15:46
    
    [~SwitchB] display vrrp6 verbose
    Vlanif100 | Virtual Router 1
    State           : Backup
    Virtual IP      : FE80::1
                      FC00::100
    Master IP       : FE80::26D:88FF:FE35:5804
    PriorityRun     : 100
    PriorityConfig  : 100
    MasterPriority  : 120
    Preempt         : YES   Delay Time : 0s   Remain : --
    TimerRun        : 100cs
    TimerConfig     : 100cs
    Virtual MAC     : 0000-5e00-0201
    Check Hop Limit : YES
    Config Type     : Normal
    Create Time      : 2013-01-12 20:15:46
    Last Change Time : 2013-01-12 20:15:46
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100 300
    #
    ospfv3 1
     router-id 1.1.1.1
     area 0.0.0.0
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00::1/64
     vrrp6 vrid 1 virtual-ip FE80::1 link-local
     vrrp6 vrid 1 virtual-ip FC00::100
     vrrp6 vrid 1 priority 120
     vrrp6 vrid 1 preempt timer delay 20
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif300
     ipv6 enable
     ipv6 address 2002::1/64
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 300
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    ospfv3 1
     router-id 2.2.2.2
     area 0.0.0.0
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00::2/64
     vrrp6 vrid 1 virtual-ip FE80::1 link-local
     vrrp6 vrid 1 virtual-ip FC00::100
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address 2001::1/64
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 200
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 200 300 400
    #
    ospfv3 1
     router-id 3.3.3.3
     area 0.0.0.0
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address 2001::2/64
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif300
     ipv6 enable
     ipv6 address 2002::2/64
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif400
     ipv6 enable
     ipv6 address 2003::2/64
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 300
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 200
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk pvid vlan 400
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 400
    #
    return
Translation
Download
Updated: 2019-03-21

Document ID: EDOC1000166606

Views: 120420

Downloads: 90

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next