No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 12800 and 12800E V200R002C50

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Associating the BFD Session with the Interface Status

Example for Associating the BFD Session with the Interface Status

Networking Requirements

In Figure 2-27, SwitchA is directly connected to SwitchB and Layer 2 transmission devices, SwitchC and SwitchD, are deployed between them. It is required that SwitchA and SwitchB quickly detect link faults of the Layer 2 transmission devices to trigger fast route convergence.

Figure 2-27 Networking diagram for associating the BFD session with the interface status

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure BFD sessions on SwitchA and SwitchB to detect faults on the link between SwitchA and SwitchB.

  2. Configure association between the BFD session status and interface status on SwitchA and SwitchB after the BFD session goes Up.

Procedure

  1. Configure interfaces that connect SwitchA and SwitchB to ensure transmission of packets at Layer 2.

    # Configure SwitchA. The configuration of SwitchB is similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 10
    [*SwitchA-vlan10] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] undo port trunk allow-pass vlan 1
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 10
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit
    

  2. Configure single-hop BFD on SwitchA.

    # Enable BFD on SwitchA.

    [~SwitchA] bfd
    [*SwitchA-bfd] quit

    # Create a BFD session on SwitchA.

    [*SwitchA] bfd atob bind peer-ip default-ip interface 10ge 1/0/1
    [*SwitchA-bfd-session-atob] discriminator local 1
    [*SwitchA-bfd-session-atob] discriminator remote 2
    [*SwitchA-bfd-session-atob] commit
    [~SwitchA-bfd-session-atob] quit
    

  3. Configure single-hop BFD on SwitchB.

    # Enable BFD on SwitchB.

    [~SwitchB] bfd
    [*SwitchB-bfd] quit

    # Create a BFD session on SwitchB.

    [*SwitchB] bfd btoa bind peer-ip default-ip interface 10ge 1/0/1
    [*SwitchB-bfd-session-btoa] discriminator local 2
    [*SwitchB-bfd-session-btoa] discriminator remote 1
    [*SwitchB-bfd-session-btoa] commit
    [~SwitchB-bfd-session-btoa] quit

  4. Configure association between the BFD session and interface status.

    # Configure association between the BFD session and the interface status on SwitchA.

    [~SwitchA] bfd atob
    [~SwitchA-bfd-session-atob] process-interface-status
    [*SwitchA-bfd-session-atob] commit
    [~SwitchA-bfd-session-atob] quit

    # Configure association between the BFD session status and the interface status on SwitchB.

    [~SwitchB] bfd btoa
    [~SwitchB-bfd-session-btoa] process-interface-status
    [*SwitchB-bfd-session-btoa] commit
    [~SwitchB-bfd-session-btoa] quit

  5. Verify the configuration.

    Run the display bfd session all verbose command on SwitchA and SwitchB. The output on SwitchA is used as an example and shows that the BFD session is in Up state and the Bind Application field is IFNET.

    [~SwitchA] display bfd session all verbose
    Total UP/DOWN Session Number : 1/0
    --------------------------------------------------------------------------------
      Name : atob                  (Single Hops)   State : Up                
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2          
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(10GE1/0/1)                                 
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 224.0.0.184                                          
      Bind Interface         : 10GE1/0/1                                            
      FSM Board ID           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000       
      WTR Interval (ms)      : -                Detect Interval (ms)   : 3000       
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : IFNET                                         
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    

    # Run the shutdown command on 10GE1/0/1 of SwitchB to make the BFD session go Down.

    [~SwitchB] interface 10ge 1/0/1
    [~SwitchB-10GE1/0/1] shutdown
    [*SwitchB-10GE1/0/1] commit
    [~SwitchB-10GE1/0/1] quit

    # Run the display bfd session all verbose and display interface 10ge 1/0/1 commands on SwitchA. You can see that the BFD session is in Down state, and the 10GE1/0/1 interface is in DOWN (BFD status down) state.

    [~SwitchA] display bfd session all verbose
    Total UP/DOWN Session Number : 0/1
    --------------------------------------------------------------------------------
      Name : atob                  (Single Hops)   State : Down             
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2          
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(10GE1/0/1)                                 
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 224.0.0.184                                          
      Bind Interface         : 10GE1/0/1                                            
      FSM Board ID           : 1                ToS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 4331             Actual Rx Interval (ms): 4331       
      WTR Interval (ms)      : -                Detect Interval (ms)   : -          
      Local Detect Multi     : 3                Active Multi           : 3          
      Destination Port       : 3784             TTL                    : 255        
      Process PST            : Disable          Config PST             : Disable    
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : IFNET                                  
      Session Not Up Reason  : In negotiation                                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
    
    [~SwitchA] display interface 10ge 1/0/1 current state : UP (ifindex: 11)                                      
    Line protocol current state : DOWN (BFD status down)
    ……

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    bfd
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 10
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
    #
    bfd atob bind peer-ip default-ip interface 10GE1/0/1
     discriminator local 1
     discriminator remote 2
     process-interface-status
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    bfd
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 10
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
    #
    bfd btoa bind peer-ip default-ip interface 10GE1/0/1
     discriminator local 2
     discriminator remote 1
     process-interface-status
    #
    return
Translation
Download
Updated: 2019-03-21

Document ID: EDOC1000166606

Views: 125300

Downloads: 90

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next