No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

CloudEngine 8800, 7800, 6800, and 5800 V200R002C50

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DNS, IP performance optimization, IPv6, DHCPv6, and IPv6 DNS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Inter-VLAN Proxy ARP

Example for Configuring Inter-VLAN Proxy ARP

Networking Requirements

As shown in Figure 2-21, VLAN2 and VLAN3 compose super-VLAN4. Requirements:
  • Servers in VLAN2 and VLAN3 cannot ping each other.
  • Servers in VLAN2 and VLAN3 can communicate after inter-VLAN proxy ARP is configured.
Figure 2-21  Networking diagram for configuring inter-VLAN proxy ARP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a super-VLAN and sub-VLANs.
  2. Add interfaces to the sub-VLANs.
  3. Create a VLANIF interface corresponding to the super-VLAN and configure an IP address for the VLANIF interface.
  4. Enable inter-VLAN proxy ARP.

Procedure

  1. Configure a super-VLAN and sub-VLANs.

    # Configure sub-VLAN2.
    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan 2
    [*Switch-vlan2] commit
    [~Switch-vlan2] quit
    # Add 10GE1/0/1 and 10GE1/0/2 to sub-VLAN2.
    [~Switch] interface 10ge 1/0/2
    [~Switch-10GE1/0/2] port default vlan 2
    [*Switch-10GE1/0/2] quit
    [*Switch] interface 10ge 1/0/1
    [*Switch-10GE1/0/1] port default vlan 2
    [*Switch-10GE1/0/1] quit
    [*Switch] commit
    # Create sub-VLAN3.
    [~Switch] vlan 3
    [*Switch-vlan3] commit
    [~Switch-vlan3] quit
    # Add 10GE1/0/3 and 10GE1/0/4 to sub-VLAN3.
    [~Switch] interface 10ge 1/0/3
    [*Switch-10GE1/0/3] port default vlan 3
    [*Switch-10GE1/0/3] quit
    [*Switch] interface 10ge 1/0/4
    [*Switch-10GE1/0/4] port default vlan 3
    [*Switch-10GE1/0/4] quit
    [*Switch] commit
    # Create super-VLAN4 and add sub-VLAN2 and sub-VLAN3 to super-VLAN4.
    [~Switch] vlan 4
    [*Switch-vlan4] aggregate-vlan
    [*Switch-vlan4] access-vlan 2
    [*Switch-vlan4] access-vlan 3
    [*Switch-vlan4] quit
    [*Switch] commit

  2. Create and configure VLANIF4.

    # Create VLANIF4.

    [~Switch] interface vlanif 4

    # Configure an IP address for VLANIF4.

    [*Switch-Vlanif4] ip address 10.10.10.1 24

  3. Enable inter-VLAN proxy ARP on VLANIF4.

    [*Switch-Vlanif4] arp proxy inter-vlan enable
    [*Switch-Vlanif4] quit
    [*Switch] commit
    [~Switch] quit

  4. Configure servers.

    # Configure IP address 10.10.10.2/24 for ServerA.

    # Configure IP address 10.10.10.3/24 for ServerB.

    # Configure IP address 10.10.10.4/24 for ServerC.

    # Configure IP address 10.10.10.5/24 for ServerD.

  5. Verify the configuration.

    # Run the display arp command to check all ARP entries.

    <Switch> display arp
    ARP Entry Types: D - Dynamic, S - Static, I - Interface                                                                             
    EXP: Expire-time
                                                                                                                                        
    IP ADDRESS      MAC ADDRESS    EXP(M) TYPE/VLAN INTERFACE       VPN-INSTANCE                                                        
    ------------------------------------------------------------------------------                                                      
    10.10.10.1      0018-2000-0083        I         Vlanif4                                                                             
    10.10.10.2      00e0-fc00-0002   19   D/2       10GE1/0/1                                                                           
    10.10.10.3      00e0-fc00-0003   19   D/2       10GE1/0/2                                                                           
    10.10.10.4      00e0-fc00-0004   19   D/3       10GE1/0/3                                                                           
    10.10.10.5      00e0-fc00-0005   19   D/3       10GE1/0/4                                                                           
    ------------------------------------------------------------------------------                                                      
    Total:5          Dynamic:4       Static:0    Interface:1  

    # Servers in VLAN2 and VLAN3 can ping each other.

Configuration File

Configuration file of the switch

#
sysname Switch
#
vlan batch 2 to 4 
#
vlan 4
 aggregate-vlan
 access-vlan 2 to 3
#
interface Vlanif4
 ip address 10.10.10.1 255.255.255.0
 arp proxy inter-vlan enable
#
interface 10GE1/0/1
 port default vlan 2
#
interface 10GE1/0/2
 port default vlan 2
#
interface 10GE1/0/3
 port default vlan 3
#
interface 10GE1/0/4
 port default vlan 3
#
return
Translation
Download
Updated: 2019-03-21

Document ID: EDOC1000166635

Views: 130202

Downloads: 282

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next