No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

CloudEngine 8800, 7800, 6800, and 5800 V200R002C50

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DNS, IP performance optimization, IPv6, DHCPv6, and IPv6 DNS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring UDP Helper

Example for Configuring UDP Helper

Networking Requirements

As shown in Figure 5-2, Switch connects to a local area network (LAN) through 10GE1/0/2, which needs to be added to VLAN20. The IP address to be assigned to VLANIF20 is 10.110.1.1/16. NetBIOS-NS is connected to 10GE1/0/1 on Switch. The IP address of the NetBIOS-NS server is 10.1.1.1/16 and 10GE1/0/1 needs to be added to VLAN10. The IP address to be assigned to VLANIF10 is 10.1.1.2/16. PC1 and PC2 on the LAN need to access each other using host names.

Figure 5-2  UDP helper network

Configuration Roadmap

  1. Because the PCs on the LAN need to access each other using host names, the host names must be resolved into IP addresses. However, the NetBIOS-NS and PCs are in different broadcast domains. The NetBIOS-NS Register packets cannot reach the NetBIOS-NS server. The Switch must be enabled with UDP helper to forward the UDP packets with destination port 137 (NetBIOS-NS port) to the NetBIOS-NS server.
  2. After UDP helper is enabled, specify the IP address of destination NetBIOS-NS server on VLANIF20.
NOTE:

After UDP helper is enabled on the Switch, the Switch relays the broadcast packets with UDP destination port 137 by default. The UDP port number, therefore, does not need to be configured in this example.

Procedure

  1. Add 10GE1/0/2 of Switch to VLAN20 and assign an IP address to VLANIF20.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan batch 20
    [*Switch] interface 10ge 1/0/2
    [*Switch-10GE1/0/2] port default vlan 20
    [*Switch-10GE1/0/2] quit
    [*Switch] interface vlanif 20
    [*Switch-Vlanif20] ip address 10.110.1.1 16
    [*Switch-Vlanif20] quit
    [*Switch] commit
    

  2. Add 10GE1/0/1 of Switch to VLAN10 and assign an IP address to VLANIF10.

    [~Switch] vlan batch 10
    [*Switch] interface 10ge 1/0/1
    [*Switch-10GE1/0/1] port default vlan 10
    [*Switch-10GE1/0/1] quit
    [*Switch] interface vlanif 10
    [*Switch-Vlanif10] ip address 10.1.1.2 16
    [*Switch-Vlanif10] quit
    [*Switch] commit
    

  3. Enable UDP helper.

    [~Switch] ip udp-helper enable
    [*Switch] commit

  4. Configure a destination server for packet relay on VLANIF20 of Switch.

    [~Switch] interface vlanif 20
    [*Switch-Vlanif20] ip udp-helper server 10.1.1.1
    [*Switch-Vlanif20] quit
    [*Switch] commit
    

  5. Verify the configuration.

    When the PCs access each other using host names, the Switch starts to collect statistics on UDP helper.

    [~Switch] display ip udp-helper server
    Vlan Interface          Server IP        Packet Received  Packet Dropped
    ------------------------------------------------------------------------
    Vlanif20                10.1.1.1                     201               0

Configuration Files

Configuration file of the Switch

#
sysname Switch
#
vlan batch 10 20
#
ip udp-helper enable
#
interface Vlanif10
 ip address 10.1.1.2 255.255.0.0
#     
interface Vlanif20
 ip address 10.110.1.1 255.255.0.0     
 ip udp-helper server 10.1.1.1 
#
interface 10GE1/0/1
 port default vlan 10
#
interface 10GE1/0/2
 port default vlan 20
#
return
Translation
Download
Updated: 2019-03-21

Document ID: EDOC1000166635

Views: 131640

Downloads: 285

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next