No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - QoS

CloudEngine 8800, 7800, 6800, and 5800 V200R002C50

This document describes the configurations of QoS functions, including MQC, priority mapping, traffic policing, traffic shaping, interface-based rate limiting, congestion avoidance, congestion management, packet filtering, redirection, traffic statistics, and ACL-based simplified traffic policy.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Congestion Monitoring and Analysis

Example for Configuring Congestion Monitoring and Analysis

Networking Requirements

Servers store information about voice, video, and data services, and a host obtains data from servers through the switch. When much data is sent from servers to the host, the sum of rates of inbound interfaces is larger than the rate of the outbound interface. In this case, congestion may occur on the outbound interface of the switch.

When packet loss occurs on the outbound interface of the switch due to queue congestion, the customer wants to learn the queue buffer usage and information about packets that cause congestion so that network traffic can be planned and adjusted subsequently.

Figure 7-1 Networking of congestion monitoring and analysis

Configuration Roadmap

The configuration roadmap is as follows:
  1. Enable congestion monitoring and configure upper and lower buffer thresholds to monitor the queue buffer usage.

  2. Enable congestion analysis so that the switch analyzes packets on an interface when congestion occurs on the interface.

Procedure

  1. Configure a VLAN for each interface so that devices can communicate with each other at the link layer.

    # On the Switch, configure 10GE1/1/1 and 10GE1/1/2 as access interfaces (the link type of an interface is access by default), configure 10GE1/1/3 as a trunk interface, and add 10GE1/1/1 to VLAN 100, 10GE1/1/2 to VLAN 200, and 10GE1/1/3 to VLAN 100 and VLAN 200.

    <HUAWEI> system-view
    [~HUAWEI] sysname Switch
    [*HUAWEI] commit
    [~Switch] vlan batch 100 200
    [*Switch] interface 10ge 1/1/1
    [*Switch-10GE1/1/1] port default vlan 100
    [*Switch-10GE1/1/1] quit
    [*Switch] interface 10ge 1/1/2
    [*Switch-10GE1/1/2] port default vlan 200
    [*Switch-10GE1/1/2] quit
    [*Switch] interface 10ge 1/1/3
    [*Switch-10GE1/1/3] port link-type trunk
    [*Switch-10GE1/1/3] port trunk allow-pass vlan 100 200
    [*Switch-10GE1/1/3] quit
    [*Switch] commit
    

  2. Enable congestion monitoring. Default upper and lower buffer thresholds are used here.

    [~Switch] interface 10GE 1/1/3
    [*Switch-10GE1/1/3] qos buffer-monitoring enable
    [*Switch-10GE1/1/3] quit
    [*Switch] commit
    

  3. Enable congestion analysis.

    [~Switch] interface 10ge 1/1/3
    [*Switch-10GE1/1/3] qos buffer-monitoring parse enable
    [*Switch-10GE1/1/3] quit
    [*Switch] commit
    

  4. Verify the configuration.

    # Check real-time congestion monitoring information about queues on 10GE1/1/3.

    [Switch] display qos buffer-monitoring result interface 10ge 1/1/3
    Queue Time                        BufferUsage(Bytes)     Percent(%) 
    -------------------------------------------------------------------- 
        0 2015-11-04 09:46:27.095                      0              0 
        1 2015-11-04 09:46:27.101                      0              0 
        2 2015-11-04 09:46:27.107                      0              0 
        3 2015-11-04 09:46:27.113                1598064            100 
        4 2015-11-04 09:46:27.118                      0              0 
        5 2015-11-04 09:46:27.124                      0              0 
        6 2015-11-04 09:46:27.130                      0              0 
        7 2015-11-04 09:46:27.136                      0              0 
    -------------------------------------------------------------------- 

    # Check the congestion analysis result of queues on 10GE1/1/3.

    [Switch] display qos buffer-monitoring parse result interface 10ge 1/1/3
    Time: 2015-11-04 09:45:55 
    ------------------------------------------------------------------------------- 
    Num Eth-Type  Dst-MAC          Src-MAC         VLAN  8021P   In-VLAN   In-8021P 
        Protocal  Dst-IPAddr       Src-IPAddr         Dst-Port  Src-Port       DSCP 
    ------------------------------------------------------------------------------- 
      0 0x0800    0000-0000-0001   0010-9400-0002    77      3       --          -- 
        --        --               --                       --       --          -- 
    ------------------------------------------------------------------------------- 

Configuration Files

Configuration file of the Switch

#
sysname Switch
#
vlan batch 100 200
#
interface 10GE1/0/1
 port default vlan 100
#
interface 10GE1/0/2
 port default vlan 200
#
interface 10GE1/0/3
 port link-type trunk
 port trunk allow-pass vlan 100 200
 qos queue 0 buffer-monitoring enable                                          
 qos queue 1 buffer-monitoring enable                                          
 qos queue 2 buffer-monitoring enable                                          
 qos queue 3 buffer-monitoring enable                                          
 qos queue 4 buffer-monitoring enable                                          
 qos queue 5 buffer-monitoring enable                                          
 qos queue 6 buffer-monitoring enable                                          
 qos queue 7 buffer-monitoring enable                                          
 qos buffer-monitoring parse enable                                            
#
return
Translation
Download
Updated: 2019-03-21

Document ID: EDOC1000166640

Views: 47351

Downloads: 219

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next