No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Unicast Routing

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IS-IS to Interact with BGP

Example for Configuring IS-IS to Interact with BGP

Networking Requirements

As shown in Figure 7-37, RouterA and RouterB belong to the same AS, and the IS-IS neighbor relationship is established between RouterA and RouterB. An EBGP connection is established between RouterB and RouterC. RouterA, RouterB, and RouterC need to communicate with each other. Besides, the metric of routes needs to be changed when AS 65009 sends the routes to AS 65008.

Figure 7-37 Networking diagram of configuring IS-IS to interact with BGP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces, and enable IS-IS and BGP to ensure that there are reachable routes inside each AS.

  2. Configure IS-IS and BGP to import routes from each other on RouterB to ensure that there are routes on each network segment. Configure a route-policy to change the metric of imported routes when IS-IS imports BGP routes.

Procedure

  1. Configure IP addresses for interfaces on each router.

    # Configure RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.1.1.1 24
    [RouterA-GigabitEthernet1/0/0] quit

    The configurations of RouterB and RouterC are similar to the configuration of RouterA, and are not mentioned here.

  2. Configure IS-IS.

    # Configure RouterA.

    [RouterA] isis 1
    [RouterA-isis-1] network-entity 10.0000.0000.0001.00
    [RouterA-isis-1] quit
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] isis enable 1
    [RouterA-GigabitEthernet1/0/0] quit

    # Configure RouterB.

    [RouterB] isis 1
    [RouterB-isis-1] network-entity 10.0000.0000.0002.00
    [RouterB-isis-1] quit
    [RouterB] interface gigabitethernet 1/0/0
    [RouterB-GigabitEthernet1/0/0] isis enable 1
    [RouterB-GigabitEthernet1/0/0] quit

  3. Configure BGP.

    # Configure RouterB.

    [RouterB] bgp 65008
    [RouterB-bgp] router-id 1.1.1.1
    [RouterB-bgp] peer 10.2.1.2 as-number 65009
    [RouterB-bgp] ipv4-family unicast
    [RouterB-bgp-af-ipv4] network 10.2.1.0 255.255.255.0

    # Configure RouterC.

    [RouterC] bgp 65009
    [RouterC-bgp] router-id 2.2.2.2
    [RouterC-bgp] peer 10.2.1.1 as-number 65008
    [RouterC-bgp] ipv4-family unicast
    [RouterC-bgp-af-ipv4] network 10.2.1.0 255.255.255.0

  4. Configure IS-IS to import BGP routes.

    # Configure a static route on RouterC.

    [RouterC] ip route-static 200.1.1.1 32 NULL 0

    # On RouterC, configure BGP to import the static route.

    [RouterC] bgp 65009
    [RouterC-bgp] import-route static

    # On RouterB, configure IS-IS to import the BGP route.

    [RouterB] isis 1
    [RouterB-isis-1] import-route bgp
    [RouterB-isis-1] quit

    # View the routing table of RouterA, and you can see that IS-IS successfully imports BGP route 200.1.1.1/32.

    [RouterA] display ip routing-table
    Route Flags: R - relay,
    D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
            Destinations : 6        Routes : 6
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
           10.1.1.0/24  Direct  0    0           D   10.1.1.1        GigabitEthernet1/0/0
           10.1.1.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
           10.1.1.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet1/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
          200.1.1.1/32  ISIS-L2 15   74          D   10.1.1.2        GigabitEthernet1/0/0

    # On RouterB, configure the AS_Path filter, and apply the filter in route-policy RTC.

    [RouterB] ip as-path-filter 1 permit 65009
    [RouterB] route-policy RTC permit node 0
    [RouterB-route-policy] if-match as-path-filter 1
    [RouterB-route-policy] apply cost 20
    [RouterB-route-policy] quit

    # On RouterB, configure IS-IS to import the BGP route.

    [RouterB] isis 1
    [RouterB-isis-1] import-route bgp route-policy RTC
    [RouterB-isis-1] quit

    # View the routing table of RouterA, and you can see that the AS_Path filter is successfully applied and the cost of imported route 200.1.1.1/32 changes from 74 to 94.

    [RouterA] display ip routing-table
    Route Flags: R - relay,
    D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
            Destinations : 6        Routes : 6
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
           10.1.1.0/24  Direct  0    0           D   10.1.1.1        GigabitEthernet1/0/0
           10.1.1.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet1/0/0
           10.1.1.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet1/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
          200.1.1.1/32  ISIS-L2 15   94          D   10.1.1.2        GigabitEthernet1/0/0

  5. Configure BGP to import IS-IS routes.

    [RouterB] bgp 65008
    [RouterB-bgp] import-route isis 1
    [RouterB-bgp] quit

    # View the routing table of RouterC, and you can see that BGP successfully imports IS-IS route 10.1.1.0/24.

    [RouterC] display ip routing-table
    Route Flags: R - relay,
    D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 7        Routes : 7
    
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
           10.1.1.0/24  EBGP   255  0           D  10.2.1.1        GigabitEthernet1/0/0
           10.2.1.0/24  Direct 0    0           D  10.2.1.2        GigabitEthernet1/0/0
           10.2.1.2/32  Direct 0    0           D  127.0.0.1       InLoopBack0
           10.2.1.2/32  Direct 0    0           D  127.0.0.1       GigabitEthernet1/0/0
          127.0.0.0/8   Direct 0    0           D  127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0           D  127.0.0.1       InLoopBack0
          200.1.1.1/32  Static 60   0           D  0.0.0.0         NULL0

Configuration Files

  • Configuration file of RouterA

    #
     sysname RouterA
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
    #
    return
  • Configuration file of RouterB

    #
     sysname RouterB
    #
    isis 1
     network-entity 10.0000.0000.0002.00
     import-route bgp route-policy RTC
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     ip address 10.2.1.1 255.255.255.0
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    bgp 65008
     router-id 1.1.1.1
     peer 10.2.1.2 as-number 65009
     #
     ipv4-family unicast
      undo synchronization
      network 10.2.1.0 255.255.255.0
      import-route isis 1
      peer 10.2.1.2 enable
    #
    route-policy RTC permit node 0
     if-match as-path-filter 1
     apply cost 20
    #
    ip as-path-filter 1 permit 65009
    #
    return
  • Configuration file of RouterC

    #
     sysname RouterC
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.1.2 255.255.255.0
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    bgp 65009
     router-id 2.2.2.2
     peer 10.2.1.1 as-number 65008
     #
     ipv4-family unicast
      undo synchronization
      network 10.2.1.0 255.255.255.0
      import-route static
      peer 10.2.1.1 enable
    #
    ip route-static 200.1.1.1 255.255.255.255 NULL0
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174069

Views: 144013

Downloads: 280

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next