No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Unicast Routing

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring OSPF Stub Areas

Example for Configuring OSPF Stub Areas

Networking Requirements

As shown in Figure 5-38, all routers run OSPF, and the entire AS is divided into three areas. Router A and Router B serve as ABRs to forward routes between areas. Router D serves as an ASBR to import external routes (static routes).

It is required to configure Area 1 as a stub area to reduce the LSAs advertised to this area without affecting the route reachability.

Figure 5-38 Configuring OSPF stub areas

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable OSPF on each router, and configure basic OSPF functions.

  2. Configure static routes on Router D, and import them into OSPF.

  3. Configure Area 1 as a stub area, and check the OSPF routing information on Router C.

  4. Stop Router A from advertising Type 3 LSAs to the stub area, and check the OSPF routing information on Router C.

Procedure

  1. Configure an IP address for each interface.

    # Configure Router A.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 192.168.0.1 24
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 192.168.1.1 24
    [RouterA-GigabitEthernet2/0/0] quit

    The configurations of Router B, Router C, Router D, Router E, and Router F are similar to the configuration of Router A, and are not mentioned here.

  2. Configure basic OSPF functions.

    # Configure Router A.

    [RouterA] router id 1.1.1.1
    [RouterA] ospf
    [RouterA-ospf-1] area 0
    [RouterA-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] quit
    [RouterA-ospf-1] area 1
    [RouterA-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.1] quit
    [RouterA-ospf-1] quit

    # Configure Router B.

    [RouterB] router id 2.2.2.2
    [RouterB] ospf
    [RouterB-ospf-1] area 0
    [RouterB-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.0] quit
    [RouterB-ospf-1] area 2
    [RouterB-ospf-1-area-0.0.0.2] network 192.168.2.0 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.2] quit
    [RouterB-ospf-1] quit

    # Configure Router C.

    [RouterC] router id 3.3.3.3
    [RouterC] ospf
    [RouterC-ospf-1] area 1
    [RouterC-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
    [RouterC-ospf-1-area-0.0.0.1] network 172.16.1.0 0.0.0.255
    [RouterC-ospf-1-area-0.0.0.1] quit
    [RouterC-ospf-1] quit

    # Configure Router D.

    [RouterD] router id 4.4.4.4
    [RouterD] ospf
    [RouterD-ospf-1] area 2
    [RouterD-ospf-1-area-0.0.0.2] network 192.168.2.0 0.0.0.255
    [RouterD-ospf-1-area-0.0.0.2] network 172.17.1.0 0.0.0.255
    [RouterD-ospf-1-area-0.0.0.2] quit
    [RouterD-ospf-1] quit

    # Configure Router E.

    [RouterE] router id 5.5.5.5
    [RouterE] ospf
    [RouterE-ospf-1] area 1
    [RouterE-ospf-1-area-0.0.0.1] network 172.16.1.0 0.0.0.255
    [RouterE-ospf-1-area-0.0.0.1] quit
    [RouterE-ospf-1] quit

    # Configure Router F.

    [RouterF] router id 6.6.6.6
    [RouterF] ospf
    [RouterF-ospf-1] area 2
    [RouterF-ospf-1-area-0.0.0.2] network 172.17.1.0 0.0.0.255
    [RouterF-ospf-1-area-0.0.0.2] quit
    [RouterF-ospf-1] quit

  3. Configure Router D to import static routes.

    [RouterD] ip route-static 200.0.0.0 8 null 0
    [RouterD] ospf
    [RouterD-ospf-1] import-route static type 1
    [RouterD-ospf-1] quit

    # View ABR/ASBR information on Router C.

    [RouterC] display ospf abr-asbr
              OSPF Process 1 with Router ID 3.3.3.3
                      Routing Table to ABR and ASBR
     RtType        Destination     Area       Cost    Nexthop          Type
     Intra-area    1.1.1.1         0.0.0.1    1       192.168.1.1      ABR
     Inter-area    4.4.4.4         0.0.0.1    3       192.168.1.1      ASBR

    # View the OSPF routing table of Router C.

    NOTE:

    When Router C is in a common area, there are AS external routes in the routing table.

    [RouterC] display ospf routing
         OSPF Process 1 with Router ID  3.3.3.3
                       Routing Tables
     Routing for Network
     Destination        Cost  Type         NextHop          AdvRouter       Area
     172.16.1.0/24      1     Transit     172.16.1.1      3.3.3.3         0.0.0.1
     172.17.1.0/24      4     Inter-area  192.168.1.1     1.1.1.1         0.0.0.1
     192.168.0.0/24     2     Inter-area  192.168.1.1     1.1.1.1         0.0.0.1
     192.168.1.0/24     1     Transit     192.168.1.2     3.3.3.3         0.0.0.1
     192.168.2.0/24     3     Inter-area  192.168.1.1     1.1.1.1         0.0.0.1
     Routing for ASEs
     Destination    Cost      Type       Tag         NextHop         AdvRouter
     200.0.0.0/8    4         Type1      1           192.168.1.1     4.4.4.4
     Total Nets: 6
     Intra Area: 2  Inter Area: 3  ASE: 1  NSSA: 0

  4. Configure Area 1 as a stub area.

    # Configure Router A.

    [RouterA] ospf
    [RouterA-ospf-1] area 1
    [RouterA-ospf-1-area-0.0.0.1] stub
    [RouterA-ospf-1-area-0.0.0.1] quit
    [RouterA-ospf-1] quit

    # Configure Router C.

    [RouterC] ospf
    [RouterC-ospf-1] area 1
    [RouterC-ospf-1-area-0.0.0.1] stub
    [RouterC-ospf-1-area-0.0.0.1] quit
    [RouterC-ospf-1] quit

    # Configure Router E.

    [RouterE] ospf
    [RouterE-ospf-1] area 1
    [RouterE-ospf-1-area-0.0.0.1] stub
    [RouterE-ospf-1-area-0.0.0.1] quit
    [RouterE-ospf-1] quit

    # View the routing table of Router C.

    NOTE:

    After the area where Router C resides is configured as a stub area, AS external routes are invisible. Instead, there is a default route.

    [RouterC] display ospf routing
              OSPF Process 1 with Router ID 3.3.3.3
                       Routing Tables
    Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     0.0.0.0/0          2    Inter-area  192.168.1.1     1.1.1.1         0.0.0.1
     172.16.1.0/24      1    Transit     172.16.1.1      3.3.3.3         0.0.0.1
     172.17.1.0/24      4    Inter-area  192.168.1.1     1.1.1.1         0.0.0.1
     192.168.0.0/24     2    Inter-area  192.168.1.1     1.1.1.1         0.0.0.1
     192.168.1.0/24     1    Transit     192.168.1.2     3.3.3.3         0.0.0.1
     192.168.2.0/24     3    Inter-area  192.168.1.1     1.1.1.1         0.0.0.1
     Total Nets: 6
     Intra Area: 2  Inter Area: 4  ASE: 0  NSSA: 0

  5. Stop Router A from advertising Type 3 LSAs to the stub area.

    [RouterA] ospf
    [RouterA-ospf-1] area 1
    [RouterA-ospf-1-area-0.0.0.1] stub no-summary
    [RouterA-ospf-1-area-0.0.0.1] quit
    [RouterA-ospf-1] quit

  6. Verify the configuration.

    # View the OSPF routing table of Router C.

    [RouterC] display ospf routing
              OSPF Process 1 with Router ID 3.3.3.3
                       Routing Tables
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     0.0.0.0/0          2   Inter-area   192.168.1.1     1.1.1.1         0.0.0.1
     172.16.1.0/24      1   Transit      172.16.1.1      3.3.3.3         0.0.0.1
     192.168.1.0/24     1   Transit      192.168.1.2     3.3.3.3         0.0.0.1
     Total Nets: 3
     Intra Area: 2  Inter Area: 1  ASE: 0  NSSA: 0
    NOTE:

    After the advertisement of summary LSAs to a stub area is disabled, the routing entries of the stub router are further reduced, and only the default route to a destination outside the AS is reserved.

Configuration Files

  • Configuration file of Router A

    #
     sysname RouterA
    #
    router id 1.1.1.1
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.0.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.1.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
      stub no-summary
    #
    return
  • Configuration file of Router B

    #
     sysname RouterB
    #
    router id 2.2.2.2
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.0.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.2.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
     area 0.0.0.2
      network 192.168.2.0 0.0.0.255
    #
    return
  • Configuration file of Router C

    #
     sysname RouterC
    #
    router id 3.3.3.3
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 172.16.1.1 255.255.255.0
    #
    ospf 1
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
      network 172.16.1.0 0.0.0.255
      stub
    #
    return
  • Configuration file of Router D

    #
     sysname RouterD
    #
    router id 4.4.4.4
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.2.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 172.17.1.1 255.255.255.0
    #
    ospf 1
     import-route static type 1
     area 0.0.0.2
      network 192.168.2.0 0.0.0.255
      network 172.17.1.0 0.0.0.255
    #
    ip route-static 200.0.0.0 255.0.0.0 NULL0
    #
    return
  • Configuration file of Router E

    #
     sysname RouterE
    #
    router id 5.5.5.5
    #
    interface GigabitEthernet2/0/0
     ip address 172.16.1.2 255.255.255.0
    #
    ospf 1
     area 0.0.0.1
      network 172.16.1.0 0.0.0.255
      stub
    #
    return
  • Configuration file of Router F

    #
     sysname RouterF
    #
    router id 6.6.6.6
    #
    interface GigabitEthernet2/0/0
     ip address 172.17.1.2 255.255.255.0
    #
    ospf 1
     area 0.0.0.2
      network 172.17.1.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174069

Views: 113305

Downloads: 254

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next