No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Unicast Routing

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring OSPF IP FRR

Example for Configuring OSPF IP FRR

Networking Requirements

When a fault occurs on the network, OSPF IP FRR can fast switch traffic to the backup link without waiting for route convergence. This ensures uninterrupted traffic transmission.

As shown in Figure 5-40:

  • OSPF runs on the four routers in the same area.

  • If the link between Router A and Router C becomes faulty, the traffic forwarded by Router A is rapidly switched to the backup link and forwarded through Router B.

Figure 5-40 Networking diagram for configuring OSPF IP FRR

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic OSPF functions on each router.

  2. Set the cost to ensure that the link from Router A to Router C is preferred.

  3. Enable OSPF IP FRR on Router A to protect the traffic forwarded by Router A.

Procedure

  1. Configure an IP address and the cost for each interface.

    # Configure IP addresses for all interfaces of RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/1
    [RouterA-GigabitEthernet1/0/1] ip address 10.2.1.1 255.255.255.0
    [RouterA-GigabitEthernet1/0/1] ospf cost 9
    [RouterA-GigabitEthernet1/0/1] quit
    [RouterA] interface gigabitethernet 1/0/2
    [RouterA-GigabitEthernet1/0/2] ip address 10.3.1.1 255.255.255.0
    [RouterA-GigabitEthernet1/0/2] ospf cost 4

    The configurations of RouterB, RouterC and RouterD are similar to the configuration of RouterA, and are not mentioned here.

  2. Configure basic OSPF functions.

    # Configure Router A.

    [RouterA] router id 10.1.1.1
    [RouterA] ospf
    [RouterA-ospf-1] area 1
    [RouterA-ospf-1-area-0.0.0.1] network 10.2.1.1 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.1] network 10.3.1.1 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.1] quit
    [RouterA-ospf-1] quit

    # Configure Router B.

    [RouterB] router id 10.2.2.2
    [RouterB] ospf
    [RouterB-ospf-1] area 1
    [RouterB-ospf-1-area-0.0.0.1] network 10.5.1.2 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.1] network 10.2.1.2 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.1] quit
    [RouterB-ospf-1] quit

    # Configure Router C.

    [RouterC] router id 10.3.3.3
    [RouterC] ospf
    [RouterC-ospf-1] area 1
    [RouterC-ospf-1-area-0.0.0.1] network 10.3.1.3 0.0.0.255
    [RouterC-ospf-1-area-0.0.0.1] network 10.4.1.3 0.0.0.255
    [RouterC-ospf-1-area-0.0.0.1] network 10.5.1.1 0.0.0.255
    [RouterC-ospf-1-area-0.0.0.1] quit
    [RouterC-ospf-1] quit

    # Configure Router D.

    [RouterD] router id 10.4.4.4
    [RouterD] ospf
    [RouterD-ospf-1] area 1
    [RouterD-ospf-1-area-0.0.0.1] network 10.4.1.4 0.0.0.255
    [RouterD-ospf-1-area-0.0.0.1] quit
    [RouterD-ospf-1] quit

  3. Enable OSPF IP FRR on Router A.

    # Enable OSPF IP FRR on Router A.

    [RouterA] ospf
    [RouterA-ospf-1] frr
    [RouterA-ospf-1-frr] loop-free-alternate
    [RouterA-ospf-1-frr] quit
    [RouterA-ospf-1] quit

  4. Verify the configuration.

    # View information about the route from Router A to Router D. You can find that OSPF generates a backup route because OSPF IP FRR is enabled.

    [RouterA] display ospf routing router-id 10.4.4.4
    
              OSPF Process 1 with Router ID 10.1.1.1
    
     Destination : 10.4.4.4                  Route Type : Intra-area
     Area        : 0.0.0.1                  AdvRouter  : 10.4.4.4
     Type        : Normal                   Age        : 00h31m27s
     URT Cost    : 59
     NextHop     : 10.3.1.3                  Interface  : GigabitEthernet1/0/2
     Backup Nexthop : 10.2.1.2             Backup Interface : GigabitEthernet1/0/1
     Backup Type : LFA LINK          
    

    The preceding display shows that a backup route is generated on Router A.

Configuration Files

  • Configuration file of Router A

    #
     sysname RouterA
    #
    router id 10.1.1.1
    #
    interface GigabitEthernet1/0/1
     ip address 10.2.1.1 255.255.255.0
     ospf cost 9
    #
    interface GigabitEthernet1/0/2
     ip address 10.3.1.1 255.255.255.0
     ospf cost 4
    #
    ospf 1 
     frr
      loop-free-alternate
     area 0.0.0.1
      network 10.2.1.1 0.0.0.255
      network 10.3.1.1 0.0.0.255
    #
    return
    
  • Configuration file of Router B

    #
     sysname RouterB
    #
    router id 10.2.2.2
    #
    interface GigabitEthernet1/0/1
     ip address 10.2.1.2 255.255.255.0
     ospf cost 9
    #
    interface GigabitEthernet1/0/2
     ip address 10.5.1.2 255.255.255.0
     ospf cost 5
    #
    ospf 1 
     area 0.0.0.1
      network 10.5.1.2 0.0.0.255
      network 10.2.1.2 0.0.0.255
    #
    return
    
  • Configuration file of Router C

    #
     sysname RouterC
    #
    router id 10.3.3.3
    #
    interface GigabitEthernet1/0/1
     ip address 10.3.1.3 255.255.255.0
     ospf cost 4
    #
    interface GigabitEthernet1/0/2
     ip address 10.4.1.3 255.255.255.0
     ospf cost 55
    #
    interface GigabitEthernet1/0/3
     ip address 10.5.1.1 255.255.255.0
     ospf cost 5
    #
    ospf 1 
     area 0.0.0.1
      network 10.3.1.3 0.0.0.255
      network 10.4.1.3 0.0.0.255
      network 10.5.1.1 0.0.0.255
    #
    return
    
  • Configuration file of Router D

    #
     sysname RouterD
    #
    router id 10.4.4.4
    #
    interface GigabitEthernet1/0/1
     ip address 10.4.1.4 255.255.255.0
     ospf cost 55
    #
    ospf 1 
     area 0.0.0.1
      network 10.4.1.4 0.0.0.255
    #
    return
    
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174069

Views: 111993

Downloads: 250

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next