No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Unicast Routing

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Basic MBGP Functions

Example for Configuring Basic MBGP Functions

Networking Requirements

As shown in Figure 9-28, the receiver receives VoD information in multicast mode. The receiver and the source reside in different ASs. Multicast routing information needs to be transmitted between ASs.

Figure 9-28 Networking diagram of configuring MBGP

Device

Interface

IP Address

Device

Interface

IP Address

RouterA

GE1/0/0

10.1.1.1/24

RouterC

GE1/0/0

10.4.1.1/24

GE2/0/0

10.10.10.1/24

GE2/0/0

10.168.1.1/24

Loopback0

1.1.1.1/32

GE3/0/0

10.2.1.1/24

RouterB

GE1/0/0

10.1.1.2/24

Loopback0

3.3.3.3/32

GE2/0/0

10.3.1.2/24

RouterD

GE1/0/0

10.4.1.2/24

GE3/0/0

10.2.1.2/24

GE2/0/0

10.3.1.1/24

Loopback0

2.2.2.2/32

Loopback0

4.4.4.4/32

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure MBGP peers for inter-AS multicast transmission.

  2. Configure the routes advertised by MBGP.

  3. Enable the multicast function on each router.

  4. Configure basic PIM-SM functions on each router in ASs and enable IGMP on receiver-side interfaces.

  5. Configure a BSR boundary on the interfaces that connect to two ASs.

  6. Configure MSDP peers to transmit inter-domain multicast source information.

Procedure

  1. Assign IP addresses to the interfaces on each router and configure OSPF in ASs.

    # Configure IP addresses and masks for the interfaces on each router according to Figure 9-28 and configure OSPF on the routers in ASs. Ensure that Router B, Router C, Router D can communicate with the receiver at the network layer, learn routes to the loopback interfaces of each other, and dynamically update routes using a unicast routing protocol. Configure OSPF process 1. The configuration procedure is not mentioned here.

  2. Configure BGP, enable the MBGP protocol, and configure MBGP peers.

    # Configure BGP and the MBGP peer on Router A.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] bgp 100
    [RouterA-bgp] peer 10.1.1.2 as-number 200
    [RouterA-bgp] ipv4-family multicast
    [RouterA-bgp-af-multicast] peer 10.1.1.2 enable
    [RouterA-bgp-af-multicast] quit
    [RouterA-bgp] quit

    # Configure BGP and the MBGP peer on Router B.

    [RouterB] bgp 200
    [RouterB-bgp] peer 10.1.1.1 as-number 100
    [RouterB-bgp] peer 10.2.1.1 as-number 200
    [RouterB-bgp] peer 10.3.1.1 as-number 200
    [RouterB-bgp] ipv4-family multicast
    [RouterB-bgp-af-multicast] peer 10.1.1.1 enable
    [RouterB-bgp-af-multicast] peer 10.2.1.1 enable
    [RouterB-bgp-af-multicast] peer 10.3.1.1 enable
    [RouterB-bgp-af-multicast] quit
    [RouterB-bgp] quit

    # Configure BGP and the MBGP peer on Router C.

    [RouterC] bgp 200
    [RouterC-bgp] peer 10.2.1.2 as-number 200
    [RouterC-bgp] peer 10.4.1.2 as-number 200
    [RouterC-bgp] ipv4-family multicast
    [RouterC-bgp-af-multicast] peer 10.2.1.2 enable
    [RouterC-bgp-af-multicast] peer 10.4.1.2 enable
    [RouterC-bgp-af-multicast] quit
    [RouterC-bgp] quit

    # Configure BGP and the MBGP peer on Router D.

    [RouterD] bgp 200
    [RouterD-bgp] peer 10.3.1.2 as-number 200
    [RouterD-bgp] peer 10.4.1.1 as-number 200
    [RouterD-bgp] ipv4-family multicast
    [RouterD-bgp-af-multicast] peer 10.3.1.2 enable
    [RouterD-bgp-af-multicast] peer 10.4.1.1 enable
    [RouterD-bgp-af-multicast] quit
    [RouterD-bgp] quit

  3. Configure the routes to be advertised.

    # Configure the routes to be advertised on Router A.

    [RouterA] bgp 100
    [RouterA-bgp] import-route direct
    [RouterA-bgp] ipv4-family multicast
    [RouterA-bgp-af-multicast] import-route direct
    [RouterA-bgp-af-multicast] quit
    [RouterA-bgp] quit

    # Configure the routes to be advertised on Router B.

    [RouterB] bgp 200
    [RouterB-bgp] import-route direct
    [RouterB-bgp] import-route ospf 1
    [RouterB-bgp] ipv4-family multicast
    [RouterB-bgp-af-multicast] import-route direct
    [RouterB-bgp-af-multicast] import-route ospf 1
    [RouterB-bgp-af-multicast] quit
    [RouterB-bgp] quit

    # Configure the routes to be advertised on Router C. The configuration of Router D is similar to the configuration of Router C, and is not mentioned here.

    [RouterC] bgp 200
    [RouterC-bgp] import-route direct
    [RouterC-bgp] ipv4-family multicast
    [RouterC-bgp-af-multicast] import-route direct
    [RouterC-bgp-af-multicast] import-route ospf 1
    [RouterC-bgp-af-multicast] quit
    [RouterC-bgp] quit

  4. Enable the multicast function on each Router and interfaces on the Routers.

    # Configure Router A.

    [RouterA] multicast routing-enable
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] pim sm
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] pim sm
    [RouterA-GigabitEthernet2/0/0] quit

    # Configure Router B.

    [RouterB] multicast routing-enable
    [RouterB] interface gigabitethernet 1/0/0
    [RouterB-GigabitEthernet1/0/0] pim sm
    [RouterB-GigabitEthernet1/0/0] quit
    [RouterB] interface gigabitethernet 2/0/0
    [RouterB-GigabitEthernet2/0/0] pim sm
    [RouterB-GigabitEthernet2/0/0] quit
    [RouterB] interface gigabitethernet 3/0/0
    [RouterB-GigabitEthernet3/0/0] pim sm
    [RouterB-GigabitEthernet3/0/0] quit

    # Configure Router C.

    [RouterC] multicast routing-enable
    [RouterC] interface gigabitethernet 1/0/0
    [RouterC-GigabitEthernet1/0/0] pim sm
    [RouterC-GigabitEthernet1/0/0] quit
    [RouterC] interface gigabitethernet 2/0/0
    [RouterC-GigabitEthernet2/0/0] pim sm
    [RouterC-GigabitEthernet2/0/0] igmp enable
    [RouterC-GigabitEthernet2/0/0] quit
    [RouterC] interface gigabitethernet 3/0/0
    [RouterC-GigabitEthernet3/0/0] pim sm
    [RouterC-GigabitEthernet3/0/0] quit

    # Configure Router D.

    [RouterD] multicast routing-enable
    [RouterD] interface gigabitethernet 1/0/0
    [RouterD-GigabitEthernet1/0/0] pim sm
    [RouterD-GigabitEthernet1/0/0] quit
    [RouterD] interface gigabitethernet 2/0/0
    [RouterD-GigabitEthernet2/0/0] pim sm
    [RouterD-GigabitEthernet2/0/0] quit

  5. Configure the BSR and RP within each AS.

    # Configure Router A.

    [RouterA] interface loopback 0
    [RouterA-LoopBack0] ip address 1.1.1.1 255.255.255.255
    [RouterA-LoopBack0] pim sm
    [RouterA-LoopBack0] quit
    [RouterA] pim
    [RouterA-pim] c-bsr loopback 0
    [RouterA-pim] c-rp loopback 0
    [RouterA-pim] quit

    # Configure Router B.

    [RouterB] interface loopback 0
    [RouterB-LoopBack0] ip address 2.2.2.2 255.255.255.255
    [RouterB-LoopBack0] pim sm
    [RouterB-LoopBack0] quit
    [RouterB] pim
    [RouterB-pim] c-bsr loopback 0
    [RouterB-pim] c-rp loopback 0
    [RouterB-pim] quit

  6. Configure a BSR boundary on the interfaces that connect to two ASs.

    # Configure Router A.

    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] pim bsr-boundary
    [RouterA-GigabitEthernet1/0/0] quit

    # Configure Router B.

    [RouterB] interface gigabitethernet 1/0/0
    [RouterB-GigabitEthernet1/0/0] pim bsr-boundary
    [RouterB-GigabitEthernet1/0/0] quit

  7. Configure MSDP peers.

    # Configure Router A.

    [RouterA] msdp
    [RouterA-msdp] peer 10.1.1.2 connect-interface gigabitethernet 1/0/0
    [RouterA-msdp] quit

    # Configure Router B.

    [RouterB] msdp
    [RouterB-msdp] peer 10.1.1.1 connect-interface gigabitethernet 1/0/0
    [RouterB-msdp] quit

  8. Verify the configuration.

    # Run the display bgp multicast peer command to view the MBGP peer relationship between Routers. For example, information about the MBGP peer relationship on Router A is as follows:

    [RouterA] display bgp multicast peer
    
    
     BGP local router ID : 1.1.1.1
     Local AS number : 100
     Total number of peers : 1                 Peers in established state : 1
    
    
      Peer        V   AS   MsgRcvd  MsgSent  OutQ  Up/Down        State     PrefRcv
      10.1.1.2    4  200        82       75     0 00:30:29  Established          17

    # Run the display msdp brief command to view information about the MSDP peer relationship between Routers. For example, brief information about the MSDP peer relationship on Router B is as follows:

    [RouterB] display msdp brief
    MSDP Peer Brief Information of VPN-Instance: public net
      Configured      Up        Listen       Connect      Shutdown     Down
      1               1         0            0            0            0
    
    
      Peer's Address     State     Up/Down time    AS     SA Count    Reset Count
      10.1.1.1           Up        00:07:17        100    1           0

Configuration Files

  • Configuration file of Router A

    #
    sysname RouterA
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 10.10.10.1 255.255.255.0
     pim sm
    #
    interface Loopback0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    pim
     c-bsr Loopback0
     c-rp Loopback0
    #
    bgp 100
     peer 10.1.1.2 as-number 200
    #
     ipv4-family unicast
      undo synchronization
      import-route direct 
      peer 10.1.1.2 enable
    #
     ipv4-family multicast
      undo synchronization
      import-route direct
      peer 10.1.1.2 enable
    #
    msdp
     peer 10.1.1.2 connect-interface GigabitEthernet1/0/0
    #
    return
  • Configuration file of Router B

    #
     sysname RouterB
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
     pim bsr-boundary 
     pim sm
    # 
    interface GigabitEthernet2/0/0
     ip address 10.3.1.2 255.255.255.0
     pim sm
    # 
    interface GigabitEthernet3/0/0
     ip address 10.2.1.2 255.255.255.0
     pim sm
    # 
    interface Loopback0
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    pim
     c-bsr Loopback0
     c-rp Loopback0
    #
    ospf 1 
     area 0.0.0.0
      network 10.2.1.0 0.0.0.255
      network 10.3.1.0 0.0.0.255
      network 2.2.2.2 0.0.0.0
    #
    bgp 200
     peer 10.1.1.1 as-number 100
     peer 10.2.1.1 as-number 200
     peer 10.3.1.1 as-number 200
    # 
     ipv4-family unicast
      undo synchronization
      import-route direct 
      import-route ospf 1
      peer 10.1.1.1 enable
      peer 10.2.1.1 enable
      peer 10.3.1.1 enable
    # 
     ipv4-family multicast
      undo synchronization
      import-route direct
      import-route ospf 1
      peer 10.1.1.1 enable
      peer 10.2.1.1 enable
      peer 10.3.1.1 enable
    # 
    msdp
     peer 10.1.1.1 connect-interface GigabitEthernet1/0/0
    # 
    return
  • Configuration file of Router C

    #
     sysname RouterC
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 10.4.1.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 10.168.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface GigabitEthernet3/0/0
     ip address 10.2.1.1 255.255.255.0
     pim sm
    # 
    interface Loopback0
     ip address 3.3.3.3 255.255.255.255
     pim sm
    #
    ospf 1 
     area 0.0.0.0
      network 10.2.1.0 0.0.0.255
      network 10.4.1.0 0.0.0.255
      network 10.168.1.0 0.0.0.255
      network 3.3.3.3 0.0.0.0
    #
    bgp 200
     peer 10.2.1.2 as-number 200
     peer 10.4.1.2 as-number 200
    #
     ipv4-family unicast
      undo synchronization
      import-route direct 
      peer 10.2.1.2 enable
      peer 10.4.1.2 enable
    #
     ipv4-family multicast
      undo synchronization
      import-route direct
      import-route ospf 1
      peer 10.2.1.2 enable
      peer 10.4.1.2 enable
    #
    return
    
  • Configuration file of Router D

    #
     sysname RouterD
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 10.4.1.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 10.3.1.1 255.255.255.0
     pim sm
    # 
    interface Loopback0
     ip address 4.4.4.4 255.255.255.255
     pim sm
    #
    ospf 1 
     area 0.0.0.0
      network 10.3.1.0 0.0.0.255
      network 10.4.1.0 0.0.0.255
      network 4.4.4.4 0.0.0.0
    #
    bgp 200
     peer 10.3.1.2 as-number 200
     peer 10.4.1.1 as-number 200
    #
     ipv4-family unicast
      undo synchronization
      import-route direct 
      peer 10.3.1.2 enable
      peer 10.4.1.1 enable
    #
     ipv4-family multicast
      undo synchronization
      import-route direct
      import-route ospf 1
      peer 10.3.1.2 enable
      peer 10.4.1.1 enable
    #
    return
    
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174069

Views: 112902

Downloads: 252

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next