No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Unicast Routing

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring SPR

Example for Configuring SPR

Networking Requirements

As shown in Figure 12-9, a financial enterprise's branch connects to the enterprise data center over two ISP networks (ISP1 and ISP2), and exchange data is saved to ServerA in the data center.

The enterprise wants ISP1 to provide a high-speed active link and ISP2 to provide a standby link. The link delay needs to be shorter than or equal to 1000 ms to ensure that exchange data is sent to the data center in a timely manner.

Figure 12-9 Networking diagram of SPR

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the NQA client on RouterA and the NQA server on RouterB so that the quality of the link between the enterprise branch and data center can be detected dynamically.
  2. Configure ACLs to classify service flows so that SPR can be applied to packets with the destination IP address as the ServerA's IP address.
  3. Configure SPR routing parameters on RouterA so that detection links are added to a link group.
  4. Configure association between SPR and services on RotuerA so that ISP1 provides the active link, ISP2 provides the standby link, and the link delay is shorter than or equal to 1000 ms.

Procedure

  1. Configure IP addresses for interfaces.

    # Configure IP addresses for all interfaces of RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 202.1.1.1 255.255.255.0
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 178.1.1.1 255.255.255.0
    [RouterA-GigabitEthernet2/0/0] quit

    # Configure IP addresses for all interfaces of RouterB.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] interface gigabitethernet 1/0/0
    [RouterB-GigabitEthernet1/0/0] ip address 202.1.2.1 255.255.255.0
    [RouterB-GigabitEthernet1/0/0] quit
    [RouterB] interface gigabitethernet 2/0/0
    [RouterB-GigabitEthernet2/0/0] ip address 178.1.2.1 255.255.255.0
    [RouterB-GigabitEthernet2/0/0] quit

    # Configure IP addresses for all interfaces of RouterC.

    <Huawei> system-view
    [Huawei] sysname RouterC
    [RouterC] interface gigabitethernet 1/0/0
    [RouterC-GigabitEthernet1/0/0] ip address 202.1.1.2 255.255.255.0
    [RouterC-GigabitEthernet1/0/0] quit
    [RouterC] interface gigabitethernet 2/0/0
    [RouterC-GigabitEthernet2/0/0] ip address 202.1.2.2 255.255.255.0
    [RouterC-GigabitEthernet2/0/0] quit

    # Configure IP addresses for all interfaces of RouterD.

    <Huawei> system-view
    [Huawei] sysname RouterD
    [RouterD] interface gigabitethernet 1/0/0
    [RouterD-GigabitEthernet1/0/0] ip address 178.1.1.2 255.255.255.0
    [RouterD-GigabitEthernet1/0/0] quit
    [RouterD] interface gigabitethernet 2/0/0
    [RouterD-GigabitEthernet2/0/0] ip address 178.1.2.2 255.255.255.0
    [RouterD-GigabitEthernet2/0/0] quit

  2. Configure static routes.

    # Configure a static route on RouterA.

    [RouterA] ip route-static 202.1.2.0 255.255.255.0 202.1.1.2
    [RouterA] ip route-static 178.1.2.0 255.255.255.0 178.1.1.2

    # Configure a static route on RouterB.

    [RouterB] ip route-static 202.1.1.0 255.255.255.0 202.1.2.2
    [RouterB] ip route-static 178.1.1.0 255.255.255.0 178.1.2.2

  3. Configure NQA test instances.

    # Configure the NQA client on RouterA.

    [RouterA] nqa test-instance admin nqa1
    [RouterA-nqa-admin-nqa1] test-type jitter
    [RouterA-nqa-admin-nqa1] destination-address ipv4 202.1.2.1
    [RouterA-nqa-admin-nqa1] destination-port 10000
    [RouterA-nqa-admin-nqa1] hardware-based enable
    [RouterA-nqa-admin-nqa1] frequency 10
    [RouterA-nqa-admin-nqa1] source-interface gigabitethernet 1/0/0
    [RouterA-nqa-admin-nqa1] start now
    [RouterA-nqa-admin-nqa1] quit
    [RouterA] nqa test-instance admin nqa2
    [RouterA-nqa-admin-nqa2] test-type jitter
    [RouterA-nqa-admin-nqa2] destination-address ipv4 178.1.2.1
    [RouterA-nqa-admin-nqa2] destination-port 10001
    [RouterA-nqa-admin-nqa2] hardware-based enable
    [RouterA-nqa-admin-nqa2] frequency 10
    [RouterA-nqa-admin-nqa2] source-interface gigabitethernet 2/0/0
    [RouterA-nqa-admin-nqa2] start now
    [RouterA-nqa-admin-nqa2] quit

    # Configure the NQA server on RouterB.

    [RouterB] nqa-server udpecho 202.1.2.1 10000
    [RouterB] nqa-server udpecho 178.1.2.1 10001
    

  4. Configure ACLs to classify service flows.

    # Configure ACL 3000 on RouterA to apply SPR to data flows with destination address 196.1.1.1.

    [RouterA] acl 3000
    [RouterA-acl-adv-3000] rule permit ip destination 196.1.1.1 0.0.0.0
    [RouterA-acl-adv-3000] quit

  5. Set SPR routing parameters on RouterA.

    [RouterA] smart-policy-route
    [RouterA-smart-policy-route] period 50
    [RouterA-smart-policy-route] route flapping suppression 100
    [RouterA-smart-policy-route] prober gigabitethernet 1/0/0 nqa admin nqa1
    [RouterA-smart-policy-route] prober gigabitethernet 2/0/0 nqa admin nqa2
    [RouterA-smart-policy-route] link-group group1
    [RouterA-smart-policy-route-link-group-group1] link-member gigabitethernet 1/0/0
    [RouterA-smart-policy-route-link-group-group1] quit
    [RouterA-smart-policy-route] link-group group2
    [RouterA-smart-policy-route-link-group-group2] link-member gigabitethernet 2/0/0
    [RouterA-smart-policy-route-link-group-group2] quit
    

  6. Set SPR service parameters.

    [RouterA-smart-policy-route] service-map map1
    [RouterA-smart-policy-route-service-map-map1] match acl 3000
    [RouterA-smart-policy-route-service-map-map1] set delay threshold 1000
    [RouterA-smart-policy-route-service-map-map1] set link-group group1 
    [RouterA-smart-policy-route-service-map-map1] set link-group group2 backup
    [RouterA-smart-policy-route-service-map-map1] quit
    [RouterA-smart-policy-route] quit

  7. Verify the configurations.

    # View the NQA test results of the detection links on RouterA.

    [RouterA] display smart-policy-route link-state
    --------------------------------------------------------------------------------
    link-name                               Delay         Jitter       Loss         
    --------------------------------------------------------------------------------
    GigabitEthernet1/0/0                    5000          3000         1000         
    GigabitEthernet2/0/0                    5000          3000         1000         
    -------------------------------------------------------------------------------- 

    # View routing information about service map1 on RouterA.

    [RouterA] display smart-policy-route service-map map1
    --------------------------------------------------------------------------------
    Match acl         : 3000                                                        
    DelayThreshold    : 1000                                                        
    LossThreshold     : 1000                                                        
    JitterThreshold   : 3000                                                        
    CmiThreshold      : 0                                                           
    GroupName         : group1                                                      
    BackupGroupName   : group2                                                      
    Description       :                                                             
    Cmi-Method        : d+l+j                                                       
    CurLinkName       : GigabitEthernet1/0/0                                               
    --------------------------------------------------------------------------------

Configuration Files

  • Configuration file of RouterA

    #                                                                               
     sysname RouterA                                                                
    #                                                                               
    acl number 3000                                                                 
     rule 5 permit ip destination 196.1.1.1 0                                       
    #                                                                               
    interface GigabitEthernet1/0/0                                                         
     ip address 202.1.1.1 255.255.255.0                                             
    #                                                                               
    interface GigabitEthernet2/0/0                                                         
     ip address 178.1.1.1 255.255.255.0                                             
    #                                                                               
    nqa test-instance admin nqa1                                                    
     test-type jitter                                                               
     destination-address ipv4 202.1.2.1                                             
     destination-port 10000                                                         
     hardware-based enable                                                          
     frequency 10                                                                   
     source-interface GigabitEthernet1/0/0                                                 
     start now                                                                      
    nqa test-instance admin nqa2                                                    
     test-type jitter                                                               
     destination-address ipv4 178.1.2.1                                             
     destination-port 10001                                                         
     hardware-based enable                                                          
     frequency 10                                                                   
     source-interface GigabitEthernet2/0/0                                                 
     start now                                                                      
    #                                                                               
    smart-policy-route                                                              
     period 50                                                                      
     route flapping suppression 100                                                 
     prober GigabitEthernet1/0/0 nqa admin nqa1                                            
     prober GigabitEthernet2/0/0 nqa admin nqa2                                            
     link-group group1                                                              
      link-member GigabitEthernet1/0/0                                                     
     link-group group2                                                              
      link-member GigabitEthernet2/0/0                                                     
     service-map map1                                                               
      match acl 3000                                                                
      set delay threshold 1000                                                      
      set link-group group1                                                         
      set link-group group2 backup                                                  
    #                                                                               
     ip route-static 202.1.2.0 255.255.255.0 202.1.1.2                              
     ip route-static 178.1.2.0 255.255.255.0 178.1.1.2                              
    #                                                                               
  • Configuration file of RouterB

    #
     sysname RouterB
    #                                                                               
    interface GigabitEthernet1/0/0                                                         
     ip address 202.1.2.1 255.255.255.0                                             
    #                                                                               
    interface GigabitEthernet2/0/0                                                  
     ip address 178.1.2.1 255.255.255.0                                             
    #                                                                               
    nqa-server udpecho 178.1.2.1 10001                                              
    nqa-server udpecho 202.1.2.1 10000                                              
    #                                                                               
     ip route-static 202.1.1.0 255.255.255.0 202.1.2.2                              
     ip route-static 178.1.1.0 255.255.255.0 178.1.2.2                              
    #                                                                               
    
  • Configuration file of RouterC

    #
     sysname RouterC
    #                                                                               
    interface GigabitEthernet1/0/0                                                         
     ip address 202.1.1.2 255.255.255.0                                             
    #                                                                               
    interface GigabitEthernet2/0/0                                                  
     ip address 202.1.2.2 255.255.255.0                                             
    #                                                                               
    
  • Configuration file of RouterD

    #
     sysname RouterD
    #                                                                               
    interface GigabitEthernet1/0/0                                                         
     ip address 178.1.1.2 255.255.255.0                                             
    #                                                                               
    interface GigabitEthernet2/0/0                                                  
     ip address 178.1.2.2 255.255.255.0                                             
    #                                                                               
    
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174069

Views: 130050

Downloads: 274

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next