No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Unicast Routing

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Dynamic BFD for RIP

Example for Configuring Dynamic BFD for RIP

Networking Requirements

As shown in Figure 3-12, there are four routers that communicate using RIP on a small-sized network. Services are transmitted through the primary link Router A->Router B->Router D. Reliability must be improved for data transmitted from Router A to Router B so that services can be rapidly switched to another path for transmission when the primary link fails.

Figure 3-12 Networking diagram for configuring BFD for RIP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP address for each interface to ensure network reachability.

  2. Enable RIP on each router to implement network connections between processes.

  3. Configure BFD for RIP on interfaces at both ends of the link between Router A and Router B. BFD can rapidly detect the link status and help RIP speed up route convergence to implement fast link switching.

Procedure

  1. Configure IP address for each interface.

    # Configure Router A.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 192.168.2.1 24
    [RouterA-GigabitEthernet1/0/0] quit

    The configurations of Router B, Router C and Router D are similar to the configuration of Router A, and are not mentioned here.

  2. Configure basic RIP functions.

    # Configure Router A.

    [RouterA] rip 1
    [RouterA-rip-1] version 2
    [RouterA-rip-1] network 192.168.2.0
    [RouterA-rip-1] network 192.168.3.0
    [RouterA-rip-1] quit

    # Configure Router B.

    [RouterB] rip 1
    [RouterB-rip-1] version 2
    [RouterB-rip-1] network 192.168.2.0
    [RouterB-rip-1] network 192.168.4.0
    [RouterB-rip-1] network 172.16.0.0
    [RouterB-rip-1] quit

    # Configure Router C.

    [RouterC] rip 1
    [RouterC-rip-1] version 2
    [RouterC-rip-1] network 192.168.3.0
    [RouterC-rip-1] network 192.168.4.0
    [RouterC-rip-1] quit

    # Configure Router D.

    [RouterD] rip 1
    [RouterD-rip-1] version 2
    [RouterD-rip-1] network 172.16.0.0
    [RouterD-rip-1] quit

    # After completing the preceding operations, run the display rip neighbor command. The command output shows that Router A, Router B, and Router C have established neighbor relationships with each other. In the following example, the display on Router A is used.

    [RouterA] display rip 1 neighbor
    ---------------------------------------------------------------------
    
     IP Address      Interface                   Type   Last-Heard-Time
    ---------------------------------------------------------------------
     192.168.2.2         GigabitEthernet1/0/0        RIP    0:0:1
     Number of RIP routes  : 1
     192.168.3.2         GigabitEthernet2/0/0        RIP    0:0:2
     Number of RIP routes  : 2 

    # Run the display ip routing-table command. The command output shows that the routers have imported routes from each other. In the following example, the display on Router A is used.

    [RouterA] display ip routing-table
    Route Flags: R - relay,
    D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 8        Routes : 9
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
        192.168.2.0/24  Direct  0    0           D   192.168.2.1     GigabitEthernet1/0/0
        192.168.2.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet1/0/0
        192.168.3.0/24  Direct  0    0           D   192.168.3.1     GigabitEthernet2/0/0
        192.168.3.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet2/0/0
        192.168.4.0/8   RIP     100  1           D   192.168.2.2     GigabitEthernet1/0/0
                        RIP     100  1           D   192.168.3.2     GigabitEthernet2/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
         172.16.0.0/16  RIP     100  1           D   192.168.2.2         GigabitEthernet1/0/0

    The preceding command output shows that the next-hop address and outbound interface of the route to destination 172.16.0.0/16 are 192.168.2.2 and GE 1/0/0 respectively, and traffic is transmitted over the active link Router A->Router B.

  3. Configure BFD in RIP processes.

    # Configure BFD on all interfaces of Router A.

    [RouterA] bfd
    [RouterA-bfd] quit
    [RouterA] rip 1
    [RouterA-rip-1] bfd all-interfaces enable
    [RouterA-rip-1] bfd all-interfaces min-rx-interval 100 min-tx-interval 100 detect-multiplier 10
    [RouterA-rip-1] quit

    The configuration of Router B is similar to that of Router A, and is not provided here.

    # After completing the preceding operations, run the display rip bfd session command on Router A. The command output shows that Router A and Router B have established a BFD session and the BFDState field value is displayed as Up. In the following example, the display on Router A is used.

    [RouterA] display rip 1 bfd session all
     LocalIp      :192.168.2.1         RemoteIp   :192.168.2.2         BFDState :Up      
     TX           :100             RX         :100             Multiplier:10       
     BFD Local Dis:8192            Interface  :GigabitEthernet1/0/0                    
     DiagnosticInfo: No diagnostic information                              
    LocalIp       :192.168.3.1         RemoteIp  :192.168.3.2         BFDState :Down
     TX            :0               RX        :0               Multiplier:0
     BFD Local Dis :8200            Interface :GigabitEthernet2/0/0
     Diagnostic Info:No diagnostic information                                      

  4. Verify the configuration.

    # Run the shutdown command on GE 1/0/0 of Router B to simulate a fault in the active link.

    NOTE:

    The link fault is simulated to verify the configuration. In actual situations, the operation is not required.

    [RouterB] interface gigabitethernet 1/0/0
    [RouterB-GigabitEthernet1/0/0] shutdown

    # Check information about the BFD session on Router A. The command output shows that there is no BFD session between Routers A and B.

    [RouterA] display rip 1 bfd session all
     LocalIp       :192.168.3.1         RemoteIp  :192.168.3.2         BFDState  :Down
     TX            :0               RX        :0               Multiplier:0
     BFD Local Dis :8200            Interface :GigabitEthernet2/0/0
     Diagnostic Info:No diagnostic information                                      

    # Check the routing table of Router A.

    [RouterA] display ip routing-table
    Route Flags: R - relay,
    D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 6        Routes : 6
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
        192.168.3.0/24  Direct  0    0           D   192.168.3.1     GigabitEthernet2/0/0
        192.168.3.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet2/0/0
        192.168.4.0/8   RIP     100  1           D   192.168.3.2     GigabitEthernet2/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
         172.16.0.0/16  RIP     100  2           D   192.168.3.2         GigabitEthernet2/0/0
    

    The preceding command output shows that the standby link Router A->Router C->Router B is used after the active link fails, and the next-hop address and outbound interface of the route to destination 172.16.0.0/16 are 192.168.3.2 and GE 2/0/0 respectively.

Configuration Files

  • Configuration file of Router A

    #
     sysname RouterA
    #
    bfd
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.2.1 255.255.255.0 
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.3.1 255.255.255.0
    #
    rip 1 
     version 2 
     network 192.168.2.0
     network 192.168.3.0
     bfd all-interfaces enable
     bfd all-interfaces min-tx-interval 100 min-rx-interval 100 detect-multiplier 10  
    #
    return
  • Configuration file of Router B

    #
     sysname RouterB
    #
    bfd
    #
    interface GigabitEthernet1/0/0 
     ip address 192.168.2.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.4.1 255.255.255.0
    #
    interface gigabitethernet3/0/0
     ip address 172.16.1.1 255.255.255.0
    #
    rip 1 
     version 2 
     network 192.168.2.0
     network 192.168.4.0
     network 172.16.0.0
     bfd all-interfaces enable 
     bfd all-interfaces min-tx-interval 100 min-rx-interval 100 detect-multiplier 10
    #
    return 
  • Configuration file of Router C

    #
     sysname RouterC
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.4.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.3.2 255.255.255.0
    #
    rip 1
     version 2  
     network 192.168.3.0
     network 192.168.4.0
    #
    return
  • Configuration file of Router D

    #
     sysname RouterD
    #
    interface GigabitEthernet1/0/0
     ip address 172.16.1.2 255.255.255.0
    #
    rip 1 
     version 2 
     network 172.16.0.0
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174069

Views: 130526

Downloads: 274

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next