No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Unicast Routing

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring BFD for OSPF

Example for Configuring BFD for OSPF

Networking Requirements

As shown in Figure 5-41, it is required as follows:

  • Run OSPF between Router A, Router B, and Router C.

  • Enable BFD of the OSPF process on Router A, Router B, and Router C.

  • Traffic is transmitted on the active link Router A -> Router B. The link Router A -> Router C -> Router B acts as the standby link.

  • BFD of the interface is configured on the link between Router A and Router B. When a fault occurs on the link, BFD can quickly detect the fault and notify OSPF of the fault; therefore, the traffic is transmitted on the standby link.

Figure 5-41 Networking diagram for configuring BFD for OSPF

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable the basic OSPF functions on each router.

  2. Enable global BFD.

  3. Enable the detection mechanism on Router A and Router B.

Procedure

  1. Assign an IP address to each router interface.

    # Configure IP addresses for all interfaces of RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.1.1.1 255.255.255.0
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 10.3.3.1 255.255.255.0
    [RouterA-GigabitEthernet2/0/0] quit

    The configurations of RouterB and RouterC are similar to the configuration of RouterA, and are not mentioned here.

  2. Configure the basic OSPF functions.

    # Configure Router A.

    [RouterA] router id 10.1.1.1
    [RouterA] ospf
    [RouterA-ospf-1] area 0
    [RouterA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] network 10.3.3.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] quit
    [RouterA-ospf-1] quit

    # Configure Router B.

    [RouterB] router id 10.2.2.2
    [RouterB] ospf
    [RouterB-ospf-1] area 0
    [RouterB-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.0] network 10.3.3.0 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.0] network 172.16.1.0 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.0] quit
    [RouterB-ospf-1] quit

    # Configure Router C.

    [RouterC] router id 10.3.3.3
    [RouterC] ospf
    [RouterC-ospf-1] area 0
    [RouterC-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [RouterC-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255
    [RouterC-ospf-1-area-0.0.0.0] quit
    [RouterC-ospf-1] quit

    # After the preceding configurations are complete, run the display ospf peer command. You can view that the neighboring relationship is set up between Router A, Router B, and Router C. Take the display of Router A as an example:

    <RouterA> display ospf peer
    
    
              OSPF Process 1 with Router ID 10.1.1.1
                      Neighbors
    
    
     Area 0.0.0.0 interface 10.1.1.1(GigabitEthernet1/0/0)'s neighbors
     Router ID: 10.3.3.3          Address: 10.1.1.2          
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 10.1.1.1  BDR: 10.1.1.2  MTU: 0
       Dead timer due in 38  sec
       Retrans timer interval: 5
       Neighbor is up for 00:00:15
       Authentication Sequence: [ 0 ]
    
    
                      Neighbors
    
    
     Area 0.0.0.0 interface 10.3.3.1(GigabitEthernet2/0/0)'s neighbors
     Router ID: 10.2.2.2          Address: 10.3.3.2          
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 10.3.3.1  BDR: 10.3.3.2  MTU: 0
       Dead timer due in 25  sec
       Retrans timer interval: 5
       Neighbor is up for 00:00:59
       Authentication Sequence: [ 0 ]

    # Display the information in the OSPF routing table on Router A. You can view the routing entries to Router B and Router C. The next hop address of the route to 172.16.1.0/24 is 10.3.3.2 and traffic is transmitted on the active link Router A -> Router B.

    <RouterA> display ospf routing
    
    
              OSPF Process 1 with Router ID 10.1.1.1
                       Routing Tables
    
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     172.16.1.0/24      2     Transit    10.3.3.2         10.2.2.2         0.0.0.0
     10.3.3.0/24         1     Transit    10.3.3.1         10.1.1.1         0.0.0.0
     10.2.2.0/24         2     Transit    10.3.3.2         10.2.2.2         0.0.0.0
     10.2.2.0/24         2     Transit    10.1.1.2         10.2.2.2         0.0.0.0
     10.1.1.0/24         1     Transit    10.1.1.1         10.1.1.1         0.0.0.0
    
    
     Total Nets: 5
     Intra Area: 5  Inter Area: 0  ASE: 0  NSSA: 0

  3. Configure OSPF BFD.

    # Enable global BFD on Router A.

    [RouterA] bfd
    [RouterA-bfd] quit
    [RouterA] ospf
    [RouterA-ospf-1] bfd all-interfaces enable
    [RouterA-ospf-1] quit

    # Enable global BFD on Router B.

    [RouterB] bfd
    [RouterB-bfd] quit
    [RouterB] ospf
    [RouterB-ospf-1] bfd all-interfaces enable
    [RouterB-ospf-1] quit

    # Enable global BFD on Router C.

    [RouterC] bfd
    [RouterC-bfd] quit
    [RouterC] ospf
    [RouterC-ospf-1] bfd all-interfaces enable
    [RouterC-ospf-1] quit

    # After the preceding configurations are complete, run the display ospf bfd session all command on Router A or Router B. You can view that the status of the BFD session is Up.

    Take the display of Router A as an example:

    [RouterA] display ospf bfd session all
    
    
              OSPF Process 1 with Router ID 10.1.1.1
      Area 0.0.0.0 interface 10.1.1.1(GigabitEthernet1/0/0)'s BFD Sessions
    
    
     NeighborId:10.3.3.3          AreaId:0.0.0.0          Interface:GigabitEthernet1/0/0
     BFDState:up            rx    :500             tx       :500
     Multiplier:4                BFD Local Dis:8195      LocalIpAdd:10.1.1.1
     RemoteIpAdd:10.1.1.2         Diagnostic Info:No diagnostic information
    
    
      Area 0.0.0.0 interface 10.3.3.1(GigabitEthernet2/0/0)'s BFD Sessions
    
    
     NeighborId:10.2.2.2          AreaId:0.0.0.0          Interface:GigabitEthernet2/0/0
     BFDState:up            rx    :500             tx       :500
     Multiplier:4                BFD Local Dis:8194      LocalIpAdd:10.3.3.1
     RemoteIpAdd:10.3.3.2         Diagnostic Info:No diagnostic information

  4. Configure BFD of the interface.

    # Configure BFD on GE 2/0/0 of Router A, set the minimum interval for sending the packets and the minimum interval for receiving the packets to 500 ms, and set the local detection time multiple to 4.

    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] ospf bfd enable
    [RouterA-GigabitEthernet2/0/0] ospf bfd min-tx-interval 500 min-rx-interval 500 detect-multiplier 4
    [RouterA-GigabitEthernet2/0/0] quit

    # Configure BFD on GE 2/0/0 of Router B, set the minimum interval for sending the packets and the minimum interval for receiving the packets to 500 ms, and set the local detection time multiple to 4.

    [RouterB] interface gigabitethernet 2/0/0
    [RouterB-GigabitEthernet2/0/0] ospf bfd enable
    [RouterB-GigabitEthernet2/0/0] ospf bfd min-tx-interval 500 min-rx-interval 500 detect-multiplier 4
    [RouterB-GigabitEthernet2/0/0] quit

    # After the preceding configurations are complete, run the display ospf bfd session all command on Router A or Router B. You can view that the status of the BFD session is Up.

    Take the display of Router B as an example:

    [RouterB] display ospf bfd session all
              OSPF Process 1 with Router ID 10.2.2.2
      Area 0.0.0.0 interface 10.3.3.2(GigabitEthernet2/0/0)'s BFD Sessions
    
     NeighborId:10.1.1.1          AreaId:0.0.0.0          Interface: GigabitEthernet2/0/0
     BFDState:up                 rx    :500             tx       :500
     Multiplier:4                BFD Local Dis:8198      LocalIpAdd:10.3.3.2
     RemoteIpAdd:10.3.3.1         Diagnostic Info:No diagnostic information

  5. Verify the configuration.

    # Run the shutdown command on GE 2/0/0 of Router B to simulate the active link failure.

    [RouterB] interface gigabitethernet 2/0/0
    [RouterB-GigabitEthernet2/0/0] shutdown

    # Display the routing table on Router A. The standby link Router A -> Router C -> Router B takes effect after the active link fails. The next hop address of the route to 172.16.1.0/24 becomes 10.1.1.2.

    <RouterA> display ospf routing
    
    
              OSPF Process 1 with Router ID 10.1.1.1
                       Routing Tables
    
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     172.16.1.0/24      3     Transit    10.1.1.2         10.2.2.2         0.0.0.0
     10.3.3.0/24         1     Transit    10.3.3.1         10.1.1.1         0.0.0.0
     10.2.2.0/24         2     Transit    10.1.1.2         10.2.2.2         0.0.0.0
     10.1.1.0/24         1     Transit    10.1.1.1         10.1.1.1         0.0.0.0
    
    
     Total Nets: 4
     Intra Area: 4  Inter Area: 0  ASE: 0  NSSA: 0
    
    

Configuration Files

  • Configuration file of Router A

    #
     sysname RouterA
    #
    router id 10.1.1.1
    #
     bfd
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.3.3.1 255.255.255.0
     ospf bfd enable
     ospf bfd min-tx-interval 500 min-rx-interval 500 detect-multiplier 4
    #
    ospf 1
     bfd all-interfaces enable
     area 0.0.0.0
      network 10.3.3.0 0.0.0.255
      network 10.1.1.0 0.0.0.255
    #
    return
  • Configuration file of Router B

    #
     sysname RouterB
    #
    router id 10.2.2.2
    #
     bfd
    #
     interface GigabitEthernet1/0/0
     ip address 10.2.2.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.3.3.2 255.255.255.0
     ospf bfd enable
     ospf bfd min-tx-interval 500 min-rx-interval 500 detect-multiplier 4
    #
    interface GigabitEthernet3/0/0
     ip address 172.16.1.1 255.255.255.0
    #
    ospf 1
     bfd all-interfaces enable
     area 0.0.0.0
      network 10.3.3.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
      network 172.16.1.0 0.0.0.255
    #
    return
  • Configuration file of Router C

    #
     sysname RouterC
    #
    router id 10.3.3.3
    #
     bfd
    #
     interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.2.2.1 255.255.255.0
     #
    ospf 1
     bfd all-interfaces enable
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174069

Views: 128800

Downloads: 274

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next