No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Network Management and Monitoring

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the LSP Ping Test for a Common Tunnel

Example for Configuring the LSP Ping Test for a Common Tunnel

Networking Requirements

In Figure 7-33:

  • The OSPF protocol runs on Router A, Router B, and Router C. The three Routers learn the 32-bit host routes on their loopback interfaces.

  • MPLS and MPLS LDP are enabled on Router A, Router B, and Router C.

  • MPLS and MPLS LDP are enabled on GE interfaces connected to Router A, Router B, and Router C to trigger the establishment of an LDP LSP.

The NQA LSP Ping test needs to be performed to check the connectivity of the LSP between Router A and Router C.

Figure 7-33  Networking diagram for configuring the LSP Ping test

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure Router A as the NQA client.

  2. Configure Router C as the NQA server.

  3. Create an LSP Ping test on Router A.

Procedure

  1. Configure reachable routes between Router A and Router B, between Router A and Router C, and between Router B and Router C. The configuration details are not mentioned here.
  2. Configure LDP on RouterA, RouterB, and RouterC. (The detailed procedure is not mentioned here.)

    For the configuration of LDP, refer to the Huawei AR Series Access Routers Configuration Guide - MPLS.

  3. Configure Router A.

    # Enable the NQA client and create an LSP Ping test for a common tunnel.

    <RouterA> system-view
    [RouterA] nqa test-instance admin lspping
    [RouterA-nqa-admin-lspping] test-type lspping
    [RouterA-nqa-admin-lspping] lsp-type ipv4
    [RouterA-nqa-admin-lspping] destination-address ipv4 10.3.3.9 lsp-masklen 32

  4. Perform the test.

    [RouterA-nqa-admin-lspping] start now

  5. Verify the configuration.

    [RouterA-nqa-admin-lspping] display nqa results test-instance admin lspping
     NQA entry(admin, lspping) :testflag is inactive ,testtype is  lspping
      1 . Test 1 result   The test is finished
       Send operation times: 3              Receive response times: 3
       Completion:success                   RTD OverThresholds number: 0
       Attempts number:1                    Drop operation number:0
       Disconnect operation number:0        Operation timeout number:0
       System busy operation number:0       Connection fail number:0
       Operation sequence errors number:0   RTT Status errors number:0
       Destination ip address:10.3.3.9
       Min/Max/Average Completion Time: 3/9/7
       Sum/Square-Sum  Completion Time: 21/171
       Last Good Probe Time: 2012-11-16 21:52:57.3
       Lost packet ratio: 0 %    

Configuration Files

  • RouterA configuration file

    #
    sysname RouterA
    #
     mpls lsr-id 10.1.1.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 10.1.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.1.9 0.0.0.0
    #
    nqa test-instance admin lspping
     test-type lspping
     destination-address ipv4 10.3.3.9 lsp-masklen 32
    #
    return
  • RouterB configuration file

    #
    sysname RouterB
    #
     mpls lsr-id 10.2.2.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 10.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.2.2.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
  • RouterC configuration file

    #
    sysname RouterC
    #
     mpls lsr-id 10.3.3.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 10.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.3.3.9 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174072

Views: 108570

Downloads: 346

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next