No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Network Management and Monitoring

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an SNMP Query Test Instance

Example for Configuring an SNMP Query Test Instance

Networking Requirements

In Figure 7-24, SNMP agent is enabled on RouterA and RouterC. An NQA SNMP query test needs to be performed to obtain the time from when RouterA sends an SNMPv3 query packet to when RouterA receives an Echo packet.

Figure 7-24  Networking diagram for configuring an SNMP query test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure RouterA as an NQA client.

  2. Enable SNMP agent on RouterA.

  3. Create and start an SNMP query test instance on RouterA.

  4. Enable the SNMP agent on RouterC.

Procedure

  1. Configure an IP address for each interface and ensure reachable routes between Routers, as shown in Figure 7-24.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.1.1.1 24
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    NOTE:

    For configurations of RouterB and RouterC, see the configuration files.

  2. Enable SNMP agent on RouterC.

    <RouterC> system-view
    [RouterC] snmp-agent

  3. Enable SNMP agent on RouterA.

    [RouterA] snmp-agent

  4. Create an SNMP query test instance on RouterA.

    [RouterA] nqa test-instance admin snmp
    [RouterA-nqa-admin-snmp] test-type snmp
    [RouterA-nqa-admin-snmp] destination-address ipv4 10.2.1.2

  5. Start the test instance.

    [RouterA-nqa-admin-snmp] start now

  6. Verify the configuration.

    # Check NQA test results on RouterA.

    [RouterA-nqa-admin-snmp] display nqa results test-instance admin snmp
     NQA entry(admin, snmp) :testflag is inactive ,testtype is snmp
      1 . Test 1 result   The test is finished
       Send operation times: 3              Receive response times: 3
       Completion:success                   RTD OverThresholds number: 0
       Attempts number:0                    Drop operation number:0
       Disconnect operation number:0        Operation timeout number:0
       System busy operation number:0       Connection fail number:0
       Operation sequence errors number:0   RTT Status errors number:0
       Destination ip address:10.2.1.2
       Min/Max/Average Completion Time: 63/172/109
       Sum/Square-Sum  Completion Time: 329/42389
       Last Good Probe Time: 2012-7-25 15:33:49.1
       Lost packet ratio: 0 %                      

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin snmp
     test-type snmp
     destination-address ipv4 10.2.1.2
    #
    return
    
  • RouterB configuration file

    #
     sysname RouterB
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.2.1.1 255.255.255.0
    #
    return
    
  • RouterC configuration file

    #
     sysname RouterC
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.1.2 255.255.255.0
    #
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
    
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174072

Views: 103713

Downloads: 343

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next