No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Network Management and Monitoring

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a TCP Test Instance

Example for Configuring a TCP Test Instance

Networking Requirements

In Figure 7-25, an NQA TCP test needs to be performed on RouterA to obtain the duration for setting up a TCP connection with RouterC.

Figure 7-25  Networking diagram for configuring a TCP test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure RouterA as an NQA client and configure RouterC as an NQA server.

  2. Configure the monitoring port number on the NQA server and create an NQA TCP test instance on the NQA client.

Procedure

  1. Configure an IP address for each interface and ensure reachable routes between Routers, as shown in Figure 7-25.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.1.1.1 24
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    NOTE:

    For configurations of RouterB and RouterC, see the configuration files.

  2. Configure an NQA server on RouterC.

    # Configure the IP address and port number for monitoring TCP connections on the NQA server.

    <RouterC> system-view
    [RouterC] nqa-server tcpconnect 10.2.1.2 9000

  3. Configure the NQA client on RouterA.

    # Enable the NQA client and create a TCP test instance.

    [RouterA] nqa test-instance admin tcp
    [RouterA-nqa-admin-tcp] test-type tcp
    [RouterA-nqa-admin-tcp] destination-address ipv4 10.2.1.2
    [RouterA-nqa-admin-tcp] destination-port 9000 

  4. Start the test instance.

    [RouterA-nqa-admin-tcp] start now

  5. Check the configuration.

    # Check NQA test results on RouterA.

    [RouterA-nqa-admin-tcp] display nqa results test-instance admin tcp
     NQA entry(admin, tcp) :testflag is inactive ,testtype is tcp
      1 . Test 1 result   The test is finished
       Send operation times: 3              Receive response times: 3
       Completion:success                   RTD OverThresholds number: 0
       Attempts number:1                    Drop operation number:0
       Disconnect operation number:0        Operation timeout number:0
       System busy operation number:0       Connection fail number:0
       Operation sequence errors number:0   RTT Status errors number:0
       Destination ip address:10.2.1.2
       Min/Max/Average Completion Time: 46/63/52
       Sum/Square-Sum  Completion Time: 156/8294
       Last Good Probe Time: 2012-7-25 16:23:49.1
       Lost packet ratio: 0 %                      

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin tcp
     test-type tcp
     destination-address ipv4 10.2.1.2
     destination-port 9000
    #
    return
    
  • RouterB configuration file

    #
     sysname RouterB
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.2.1.1 255.255.255.0
    #
    return
    
  • RouterC configuration file

    #
     sysname RouterC
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.1.2 255.255.255.0
    #
    nqa-server tcpconnect 10.2.1.2 9000
    #
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
    
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174072

Views: 101662

Downloads: 335

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next