No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Network Management and Monitoring

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IP FPM End-to-End Performance Measurement

Example for Configuring IP FPM End-to-End Performance Measurement

This section provides an example for configuring IP FPM end-to-end packet loss and delay measurement on an IP Radio Access Network (IP RAN) network.

Networking Requirements

As networks rapidly develop and applications become diversified, various value-added services are widely used. Link connectivity and network performance influence network quality. Therefore, performance monitoring is especially important for service transmission.
  • For example, users will not sense any change in voice quality if the packet loss rate on voice links is lower than 5%. However, when the packet loss rate is higher than 10%, user experience obviously degrades.

  • The real-time services such as Voice over Internet Protocol (VoIP), online gaming, and online video require the delay lower than 100 ms. Some delay-sensitive services even require that the delay be lower than 50 ms. Otherwise, user experience will degrade.

To meet high requirements for voice, online gaming, and online video on the network, carriers should be able to monitor the packet loss and delay of the links. They can adjust the links if service quality decreases.

The IP RAN in Figure 4-11 carries voice services. A voice service flow is a bidirectional symmetrical flow, so is divided into two unidirectional flows logically. The forward service flow enters the network through the UPE, travels across SPEs, and leaves the network through the NPE. The backward service flow enters the network through the NPE, also travels across SPEs, and leaves the network through the UPE.

Figure 4-11  IP FPM networking
Table 4-3  IP FPM Parameter Configuration

Device (Role)

Interface

Peer Device (Role)

IP Address

UPE (DCP1/MCP)

Loopback1

-

1.1.1.1/32

GE1/0/0

NodeB

10.1.1.1/24

GE0/0/0

SPE1

172.16.1.1/24

GE0/0/1

SPE2

172.16.2.1/24

SPE1

Loopback1

-

2.2.2.2/32

GE0/0/0

UPE (DCP1/MCP)

172.16.1.2/24

GE0/0/1

NPE (DCP2)

172.16.4.1/24

GE0/0/2

SPE2

172.16.3.1/24

SPE2

Loopback1

-

3.3.3.3/32

GE0/0/0

NPE (DCP2)

172.16.5.1/24

GE0/0/1

UPE (DCP1/MCP)

172.16.2.2/24

GE0/0/2

SPE1

172.16.3.2/24

NPE (DCP2)

Loopback1

-

4.4.4.4/32

GE0/0/0

SPE2

172.16.5.2/24

GE0/0/1

SPE1

172.16.4.2/24

GE0/0/2

RNC

10.2.1.1/24

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure an IP address and a routing protocol for each interface so that all devices can communicate at the network layer. This example uses Open Shortest Path First (OSPF) as the routing protocol.

  2. Configure Multiprotocol Label Switching (MPLS) and public network tunnels to carry L3VPN services. In this example, RSVP-TE tunnels are established between the UPE and SPEs, and LDP-LSP tunnels are established between the SPEs and between the SPEs and NPE.

  3. Create a VPN instance on the UPE and NPE, and import local direct routes on the UPE and NPE.

  4. Establish Multiprotocol Interior Border Gateway Protocol (MP-IBGP) peer relationships between the UPE and SPEs, and between the NPE and SPEs.

  5. Configure SPEs as route reflectors (RRs) and specify the UPE and NPE as RR clients.

  6. Configure VPN fast route (FRR) on the UPE and NPE to improve network reliability.

  7. Configure Network Time Protocol (NTP) to implement clock synchronization among the UPE, SPEs, and NPE.

  8. Configure continuous packet loss and delay measurement on the link between the UPE and NPE to collect packet loss and delay statistics at intervals.

Data Preparation

To complete the configuration, you need the following data:
  • IP address of each interface listed in Table 4-3.

  • IGP (OSPD), process ID (1), and area ID (0).

  • Label switching router (LSR) IDs of the UPE (1.1.1.1), SPE1 (2.2.2.2), SPE2 (3.3.3.3), and NPE (4.4.4.4).

  • Tunnel interface names (Tunnel0/0/0), tunnel IDs (100), and tunnel interface addresses (loopback interface addresses) for forward and backward tunnels between the UPE and SPE1. Tunnel interface names (Tunnel0/0/1), tunnel IDs (200), and tunnel interface addresses (loopback interface addresses) for forward and backward tunnels between the UPE and SPE2. Tunnel policy names (policy1) for the tunnels between the UPE and SPEs and tunnel selector names (BindTE) on the SPEs.

  • Name of the VPN instance (vpna), RD (100:1), and VPN target (1:1) created on the UPE and NPE

  • UPE functions as the NTP master clock, and its clock stratum is 1; the clock synchronization interval for the UPE, SPE, and NPE is 180s; the time difference (offset) between the clocks of server and client is 50s; the maximum polling time is 64s.

  • UPE's DCP ID and MCP ID (both 1.1.1.1); NPE's DCP ID (4.4.4.4).

  • IP FPM instance ID (1) and statistical period (10s).

  • Forward target flow's source IP address (10.1.1.2) and destination IP address (10.2.1.2); backward target flow's source IP address (10.2.1.2) and destination IP address (10.1.1.2).

  • Measurement points (TLP100 and TLP310).

  • The third and forth color bits in the Type of Service (ToS) field of an IPv4 packet header are used for packet loss measurement and delay measurement respectively.
    NOTE:

    You can use several fixed bits of the IPv4 packet header as the color bits, including the third to seventh bits in the ToS field and bit 0 in the Flags field. If two or more bits in packets are reserved, IP FPM can measure both packet loss rate and delay. If only one bit is reserved, IP FPM can only measure either packet loss rate or delay.

    For details on IP FPM color bits, see Color Bits.

  • Authentication mode (HMAC-SHA256), password (Huawei-123), key ID (1), and UDP port number (2048) on the UPE and NPE.

Procedure

  1. Configure an IP address for each interface.

    Configure an IP address for each interface according to Table 4-3 and create a loopback interface on each node. For configuration details, see Configuration Files in this section.

  2. Configure OSPF.

    Configure the OSPF protocol on each device so that the devices can communicate at the network layer. For configuration details, see Configuration Files in this section.

  3. Configure basic MPLS functions and public network tunnels.

    • Configure basic MPLS functions and enable MPLS TE, RSVP-TE, and Constrained Shortest Path First (CSPF).

      # Configure the UPE.

      [UPE] mpls lsr-id 1.1.1.1
      [UPE] mpls
      [UPE-mpls] mpls te
      [UPE-mpls] mpls rsvp-te
      [UPE-mpls] mpls te cspf
      [UPE-mpls] quit
      [UPE] interface gigabitethernet 0/0/0
      [UPE-GigabitEthernet0/0/0] mpls
      [UPE-GigabitEthernet0/0/0] mpls te
      [UPE-GigabitEthernet0/0/0] mpls rsvp-te
      [UPE-GigabitEthernet0/0/0] quit
      [UPE] interface gigabitethernet 0/0/1
      [UPE-GigabitEthernet0/0/1] mpls
      [UPE-GigabitEthernet0/0/1] mpls te
      [UPE-GigabitEthernet0/0/1] mpls rsvp-te
      [UPE-GigabitEthernet0/0/1] quit
      [UPE] ospf 1
      [UPE-ospf-1] opaque-capability enable
      [UPE-ospf-1] area 0
      [UPE-ospf-1-area-0.0.0.0] mpls-te enable
      [UPE-ospf-1-area-0.0.0.0] quit
      [UPE-ospf-1] quit

      # Configure SPE1.

      [SPE1] mpls lsr-id 2.2.2.2
      [SPE1] mpls
      [SPE1-mpls] mpls te
      [SPE1-mpls] mpls rsvp-te
      [SPE1-mpls] mpls te cspf
      [SPE1-mpls] quit
      [SPE1] mpls ldp
      [SPE1-mpls-ldp] quit
      [SPE1] interface gigabitethernet 0/0/0
      [SPE1-GigabitEthernet0/0/0] mpls
      [SPE1-GigabitEthernet0/0/0] mpls te
      [SPE1-GigabitEthernet0/0/0] mpls rsvp-te
      [SPE1-GigabitEthernet0/0/0] quit
      [SPE1] interface gigabitethernet 0/0/2
      [SPE1-GigabitEthernet0/0/2] mpls
      [SPE1-GigabitEthernet0/0/2] mpls ldp
      [SPE1-GigabitEthernet0/0/2] quit
      [SPE1] ospf 1
      [SPE1-ospf-1] opaque-capability enable
      [SPE1-ospf-1] area 0
      [SPE1-ospf-1-area-0.0.0.0] mpls-te enable
      [SPE1-ospf-1-area-0.0.0.0] quit
      [SPE1-ospf-1] quit

      # Configure SPE2.

      [SPE2] mpls lsr-id 3.3.3.3
      [SPE2] mpls
      [SPE2-mpls] mpls te
      [SPE2-mpls] mpls rsvp-te
      [SPE2-mpls] mpls te cspf
      [SPE2-mpls] quit
      [SPE2] mpls ldp
      [SPE2-mpls-ldp] quit
      [SPE2] interface gigabitethernet 0/0/1
      [SPE2-GigabitEthernet0/0/1] mpls
      [SPE2-GigabitEthernet0/0/1] mpls te
      [SPE2-GigabitEthernet0/0/1] mpls rsvp-te
      [SPE2-GigabitEthernet0/0/1] quit
      [SPE2] interface gigabitethernet 0/0/2
      [SPE2-GigabitEthernet0/0/2] mpls
      [SPE2-GigabitEthernet0/0/2] mpls ldp
      [SPE2-GigabitEthernet0/0/2] quit
      [SPE2] ospf 1
      [SPE2-ospf-1] opaque-capability enable
      [SPE2-ospf-1] area 0
      [SPE2-ospf-1-area-0.0.0.0] mpls-te enable
      [SPE2-ospf-1-area-0.0.0.0] quit
      [SPE2-ospf-1] quit

      # Configure the NPE.

      [NPE] mpls lsr-id 4.4.4.4
      [NPE] mpls
      [NPE-mpls] quit
      [NPE] mpls ldp
      [NPE-mpls-ldp] quit
      [NPE] interface gigabitethernet 0/0/0
      [NPE-GigabitEthernet0/0/0] mpls
      [NPE-GigabitEthernet0/0/0] mpls ldp
      [NPE-GigabitEthernet0/0/0] quit
      [NPE] interface gigabitethernet 0/0/1
      [NPE-GigabitEthernet0/0/1] mpls
      [NPE-GigabitEthernet0/0/1] mpls ldp
      [NPE-GigabitEthernet0/0/1] quit
    • Enable the egress node of each unidirectional tunnel to assign labels to the penultimate hop.

      # Configure the UPE.
      [UPE] mpls
      [UPE-mpls] label advertise non-null
      [UPE-mpls] quit
      # Configure SPE1.
      [SPE1] mpls
      [SPE1-mpls] label advertise non-null
      [SPE1-mpls] quit
      # Configure SPE2.
      [SPE2] mpls
      [SPE2-mpls] label advertise non-null
      [SPE2-mpls] quit
    • Configure MPLS TE tunnel interfaces.

      # Configure the UPE.

      [UPE] interface tunnel 0/0/0
      [UPE-Tunnel0/0/0] ip address unnumbered interface loopback 1
      [UPE-Tunnel0/0/0] tunnel-protocol mpls te
      [UPE-Tunnel0/0/0] destination 2.2.2.2
      [UPE-Tunnel0/0/0] mpls te tunnel-id 100
      [UPE-Tunnel0/0/0] mpls te signal-protocol rsvp-te
      [UPE-Tunnel0/0/0] mpls te reserved-for-binding
      [UPE-Tunnel0/0/0] mpls te commit
      [UPE-Tunnel0/0/0] quit
      [UPE] interface tunnel 0/0/1
      [UPE-Tunnel0/0/1] ip address unnumbered interface loopback 1
      [UPE-Tunnel0/0/1] tunnel-protocol mpls te
      [UPE-Tunnel0/0/1] destination 3.3.3.3
      [UPE-Tunnel0/0/1] mpls te tunnel-id 200
      [UPE-Tunnel0/0/1] mpls te signal-protocol rsvp-te
      [UPE-Tunnel0/0/1] mpls te reserved-for-binding
      [UPE-Tunnel0/0/1] mpls te commit
      [UPE-Tunnel0/0/1] quit

      # Configure SPE1.

      [SPE1] interface tunnel 0/0/0
      [SPE1-Tunnel0/0/0] ip address unnumbered interface loopback 1
      [SPE1-Tunnel0/0/0] tunnel-protocol mpls te
      [SPE1-Tunnel0/0/0] destination 1.1.1.1
      [SPE1-Tunnel0/0/0] mpls te tunnel-id 100
      [SPE1-Tunnel0/0/0] mpls te signal-protocol rsvp-te
      [SPE1-Tunnel0/0/0] mpls te reserved-for-binding
      [SPE1-Tunnel0/0/0] mpls te commit
      [SPE1-Tunnel0/0/0] quit

      # Configure SPE2.

      [SPE2] interface tunnel 0/0/1
      [SPE2-Tunnel0/0/1] ip address unnumbered interface loopback 1
      [SPE2-Tunnel0/0/1] tunnel-protocol mpls te
      [SPE2-Tunnel0/0/1] destination 1.1.1.1
      [SPE2-Tunnel0/0/1] mpls te tunnel-id 200
      [SPE2-Tunnel0/0/1] mpls te signal-protocol rsvp-te
      [SPE2-Tunnel0/0/1] mpls te reserved-for-binding
      [SPE2-Tunnel0/0/1] mpls te commit
      [SPE2-Tunnel0/0/1] quit
    • Configure tunnel policies.

      # Configure the UPE.

      [UPE] tunnel-policy policy1
      [UPE-tunnel-policy-policy1] tunnel binding destination 2.2.2.2 te tunnel 0/0/0
      [UPE-tunnel-policy-policy1] tunnel binding destination 3.3.3.3 te tunnel 0/0/1
      [UPE-tunnel-policy-policy1] quit

      # Configure SPE1.

      [SPE1] tunnel-policy policy1
      [SPE1-tunnel-policy-policy1] tunnel binding destination 1.1.1.1 te tunnel 0/0/0
      [SPE1-tunnel-policy-policy1] quit

      # Configure SPE2.

      [SPE2] tunnel-policy policy1
      [SPE2-tunnel-policy-policy1] tunnel binding destination 1.1.1.1 te tunnel 0/0/1
      [SPE2-tunnel-policy-policy1] quit

  4. Create a VPN instance on the UPE and NPE, and import local direct routes on the UPE and NPE.

    # Configure the UPE.

    [UPE] ip vpn-instance vpna
    [UPE-vpn-instance-vpna] ipv4-family
    [UPE-vpn-instance-vpna-af-ipv4] route-distinguisher 100:1
    [UPE-vpn-instance-vpna-af-ipv4] vpn-target 1:1
    [UPE-vpn-instance-vpna-af-ipv4] quit
    [UPE-vpn-instance-vpna] quit
    [UPE] interface gigabitethernet 1/0/0
    [UPE-GigabitEthernet1/0/0] ip binding vpn-instance vpna
    [UPE-GigabitEthernet1/0/0] ip address 10.1.1.1 24
    [UPE-GigabitEthernet1/0/0] quit
    [UPE] bgp 100
    [UPE-bgp] ipv4-family vpn-instance vpna
    [UPE-bgp-vpna] import-route direct
    [UPE-bgp-vpna] quit
    [UPE-bgp] quit

    # Configure the NPE.

    [NPE] ip vpn-instance vpna
    [NPE-vpn-instance-vpna] ipv4-family
    [NPE-vpn-instance-vpna-af-ipv4] route-distinguisher 100:1
    [NPE-vpn-instance-vpna-af-ipv4] vpn-target 1:1
    [NPE-vpn-instance-vpna-af-ipv4] quit
    [NPE-vpn-instance-vpna] quit
    [NPE] interface gigabitethernet 0/0/2
    [NPE-GigabitEthernet0/0/2] ip binding vpn-instance vpna
    [NPE-GigabitEthernet0/0/2] ip address 10.2.1.1 24
    [NPE-GigabitEthernet0/0/2] quit
    [NPE] bgp 100
    [NPE-bgp] ipv4-family vpn-instance vpna
    [NPE-bgp-vpna] import-route direct
    [NPE-bgp-vpna] quit
    [NPE-bgp] quit

  5. Configure MP-IBGP peer relationships between the UPE and SPEs, and between the NPE and SPEs.

    # Configure the UPE.

    [UPE] bgp 100
    [UPE-bgp] router-id 1.1.1.1
    [UPE-bgp] peer 2.2.2.2 as-number 100
    [UPE-bgp] peer 2.2.2.2 connect-interface loopback 1
    [UPE-bgp] peer 3.3.3.3 as-number 100
    [UPE-bgp] peer 3.3.3.3 connect-interface loopback 1
    [UPE-bgp] ipv4-family vpnv4
    [UPE-bgp-af-vpnv4] peer 2.2.2.2 enable
    [UPE-bgp-af-vpnv4] peer 3.3.3.3 enable
    [UPE-bgp-af-vpnv4] quit
    [UPE-bgp] quit

    # Configure SPE1.

    [SPE1] bgp 100
    [SPE1-bgp] router-id 2.2.2.2
    [SPE1-bgp] peer 1.1.1.1 as-number 100
    [SPE1-bgp] peer 1.1.1.1 connect-interface loopback 1
    [SPE1-bgp] peer 3.3.3.3 as-number 100
    [SPE1-bgp] peer 3.3.3.3 connect-interface loopback 1
    [SPE1-bgp] peer 4.4.4.4 as-number 100
    [SPE1-bgp] peer 4.4.4.4 connect-interface loopback 1
    [SPE1-bgp] ipv4-family vpnv4
    [SPE1-bgp-af-vpnv4] undo policy vpn-target
    [SPE1-bgp-af-vpnv4] peer 1.1.1.1 enable
    [SPE1-bgp-af-vpnv4] peer 3.3.3.3 enable
    [SPE1-bgp-af-vpnv4] peer 4.4.4.4 enable
    [SPE1-bgp-af-vpnv4] quit
    [SPE1-bgp] quit

    The configuration for SPE2 is similar to that for SPE1. For configuration details, see Configuration Files in this section.

    # Configure the NPE.

    [NPE] bgp 100
    [NPE-bgp] router-id 4.4.4.4
    [NPE-bgp] peer 2.2.2.2 as-number 100
    [NPE-bgp] peer 2.2.2.2 connect-interface loopback 1
    [NPE-bgp] peer 3.3.3.3 as-number 100
    [NPE-bgp] peer 3.3.3.3 connect-interface loopback 1
    [NPE-bgp] ipv4-family vpnv4
    [NPE-bgp-af-vpnv4] peer 2.2.2.2 enable
    [NPE-bgp-af-vpnv4] peer 3.3.3.3 enable
    [NPE-bgp-af-vpnv4] quit
    [NPE-bgp] quit

  6. Configure SPEs as RRs and specify the UPE and NPE as RR clients. The following example uses SPE1.

    [SPE1] bgp 100
    [SPE1-bgp] ipv4-family vpnv4
    [SPE1-bgp-af-vpnv4] peer 1.1.1.1 reflect-client
    [SPE1-bgp-af-vpnv4] peer 1.1.1.1 next-hop-local
    [SPE1-bgp-af-vpnv4] peer 4.4.4.4 reflect-client
    [SPE1-bgp-af-vpnv4] peer 4.4.4.4 next-hop-local
    [SPE1-bgp-af-vpnv4] quit
    [SPE1-bgp] quit

  7. Configure a tunnel policy on the UPE and a tunnel selector on each SPE to bind the TE tunnels between the UPE and SPEs.

    # Configure a tunnel policy on the UPE.

    [UPE] ip vpn-instance vpna
    [UPE-vpn-instance-vpna] ipv4-family
    [UPE-vpn-instance-vpna-af-ipv4] route-distinguisher 100:1
    [UPE-vpn-instance-vpna-af-ipv4] tnl-policy policy1
    [UPE-vpn-instance-vpna-af-ipv4] quit
    [UPE-vpn-instance-vpna] quit

    # As no VPN instance is configured on SPEs, configure tunnel selectors on the SPEs bind TE tunnels. The following example uses SPE1.

    [SPE1] tunnel-selector bindTE permit node 10
    [SPE1-tunnel-selector] apply tunnel-policy policy1
    [SPE1-tunnel-selector] quit
    [SPE1] bgp 100
    [SPE1-bgp] ipv4-family vpnv4
    [SPE1-bgp-af-vpnv4] tunnel-selector bindTE
    [SPE1-bgp-af-vpnv4] quit

    The configuration for SPE2 is similar to that for SPE1. For configuration details, see Configuration Files in this section.

  8. Configure VPN FRR on the UPE and NPE to improve network reliability.

    # Configure the VPN FRR function on the UPE and NPE. The following example uses UPE.

    [UPE] bgp 100
    [UPE-bgp] ipv4-family vpn-instance vpna
    [UPE-bgp-vpna] auto-frr
    [UPE-bgp-vpna] quit
    [UPE-bgp] quit

    After completing the configurations, run the display bgp vpnv4 vpn-instance vpna routing-table command on the UPE and NPE to view detailed information about received routes.
    [UPE] display bgp vpnv4 vpn-instance vpna routing-table
     BGP Local router ID is 1.1.1.1
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
     VPN-Instance vpna, Router ID 1.1.1.1:
    
     Total Number of Routes: 4
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
     *>   10.1.1.0/24       0.0.0.0         0                     0      ?
     *>   10.1.1.1/32       0.0.0.0         0                     0      ?
     *>i  10.2.1.0/24       2.2.2.2        0          100        0      ?
     * i                     4.4.4.4         0          100        0      ? 
    [NPE] display bgp vpnv4 vpn-instance vpna routing-table
     BGP Local router ID is 4.4.4.4
     Status codes: * - valid, > - best, d - damped,
                   h - history,  i - internal, s - suppressed, S - Stale
                   Origin : i - IGP, e - EGP, ? - incomplete
    
    
     VPN-Instance vpna, Router ID 4.4.4.4:
    
     Total Number of Routes: 4
          Network            NextHop        MED        LocPrf    PrefVal Path/Ogn
    
     *>i  10.1.1.0/24       2.2.2.2        0          100        0      ?
     * i                     4.4.4.4         0          100        0      ?
     *>   10.2.1.0/24       0.0.0.0         0                     0      ?
     *>   10.2.1.1/32       0.0.0.0         0                     0      ?

    The command output shows that both the UPE and NPE preferentially select the routes advertised by SPE1 and use UPE-SPE1-NPE as the primary path.

  9. Configure NTP to implement clock synchronization among the UPE, SPE1, and NPE.

    # Configure the UPE.
    [UPE] ntp-service refclock-master 2
    # Configure SPE1.
    [SPE1] ntp-service unicast-server 172.16.1.1
    # Configure the NPE.
    [NPE] ntp-service unicast-server 172.16.4.1

    After completing the configurations, run the display ntp-service status command on the UPE, SPE1, and NPE to view information about clock synchronization.

    Check the NTP status on the UPE. The command output shows that the clock status is synchronized, which means that synchronization is complete.
    [UPE] display ntp-service status
     clock status: synchronized
     clock stratum: 2
     reference clock ID: LOCAL(0)
     nominal frequency: 100.0000 Hz
     actual frequency: 100.0000 Hz
     clock precision: 2^18
     clock offset: 0.0000 ms
     root delay: 0.00 ms
     root dispersion: 10.95 ms
     peer dispersion: 10.00 ms
     reference time: 16:46:27.496 UTC Jun 24 2017(DCF915E3.7F2A9D62)
    Check the NTP status on SPE1. The command output shows that the clock status is synchronized, which means that synchronization is complete. The clock stratum is 2, lower than that of the UPE.
    [SPE1] display ntp-service status
     clock status: synchronized
     clock stratum: 3
     reference clock ID: 172.16.1.1
     nominal frequency: -nan Hz
     actual frequency: -nan Hz
     clock precision: 2^15
     clock offset: -1.1605 ms
     root delay: 1.51 ms
     root dispersion: -nan ms
     peer dispersion: 0.00 ms
     reference time: 16:45:53.064 UTC Jun 24 2017(DCF915C1.107314CA)
    Check the NTP status on the NPE. The command output shows that the clock status is synchronized, which means that synchronization is complete. The clock stratum is 3, lower than that of the UPE.
    [NPE] display ntp-service status
     clock status: synchronized
     clock stratum: 4
     reference clock ID: 172.16.4.1
     nominal frequency: 100.0000 Hz
     actual frequency: 100.0000 Hz
     clock precision: 2^18
     clock offset: 0.0025 ms
     root delay: 2.46 ms
     root dispersion: 32.52 ms
     peer dispersion: 22.37 ms
     reference time: 16:47:26.933 UTC Jun 24 2017(DCF9161E.EEE8F29D)

  10. Configure continuous packet loss and delay measurement on the link between the UPE and NPE. Configure the NPE as the DCP and TLP 310 on the NPE; configure the UPE as the DCP and also an MCP and configure TLP 100 on the UPE.

    # Configure the UPE.
    • Configure the MCP.
      [UPE] nqa ipfpm mcp
      [UPE-nqa-ipfpm-mcp] mcp id 1.1.1.1
      [UPE-nqa-ipfpm-mcp] protocol udp port 2048
      [UPE-nqa-ipfpm-mcp] authentication-mode hmac-sha256 key-id 1 cipher Huawei-123
      [UPE-nqa-ipfpm-mcp] instance 1
      [UPE-nqa-ipfpm-mcp-instance-1] dcp 1.1.1.1
      [UPE-nqa-ipfpm-mcp-instance-1] dcp 4.4.4.4
      [UPE-nqa-ipfpm-mcp-instance-1] quit
      [UPE-nqa-ipfpm-mcp] quit
      After completing the configurations, run the display ipfpm mcp command on the UPE. The command output shows MCP configurations and status on the UPE.
      [UPE] display ipfpm mcp
      Specification Information:
       Max Instance Number                       :4000
       Max DCP Number Per Instance               :1000
      
      Configuration Information:
       MCP ID                                    :1.1.1.1
       Status                                    :Active
       Protocol Port                             :2048
       Current Instance Number                   :1 
    • Configure the DCP.
      [UPE] nqa ipfpm dcp
      [UPE-nqa-ipfpm-dcp] dcp id 1.1.1.1
      [UPE-nqa-ipfpm-dcp] authentication-mode hmac-sha256 key-id 1 cipher Huawei-123
      [UPE-nqa-ipfpm-dcp] color-flag loss-measure tos-bit 3 delay-measure tos-bit 4
      [UPE-nqa-ipfpm-dcp] mcp 1.1.1.1 port 2048
      [UPE-nqa-ipfpm-dcp] instance 1
      [UPE-nqa-ipfpm-dcp-instance-1] interval 10
      [UPE-nqa-ipfpm-dcp-instance-1] flow bidirectional source 10.1.1.2 destination 10.2.1.2
      [UPE-nqa-ipfpm-dcp-instance-1] tlp 100 in-point ingress
      [UPE-nqa-ipfpm-dcp-instance-1] quit
      [UPE-nqa-ipfpm-dcp] quit
      After completing the configurations, run the display ipfpm dcp command on the UPE. The command output shows DCP configurations on the UPE.
      [UPE] display ipfpm dcp
      Specification Information(Main Board):
       Max Instance Number                       :16384
       Max 10s Instance Number                   :16384
       Max TLP Number                            :2048
       Max TLP Number Per Instance               :16
      
      Specification Information(IO Board):
       Board ID:1
       Max 1s Instance Number                    :256
       Max non-1s Instance Number                :2048
       Max TLP Number                            :2048
      
      Configuration Information:
       DCP ID                                    : 1.1.1.1
       Loss-measure Flag                         : tos-bit3
       Delay-measure Flag                        : tos-bit4
       Authentication Mode                       : hmac-sha256
       Test Instances MCP ID                     : 1.1.1.1
       Test Instances MCP Port                   : 2048
       Current Instance Number                   : 1 
    • Bind the TLP to an interface.
      [UPE] interface GigabitEthernet1/0/0
      [UPE-GigabitEthernet1/0/0] ipfpm tlp 100
      [UPE-GigabitEthernet1/0/0] quit
    • Enable packet loss and delay measurement.
      [UPE] nqa ipfpm dcp
      [UPE-nqa-ipfpm-dcp] instance 1
      [UPE-nqa-ipfpm-dcp-instance-1] loss-measure enable continual
      [UPE-nqa-ipfpm-dcp-instance-1] delay-measure enable two-way tlp 100 continual
      [UPE-nqa-ipfpm-dcp-instance-1] quit
      [UPE-nqa-ipfpm-dcp] quit
    # Configure the NPE.
    • Configure the DCP.
      [NPE] nqa ipfpm dcp
      [NPE-nqa-ipfpm-dcp] dcp id 4.4.4.4
      [NPE-nqa-ipfpm-dcp] authentication-mode hmac-sha256 key-id 1 cipher Huawei-123
      [UPE-nqa-ipfpm-dcp] color-flag loss-measure tos-bit 3 delay-measure tos-bit 4
      [NPE-nqa-ipfpm-dcp] mcp 1.1.1.1 port 2048
      [NPE-nqa-ipfpm-dcp] instance 1
      [NPE-nqa-ipfpm-dcp-instance-1] interval 10
      [NPE-nqa-ipfpm-dcp-instance-1] flow bidirectional source 10.1.1.2 destination 10.2.1.2
      [NPE-nqa-ipfpm-dcp-instance-1] tlp 310 out-point egress
      [NPE-nqa-ipfpm-dcp-instance-1] quit
      [NPE-nqa-ipfpm-dcp] quit
      After completing the configurations, run the display ipfpm dcp command on the NPE. The command output shows DCP configurations on the NPE.
      [NPE] display ipfpm dcp
      Specification Information(Main Board):
       Max Instance Number                       :16384
       Max 10s Instance Number                   :16384
       Max 1s Instance Number                    :256
       Max TLP Number                            :2048
       Max TLP Number Per Instance               :16
      
      Specification Information(IO Board):
       Board ID:1
       Max 1s Instance Number                    :256
       Max non-1s Instance Number                :2048
       Max TLP Number                            :2048
      
      Configuration Information:
       DCP ID                                    : 4.4.4.4
       Loss-measure Flag                         : tos-bit3
       Delay-measure Flag                        : tos-bit4
       Authentication Mode                       : hmac-sha256
       Test Instances MCP ID                     : 1.1.1.1
       Test Instances MCP Port                   : 2048
       Current Instance Number                   : 1
    • Bind the TLP to an interface.
      [NPE] interface gigabitethernet0/0/2
      [NPE-GigabitEthernet0/0/2] ipfpm tlp 310
      [NPE-GigabitEthernet0/0/2] quit
    • Enable packet loss and delay measurement.
      [NPE] nqa ipfpm dcp
      [NPE-nqa-ipfpm-dcp] instance 1
      [NPE-nqa-ipfpm-dcp-instance-1] loss-measure enable continual
      [NPE-nqa-ipfpm-dcp-instance-1] delay-measure enable two-way tlp 310 continual

  11. Verify the configuration.

    Run the display ipfpm statistic-type { loss | twoway-delay } instance instance-id command on the UPE to view the performance statistics for a specified IP FPM instance.
    • # View the packet loss statistics for IP FPM instance 1.

      [UPE] display ipfpm statistic-type loss instance 1
      Latest loss statistics of forward flow:
      Unit: p - packet, b - byte      
      ------------------------------------------------------------------------------------------ 
       Period               Loss(p)              LossRatio(p)  Loss(b)              LossRatio(b) 
      ------------------------------------------------------------------------------------------ 
       136118757            20                      20.000000% 2000                   20.000000%
       136118756            20                      20.000000% 2000                   20.000000%
       136118755            20                      20.000000% 2000                   20.000000%
       136118753            20                      20.000000% 2000                   20.000000%
       136118752            20                      20.000000% 2000                   20.000000%
       136118751            20                      20.000000% 2000                   20.000000%
       136118750            20                      20.000000% 2000                   20.000000%
       136118749            20                      20.000000% 2000                   20.000000%
       136118748            20                      20.000000% 2000                   20.000000%
       136118747            20                      20.000000% 2000                   20.000000%
       136118746            20                      20.000000% 2000                   20.000000%
       136118745            20                      20.000000% 2000                   20.000000%
                 
      Latest loss statistics of backward flow:
      Unit: p - packet, b - byte      
      ------------------------------------------------------------------------------------------ 
       Period               Loss(p)              LossRatio(p)  Loss(b)              LossRatio(b) 
      ------------------------------------------------------------------------------------------ 
       136118757            20                      20.000000% 2000                   20.000000%
       136118756            20                      20.000000% 2000                   20.000000%
       136118755            20                      20.000000% 2000                   20.000000%
       136118753            20                      20.000000% 2000                   20.000000%
       136118752            20                      20.000000% 2000                   20.000000%
       136118751            20                      20.000000% 2000                   20.000000%
       136118750            20                      20.000000% 2000                   20.000000%
       136118749            20                      20.000000% 2000                   20.000000%
       136118748            20                      20.000000% 2000                   20.000000%
       136118747            20                      20.000000% 2000                   20.000000%
       136118746            20                      20.000000% 2000                   20.000000%
       136118745            20                      20.000000% 2000                   20.000000%
    • # View the two-way delay statistics for IP FPM instance 1.
      [UPE] display ipfpm statistic-type twoway-delay instance 1
      Latest two-way delay statistics:
      --------------------------------------------------
       Period               Delay(usec) Delay
                                        Variation(usec)
      --------------------------------------------------
       136118757            800         0
       136118756            800         0
       136118755            800         0
       136118753            800         0
       136118752            800         0
       136118751            800         0
       136118750            800         0
       136118749            800         0
       136118748            800         0
       136118747            800         0
       136118746            800         0
       136118745            800         0

Configuration Files

  • UPE configuration file

    #                                                                               
    sysname UPE                                                                 
    #                                                                               
    ip vpn-instance vpna                                                            
     ipv4-family                                                                    
      route-distinguisher 100:1                                                     
      tnl-policy policy1                                                            
      vpn-target 1:1 export-extcommunity                                            
      vpn-target 1:1 import-extcommunity                                            
    #                                                                               
    mpls lsr-id 1.1.1.1                                                             
    mpls                                                                            
     mpls te                                                                        
     label advertise non-null                                                       
     mpls rsvp-te                                                                   
     mpls te cspf                                                                   
    #                                                                               
    ntp-service refclock-master 2                                                   
    #                                                                               
    interface GigabitEthernet0/0/0                                                  
     undo shutdown                                                                  
     ip address 172.16.1.1 255.255.255.0                                             
     mpls                                                                           
     mpls te                                                                        
     mpls rsvp-te                                                                   
    #                                                                               
    interface GigabitEthernet0/0/1                                               
     undo shutdown                                                                  
     ip address 172.16.2.1 255.255.255.0                                             
     mpls                                                                           
     mpls te                                                                        
     mpls rsvp-te                                                                   
    #                                                                               
    interface GigabitEthernet1/0/0                                                  
     undo shutdown                                                                  
     ip binding vpn-instance vpna                                                   
     ip address 10.1.1.1 255.255.255.0                                             
     ipfpm tlp 100                                                                 
    #                                                                               
    interface LoopBack1                                                             
     ip address 1.1.1.1 255.255.255.255                                             
    #                                                                               
    interface Tunnel0/0/0                                                           
     ip address unnumbered interface LoopBack1                                      
     tunnel-protocol mpls te                                                        
     destination 2.2.2.2                                                            
     mpls te tunnel-id 100                                                          
     mpls te reserved-for-binding
     mpls te commit                                                    
    #                                                                               
    interface Tunnel0/0/1                                                          
     ip address unnumbered interface LoopBack1                                      
     tunnel-protocol mpls te                                                        
     destination 3.3.3.3                                                            
     mpls te tunnel-id 200                                                          
     mpls te reserved-for-binding
     mpls te commit                                                   
    #                                                                               
    bgp 100                                                                         
     router-id 1.1.1.1                                                              
     peer 2.2.2.2 as-number 100                                                     
     peer 2.2.2.2 connect-interface LoopBack1                                       
     peer 3.3.3.3 as-number 100                                                     
     peer 3.3.3.3 connect-interface LoopBack1                                       
     #                                                                              
     ipv4-family unicast                                                            
      undo synchronization                                                          
      peer 2.2.2.2 enable                                                           
      peer 3.3.3.3 enable                                                           
     #                                                                              
     ipv4-family vpnv4                                                              
      policy vpn-target                                                             
      peer 2.2.2.2 enable                                                           
      peer 3.3.3.3 enable                                                           
     #                                                                              
     ipv4-family vpn-instance vpna                                                  
      import-route direct                                                           
      auto-frr                                                                      
    #                                                                               
    ospf 1                                                                          
     opaque-capability enable                                                       
     area 0.0.0.0                                                                   
      network 1.1.1.1 0.0.0.0                                                       
      network 172.16.1.0 0.0.0.255                                                   
      network 172.16.2.0 0.0.0.255                                                   
      mpls-te enable                                                                
    #                                                                               
    tunnel-policy policy1                                                           
     tunnel binding destination 2.2.2.2 te Tunnel0/0/0                              
     tunnel binding destination 3.3.3.3 te Tunnel0/0/1                             
    #                                                                               
    nqa ipfpm dcp                                                                   
     dcp id 1.1.1.1                                                                 
     mcp 1.1.1.1 port 2048                                                          
     authentication-mode hmac-sha256 key-id 1 cipher %#%#wby+WKE/g70T%D;W4(K9o"":C.B^K~/1(WXD1lLB%#%#
     color-flag loss-measure tos-bit 3 delay-measure tos-bit 4
     instance 1
      flow bidirectional source 10.1.1.2 destination 10.2.1.2  
      tlp 100 in-point ingress
      loss-measure enable continual
      delay-measure enable two-way tlp 100 continual
    #                                                                               
    nqa ipfpm mcp                                                                   
     mcp id 1.1.1.1                                                                 
     protocol udp port 2048                                                         
     authentication-mode hmac-sha256 key-id 1 cipher %^%#\8u;Ufa-'-+mtJG0r#:00dV[Kds2oUW4(K9o"":CKE/gs%^%#
    instance 1                                                                     
      dcp 1.1.1.1                                                                   
      dcp 4.4.4.4                                                                   
     #                                                                               
    return 
  • SPE1 configuration file

    #                                                                               
    sysname SPE1                                                                 
    #                                                                               
    tunnel-selector bindTE permit node 10                                           
     apply tunnel-policy policy1                                                    
    #                                                                               
    mpls lsr-id 2.2.2.2                                                             
    mpls                                                                            
     mpls te                                                                        
     label advertise non-null                                                       
     mpls rsvp-te                                                                   
     mpls te cspf                                                                   
    #                                                                               
    mpls ldp                                                                        
    #                                                                               
    ntp-service unicast-server 172.16.1.1                                            
    #                                                                               
    interface GigabitEthernet0/0/0                                                  
     undo shutdown                                                                  
     ip address 172.16.1.2 255.255.255.0                                             
     mpls                                                                           
     mpls te                                                                        
     mpls rsvp-te                                                                   
    #                                                                               
    interface GigabitEthernet0/0/1                                                  
     undo shutdown                                                                  
     ip address 172.16.4.1 255.255.255.0                                             
     mpls                                                                           
     mpls ldp                                                                       
    #                                                                               
    interface GigabitEthernet0/0/2                                                  
     undo shutdown                                                                  
     ip address 172.16.3.1 255.255.255.0                                             
     mpls                                                                           
     mpls ldp                                                                       
    #                                                                               
    interface LoopBack1                                                             
     ip address 2.2.2.2 255.255.255.0                                               
    #                                                                               
    interface Tunnel0/0/0                                                           
     ip address unnumbered interface LoopBack1                                      
     tunnel-protocol mpls te                                                        
     destination 1.1.1.1                                                            
     mpls te tunnel-id 100                                                          
     mpls te reserved-for-binding
     mpls te commit                                                   
    #                                                                               
    bgp 100                                                                         
     router-id 2.2.2.2                                                              
     peer 1.1.1.1 as-number 100                                                     
     peer 1.1.1.1 connect-interface LoopBack1                                       
     peer 3.3.3.3 as-number 100                                                     
     peer 3.3.3.3 connect-interface LoopBack1                                       
     peer 4.4.4.4 as-number 100                                                     
     peer 4.4.4.4 connect-interface LoopBack1                                       
     #                                                                              
     ipv4-family unicast                                                            
      undo synchronization                                                          
      peer 1.1.1.1 enable                                                           
      peer 3.3.3.3 enable                                                           
      peer 4.4.4.4 enable                                                           
     #                                                                              
     ipv4-family vpnv4                                                              
      undo policy vpn-target                                                        
      tunnel-selector bindTE                                                        
      peer 1.1.1.1 enable                                                           
      peer 1.1.1.1 reflect-client                                                   
      peer 1.1.1.1 next-hop-local                                                   
      peer 3.3.3.3 enable                                                           
      peer 4.4.4.4 enable                                                           
      peer 4.4.4.4 reflect-client                                                   
      peer 4.4.4.4 next-hop-local                                                   
    #                                                                               
    ospf 1                                                                          
     opaque-capability enable                                                       
     area 0.0.0.0                                                                   
      network 2.2.2.2 0.0.0.0                                                       
      network 172.16.1.0 0.0.0.255                                                   
      network 172.16.3.0 0.0.0.255                                                   
      network 172.16.4.0 0.0.0.255                                                   
      mpls-te enable                                                                
    #                                                                               
    tunnel-policy policy1                                                           
     tunnel binding destination 1.1.1.1 te Tunnel0/0/0                              
    # 
    return
  • SPE2 configuration file

    #
    sysname SPE2
    #
    tunnel-selector bindTE permit node 10
     apply tunnel-policy policy1
    #
    mpls lsr-id 3.3.3.3
    mpls
     mpls te
     label advertise non-null
     mpls rsvp-te
     mpls te cspf
    #
    mpls ldp
    #
    interface GigabitEthernet0/0/0
     undo shutdown
     ip address 172.16.5.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/0/1
     undo shutdown
     ip address 172.16.2.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet0/0/2
     undo shutdown
     ip address 172.16.3.2 255.255.255.0
     mpls
     mpls te
     mpls ldp
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    interface Tunnel0/0/1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 1.1.1.1
     mpls te tunnel-id 200
     mpls te reserved-for-binding
     mpls te commit
    #
    bgp 100
     router-id 3.3.3.3
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
      peer 4.4.4.4 enable
     #
     ipv4-family vpnv4
      undo policy vpn-target
      tunnel-selector bindTE
      peer 1.1.1.1 enable
      peer 1.1.1.1 reflect-client
      peer 1.1.1.1 next-hop-local
      peer 2.2.2.2 enable
      peer 4.4.4.4 enable
      peer 4.4.4.4 reflect-client
      peer 4.4.4.4 next-hop-local
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 172.16.2.0 0.0.0.255
      network 172.16.3.0 0.0.0.255
      network 172.16.5.0 0.0.0.255
      mpls-te enable
    #
    tunnel-policy policy1
     tunnel binding destination 1.1.1.1 te Tunnel0/0/1
    #
    return
  • NPE configuration file

    #
    sysname NPE
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    mpls lsr-id 4.4.4.4
    mpls
    #
    mpls ldp
    #
    ntp-service unicast-server 172.16.4.1
    #
    interface GigabitEthernet0/0/0
     undo shutdown
     ip address 172.16.5.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/0/1
     undo shutdown
     ip address 172.16.4.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/0/2
     undo shutdown
     ip binding vpn-instance vpna
     ip address 10.2.1.1 255.255.255.0
     ipfpm tlp 310
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
    #
    bgp 100
     router-id 4.4.4.4
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
     #
     ipv4-family vpn-instance vpna
      import-route direct
      auto-frr
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 172.16.4.0 0.0.0.255
      network 172.16.5.0 0.0.0.255
    #
    nqa ipfpm dcp
     dcp id 4.4.4.4
     mcp 1.1.1.1 port 2048
     authentication-mode hmac-sha256 key-id 1 cipher %^%#;\VV*UAUfP'8+uS{,4v+1GjvKE/g70T%D;Ufa-'-+mtJG%^%#
     color-flag loss-measure tos-bit 3 delay-measure tos-bit 4 
     instance 1
      flow bidirectional source 10.1.1.2 destination 10.2.1.2
      tlp 310 out-point egress
      loss-measure enable continual
      delay-measure enable two-way tlp 310 continual
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174072

Views: 101528

Downloads: 335

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next