No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Network Management and Monitoring

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a DHCP Test Instance

Example for Configuring a DHCP Test Instance

Networking Requirements

In Figure 7-17, RouterB functions as a DHCP server. RouterA functions as the DHCP client to test the time it takes to obtain an IP address from the DHCP server.

Figure 7-17  Networking diagram for configuring a DHCP test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure RouterB as the DHCP server and configure the related functions. (see the configuration file.)

  2. Configure RouterA as an DHCP client.

  3. Create and start the DHCP test on the RouterA to check whether a connection can be set up between the Router and the DHCP server and whether an IP address can be assigned.

Procedure

  1. Configure the DHCP client on RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.1.1.3 24
    [RouterA-GigabitEthernet1/0/0] quit

  2. Configure a DHCP test instance on RouterA.

    [RouterA] nqa test-instance admin dhcp
    [RouterA-nqa-admin-dhcp] test-type dhcp
    [RouterA-nqa-admin-dhcp] source-interface gigabitethernet 1/0/0
    [RouterA-nqa-admin-dhcp] timeout 20

  3. Start the test instance.

    [RouterA-nqa-admin-dhcp] start now

  4. Check the configuration.

    [RouterA-nqa-admin-dhcp] display nqa results test-instance admin dhcp
    NQA entry£¨admin, dhcp£© :testflag is inactive ,testtype is dhcp
      1 . Test 1 result   The test is finished
       Send operation times: 3              Receive response times: 3
       Completion:success                   RTD OverThresholds number: 0
       Attempts number:1                    Drop operation number:0
       Disconnect operation number:0        Operation timeout number:0
       System busy operation number:0       Connection fail number:0
       Operation sequence errors number:0   RTT Stats errors number:0
       Destination ip address:10.1.1.2
       Min/Max/Average Completion Time: 1018/1019/1018
       Sum/Square-Sum  Completion Time: 3055/3111009
       Last Good Probe Time: 2012-7-11 9:26:38.5
       Lost packet ratio: 0 %

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.3 255.255.255.0
    #
    nqa test-instance admin dhcp
     test-type dhcp
     timeout 20
     source-interface GigabitEthernet1/0/0
    #
    return
    
  • RouterB configuration file

    #
     sysname RouterB
    #
     dhcp enable 
    #
    ip pool 1
     gateway-list 10.1.1.1
     network 10.1.1.0 mask 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
     dhcp select global
    #
    return
    
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174072

Views: 101616

Downloads: 335

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next