No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Network Management and Monitoring

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a UDP Jitter Test Instance

Example for Configuring a UDP Jitter Test Instance

Networking Requirements

In Figure 7-28, a UDP Jitter test needs to be performed to obtain the jitter time of transmitting a packet from RouterA to RouterC.

Figure 7-28  Networking diagram for configuring a jitter test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure RouterA as an NQA client and configure RouterC as an NQA server.

  2. Configure the monitoring service type and port number on the NQA server.

  3. Create a UDP Jitter test instance on the NQA client.

Procedure

  1. Configure an IP address for each interface and ensure reachable routes between Routers, as shown in Figure 7-28.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.1.1.1 24
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    NOTE:

    For configurations of RouterB and RouterC, see the configuration files.

  2. Configure an NQA server on RouterC.

    # Configure the monitoring IP address and UDP port number on the NQA server.

    <RouterC> system-view
    [RouterC] nqa-server udpecho 10.2.1.2 9000

  3. Configure RouterA.

    # Enable the NQA client and create a UDP Jitter test instance.

    [RouterA] nqa test-instance admin jitter
    [RouterA-nqa-admin-jitter] test-type jitter
    [RouterA-nqa-admin-jitter] destination-address ipv4 10.2.1.2
    [RouterA-nqa-admin-jitter] destination-port 9000 

  4. Start the test instance.

    [RouterA-nqa-admin-jitter] start now

  5. Verify the configuration.

    [RouterA-nqa-admin-jitter] display nqa results test-instance admin jitter
    NQA entry(admin, jitter) :testflag is inactive ,testtype is jitter
      1 . Test 1 result   The test is finished
       SendProbe:60                         ResponseProbe:60
       Completion:success                   RTD OverThresholds number:0
       OWD OverThresholds SD number:0       OWD OverThresholds DS number:0
       Min/Max/Avg/Sum RTT:1/4/1/63         RTT  Square Sum:75
       NumOfRTT:60                          Drop operation number:0
       Operation sequence errors number:0   RTT Stats errors number:0
       System busy operation number:0       Operation timeout number:0
       Min Positive SD:1                    Min Positive DS:1
       Max Positive SD:1                    Max Positive DS:3
       Positive SD Number:15                Positive DS Number:14
       Positive SD Sum:15                   Positive DS Sum:16
       Positive SD Square Sum:15            Positive DS Square Sum:22
       Min Negative SD:1                    Min Negative DS:1
       Max Negative SD:1                    Max Negative DS:4
       Negative SD Number:16                Negative DS Number:12
       Negative SD Sum:16                   Negative DS Sum:15
       Negative SD Square Sum:16            Negative DS Square Sum:27
       Min Delay SD:0                       Min Delay DS:0
       Avg Delay SD:0                       Avg Delay DS:0
       Max Delay SD:2                       Max Delay DS:1
       Delay SD Square Sum:4                Delay DS Square Sum:1
       Packet Loss SD:0                     Packet Loss DS:0
       Packet Loss Unknown:0                Average of Jitter:1
       Average of Jitter SD:1               Average of Jitter DS:1
       Jitter out value:0.0322917           Jitter in value:0.0322917
       NumberOfOWD:60                       Packet Loss Ratio: 0%
       OWD SD Sum:2                         OWD DS Sum:1
       ICPIF value: 0                       MOS-CQ value: 0
       TimeStamp unit: ms                   Packet Rewrite Number: 0
       Packet Rewrite Ratio: 0%             Packet Disorder Number: 0
       Packet Disorder Ratio: 0%            Fragment-disorder Number: 0
       Fragment-disorder Ratio: 0%          Jitter OverThresholds SD number:0
       Jitter OverThresholds DS number:0    OverallOverThresholds number:0             

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin jitter
     test-type jitter
     destination-address ipv4 10.2.1.2
     destination-port 9000
    #
    return
  • RouterB configuration file

    #
     sysname RouterB
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.2.1.1 255.255.255.0
    #
    return
  • RouterC configuration file

    #
     sysname RouterC
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.1.2 255.255.255.0
    #
    nqa-server udpecho 10.2.1.2 9000
    #
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174072

Views: 100330

Downloads: 332

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next