No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Network Management and Monitoring

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a Trace Test Instance

Example for Configuring a Trace Test Instance

Networking Requirements

In Figure 7-26, a trace test needs to be performed to trace the IP address of GE1/0/0 of RouterC on RouterA.

Figure 7-26  Networking diagram for configuring a trace test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure RouterA as an NQA client.

  2. Create and start a trace test instance on RouterA to obtain statistics about each hop from RouterA to RouterC.

Procedure

  1. Configure an IP address for each interface and ensure reachable routes between Routers, as shown in Figure 7-26.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.1.1.1 24
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    NOTE:

    For configurations of RouterB and RouterC, see the configuration files.

  2. Create an NQA trace test instance on RouterA and set the destination IP address to 10.2.1.2.

    [RouterA] nqa test-instance admin trace
    [RouterA-nqa-admin-trace] test-type trace
    [RouterA-nqa-admin-trace] destination-address ipv4 10.2.1.2

  3. Start the test instance.

    [RouterA-nqa-admin-trace] start now

  4. Verify the configuration.

    # Check NQA test results on RouterA.

    [RouterA-nqa-admin-trace] display nqa results test-instance admin trace
     NQA entry(admin, trace) :testflag is inactive ,testtype is trace
      1 . Test 1 result   The test is finished
       Completion:success                   Attempts number:1
       Disconnect operation number:0        Operation timeout number:0
       System busy operation number:0       Connection fail number:0
       Operation sequence errors number:0   RTT Stats errors number:0
       Drop operation number:0
       Last good path Time:2012-07-17 11:21:27.2
       1 . Hop 1
        Send operation times: 3              Receive response times: 3
        Min/Max/Average Completion Time: 1/1/1
        Sum/Square-Sum  Completion Time: 3/3
        RTD OverThresholds number: 0
        Last Good Probe Time: 2012-07-17 11:21:27.2
        Destination ip address:10.1.1.2
        Lost packet ratio: 0 %
       2 . Hop 2
        Send operation times: 3              Receive response times: 3
        Min/Max/Average Completion Time: 1/1/1
        Sum/Square-Sum  Completion Time: 3/3
        RTD OverThresholds number: 0
        Last Good Probe Time: 2012-07-17 11:21:27.2
        Destination ip address:10.2.1.2
        Lost packet ratio: 0 %  

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin trace
     test-type  trace
     destination-address ipv4 10.2.1.2
    #
    return
    
  • RouterB configuration file

    #
     sysname RouterB
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.2.1.1 255.255.255.0
    #
    return
    
  • RouterC configuration file

    #
     sysname RouterC
    #
    icmp port-unreachable send 
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.1.2 255.255.255.0
    #
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
    
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174072

Views: 110553

Downloads: 348

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next