No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Network Management and Monitoring

AR100, AR120, AR150, AR160, AR200, AR1200, AR2200, AR3200, and AR3600 V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the LSP Trace Test for Checking the CR-LSP Hotstandby Tunnel

Example for Configuring the LSP Trace Test for Checking the CR-LSP Hotstandby Tunnel

Networking Requirements

In the MPLS VPN shown in Figure 7-35, a TE tunnel with Router C being the egress is set up on Router A, and CR-LSP hot standby is configured on the TE tunnel.

  • OSPF is configured on RouterA, RouterB, RouterC, and RouterD to enable them to learn the 32-bit host addresses of the loopback interfaces from each other.

  • MPLS, MPLS TE, MPLS RSVP-TE, and MPLS TE CSPF are enabled on RouterA, RouterB, RouterC, and RouterD.

  • MPLS, MPLS TE, and MPLS RSVP-TE are enabled on the interfaces connected to RouterA, RouterB, RouterC, and RouterD. Then, a TE tunnel is set up from RouterA to RouterC.

In the preceding configurations:
  • The primary CR-LSP is Router A-Router B-Router C.
  • The hotstandby CR-LSP is Router A-Router D-Router C.
In this manner, when the primary CR-LSP becomes faulty, traffic can be switched to the hot-standby CR-LSP. Traffic is switched back to the primary CR-LSP 15 seconds after the fault on the primary CR-LSP is rectified.

But if the hotstandby CR-LSP is faulty and therefore is unable to carry the traffic that is switched from the primary CR-LSP, the hotstandby CR-LSP needs to be detected. NQA LSP Trace can be used to detect the connectivity of the hotstandby CR-LSP. This function can detect the connectivity of the hotstandby CR-LSP and its performance in real time. This helps detect and identify faults on the hotstandby CR-LSP.

Figure 7-35  Networking diagram of the LSP Trace test

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure RouterA as the NQA client and create an LSP Trace test instance on Router A.

  2. Configure RouterC as the NQA server.

Procedure

  1. Configure routes among RouterA, RouterB, RouterC and RouterD.

    For detailed configuration, see the configuration files in this example.

  2. Configure MPLS RSVP-TE on RouterA, RouterB, RouterC, and RouterD.

    For detailed configuration, see the configuration files in this example.

  3. On RouterA, set up a TE tunnel to RouterC.

    For detailed configuration, see the configuration files in this example.

  4. Configure an NQA test instance on RouterA.

    # Enable the NQA client and create an LSP Trace test instance for checking the TE tunnel.

    <RouterA> system-view
    [RouterA] nqa test-instance admin lsptrace
    [RouterA-nqa-admin-lsptrace] test-type lsptrace
    [RouterA-nqa-admin-lsptrace] lsp-type te
    [RouterA-nqa-admin-lsptrace] lsp-tetunnel tunnel 0/0/1 hot-standby

  5. Start the test.

    [RouterA-nqa-admin-lsptrace] start now

  6. Verify the configuration.

    [RouterA-nqa-admin-lsptrace] display nqa results test-instance admin lsptrace
     NQA entry(admin, lsptrace) :testFlag is inactive ,testtype is lsptrace
       1 . Test 1 result   The test is finished
       Completion:success                                Attempts number:1
       Disconnect operation number:0                     Operation timeout number:0
       System busy operation number:0                    Connection fail number:0
       Operation sequence errors number:0                RTT Status errors number:0
       Drop operation number:0
       Last good path Time:2009-04-24 11:22:21.2
       1 . Hop 1
        Send operation times: 3               Receive response times: 3
        Min/Max/Average Completion Time: 50/60/56
        Sum/Square-Sum  Completion Time: 170/9700
        RTD OverThresholds number: 0
        Last Good Probe Time: 2009-04-24 11:22:20.8
        Destination ip address:10.30.1.2
        Lost packet ratio: 0 %
       2 . Hop 2
        Send operation times: 3               Receive response times: 3
        Min/Max/Average Completion Time: 80/110/93
        Sum/Square-Sum  Completion Time: 280/26600
        RTD OverThresholds number: 0
        Last Good Probe Time: 2009-04-24 11:22:21.2
        Destination ip address:10.30.3.3
        Lost packet ratio: 0 % 

Configuration Files

  • RouterA configuration file

    #
    sysname RouterA
    #
     mpls lsr-id 10.10.1.1
     mpls
      mpls te
      mpls rsvp-te
      mpls te cspf
    #
     explicit-path backup
      next hop 10.30.1.2
      next hop 10.40.1.2
      next hop 10.30.3.3
    #
     explicit-path main
      next hop 10.1.1.2
      next hop 10.20.1.2
      next hop 10.30.3.3
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet2/0/0
     ip address 10.30.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface LoopBack1
     ip address 10.10.1.1 255.255.255.255
    #
    interface Tunnel0/0/1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 10.30.3.3
     mpls te tunnel-id 100
     mpls te record-route
     mpls te path explicit-path main
     mpls te path explicit-path backup secondary
     mpls te commit
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.10.1.1 0.0.0.0
      network 10.30.1.0 0.0.0.255
      mpls-te enable
    #
    nqa test-instance admin lsptrace
     test-type lsptrace
     lsp-type te
     lsp-tetunnel Tunnel0/0/1 hot-standby
    #
    return
  • RouterB configuration file

    #
    sysname RouterB
    #
     mpls lsr-id 10.20.2.2
     mpls
      mpls te
      mpls rsvp-te
      mpls te cspf
    #
    interface GigabitEthernet1/0/0
     ip address 10.20.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface LoopBack1
     ip address 10.20.2.2 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.20.1.0 0.0.0.255
      network 10.20.2.2 0.0.0.0
      mpls-te enable
    #
    return
    
  • RouterC configuration file

    #
    sysname RouterC
    #
     mpls lsr-id 10.30.3.3
     mpls
      mpls te
      mpls rsvp-te
      mpls te cspf
    #
    interface GigabitEthernet1/0/0
     ip address 10.40.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet2/0/0
     ip address 10.20.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface LoopBack1
     ip address 10.30.3.3 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.20.1.0 0.0.0.255
      network 10.30.3.3 0.0.0.0
      network 10.40.1.0 0.0.0.255
      mpls-te enable
    #
    return
    
  • RouterD configuration file

    #
    sysname RouterD
    #
     mpls lsr-id 10.40.4.4
     mpls
      mpls te
      mpls rsvp-te
      mpls te cspf
    #
    interface GigabitEthernet1/0/0
     ip address 10.30.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet2/0/0
     ip address 10.40.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface LoopBack1
     ip address 10.40.4.4 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.30.1.0 0.0.0.255
      network 10.40.1.0 0.0.0.255
      network 10.40.4.4 0.0.0.0
      mpls-te enable
    #
    return
    
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174072

Views: 110046

Downloads: 348

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next