No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009 CLI-based Configuration Guide - Ethernet Switching

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Remote Bridging with VLAN ID Transparent Transmission

Example for Configuring Remote Bridging with VLAN ID Transparent Transmission

Remote bridging with VLAN ID transparent transmission allows the devices in the same VLAN but different in locations to communicate with each other.

Networking Requirements

An enterprise has multiple departments in different locations. To allow the communication between departments in different locations, remote bridging can be used. To allow users in the same department (the same VLAN) to communicate with each other, while isolating users in different departments (different VLANs), VLAN ID transparent transmission must be enabled.

As shown in Figure 15-22, User 1, User 2, User 3, and User 4 are on the same network segment. User 1 and User 3 belong to a VLAN; User 2 and User 4 belong to the other VLAN. To allow users in the same VLAN to communicate with each other and isolate users in different VLANs, remote bridging and VLAN ID transparent transmission can be enabled. In this manner, User 1 can only communicate with User 3, and User 2 can only communicate with User 4.

Figure 15-22  Networking diagram for remote bridging

Configuration Roadmap

The configuration roadmap is as follows:

  • On Switch 1 and Switch 2:

    1. Create VLANs.

    2. Add interfaces to the VLANs.

    3. Configure interfaces to allow the packets from VLAN 11 and VLAN 12 to pass through.

  • On Router A and Router B:

    1. Configure bridge groups.

    2. Add WAN interfaces Ethernet1/0/0 and Ethernet2/0/0 to the same bridge group.

    3. Enable VLAN ID transparent transmission on user-side interfaces and network-side interfaces to allow users in the same VLAN to communicate with each other and isolate users in different VLANs.

Procedure

  1. Configure Router A.

    # Create bridge group 1.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] bridge 1
    [RouterA-bridge1] undo shutdown
    [RouterA-bridge1] quit

    # Add Ethernet1/0/0 and Ethernet2/0/0 to bridge group 1, and enable VLAN ID transparent transmission on the two interfaces.

    [RouterA] interface ethernet 1/0/0
    [RouterA-Ethernet1/0/0] bridge 1
    [RouterA-Ethernet1/0/0] bridge vlan-transmit enable
    [RouterA-Ethernet1/0/0] quit
    [RouterA] interface ethernet 2/0/0
    [RouterA-Ethernet2/0/0] bridge 1
    [RouterA-Ethernet2/0/0] bridge vlan-transmit enable
    [RouterA-Ethernet2/0/0] quit

  2. Configure Switch 1.

    # Create VLANs.

    <Huawei> system-view
    [Huawei] sysname Switch1
    [Switch1] vlan 11
    [Switch1-vlan11] quit
    [Switch1] vlan 12
    [Switch1-vlan12] quit

    # Add Ethernet1/0/1 to VLAN 11 and Ethernet1/0/2 to VLAN 12.

    [Switch1] interface ethernet 1/0/1
    [Switch1-Ethernet1/0/1] port link-type access
    [Switch1-Ethernet1/0/1] port default vlan 11
    [Switch1-Ethernet1/0/1] quit
    [Switch1] interface ethernet 1/0/2
    [Switch1-Ethernet1/0/2] port link-type access
    [Switch1-Ethernet1/0/2] port default vlan 12
    [Switch1-Ethernet1/0/2] quit

    # Configure Ethernet 1/0/3 to allow the packets from VLAN 11 and VLAN 12 to pass through.

    [Switch1] interface ethernet 1/0/3
    [Switch1-Ethernet1/0/3] port link-type trunk
    [Switch1-Ethernet1/0/3] port trunk allow-pass vlan 11 to 12
    [Switch1-Ethernet1/0/3] quit

  3. Configure Router B.

    # Create bridge group 2.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] bridge 2
    [RouterB-bridge2] quit

    # Add Ethernet1/0/0 and Ethernet2/0/0 to bridge group 2, and enable VLAN ID transparent transmission on the two interfaces.

    [RouterB] interface ethernet 1/0/0
    [RouterB-Ethernet1/0/0] bridge 2
    [RouterB-Ethernet1/0/0] bridge vlan-transmit enable
    [RouterB-Ethernet1/0/0] quit
    [RouterB] interface ethernet 2/0/0
    [RouterB-Ethernet2/0/0] bridge 2
    [RouterB-Ethernet2/0/0] bridge vlan-transmit enable
    [RouterB-Ethernet2/0/0] quit

  4. Configure Switch 2.

    # Create VLANs.

    <Huawei> system-view
    [Huawei] sysname Switch2
    [Switch2] vlan 11
    [Switch2-vlan11] quit
    [Switch2] vlan 12
    [Switch2-vlan12] quit

    # Add Ethernet1/0/1 to VLAN 11 and Ethernet1/0/2 to VLAN 12.

    [Switch2] interface ethernet 1/0/1
    [Switch2-Ethernet1/0/1] port link-type access
    [Switch2-Ethernet1/0/1] port default vlan 11
    [Switch2-Ethernet1/0/1] quit
    [Switch2] interface ethernet 1/0/2
    [Switch2-Ethernet1/0/2] port link-type access
    [Switch2-Ethernet1/0/2] port default vlan 12
    [Switch2-Ethernet1/0/2] quit

    # Configure Ethernet1/0/3 to allow the packets from VLAN 11 and VLAN 12 to pass through.

    [Switch2] interface ethernet 1/0/3
    [Switch2-Ethernet1/0/3] port link-type trunk
    [Switch2-Ethernet1/0/3] port trunk allow-pass vlan 11 to 12
    [Switch2-Ethernet1/0/3] quit

  5. Verify the configuration.

    # After the preceding configurations are complete, User 1 and User 3 can ping each other; User 2 and User 4 can ping each other.

Configuration Files

  • Configuration file of Router A

    #
     sysname RouterA
    #
    vlan batch 11 to 12
    #
    bridge 1
    #
    interface Ethernet1/0/0
     bridge 1
     bridge vlan-transmit enable
    #
    interface Ethernet2/0/0
     bridge 1
     bridge vlan-transmit enable
    #
    return
  • Configuration file of Router B

    #
     sysname RouterB
    #
    vlan batch 11 to 12
    #
    bridge 2
    #
    interface Ethernet1/0/0
     bridge 2
     bridge vlan-transmit enable
    #
    interface Ethernet2/0/0
     bridge 2
     bridge vlan-transmit enable
    
    #
    return
    
  • Configuration file of Switch 1

    #
     sysname Switch1
    #
    vlan batch 11 to 12
    #
    interface Ethernet1/0/1
     port link-type access
     port default vlan 11
    #
    interface Ethernet1/0/2
     port link-type access
     port default vlan 12
    #
    interface Ethernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 11 to 12
    #
    return 
  • Configuration file of Switch 2

    #
     sysname Switch2
    #
    vlan batch 11 to 12
    #
    #
    interface Ethernet1/0/1
     port link-type access
     port default vlan 11
    #
    interface Ethernet1/0/2
     port link-type access
     port default vlan 12
    #
    interface Ethernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 11 to 12
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174108

Views: 56372

Downloads: 42

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next