No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009 CLI-based Configuration Guide - Ethernet Switching

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Inter-Device MUX VLAN

Example for Configuring Inter-Device MUX VLAN

Networking Requirements

An enterprise forbids communication between some departments and allows communication between other departments. All employees in the enterprise are allowed to access certain servers.

The MUX VLAN function can be configured to meet the preceding requirements. The enterprise needs to add the servers to the principal VLAN, add the hosts that are allowed to communicate to a group VLAN, and add the hosts that need to be isolated to a separate VLAN. Employing this function reduces the needed VLAN IDs.

When employees connect to servers through multiple devices, inter-device MUX VLAN can be configured.

As shown in Figure 5-3, Ethernet2/0/1 of each Router is connected a server, Ethernet2/0/2 to Ethernet2/0/5 are connected to PCs. The Routers use Ethernet2/0/6 to communicate with each other. To meet the preceding requirements, the enterprise needs to perform the following configurations on the Routers: configure VLAN 2 as a principal VLAN and add Ethernet2/0/1 to VLAN 2; configure VLAN 3 as a subordinate group VLAN and add Ethernet2/0/2 and Ethernet2/0/3 to VLAN 3; configure VLAN 4 as a subordinate separate VLAN and add Ethernet2/0/4 and Ethernet2/0/5 to VLAN 4. Configure Ethernet2/0/6 to allow VLAN 2, VLAN 3, and VLAN 4 to pass through.

Figure 5-3  Network diagram of inter-device MUX VLAN

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the principal VLAN.

  2. Configure the subordinate group VLAN.

  3. Configure the subordinate separate VLAN.

  4. Add interfaces to the VLANs and enable the MUX VLAN function on the interfaces.

  5. Configure the interfaces between RouterA and RouterB to allow the principal VLAN and subordinate VLANs to pass through.

Procedure

  1. Configure the MUX VLAN function on RouterA.

    # Create VLAN 2, VLAN 3, and VLAN 4.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] vlan batch 2 3 4

    # Configure the principal VLAN and subordinate VLANs.

    [RouterA] vlan 2
    [RouterA-vlan2] mux-vlan
    [RouterA-vlan2] subordinate group 3
    [RouterA-vlan2] subordinate separate 4
    [RouterA-vlan2] quit

    # Add Ethernet2/0/1 to Ethernet2/0/5 to VLANs and enable the MUX VLAN function on the interfaces.

    [RouterA] interface ethernet 2/0/1
    [RouterA-Ethernet2/0/1] port link-type access
    [RouterA-Ethernet2/0/1] port default vlan 2
    [RouterA-Ethernet2/0/1] port mux-vlan enable
    [RouterA-Ethernet2/0/1] quit
    [RouterA] interface ethernet 2/0/2
    [RouterA-Ethernet2/0/2] port link-type access
    [RouterA-Ethernet2/0/2] port default vlan 3
    [RouterA-Ethernet2/0/2] port mux-vlan enable
    [RouterA-Ethernet2/0/2] quit
    [RouterA] interface ethernet 2/0/3
    [RouterA-Ethernet2/0/3] port link-type access
    [RouterA-Ethernet2/0/3] port default vlan 3
    [RouterA-Ethernet2/0/3] port mux-vlan enable
    [RouterA-Ethernet2/0/3] quit
    [RouterA] interface ethernet 2/0/4
    [RouterA-Ethernet2/0/4] port link-type access
    [RouterA-Ethernet2/0/4] port default vlan 4
    [RouterA-Ethernet2/0/4] port mux-vlan enable
    [RouterA-Ethernet2/0/4] quit
    [RouterA] interface ethernet 2/0/5
    [RouterA-Ethernet2/0/5] port link-type access
    [RouterA-Ethernet2/0/5] port default vlan 4
    [RouterA-Ethernet2/0/5] port mux-vlan enable
    [RouterA-Ethernet2/0/5] quit

    # Configure Ethernet2/0/6 to allow the principal VLAN and subordinate VLANs to pass through.

    [RouterA] interface ethernet 2/0/6
    [RouterA-Ethernet2/0/6] port link-type trunk
    [RouterA-Ethernet2/0/6] port trunk allow-pass vlan 2 to 4
    [RouterA-Ethernet2/0/6] quit

  2. Configure the MUX VLAN function on RouterB.

    # Create VLAN 2, VLAN 3, and VLAN 4.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] vlan batch 2 3 4

    # Configure the principal VLAN and subordinate VLANs.

    [RouterB] vlan 2
    [RouterB-vlan2] mux-vlan
    [RouterB-vlan2] subordinate group 3
    [RouterB-vlan2] subordinate separate 4
    [RouterB-vlan2] quit

    # Add Ethernet2/0/1 to Ethernet2/0/5 to VLANs and enable the MUX VLAN function on the interfaces.

    [RouterB] interface ethernet 2/0/1
    [RouterB-Ethernet2/0/1] port link-type access
    [RouterB-Ethernet2/0/1] port default vlan 2
    [RouterB-Ethernet2/0/1] port mux-vlan enable
    [RouterB-Ethernet2/0/1] quit
    [RouterB] interface ethernet 2/0/2
    [RouterB-Ethernet2/0/2] port link-type access
    [RouterB-Ethernet2/0/2] port default vlan 3
    [RouterB-Ethernet2/0/2] port mux-vlan enable
    [RouterB-Ethernet2/0/2] quit
    [RouterB] interface ethernet 2/0/3
    [RouterB-Ethernet2/0/3] port link-type access
    [RouterB-Ethernet2/0/3] port default vlan 3
    [RouterB-Ethernet2/0/3] port mux-vlan enable
    [RouterB-Ethernet2/0/3] quit
    [RouterB] interface ethernet 2/0/4
    [RouterB-Ethernet2/0/4] port link-type access
    [RouterB-Ethernet2/0/4] port default vlan 4
    [RouterB-Ethernet2/0/4] port mux-vlan enable
    [RouterB-Ethernet2/0/4] quit
    [RouterB] interface ethernet 2/0/5
    [RouterB-Ethernet2/0/5] port link-type access
    [RouterB-Ethernet2/0/5] port default vlan 4
    [RouterB-Ethernet2/0/5] port mux-vlan enable
    [RouterB-Ethernet2/0/5] quit

    # Configure Ethernet2/0/6 to allow the principal VLAN and subordinate VLANs to pass through.

    [RouterB] interface ethernet 2/0/6
    [RouterB-Ethernet2/0/6] port link-type trunk
    [RouterB-Ethernet2/0/6] port trunk allow-pass vlan 2 to 4
    [RouterB-Ethernet2/0/6] quit

  3. Verify the configuration.

    # All the hosts can access Server A and Server B in the principal VLAN.

    # Host A, Host B, Host E, and Host F in the group VLAN can communicate with each other.

    # Host C, Host D, Host G, and Host H in the separate VLAN cannot communicate with each other.

    # Hosts in the group VLAN cannot communicate with hosts in the separate VLAN.

Configuration Files

Configuration file of RouterA

#
 sysname RouterA
#
vlan batch 2 to 4
#
vlan 2
 mux-vlan
 subordinate group 3
 subordinate separate 4 
#
interface Ethernet2/0/1
 port link-type access
 port default vlan 2 
 port mux-vlan enable
#
interface Ethernet2/0/2
 port link-type access
 port default vlan 3
 port mux-vlan enable
#
interface Ethernet2/0/3
 port link-type access
 port default vlan 3
 port mux-vlan enable
#
interface Ethernet2/0/4
 port link-type access
 port default vlan 4
 port mux-vlan enable
#
interface Ethernet2/0/5
 port link-type access
 port default vlan 4
 port mux-vlan enable
#
interface Ethernet2/0/6
 port link-type trunk
 port trunk allow-pass vlan 2 to 4
#
return

Configuration file of RouterB

#
 sysname RouterB
#
vlan batch 2 to 4
#
vlan 2
 mux-vlan
 subordinate group 3
 subordinate separate 4 
#
interface Ethernet2/0/1
 port link-type access
 port default vlan 2 
 port mux-vlan enable
#
interface Ethernet2/0/2
 port link-type access
 port default vlan 3
 port mux-vlan enable
#
interface Ethernet2/0/3
 port link-type access
 port default vlan 3
 port mux-vlan enable
#
interface Ethernet2/0/4
 port link-type access
 port default vlan 4
 port mux-vlan enable
#
interface Ethernet2/0/5
 port link-type access
 port default vlan 4
 port mux-vlan enable
#
interface Ethernet2/0/6
 port link-type trunk
 port trunk allow-pass vlan 2 to 4
#
return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174108

Views: 62207

Downloads: 49

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next