No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009 CLI-based Configuration Guide - Ethernet Switching

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Connecting a Dot1q Sub-interface to a VLL Network

Example for Connecting a Dot1q Sub-interface to a VLL Network

Networking Requirements

As shown in Figure 8-9, CE1 and CE2 are connected to PE1 and PE2 respectively through VLANs.

A Martini VLL is created between PE1 and PE2 so that user networks connected to CE1 and CE2 can communicate.

Figure 8-9  Networking diagram for connecting a Dot1q VLAN tag termination sub-interface to a VLL network

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a routing protocol on devices (PE and P) of the backbone network to implement interworking, and enable MPLS.

  2. Use the default tunnel policy to create an LSP and configure the LSP for data transmission.

  3. Enable MPLS L2VPN and create VC connections on PEs.

  4. Configure Dot1q sub-interfaces on PE interfaces connected to CEs to implement VLL access.

Procedure

  1. Configure IP addresses for interfaces on CEs, PEs, and the P devices according to Figure 8-9.

    # Configure CE1. The configuration details of other devices are not mentioned here.

    <Huawei> system-view
    [Huawei] sysname CE1
    [CE1] interface gigabitethernet 1/0/0.1
    [CE1-GigabitEthernet1/0/0.1] ip address 10.100.1.1 255.255.255.0
    [CE1-GigabitEthernet1/0/0.1] quit

  2. Configure CEs to add a VLAN tag to packets destined for PEs.

    # VLAN 10 is used as an example. Configure CE1.

    [CE1] interface gigabitethernet 1/0/0.1
    [CE1-GigabitEthernet1/0/0.1] dot1q termination vid 10
    [CE1-GigabitEthernet1/0/0.1] quit

    # Configure CE2.

    [CE2] interface gigabitethernet 1/0/0.1
    [CE2-GigabitEthernet1/0/0.1] dot1q termination vid 10
    [CE2-GigabitEthernet1/0/0.1] quit

  3. Configure an IGP on the MPLS backbone network. OSPF is used as an example.

    # Configure PE1, P, and PE2 to advertise 32-bit loopback interface addresses as the LSR IDs.

    # Configure PE1. The configuration details of other devices are not mentioned here.

    [PE1] ospf 1
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] network 10.10.1.9 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit
    

  4. Configure basic MPLS functions and MPLS LDP on the MPLS network.

    # Configure PE1.

    [PE1] mpls lsr-id 10.10.1.9
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] mpls
    [PE1-GigabitEthernet2/0/0] mpls ldp
    [PE1-GigabitEthernet2/0/0] quit

    # Configure P.

    [P] mpls lsr-id 10.20.2.9
    [P] mpls
    [P-mpls] quit
    [P] mpls ldp
    [P-mpls-ldp] quit
    [P] interface gigabitethernet 2/0/0
    [P-GigabitEthernet2/0/0] mpls
    [P-GigabitEthernet2/0/0] mpls ldp
    [P-GigabitEthernet2/0/0] quit
    [P] interface gigabitethernet 1/0/0
    [P-GigabitEthernet1/0/0] mpls
    [P-GigabitEthernet1/0/0] mpls ldp
    [P-GigabitEthernet1/0/0] quit

    # Configure PE2.

    [PE2] mpls lsr-id 10.30.3.9
    [PE2] mpls
    [PE2-mpls] quit
    [PE2] mpls ldp
    [PE2-mpls-ldp] quit
    [PE2] interface gigabitethernet 1/0/0
    [PE2-GigabitEthernet1/0/0] mpls
    [PE2-GigabitEthernet1/0/0] mpls ldp
    [PE2-GigabitEthernet1/0/0] quit

  5. Set up a remote LDP session between PEs.

    # Configure PE1.

    [PE1] mpls ldp remote-peer 10.30.3.9
    [PE1-mpls-ldp-remote-10.30.3.9] remote-ip 10.30.3.9
    [PE1-mpls-ldp-remote-10.30.3.9] quit

    # Configure PE2.

    [PE2] mpls ldp remote-peer 10.10.1.9
    [PE2-mpls-ldp-remote-10.10.1.9] remote-ip 10.10.1.9
    [PE2-mpls-ldp-remote-10.10.1.9] quit

    # After the configuration is complete, run the display mpls ldp session command on PE1 to view the LDP session setup. You can see that an LDP session is set up between PE1 and PE2.

    [PE1] display mpls ldp session
                                                                                    
     LDP Session(s) in Public Network                                               
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)                  
     A '*' before a session means the session is being deleted.                     
     ------------------------------------------------------------------------------ 
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv            
     ------------------------------------------------------------------------------ 
     10.20.2.9:0          Operational DU   Passive  0000:00:11  46/45                 
     10.30.3.9:0          Operational DU   Passive  0000:00:01  8/8                   
     ------------------------------------------------------------------------------ 
     TOTAL: 2 session(s) Found.                                                     
                                                                                    

  6. Enable MPLS L2VPN and create VCs on PEs.

    # On PE1, create a VC on GE1/0/0.1 connected to CE1.

    [PE1] mpls l2vpn
    [PE1-l2vpn] quit
    [PE1] interface gigabitethernet 1/0/0.1
    [PE1-GigabitEthernet1/0/0.1] dot1q termination vid 10
    [PE1-GigabitEthernet1/0/0.1] mpls l2vc 10.30.3.9 101
    [PE1-GigabitEthernet1/0/0.1] quit

    # On PE2, create a VC on GE2/0/0.1 connected to CE2.

    [PE2] mpls l2vpn
    [PE2-l2vpn] quit
    [PE2] interface gigabitethernet 2/0/0.1
    [PE2-GigabitEthernet2/0/0.1] dot1q termination vid 10
    [PE2-GigabitEthernet2/0/0.1] mpls l2vc 10.10.1.9 101
    [PE2-GigabitEthernet2/0/0.1] quit

  7. Verify the configuration.

    # Check L2VPN connections on PEs. You can see that an L2VC connection has been set up and is in Up state.

    [PE1] display mpls l2vc interface gigabitethernet 1/0/0.1
     *client interface       : GigabitEthernet1/0/0.1 is up
      Administrator PW       : no
      session state          : up
      AC status              : up
      Ignore AC state        : disable
      VC state               : up
      Label state            : 0
      Token state            : 0
      VC ID                  : 101
      VC type                : VLAN
      destination            : 10.30.3.9
      local group ID         : 0            remote group ID      : 0
      local VC label         : 1024         remote VC label      : 1024
      local AC OAM State     : up
      local PSN OAM State    : up
      local forwarding state : forwarding
      local status code      : 0x0
      remote AC OAM state    : up
      remote PSN OAM state   : up
      remote forwarding state: forwarding
      remote status code     : 0x0
      ignore standby state   : no
      BFD for PW             : unavailable
      VCCV State             : up
      manual fault           : not set
      active state           : active
      forwarding entry       : exist
      link state             : up
      local VC MTU           : 1500         remote VC MTU        : 1500
      local VCCV             : alert ttl lsp-ping bfd
      remote VCCV            : alert ttl lsp-ping bfd
      local control word     : disable      remote control word  : disable
      tunnel policy name     : --
      PW template name       : --
      primary or secondary   : primary
      load balance type      : flow
      Access-port            : false
      Switchover Flag        : false
      VC tunnel/token info   : 1 tunnels/tokens
        NO.0  TNL type       : lsp   , TNL ID : 0x5
        Backup TNL type      : lsp   , TNL ID : 0x0
      create time            : 0 days, 0 hours, 27 minutes, 15 seconds
      up time                : 0 days, 0 hours, 2 minutes, 22 seconds
      last change time       : 0 days, 0 hours, 2 minutes, 22 seconds
      VC last up time        : 2011/09/26 15:29:03
      VC total up time       : 0 days, 0 hours, 2 minutes, 22 seconds
      CKey                   : 5
      NKey                   : 4
      PW redundancy mode     : frr
      AdminPw interface      : --
      AdminPw link state     : --
      Diffserv Mode          : uniform
      Service Class          : --
      Color                  : --
      DomainId               : --
      Domain Name            : --
      

    # CE1 and CE2 can ping each other.

    [CE1] ping 10.100.1.2
      PING 10.100.1.2: 56  data bytes, press CTRL_C to break
        Reply from 10.100.1.2: bytes=56 Sequence=1 ttl=255 time=31 ms
        Reply from 10.100.1.2: bytes=56 Sequence=2 ttl=255 time=10 ms
        Reply from 10.100.1.2: bytes=56 Sequence=3 ttl=255 time=5 ms
        Reply from 10.100.1.2: bytes=56 Sequence=4 ttl=255 time=2 ms
        Reply from 10.100.1.2: bytes=56 Sequence=5 ttl=255 time=28 ms
      --- 10.100.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 2/15/31 ms 

Configuration Files

  • CE1 configuration file

    #
     sysname CE1
    #
    interface GigabitEthernet1/0/0
    #
    interface GigabitEthernet1/0/0.1
     dot1q termination vid 10
     ip address 10.100.1.1 255.255.255.0
    #
    return
  • PE1 configuration file

    #
     sysname PE1
    #
    mpls lsr-id 10.10.1.9
    mpls
    #
    mpls l2vpn
    #
    mpls ldp
    #
    mpls ldp remote-peer 10.30.3.9
     remote-ip 10.30.3.9
    #
    interface GigabitEthernet1/0/0
    #
    interface GigabitEthernet1/0/0.1
     dot1q termination vid 10
     mpls l2vc 10.30.3.9 101
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 10.10.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.10.1.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • P configuration file

    #
     sysname P
    #
    mpls lsr-id 10.20.2.9
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 10.20.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.20.2.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
  • PE2 configuration file

    #
     sysname PE2
    #
    mpls lsr-id 10.30.3.9
    mpls
    #
    mpls l2vpn
    #
    mpls ldp
    #
    mpls ldp remote-peer 10.10.1.9
     remote-ip 10.10.1.9
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
    #
    interface GigabitEthernet2/0/0.1
     dot1q termination vid 10
     mpls l2vc 10.10.1.9 101
    #
    interface LoopBack1
     ip address 10.30.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.30.3.9 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
  • CE2 configuration file

    #
     sysname CE2
    #
    interface GigabitEthernet1/0/0
    #
    interface GigabitEthernet1/0/0.1
     dot1q termination vid 10
     ip address 10.100.1.2 255.255.255.0
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174108

Views: 56299

Downloads: 42

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next