No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009 CLI-based Configuration Guide - Ethernet Switching

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Connecting a QinQ VLAN Tag Termination Sub-interface to an L3VPN

Example for Connecting a QinQ VLAN Tag Termination Sub-interface to an L3VPN

Networking Requirements

As shown in Figure 6-12, CE1 and CE3 belong to VPN-A, and CE2 and CE4 belong to VPN-B. The VPN targets of VPN-A and VPN-B are 111:1 and 222:2 respectively. Users in different VPNs cannot communicate with each other.

Figure 6-12  Networking diagram for connecting a QinQ VLAN tag termination sub-interface to an L3VPN

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure VPN instances on PEs connected to CEs on the backbone network, bind interfaces connected to CEs to VPN instances, and assign IP addresses to interfaces connected to CEs.

  2. Configure OSPF on PEs to implement interworking.

  3. Configure basic MPLS functions and MPLS LDP, and set up MPLS LSPs.

  4. Configure the Multi-protocol Extensions for Interior Border Gateway Protocol (MP-IBGP) on PEs to exchange VPN routing information.

  5. Configure EBGP on CEs and PEs to exchange VPN routing information.

  6. Configure QinQ sub-interfaces on PE interfaces connected to CEs to connect the QinQ sub-interfaces to the L3VPN network.

Procedure

  1. Configure OSPF on the MPLS backbone network so that the PEs and P can communicate with each other.

    # Configure PE1.

    <Huawei> system-view
    [Huawei] sysname PE1
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 10.10.1.9 32
    [PE1-LoopBack1] quit
    [PE1] interface gigabitethernet 3/0/0
    [PE1-GigabitEthernet3/0/0] ip address 172.16.1.1 24
    [PE1-GigabitEthernet3/0/0] quit
    [PE1] ospf 1
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 172.16.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] network 10.10.1.9 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit
    

    # Configure P.

    <Huawei> system-view
    [Huawei] sysname P
    [P] interface loopback 1
    [P-LoopBack1] ip address 10.20.2.9 32
    [P-LoopBack1] quit
    [P] interface gigabitethernet 1/0/0 
    [P-GigabitEthernet1/0/0] ip address 172.16.1.2 24
    [P-GigabitEthernet1/0/0] quit
    [P] interface gigabitethernet 2/0/0
    [P-GigabitEthernet2/0/0] ip address 172.26.1.1 24
    [P-GigabitEthernet2/0/0] quit
    [P] ospf 1
    [P-ospf-1] area 0
    [P-ospf-1-area-0.0.0.0] network 172.16.1.0 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 172.26.1.0 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 10.20.2.9 0.0.0.0
    [P-ospf-1-area-0.0.0.0] quit
    [P-ospf-1] quit
    

    # Configure PE2.

    <Huawei> system-view
    [Huawei] sysname PE2
    [PE2] interface loopback 1
    [PE2-LoopBack1] ip address 10.30.3.9 32
    [PE2-LoopBack1] quit
    [PE2] interface gigabitethernet 3/0/0 
    [PE2-GigabitEthernet3/0/0] ip address 172.26.1.2 24
    [PE2-GigabitEthernet3/0/0] quit
    [PE2] ospf 1
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 172.26.1.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] network 10.30.3.9 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit
    

    # After the configuration is complete, PE1, P, and PE2 can establish OSPF neighbor relationships. Run the display ospf peer command. The command output shows that the OSPF neighbor relationship status is Full. Run the display ip routing-table command. The command output shows that PEs have learned the routes to the each other's Loopback1 interface.

    # The display on PE1 is used as an example.

    [PE1] display ip routing-table
    Route Flags: R - relay,
    D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 11       Routes : 11
    
      Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
    
           10.10.1.9/32   Direct 0    0           D  10.0.0.1       LoopBack1
           10.20.2.9/32   OSPF   10   1           D  172.16.1.2     GigabitEthernet3/0/0
           10.30.3.9/32   OSPF   10   2           D  172.16.1.2     GigabitEthernet3/0/0
            10.0.0.0/8    Direct 0    0           D  10.0.0.1       InLoopBack0
            10.0.0.1/32   Direct 0    0           D  10.0.0.1       InLoopBack0
      10.255.255.255/32   Direct 0    0           D  10.0.0.1       InLoopBack0 
          172.16.1.0/24   Direct 0    0           D  172.16.1.1     GigabitEthernet3/0/0
          172.16.1.1/32   Direct 0    0           D  10.0.0.1       GigabitEthernet3/0/0
        172.16.1.255/32   Direct 0    0           D  10.0.0.1       GigabitEthernet3/0/0
          172.26.1.0/24   OSPF   10   2           D  172.16.1.2     GigabitEthernet3/0/0
     255.255.255.255/32   Direct 0    0           D  10.0.0.1       InLoopBack0
    [PE1] display ospf peer
    
              OSPF Process 1 with Router ID 10.10.1.9
                      Neighbors
    
     Area 0.0.0.0 interface 172.16.1.1(GigabitEthernet3/0/0)'s neighbors
     Router ID: 10.20.2.9         Address: 172.16.1.2
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 172.16.1.1  BDR: 172.16.1.2  MTU: 0 
       Dead timer due in 37  sec
       Retrans timer interval: 5
       Neighbor is up for 00:16:21
       Authentication Sequence: [ 0 ]

  2. Configure basic MPLS functions and MPLS LDP on the MPLS backbone network to set up LDP LSPs.

    # Configure PE1.

    [PE1] mpls lsr-id 10.10.1.9
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface gigabitethernet 3/0/0
    [PE1-GigabitEthernet3/0/0] mpls
    [PE1-GigabitEthernet3/0/0] mpls ldp
    [PE1-GigabitEthernet3/0/0] quit

    # Configure P.

    [P] mpls lsr-id 10.20.2.9
    [P] mpls
    [P-mpls] quit
    [P] mpls ldp
    [P-mpls-ldp] quit
    [P] interface gigabitethernet 1/0/0
    [P-GigabitEthernet1/0/0] mpls
    [P-GigabitEthernet1/0/0] mpls ldp
    [P-GigabitEthernet1/0/0] quit
    [P] interface gigabitethernet 2/0/0
    [P-GigabitEthernet2/0/0] mpls
    [P-GigabitEthernet2/0/0] mpls ldp
    [P-GigabitEthernet2/0/0] quit
    

    # Configure PE2.

    [PE2] mpls lsr-id 10.30.3.9
    [PE2] mpls
    [PE2-mpls] quit
    [PE2] mpls ldp
    [PE2-mpls-ldp] quit
    [PE2] interface gigabitethernet 3/0/0
    [PE2-GigabitEthernet3/0/0] mpls
    [PE2-GigabitEthernet3/0/0] mpls ldp
    [PE2-GigabitEthernet3/0/0] quit
    

    # After the configuration is complete, LDP sessions can be set up between PE1 and the P, and between the P and PE2. Run the display mpls ldp session command. The command output shows that the Status field is Operational. Run the display mpls ldp lsp command. Information about the established LDP LSPs is displayed.

    # The display on PE1 is used as an example.

    [PE1] display mpls ldp session
    
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     A '*' before a session means the session is being deleted. 
     ------------------------------------------------------------------------------
     PeerID           Status      LAM  SsnRole  SsnAge      KASent/Rcv
     ------------------------------------------------------------------------------
     10.20.2.9:0          Operational DU   Active   0000:00:01  6/6
     ------------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.
    [PE1] display mpls ldp lsp
    
    LDP LSP Information
     -------------------------------------------------------------------------------
     DestAddress/Mask   In/OutLabel   UpstreamPeer     NextHop     OutInterface   
     -------------------------------------------------------------------------------
     10.10.1.9/32         3/NULL        10.20.2.9          10.0.0.1   InLoop0    
    *10.10.1.9/32         Liberal/1024                   DS/10.20.2.9 
     10.20.2.9/32         NULL/3        -                172.16.1.2   GE3/0/0       
     10.20.2.9/32         1024/3        10.20.2.9          172.16.1.2   GE3/0/0       
     10.30.3.9/32         NULL/1025     -                172.16.1.2   GE3/0/0       
     10.30.3.9/32         1025/1025     10.20.2.9          172.16.1.2   GE3/0/0      
     -------------------------------------------------------------------------------
     TOTAL: 5 Normal LSP(s) Found.
     TOTAL: 1 Liberal LSP(s) Found.
     TOTAL: 0 Frr LSP(s) Found.
     A '*' before an LSP means the LSP is not established                           
     A '*' before a Label means the USCB or DSCB is stale                           
     A '*' before a UpstreamPeer means the session is stale                         
     A '*' before a DS means the session is stale                                   
     A '*' before a NextHop means the LSP is FRR LSP

  3. Configure CEs to send double-tagged packets to PEs.

    # Here, the inner VLAN ID in packets sent by CE1 and CE3 is VLAN 10, and outer VLAN ID is VLAN 100; the inner VLAN ID in packets sent by CE2 and CE4 is VLAN 20, and outer VLAN ID is VLAN 200.

    # Configure CE1.

    <Huawei> system-view
    [Huawei] sysname CE1
    [CE1] interface gigabitethernet 1/0/0.1
    [CE1-GigabitEthernet1/0/0.1] ip address 10.1.1.1 255.255.255.0
    [CE1-GigabitEthernet1/0/0.1] qinq termination pe-vid 100 ce-vid 10
    [CE1-GigabitEthernet1/0/0.1] quit

    # Configure CE2.

    <Huawei> system-view
    [Huawei] sysname CE2
    [CE2] interface gigabitethernet 1/0/0.1
    [CE2-GigabitEthernet1/0/0.1] ip address 10.2.1.1 255.255.255.0
    [CE2-GigabitEthernet1/0/0.1] qinq termination pe-vid 200 ce-vid 20
    [CE2-GigabitEthernet1/0/0.1] quit

    # Configure CE3.

    <Huawei> system-view
    [Huawei] sysname CE3
    [CE3] interface gigabitethernet 1/0/0.1
    [CE3-GigabitEthernet1/0/0.1] ip address 10.3.1.1 255.255.255.0
    [CE3-GigabitEthernet1/0/0.1] qinq termination pe-vid 100 ce-vid 10
    [CE3-GigabitEthernet1/0/0.1] quit

    # Configure CE4.

    <Huawei> system-view
    [Huawei] sysname CE4
    [CE4] interface gigabitethernet 1/0/0.1
    [CE4-GigabitEthernet1/0/0.1] ip address 10.4.1.1 255.255.255.0
    [CE4-GigabitEthernet1/0/0.1] qinq termination pe-vid 200 ce-vid 20
    [CE4-GigabitEthernet1/0/0.1] quit

  4. Configure VPN instances on PEs and bind the instances to the interfaces connected to CEs.

    # Configure PE1.

    [PE1] ip vpn-instance vpna
    [PE1-vpn-instance-vpna] ipv4-family
    [PE1-vpn-instance-vpna-af-ipv4] route-distinguisher 100:1
    [PE1-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE1-vpn-instance-vpna-af-ipv4] quit
    [PE1-vpn-instance-vpna] quit
    [PE1] ip vpn-instance vpnb
    [PE1-vpn-instance-vpnb] ipv4-family
    [PE1-vpn-instance-vpnb-af-ipv4] route-distinguisher 100:2
    [PE1-vpn-instance-vpnb-af-ipv4] vpn-target 222:2 both
    [PE1-vpn-instance-vpnb-af-ipv4] quit
    [PE1-vpn-instance-vpnb] quit
    [PE1] interface gigabitethernet 1/0/0.1
    [PE1-GigabitEthernet1/0/0.1] ip binding vpn-instance vpna
    [PE1-GigabitEthernet1/0/0.1] ip address 10.1.1.2 24
    [PE1-GigabitEthernet1/0/0.1] qinq termination pe-vid 100 ce-vid 10
    [PE1-GigabitEthernet1/0/0.1] quit
    [PE1] interface gigabitethernet 2/0/0.1
    [PE1-GigabitEthernet2/0/0.1] ip binding vpn-instance vpnb
    [PE1-GigabitEthernet2/0/0.1] ip address 10.2.1.2 24
    [PE1-GigabitEthernet2/0/0.1] qinq termination pe-vid 200 ce-vid 20
    [PE1-GigabitEthernet2/0/0.1] quit
    

    # Configure PE2.

    [PE2] ip vpn-instance vpna
    [PE2-vpn-instance-vpna] ipv4-family
    [PE2-vpn-instance-vpna-af-ipv4] route-distinguisher 200:1
    [PE2-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE2-vpn-instance-vpna-af-ipv4] quit
    [PE2-vpn-instance-vpna] quit
    [PE2] ip vpn-instance vpnb
    [PE2-vpn-instance-vpnb] ipv4-family
    [PE2-vpn-instance-vpnb-af-ipv4] route-distinguisher 200:2
    [PE2-vpn-instance-vpnb-af-ipv4] vpn-target 222:2 both
    [PE2-vpn-instance-vpnb-af-ipv4] quit
    [PE2-vpn-instance-vpnb] quit
    [PE2] interface gigabitethernet 1/0/0.1
    [PE2-GigabitEthernet1/0/0.1] ip binding vpn-instance vpna
    [PE2-GigabitEthernet1/0/0.1] ip address 10.3.1.2 24
    [PE2-GigabitEthernet1/0/0.1] qinq termination pe-vid 100 ce-vid 10
    [PE2-GigabitEthernet1/0/0.1] quit
    [PE2] interface gigabitethernet 2/0/0.1
    [PE2-GigabitEthernet2/0/0.1] ip binding vpn-instance vpnb
    [PE2-GigabitEthernet2/0/0.1] ip address 10.4.1.2 24
    [PE2-GigabitEthernet2/0/0.1] qinq termination pe-vid 200 ce-vid 20
    [PE2-GigabitEthernet2/0/0.1] quit
    

    # After the configuration is complete, run the display ip vpn-instance verbose command on PEs to check the VPN instance configuration. Each PE can ping its connected CE.

    NOTE:

    If multiple interfaces of a PE are bound to the same VPN instance, run the ping -vpn-instance vpn-instance-name -a source-ip-address dest-ip-address command with -a source-ip-address specified to ping the CE connected to the remote PE. Otherwise, the ping operation may fail.

    The display on PE1 is used as an example.

    [PE1] display ip vpn-instance verbose
     Total VPN-Instances configured : 2
     Total IPv4 VPN-Instances configured : 2
     Total IPv6 VPN-Instances configured : 0
    
     VPN-Instance Name and ID : vpna, 1
      Interfaces : GigabitEthernet1/0/0.1
     Address family ipv4
      Create date : 2012/07/25 00:58:17
      Up time : 0 days, 22 hours, 24 minutes and 53 seconds
      Route Distinguisher : 100:1
      Export VPN Targets :  111:1
      Import VPN Targets :  111:1
      Label Policy : label per route
      Log Interval : 5
    
     VPN-Instance Name and ID : vpnb, 2
      Interfaces : GigabitEthernet2/0/0.1
     Address family ipv4
      Create date : 2012/07/25 00:58:17
      Up time : 0 days, 22 hours, 24 minutes and 53 seconds
      Route Distinguisher : 100:2
      Export VPN Targets :  222:2
      Import VPN Targets :  222:2
      Label Policy : label per route
      Log Interval : 5
    [PE1] ping -vpn-instance vpna 10.1.1.1
      PING 10.1.1.1: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.1: bytes=56 Sequence=1 ttl=255 time=5 ms
        Reply from 10.1.1.1: bytes=56 Sequence=2 ttl=255 time=3 ms
        Reply from 10.1.1.1: bytes=56 Sequence=3 ttl=255 time=3 ms
        Reply from 10.1.1.1: bytes=56 Sequence=4 ttl=255 time=3 ms
        Reply from 10.1.1.1: bytes=56 Sequence=5 ttl=255 time=16 ms
    
      --- 10.1.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 3/6/16 ms

  5. Set up an MP-IBGP peer relationship between PEs.

    # Configure PE1.

    [PE1] bgp 100
    [PE1-bgp] peer 10.30.3.9 as-number 100
    [PE1-bgp] peer 10.30.3.9 connect-interface loopback 1
    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 10.30.3.9 enable
    [PE1-bgp-af-vpnv4] quit
    [PE1-bgp] quit

    # Configure PE2.

    [PE2] bgp 100
    [PE2-bgp] peer 10.10.1.9 as-number 100
    [PE2-bgp] peer 10.10.1.9 connect-interface loopback 1
    [PE2-bgp] ipv4-family vpnv4
    [PE2-bgp-af-vpnv4] peer 10.10.1.9 enable
    [PE2-bgp-af-vpnv4] quit
    [PE2-bgp] quit

    # After the configuration is complete, run the display bgp peer or display bgp vpnv4 all peer command on PEs. The command output shows that a BGP peer relationship has been established between PEs.

    [PE1] display bgp peer
    
     BGP local router ID : 10.10.1.9
     Local AS number : 100
     Total number of peers : 1                 Peers in established state : 1
    
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State              PrefRcv
    
      10.30.3.9         4   100       12        6     0 00:02:21        Established       0
    [PE1] display bgp vpnv4 all peer
    
    BGP local router ID : 10.10.1.9
     Local AS number : 100
     Total number of peers : 1                 Peers in established state : 1
    
      Peer            V    AS  MsgRcvd  MsgSent    OutQ  Up/Down    State        PrefRcv
    
      10.30.3.9         4   100   12      18         0     00:09:38   Established   0

  6. Set up EBGP peer relationships between PEs and CEs and import VPN routes into BGP.

    # Configure CE1. The configurations of other CEs are similar to the configuration on CE1, and are not mentioned here.

    [CE1] bgp 65410
    [CE1-bgp] peer 10.1.1.2 as-number 100
    [CE1-bgp] import-route direct
    [CE1-bgp] quit
    

    # Configure PE1. The configuration of PE2 is similar to the configuration of PE1, and is not mentioned here.

    [PE1] bgp 100
    [PE1-bgp] ipv4-family vpn-instance vpna
    [PE1-bgp-vpna] peer 10.1.1.1 as-number 65410
    [PE1-bgp-vpna] import-route direct
    [PE1-bgp-vpna] quit
    [PE1-bgp] ipv4-family vpn-instance vpnb
    [PE1-bgp-vpnb] peer 10.2.1.1 as-number 65420
    [PE1-bgp-vpnb] import-route direct
    [PE1-bgp-vpnb] quit
    [PE1-bgp] quit

    # After the configuration is complete, run the display bgp vpnv4 vpn-instance peer command on PEs. The command output shows that BGP peer relationships have been established between PEs and CEs.

    # The peer relationship between PE1 and CE1 is used as an example.

    [PE1] display bgp vpnv4 vpn-instance vpna peer
                                                                                    
     BGP local router ID : 10.10.1.9                                                  
     Local AS number : 100                                                          
                                                                                    
     VPN-Instance vpna, Router ID 10.10.1.9:                                          
     Total number of peers : 1                Peers in established state : 1        
                                                                                    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
                                                                                    
      10.1.1.1        4       65410        6        3     0 00:00:02 Established       4  

  7. Verify the configuration.

    # Run the display ip routing-table vpn-instance command on PEs to view the routes to the remote CEs.

    # The display on PE1 is used as an example.

    [PE1] display ip routing-table vpn-instance vpna
    Route Flags: R - relay,
    D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: vpna
             Destinations : 5        Routes : 5
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface  
    
           10.1.1.0/24  Direct  0    0           D   10.1.1.2       GigabitEthernet1/0/0
           10.1.1.2/32  Direct  0    0           D   10.0.0.1       GigabitEthernet1/0/0
         10.1.1.255/32  Direct  0    0           D   10.0.0.1       GigabitEthernet1/0/0
           10.3.1.0/24  IBGP    255  0           RD  10.30.3.9      GigabitEthernet3/0/0
    255.255.255.255/32  Direct  0    0           D   10.0.0.1       InLoopBack0   
    [PE1] display ip routing-table vpn-instance vpnb
    Route Flags: R - relay,
    D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: vpnb
             Destinations : 5        Routes : 5
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface  
    
           10.2.1.0/24  Direct  0    0         D     10.2.1.2       GigabitEthernet2/0/0
           10.2.1.2/32  Direct  0    0         D     10.0.0.1       GigabitEthernet2/0/0
         10.2.1.255/32  Direct  0    0         D     10.0.0.1       GigabitEthernet2/0/0
           10.4.1.0/24  IBGP    255  0         RD    10.30.3.9      GigabitEthernet3/0/0
    255.255.255.255/32  Direct  0    0         D     10.0.0.1       InLoopBack0

    # CEs in the same VPN can ping each other, whereas CEs in different VPNs cannot.

    # For example, CE1 can ping CE3 at 10.3.1.1 but cannot ping CE4 at 10.4.1.1.

    [CE1] ping 10.3.1.1
      PING 10.3.1.1: 56  data bytes, press CTRL_C to break
        Reply from 10.3.1.1: bytes=56 Sequence=1 ttl=253 time=72 ms
        Reply from 10.3.1.1: bytes=56 Sequence=2 ttl=253 time=34 ms
        Reply from 10.3.1.1: bytes=56 Sequence=3 ttl=253 time=50 ms
        Reply from 10.3.1.1: bytes=56 Sequence=4 ttl=253 time=50 ms
        Reply from 10.3.1.1: bytes=56 Sequence=5 ttl=253 time=34 ms
      --- 10.3.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 34/48/72 ms  
    [CE1] ping 10.4.1.1
      PING 10.4.1.1: 56  data bytes, press CTRL_C to break
        Request time out
        Request time out
        Request time out
        Request time out
        Request time out
      --- 10.4.1.1 ping statistics ---
        5 packet(s) transmitted
        0 packet(s) received
        100.00% packet loss

Configuration Files

  • PE1 configuration file

    #
     sysname PE1
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 100:2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
     mpls lsr-id 10.10.1.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
    #
    interface GigabitEthernet1/0/0.1
     qinq termination pe-vid 100 ce-vid 10
     ip binding vpn-instance vpna
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
    #
    interface GigabitEthernet2/0/0.1
     qinq termination pe-vid 200 ce-vid 20
     ip binding vpn-instance vpnb
     ip address 10.2.1.2 255.255.255.0
    #
    interface GigabitEthernet3/0/0
     ip address 172.16.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 10.10.1.9 255.255.255.255
    # 
    bgp 100
     peer 10.30.3.9 as-number 100
     peer 10.30.3.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 10.30.3.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 10.30.3.9 enable
     #
     ipv4-family vpn-instance vpna
      import-route direct
      peer 10.1.1.1 as-number 65410
    #
     ipv4-family vpn-instance vpnb
      import-route direct
      peer 10.2.1.1 as-number 65420
    #
    ospf 1
     area 0.0.0.0
      network 10.10.1.9 0.0.0.0
      network 172.16.1.0 0.0.0.255
    #
    return
  • P configuration file

    #
     sysname P
    #
     mpls lsr-id 10.20.2.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip address 172.16.1.2 255.255.255.0
     mpls
     mpls ldp
    # 
    interface GigabitEthernet2/0/0
     ip address 172.26.1.1 255.255.255.0
     mpls
     mpls ldp
    # 
    interface LoopBack1
     ip address 10.20.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.20.2.9 0.0.0.0
      network 172.16.1.0 0.0.0.255
      network 172.26.1.0 0.0.0.255
    #
    return
  • PE2 configuration file

    #
     sysname PE2
    #
    ip vpn-instance vpna                                                            
     ipv4-family  
      route-distinguisher 200:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb                                                            
     ipv4-family           
      route-distinguisher 200:2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
     mpls lsr-id 10.30.3.9
     mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
    #
    interface GigabitEthernet1/0/0.1
     qinq termination pe-vid 100 ce-vid 10
     ip binding vpn-instance vpna
     ip address 10.3.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
    #
    interface GigabitEthernet2/0/0.1
     qinq termination pe-vid 200 ce-vid 20
     ip binding vpn-instance vpnb
     ip address 10.4.1.2 255.255.255.0
    # 
    interface GigabitEthernet3/0/0
     ip address 172.26.1.2 255.255.255.0
     mpls
     mpls ldp
    # 
    interface LoopBack1
     ip address 10.30.3.9 255.255.255.255
    #
    bgp 100
     peer 10.10.1.9 as-number 100
     peer 10.10.1.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 10.10.1.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 10.10.1.9 enable 
     #
     ipv4-family vpn-instance vpna
      import-route direct
      peer 10.3.1.1 as-number 65430
     #
     ipv4-family vpn-instance vpnb
      import-route direct
      peer 10.4.1.1 as-number 65440
    #
    ospf 1
     area 0.0.0.0
      network 10.30.3.9 0.0.0.0
      network 172.26.1.0 0.0.0.255
    # 
    return
  • CE1 configuration file

    #
     sysname CE1
    #
    interface GigabitEthernet1/0/0
    #
    interface GigabitEthernet1/0/0.1
     qinq termination pe-vid 100 ce-vid 10
     ip address 10.1.1.1 255.255.255.0
    #
    bgp 65410
     peer 10.1.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.1.1.2 enable
    #
    return
  • CE2 configuration file

    #
     sysname CE2
    #
    interface GigabitEthernet1/0/0
    #
    interface GigabitEthernet1/0/0.1
     qinq termination pe-vid 200 ce-vid 20
     ip address 10.2.1.1 255.255.255.0
    #
    bgp 65420
     peer 10.2.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.2.1.2 enable
    #
    return
  • CE3 configuration file

    #
     sysname CE3
    #
    interface GigabitEthernet1/0/0
    #
    interface GigabitEthernet1/0/0.1
     qinq termination pe-vid 100 ce-vid 10
     ip address 10.3.1.1 255.255.255.0
    #
    bgp 65430
     peer 10.3.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.3.1.2 enable
    #
    return
  • CE4 configuration file

    #
     sysname CE4
    #
    interface GigabitEthernet1/0/0
    #
    interface GigabitEthernet1/0/0.1
     qinq termination pe-vid 200 ce-vid 20
     ip address 10.4.1.1 255.255.255.0
    #
    bgp 65440
     peer 10.4.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.4.1.2 enable
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174108

Views: 56382

Downloads: 42

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next