No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009 CLI-based Configuration Guide - Ethernet Switching

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the MUX VLAN Function

Example for Configuring the MUX VLAN Function

Networking Requirements

An enterprise forbids communication between some departments and allows communication between other departments. All employees in the enterprise are allowed to access certain servers.

The MUX VLAN function can be configured to meet the preceding requirements. The enterprise needs to add the servers to the principal VLAN, add the hosts that need to communicate to a group VLAN, and add the hosts that need to be isolated to a separate VLAN. Employing this function reduces the needed VLAN IDs.

As shown in Figure 5-2, Ethernet 2/0/1 is connected to Server A; Ethernet 2/0/2 is connected to Host B; Ethernet 2/0/3 is connected to Host C; Ethernet 2/0/4 is connected to Host D; Ethernet 2/0/5 is connected to Host E. To meet the preceding requirements, the enterprise needs to perform the following configurations: configure VLAN 2 as a principal VLAN and add Ethernet 2/0/1 to VLAN 2; configure VLAN 3 as a subordinate group VLAN and add Ethernet 2/0/2 and Ethernet 2/0/3 to VLAN 3; configure VLAN 4 as a subordinate separate VLAN and add Ethernet 2/0/4 and Ethernet 2/0/5 to VLAN 4.

Figure 5-2  Network diagram of MUX VLAN

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the principal VLAN.

  2. Configure the group VLAN.

  3. Configure the separate VLAN.

  4. Add interfaces to the VLANs and enable the MUX VLAN function on the interfaces.

Procedure

  1. Configure the MUX VLAN function.

    # Create VLAN 2, VLAN 3, and VLAN 4.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 2 3 4

    # Configure the principal and subordinate VLANs.

    [Router] vlan 2
    [Router-vlan2] mux-vlan
    [Router-vlan2] subordinate group 3
    [Router-vlan2] subordinate separate 4
    [Router-vlan2] quit

    # Add interfaces to the VLANs and enable the MUX VLAN function on the interfaces.

    [Router] interface ethernet 2/0/1
    [Router-Ethernet2/0/1] port link-type access
    [Router-Ethernet2/0/1] port default vlan 2
    [Router-Ethernet2/0/1] port mux-vlan enable
    [Router-Ethernet2/0/1] quit
    [Router] interface ethernet 2/0/2
    [Router-Ethernet2/0/2] port link-type access
    [Router-Ethernet2/0/2] port default vlan 3
    [Router-Ethernet2/0/2] port mux-vlan enable
    [Router-Ethernet2/0/2] quit
    [Router] interface ethernet 2/0/3
    [Router-Ethernet2/0/3] port link-type access
    [Router-Ethernet2/0/3] port default vlan 3
    [Router-Ethernet2/0/3] port mux-vlan enable
    [Router-Ethernet2/0/3] quit
    [Router] interface ethernet 2/0/4
    [Router-Ethernet2/0/4] port link-type access
    [Router-Ethernet2/0/4] port default vlan 4
    [Router-Ethernet2/0/4] port mux-vlan enable
    [Router-Ethernet2/0/4] quit
    [Router] interface ethernet 2/0/5
    [Router-Ethernet2/0/5] port link-type access
    [Router-Ethernet2/0/5] port default vlan 4
    [Router-Ethernet2/0/5] port mux-vlan enable
    [Router-Ethernet2/0/5] quit

  2. Verify the configuration.

    # Server A can ping Hosts B to E. Hosts B to E can also ping Server A.

    # Host B and Host C can ping each other.

    # Host D and Host E cannot ping each other.

    # Host B and Host C cannot ping Host D or host E. Host D and Host E cannot ping Host B or Host C.

Configuration Files

Configuration file of the Router

#
 sysname Router
#
vlan batch 2 to 4
#
vlan 2
 mux-vlan
 subordinate separate 4 
 subordinate group 3
#
interface Ethernet2/0/1
 port link-type access
 port default vlan 2 
 port mux-vlan enable
#
interface Ethernet2/0/2
 port link-type access
 port default vlan 3
 port mux-vlan enable
#
interface Ethernet2/0/3
 port link-type access
 port default vlan 3
 port mux-vlan enable
#
interface Ethernet2/0/4
 port link-type access
 port default vlan 4
 port mux-vlan enable
#
interface Ethernet2/0/5
 port link-type access
 port default vlan 4
 port mux-vlan enable
#
return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174108

Views: 56731

Downloads: 42

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next