No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009 CLI-based Configuration Guide - Ethernet Switching

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Connecting QinQ Termination Sub-interfaces to a VLL Network

Example for Connecting QinQ Termination Sub-interfaces to a VLL Network

Networking Requirements

As shown in Figure 6-10, CE1 and CE2 are connected to PE1 and PE2 respectively through VLANs.

A Martini VLL connection is set up between PE1 and PE2 to implement interworking between CE1 and CE2.

Figure 6-10  Networking for connecting Dot1q termination sub-interfaces to a VLL network

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IGP on PEs and the P on the backbone network to ensure reachability between them, and enable MPLS.

  2. Use the default tunnel policy to set up LSPs for transmitting user data.

  3. Enable MPLS L2VPN and create VCs on PEs.

  4. On PE interfaces connected to CEs, create QinQ sub-interfaces and connect the sub-interfaces to the VLL network.

Procedure

  1. Create a bridge group and add a sub-interface to the bridge group.

    # The display on CE1 is used as an example. The configuration of CE2 is similar to that of CE1, and is not mentioned here.

    <Huawei> system-view
    [Huawei] sysname CE1
    [CE1] bridge 1
    [CE1-bridge1] quit
    [CE1] interface gigabitethernet 1/0/0.1
    [CE1-GigabitEthernet1/0/0.1] bridge 1
    [CE1-GigabitEthernet1/0/0.1] bridge vlan-transmit enable
    [CE1-GigabitEthernet1/0/0.1] quit
    

  2. Configure CEs to send double-tagged packets to PEs.

    # Here, the inner VLAN ID is VLAN 10 and outer VLAN ID is VLAN 100. # The display on CE1 is used as an example. The configuration of CE2 is similar to that of CE1, and is not mentioned here.

    <Huawei> system-view
    [Huawei] sysname CE1
    [CE1] interface gigabitethernet 1/0/0.1
    [CE1-GigabitEthernet1/0/0.1] vlan stacking vid 10 pe-vid 100
    [CE1-GigabitEthernet1/0/0.1] quit

  3. Configure PEs to terminate double-tagged packets.

    # The display on PE1 is used as an example. The configuration of PE2 is similar to that of PE1, and is not mentioned here.

    <Huawei> system-view
    [Huawei] sysname PE1
    [PE1] interface gigabitethernet 1/0/0.1
    [PE1-GigabitEthernet1/0/0.1] qinq termination pe-vid 100 ce-vid 10
    [PE1-GigabitEthernet1/0/0.1] quit

  4. Assign an IP address to each device.

    # The display on PE1 is used as an example. The configuration of PE2 and P is similar to that of PE1, and is not mentioned here.

    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 10.10.1.9 255.255.255.255
    [PE1-LoopBack1] quit
    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] ip address 10.1.1.1 255.255.255.0
    [PE1-GigabitEthernet2/0/0] quit
    

  5. Configure an IGP on the MPLS backbone network. This example uses OSPF.

    # Configure OSPF to advertise the loopback interface addresses of 32-bit mask length on PE1, PE2, and P, which are used as the LSR IDs.

    # The display on PE1 is used as an example. The configurations of other devices are similar to the configuration of PE1, and are not mentioned here.

    [PE1] ospf 1
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] network 10.10.1.9 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit
    

  6. Configure basic MPLS functions and enable MPLS LDP on the MPLS backbone network.

    # Configure PE1.

    [PE1] mpls lsr-id 10.10.1.9
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] mpls
    [PE1-GigabitEthernet2/0/0] mpls ldp
    [PE1-GigabitEthernet2/0/0] quit

    # Configure the P.

    [P] mpls lsr-id 10.20.2.9
    [P] mpls
    [P-mpls] quit
    [P] mpls ldp
    [P-mpls-ldp] quit
    [P] interface gigabitethernet 2/0/0
    [P-GigabitEthernet2/0/0] mpls
    [P-GigabitEthernet2/0/0] mpls ldp
    [P-GigabitEthernet2/0/0] quit
    [P] interface gigabitethernet 1/0/0
    [P-GigabitEthernet1/0/0] mpls
    [P-GigabitEthernet1/0/0] mpls ldp
    [P-GigabitEthernet1/0/0] quit

    # Configure PE2.

    [PE2] mpls lsr-id 10.30.3.9
    [PE2] mpls
    [PE2-mpls] quit
    [PE2] mpls ldp
    [PE2-mpls-ldp] quit
    [PE2] interface gigabitethernet 1/0/0
    [PE2-GigabitEthernet1/0/0] mpls
    [PE2-GigabitEthernet1/0/0] mpls ldp
    [PE2-GigabitEthernet1/0/0] quit

  7. Create a remote LDP session between PE1 and PE2.

    # Configure PE1.

    [PE1] mpls ldp remote-peer 10.30.3.9
    [PE1-mpls-ldp-remote-10.30.3.9] remote-ip 10.30.3.9
    [PE1-mpls-ldp-remote-10.30.3.9] quit

    # Configure PE2.

    [PE2] mpls ldp remote-peer 10.10.1.9
    [PE2-mpls-ldp-remote-10.10.1.9] remote-ip 10.10.1.9
    [PE2-mpls-ldp-remote-10.10.1.9] quit

    # After the configuration is complete, run the display mpls ldp session command on PE1 to view the LDP session status. You can see that an LDP session is set up between PE1 and PE2.

    [PE1] display mpls ldp session
                                                                                    
     LDP Session(s) in Public Network                                               
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)                  
     A '*' before a session means the session is being deleted.                     
     ------------------------------------------------------------------------------ 
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv            
     ------------------------------------------------------------------------------ 
     10.20.2.9:0          Operational DU   Passive  0000:00:11  46/45                 
     10.30.3.9:0          Operational DU   Passive  0000:00:01  8/8                   
     ------------------------------------------------------------------------------ 
     TOTAL: 2 session(s) Found.                                                     
                                                                                    

  8. Enable MPLS L2VPN on PEs and establish VCs.

    # On PE1, create a VC on GE1/0/0.1 connected to CE1.

    [PE1] mpls l2vpn
    [PE1-l2vpn] quit
    [PE1] interface gigabitethernet 1/0/0.1
    [PE1-GigabitEthernet1/0/0.1] qinq termination pe-vid 100 ce-vid 10
    [PE1-GigabitEthernet1/0/0.1] mpls l2vc 10.30.3.9 101
    [PE1-GigabitEthernet1/0/0.1] quit

    # On PE2, create a VC on GE2/0/0.1 connected to CE2.

    [PE2] mpls l2vpn
    [PE2-l2vpn] quit
    [PE2] interface gigabitethernet 2/0/0.1
    [PE2-GigabitEthernet2/0/0.1] qinq termination pe-vid 100 ce-vid 10
    [PE2-GigabitEthernet2/0/0.1] mpls l2vc 10.10.1.9 101
    [PE2-GigabitEthernet2/0/0.1] quit

  9. Verify the configuration.

    # On PEs, check the L2VPN connections. You can see that an L2VC connection is set up and is in Up state.

    [PE1] display mpls l2vc interface gigabitethernet 1/0/0.1
     *client interface       : GigabitEthernet1/0/0.1 is up                                  
      Administrator PW       : no                                                   
      session state          : up                                                   
      AC status              : up                                                   
      Ignore AC state        : disable
      VC state               : up                                                   
      Label state            : 0                                                    
      Token state            : 0                                                    
      VC ID                  : 101                                                  
      VC type                : VLAN                                                 
      destination            : 10.30.3.9                                              
      local group ID         : 0            remote group ID      : 0                
      local VC label         : 1024         remote VC label      : 1024             
      local AC OAM State     : up                                                   
      local PSN OAM State    : up                                                   
      local forwarding state : forwarding                                           
      local status code      : 0x0                                                  
      remote AC OAM state    : up                                                   
      remote PSN OAM state   : up                                                   
      remote forwarding state: forwarding                                           
      remote status code     : 0x0                                                  
      ignore standby state   : no                                                   
      BFD for PW             : unavailable                                          
      VCCV State             : up                                                   
      manual fault           : not set                                              
      active state           : active                                               
      forwarding entry       : exist                                                
      link state             : up                                                   
      local VC MTU           : 1500         remote VC MTU        : 1500             
      local VCCV             : alert ttl lsp-ping bfd                               
      remote VCCV            : alert ttl lsp-ping bfd                               
      local control word     : disable      remote control word  : disable          
      tunnel policy name     : --                                                   
      PW template name       : --                                                   
      primary or secondary   : primary                                              
      load balance type      : flow                                                 
      Access-port            : false                                                
      Switchover Flag        : false                                                
      VC tunnel/token info   : 1 tunnels/tokens                                     
        NO.0  TNL type       : lsp   , TNL ID : 0x5                                 
        Backup TNL type      : lsp   , TNL ID : 0x0                                 
      create time            : 0 days, 0 hours, 27 minutes, 15 seconds              
      up time                : 0 days, 0 hours, 2 minutes, 22 seconds               
      last change time       : 0 days, 0 hours, 2 minutes, 22 seconds               
      VC last up time        : 2011/09/26 15:29:03                                  
      VC total up time       : 0 days, 0 hours, 2 minutes, 22 seconds               
      CKey                   : 5                                                    
      NKey                   : 4                                                    
      PW redundancy mode     : frr                                                  
      AdminPw interface      : --                                                   
      AdminPw link state     : --                                                   
      Diffserv Mode          : uniform                                              
      Service Class          : --                                                   
      Color                  : --                                                   
      DomainId               : --                                                   
      Domain Name            : --                                                   
                                                                                    

    # CE1 and CE2 can ping each other.

Configuration Files

  • Configuration file of CE1

    #
     sysname CE1
    #
    bridge 1
    #
    interface GigabitEthernet1/0/0
    #
    interface GigabitEthernet1/0/0.1
     bridge 1
     bridge vlan-transmit enable
     vlan stacking vid 10 pe-vid 100
    #
    return
  • Configuration file of CE2

    #
     sysname CE2
    #
    bridge 1
    #
    interface GigabitEthernet1/0/0
    #
    interface GigabitEthernet1/0/0.1
     bridge 1
     bridge vlan-transmit enable
     vlan stacking vid 10 pe-vid 100
    #
    return
  • Configuration file of PE1

    #
     sysname PE1
    #
    mpls lsr-id 10.10.1.9
    mpls
    #
    mpls l2vpn
    #
    mpls ldp
    #
    mpls ldp remote-peer 10.30.3.9
     remote-ip 10.30.3.9
    #
    interface GigabitEthernet1/0/0
    #
    interface GigabitEthernet1/0/0.1
     qinq termination pe-vid 100 ce-vid 10
     mpls l2vc 10.30.3.9 101
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 10.10.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.10.1.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • Configuration file of the P

    #
     sysname P
    #
    mpls lsr-id 10.20.2.9
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 10.20.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.20.2.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
  • Configuration file of PE2

    #
     sysname PE2
    #
    mpls lsr-id 10.30.3.9
    mpls
    #
    mpls l2vpn
    #
    mpls ldp
    #
    mpls ldp remote-peer 10.10.1.9
     remote-ip 10.10.1.9
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
    #
    interface GigabitEthernet2/0/0.1
     qinq termination pe-vid 100 ce-vid 10
     mpls l2vc 10.10.1.9 101
    #
    interface LoopBack1
     ip address 10.30.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.30.3.9 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174108

Views: 55930

Downloads: 41

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next