No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009 CLI-based Configuration Guide - Ethernet Switching

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Remote Bridging with IP Routing

Example for Configuring Remote Bridging with IP Routing

Configuring remote bridging with IP routing allows LANs in different geographical locations and on different network segments to communicate.

Networking Requirements

Departments of Enterprise A need to communicate with other and with Enterprises C (in a different geographical location).

Departments of Enterprise A belong to the LANs on the same network segment and can be bridged, but Enterprise C belongs to a different network segment. As a result, link-layer bridging cannot be used to communicate between Enterprise A and Enterprise C.

In this scenario, local bridging integrated with IP routing offers a viable solution.

As shown in Figure 15-21, bridge groups are configured on local bridging, and interfaces are added to different bridge groups. After Bridge-if interfaces are created and assigned IP addresses, and the IP routing function is enabled, the two hosts of Enterprise A can communicate with the hosts of Enterprises C.

Figure 15-21  Networking diagram of remote bridging integrated with IP routing

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure bridge groups on RouterA and RouterB.

  2. Add Ethernet 2/0/1 and Ethernet 2/0/2 on Router A to a bridge group so that the two hosts of Enterprise A can communicate with each other.

  3. Add Ethernet3/0/0 to another bridge group on Router A, and add Ethernet 3/0/0 to the bridge group on Router B.

  4. Create Bridge-if interfaces and enable the IP routing function for the bridge groups on Router A and Router B. This allows Enterprise A and Enterprise C to communicate with each other.

Procedure

  1. Configure RouterA.

    # Create bridge group 1 and bridge group, then enable the IP routing function for the bridge groups.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] bridge 1
    [RouterA-bridge1] routing ip
    [RouterA-bridge1] quit
    [RouterA] bridge 2
    [RouterA-bridge2] routing ip
    [RouterA-bridge2] quit

    # Add Eth2/0/1 and Eth2/0/2 to VLAN 11 to allow the communication between User 1 and User 2.

    [RouterA] vlan 11
    [RouterA-vlan11] quit
    [RouterA] interface ethernet 2/0/1
    [RouterA-Ethernet2/0/1] port link-type access
    [RouterA-Ethernet2/0/1] port default vlan 11
    [RouterA-Ethernet2/0/1] quit
    [RouterA] interface ethernet 2/0/2
    [RouterA-Ethernet2/0/2] port link-type access
    [RouterA-Ethernet2/0/2] port default vlan 11
    [RouterA-Ethernet2/0/2] quit

    #Add VLANIF 11 to bridge group 1.

    [RouterA] interface vlanif 11
    [RouterA-Vlanif11] bridge 1
    [RouterA-Vlanif11] quit

    # Add Ethernet3/0/0 on Router A to bridge group 2.

    [RouterA] interface ethernet 3/0/0
    [RouterA-Ethernet3/0/0] bridge 2
    [RouterA-Ethernet3/0/0] quit

    # Create Bridge-if interface 1 for bridge group 1 and Bridge-if interface 2 for bridge group 2, and then configure IP addresses for the two Bridge-if interfaces.

    [RouterA] interface bridge-if 1
    [RouterA-Bridge-if1] ip address 10.1.1.3 255.255.255.0
    [RouterA-Bridge-if1] quit
    [RouterA] interface bridge-if 2
    [RouterA-Bridge-if2] ip address 10.1.2.3 255.255.255.0
    [RouterA-Bridge-if2] quit

  2. Configure RouterB.

    # Create bridge group 2 and enable the IP routing function for the bridge groups.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] bridge 2
    [RouterB-bridge2] routing ip
    [RouterB-bridge2] quit

    # Add Ethernet2/0/0 to VLAN11.

    [RouterB] vlan 11
    [RouterB-vlan11] quit
    [RouterB] interface ethernet 2/0/0
    [RouterB-Ethernet2/0/0] port link-type access
    [RouterB-Ethernet2/0/0] port default vlan 11
    [RouterB-Ethernet2/0/0] quit

    #Add VLANIF 11 to bridge group 2.

    [RouterB] interface vlanif 11
    [RouterB-Vlanif11] bridge 2
    [RouterB-Vlanif11] quit

    # Add Ethernet3/0/0 on Router B to bridge group 2.

    [RouterB] interface ethernet 3/0/0
    [RouterB-Ethernet3/0/0] bridge 2
    [RouterB-Ethernet3/0/0] quit

  3. Verify the configuration.

    # After the preceding configuration is complete, User 1 and User 4 can successfully ping each other.

Configuration Files

  • Configuration file of RouterA

    #
     sysname RouterA
    #
    vlan batch 11
    #
    bridge 1
     routing ip
    bridge 2
     routing ip
    #
    interface Vlanif11
     bridge 1
    #
    interface Ethernet2/0/1
     port link-type access
     port default vlan 11
    #
    interface Ethernet2/0/2
     port link-type access
     port default vlan 11
    #
    interface Bridge-if1
     ip address 10.1.1.3 255.255.255.0
    #
    interface Bridge-if2
     ip address 10.1.2.3 255.255.255.0
    #
    interface Ethernet3/0/0
     bridge 2
    #
    return
  • Configuration file of RouterB

    #
     sysname RouterB
    #
    vlan batch 11
    #
    bridge 2
     routing ip
    #
    interface Vlanif11
     bridge 2
    #
    interface Ethernet2/0/0
     port link-type access
     port default vlan 11
    #
    interface Ethernet3/0/0
     bridge 2
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174108

Views: 56195

Downloads: 41

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next