No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009 CLI-based Configuration Guide - Ethernet Switching

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Selective QinQ

Example for Configuring Selective QinQ

Networking Requirements

As shown in Figure 8-8, enterprise A has two branches that connect to the carrier network through PE1 and PE2 respectively. Enterprise A has different services, so different VLANs are assigned. Data services are transmitted in VLAN 10 to VLAN 30, and voice services are transmitted in VLAN 31 to VLAN 50.

The requirements are as follows:
  • VLANs are assigned independently in enterprise A, and are independent of carrier VLANs or VLANs of other enterprises.
  • Traffic between two branches of enterprise A is transparently transmitted through the public network, devices transmitting the same service in different branches of enterprise A are allowed to communicate, and devices transmitting different services are isolated.
  • High-priority voice services are transmitted first.
Figure 8-8  Networking diagram for configuring selective QinQ

Configuration Roadmap

The configuration roadmap is as follows:

You can configure selective QinQ on the CE user-side interface and implement communication between two branches of enterprise A through VLAN 60 and VLAN 61 provided by the carrier.

  1. Create a bridge group and add sub-interfaces to the bridge group.

  2. Configure VLANs allowed by the user-side sub-interfaces of the CE, configure the CE user-side interface to add different outer VLAN tags to packets with different user VLAN IDs, and re-mark voice services with high priority.

  3. Add the CE interface connected to the PE, PE interface, and P interface to VLAN 20 and VLAN 21 so that packets from VLAN 20 and VLAN 21 are allowed to pass through.

Procedure

  1. Create a bridge group and add sub-interfaces to the bridge group.

    <Huawei> system-view
    [Huawei] sysname CE1
    [CE1] bridge 1
    [CE1-bridge1] quit
    [CE1] interface gigabitethernet 0/0/1.1
    [CE1-GigabitEthernet0/0/1.1] bridge 1
    [CE1-GigabitEthernet0/0/1.1] bridge vlan-transmit enable
    [CE1-GigabitEthernet0/0/1.1] quit
    [CE1] interface gigabitethernet 0/0/1.2
    [CE1-GigabitEthernet0/0/1.2] bridge 1
    [CE1-GigabitEthernet0/0/1.2] bridge vlan-transmit enable
    [CE1-GigabitEthernet0/0/1.2] quit
    

    # The configuration of CE2 is similar to that of CE1, and is not mentioned here.

  2. Configure CE1 user-side interface to add VLAN tags to user packets and re-mark voice services with high priority.

    [CE1] interface gigabitethernet 0/0/1.1
    [CE1-GigabitEthernet0/0/1.1] vlan stacking vid 10 to 30 pe-vid 60
    [CE1-GigabitEthernet0/0/1.1] quit
    [CE1] interface gigabitethernet 0/0/1.2
    [CE1-GigabitEthernet0/0/1.2] vlan stacking vid 31 to 50 pe-vid 61 remark-8021p 7
    [CE1-GigabitEthernet0/0/1.2] quit
    

    # The configuration of CE2 is similar to that of CE1, and is not mentioned here.

  3. Add sub-interfaces of GE0/0/0 on CE1 to bridge 1, VLAN 60, and VLAN 61. Add GE0/0/0 and GE0/0/1 on PE1 to VLAN 60 and VLAN 61 in trunk mode.

    # Add sub-interfaces of GE0/0/0 on CE1 to bridge 1, VLAN 60 and VLAN 61 in trunk mode. The configuration of CE2 is similar to that of CE1. For details, see the configuration files.

    [CE1] vlan batch 60 to 61
    [CE1] interface gigabitethernet 0/0/0
    [CE1] interface gigabitethernet 0/0/0.33
    [CE1-GigabitEthernet0/0/0.33] bridge 1
    [CE1-GigabitEthernet0/0/0.33] bridge vlan-transmit enable
    [CE1-GigabitEthernet0/0/0.33] vlan allow-pass vlan 60 61
    [CE1-GigabitEthernet0/0/0.33] quit

    # Add GE0/0/0 and GE0/0/1 on PE1 to VLAN 60 and VLAN 61 in trunk mode. The configurations of PE2 and P are similar to the configuration of PE1, and are not mentioned here.

    <Huawei> system-view
    [Huawei] sysname PE1
    [PE1] vlan batch 60 to 61
    [PE1] interface gigabitethernet 0/0/0
    [PE1-GigabitEthernet0/0/0] port link-type trunk
    [PE1-GigabitEthernet0/0/0] port trunk allow-pass vlan 60 61
    [PE1-GigabitEthernet0/0/0] quit
    [PE1] interface gigabitethernet 0/0/1
    [PE1-GigabitEthernet0/0/1] port link-type trunk
    [PE1-GigabitEthernet0/0/1] port trunk allow-pass vlan 60 61
    [PE1-GigabitEthernet0/0/1] quit
    

  4. Verify the configuration.

    # On a PC in a VLAN of a branch in enterprise A, ping a PC in the same VLAN of the other branch in enterprise A. The ping operation succeeds, indicating that devices transmitting the same service can communicate with each other.

Configuration Files

  • CE1 configuration file
    #
     sysname CE1
    #
    vlan batch 60 to 61
    #
    bridge 1
    #                                                                               
    interface GigabitEthernet0/0/0
    #
    interface GigabitEthernet0/0/0.33
     bridge 1
     bridge vlan-transmit enable
     vlan allow-pass vlan 60 61 
    #
    interface GigabitEthernet0/0/1
    #
    interface GigabitEthernet0/0/1.1
     bridge 1    
     bridge vlan-transmit enable
     vlan stacking vid 10 to 30 pe-vid 60
    #
    interface GigabitEthernet0/0/1.2
     bridge 1    
     bridge vlan-transmit enable
     vlan stacking vid 31 to 50 pe-vid 61 remark 8021p 7
    #
     return
  • CE2 configuration file
    #
     sysname CE2
    #
     vlan batch 60 to 61
    #
    bridge 1
    #                                                                               
    interface GigabitEthernet0/0/0
    #
    interface GigabitEthernet0/0/0.33
     bridge 1
     bridge vlan-transmit enable
     vlan allow-pass vlan 60 61
    #
    interface GigabitEthernet0/0/1
    #
    interface GigabitEthernet0/0/1.1
     bridge 1    
     bridge vlan-transmit enable
     vlan stacking vid 10 to 30 pe-vid 60
    #
    interface GigabitEthernet0/0/1.2
     bridge 1    
     bridge vlan-transmit enable
     vlan stacking vid 31 to 50 pe-vid 61 remark 8021p 7
    #
     return
  • PE1 configuration file
    #
     sysname PE1
    #
    vlan batch 60 to 61
    #
    interface GigabitEthernet0/0/0
     port link-type trunk
     port trunk allow-pass vlan 60 to 61
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 60 to 61
    #
    return
  • PE2 configuration file
    #
     sysname PE2
    #
    vlan batch 60 to 61
    #
    interface GigabitEthernet0/0/0
     port link-type trunk
     port trunk allow-pass vlan 60 to 61
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 60 to 61
    #
     return
  • P configuration file
    #
     sysname P
    #
    vlan batch 60 to 61
    #
    interface GigabitEthernet0/0/0
     port link-type trunk
     port trunk allow-pass vlan 60 to 61
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 60 to 61
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174108

Views: 62560

Downloads: 51

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next