No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - QoS

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Bandwidth Management

Example for Configuring Bandwidth Management

Networking Requirements

As shown in Figure 10-2, RouterA is used to connect departments on the enterprise network, and the enterprise network connects to the WAN through GE3/0/0 of RouterA. Bandwidth management needs to be configured correctly to meet the following requirements:

  • The downlink rate of packets between R&D departments and the Internet cannot exceed 256 kbit/s during the working time (8:00 a.m. to 17:30 p.m. from Monday to Friday).
  • Packets from the president office are sent preferentially, and the minimum bandwidth of packets from the president office is 2048 kbit/s when congestion occurs.
Figure 10-2  Networking for configuring bandwidth management

Configuration Roadmap

The configuration roadmap is as follows:
  1. Create VLANs and VLANIF interfaces on RouterA and configure interfaces to enable enterprise users to access the WAN through RouterA.
  2. Configure a time range.
  3. Set different bandwidths for departments on GE3/0/0 of RouterA.

Procedure

  1. Create VLANs and VLANIF interfaces, and configure interfaces.

    # Create VLAN 10 and VLAN 20 on RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] vlan batch 10 20

    # Configure Eth2/0/0 and Eth2/0/1 on RouterA as access interfaces, and add 2/0/0 and Eth2/0/1 to VLAN 10 and VLAN 20 respectively.

    [RouterA] interface ethernet 2/0/0
    [RouterA-Ethernet2/0/0] port link-type access
    [RouterA-Ethernet2/0/0]  port default vlan 10
    [RouterA-Ethernet2/0/0] quit
    [RouterA] interface ethernet 2/0/1
    [RouterA-Ethernet2/0/1] port link-type access
    [RouterA-Ethernet2/0/1]  port default vlan 20
    [RouterA-Ethernet2/0/1] quit
    

    # Create VLANIF 10 and VLANIF 20, configure IP addresses of 10.10.1.1/24 and 10.10.2.1/24 for VLANIF 10 and VLANIF 20 respectively.

    [RouterA] interface vlanif 10
    [RouterA-Vlanif10] ip address 10.10.1.1 24
    [RouterA-Vlanif10] quit
    [RouterA] interface vlanif 20
    [RouterA-Vlanif20] ip address 10.10.2.1 24
    [RouterA-Vlanif20] quit
    

    # Configure the IP address of 1.1.1.1/24 for GE3/0/0 on RouterA.

    [RouterA] interface gigabitethernet 3/0/0
    [RouterA-GigabitEthernet3/0/0] ip address 1.1.1.1 24
    [RouterA-GigabitEthernet3/0/0] quit

    # Configure RouterB to ensure reachable routes between RouterB and RouterA. The configuration is not provided here.

  2. Configure a time range.

    # Configure the time range from 8:00 to 17:30.

    [RouterA] time-range worktime 8:00 to 17:30 working-day
    

  3. Set different bandwidths for departments on GE3/0/0 of RouterA.

    # On GE3/0/0 of RouterA, set the downlink rate limit for packets of R&D departments to 256 kbit/s during the working time.

    [RouterA] web
    [RouterA-web] user-set vd
    [RouterA-web-user-set-vd] user-ip from 10.10.1.2 to 10.10.1.254
    [RouterA-web-user-set-vd] quit
    [RouterA-web] bandlimit interface gigabitethernet 3/0/0 type user-set vd inbound cir 256 time-range worktime
    [RouterA-web] quit
    

    # On GE3/0/0 of RouterA, set the minimum bandwidth of packets from the president office to 2048 kbit/s.

    [RouterA] web
    [RouterA-web] bandguarantee interface gigabitethernet 3/0/0 type ip 10.10.2.4 cir 2048
    [RouterA-web] quit
    

  4. Verify the configuration.

    # Check the bandwidth management configuration on RouterA.

    <RouterA> display current-configuration
    #                                                                               
    traffic classifier Class10.10.2.4 operator or                                   
     if-match acl Acl10.10.2.4                                                      
    #                                                                               
    traffic behavior Behavior10.10.2.4                                              
     queue af bandwidth 2048                                                        
     statistic enable                                                               
    #                                                                               
    traffic policy GigabitEthernet3/0/0                                             
     classifier Class10.10.2.4 behavior Behavior10.10.2.4                           
    #                                                                               
    interface GigabitEthernet3/0/0                                                  
     qos car inbound destination-ip-address range 10.10.1.2 to 10.10.1.254 cir 256 c
    bs 48128 pbs 80128 green pass yellow pass red discard                           
     traffic-policy GigabitEthernet3/0/0 outbound                                   
    #
    return                                                                          

Configuration Files

  • Configuration file of RouterA
    #
     sysname RouterA
    #                                                                               
     time-range worktime 08:00 to 17:30 working-day                                 
    #                                                                               
    vlan batch 10 20                                                                
    #                                                                               
    web                                                                             
     user-set vd                                                                    
      user-ip from 10.10.1.2 to 10.10.1.254                                         
     bandlimit interface GigabitEthernet3/0/0 type user-set vd inbound cir 256 time-
    range worktime                                                                  
     bandguarantee interface GigabitEthernet3/0/0 type ip 10.10.2.4 cir 2048        
    #                                                                               
    traffic classifier Class10.10.2.4 operator or                                   
     if-match acl Acl10.10.2.4                                                      
    #                                                                               
    traffic behavior Behavior10.10.2.4                                              
     queue af bandwidth 2048                                                        
     statistic enable                                                               
    #                                                                               
    traffic policy GigabitEthernet3/0/0                                             
     classifier Class10.10.2.4 behavior Behavior10.10.2.4                           
    #                                                                               
    interface Vlanif10                                                              
     ip address 10.10.1.1 255.255.255.0                                             
    #                                                                               
    interface Vlanif20                                                              
     ip address 10.10.2.1 255.255.255.0                                             
    #                                                                               
    interface Ethernet0/0/1                                                  
     port link-type access                                                          
     port default vlan 10                                                           
    #                                                                               
    interface Ethernet0/0/2                                                  
     port link-type access                                                          
     port default vlan 20                                                           
    #                                                                               
    interface GigabitEthernet3/0/0                                                  
     ip address 1.1.1.1 255.255.255.0                                               
     qos car inbound destination-ip-address range 10.10.1.2 to 10.10.1.254 cir 256 c
    bs 48128 pbs 80128 green pass yellow pass red discard                           
     traffic-policy GigabitEthernet3/0/0 outbound                                   
    #
    return
    
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174115

Views: 40128

Downloads: 28

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next