No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Associating Interface Backup with Routing to Configure an ADSL Interface as the Backup of an Ethernet Interface

Example for Associating Interface Backup with Routing to Configure an ADSL Interface as the Backup of an Ethernet Interface

Networking Requirements

As shown in Figure 2-25, the egress gateway RouterA in the headquarters of company A connects to the IP network through GE0/0/1. The link between GE0/0/1 and the IP network is used as the primary link, and the link between ATM0/0/0 and the Internet is used as the backup link.

The company wants to monitor the route status of the primary interface to detect connectivity of the primary link. When the routing entry of the primary link is deleted or becomes inactive, a backup link is started to transmit services to reduce the impact of the primary link fault on service transmission.

Figure 2-25  Networking diagram of association between interface backup and routing

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces on routers of the primary link.

  2. Configure OSPF on the primary link to ensure connectivity at the network layer.

  3. Configure RS-DCC on RouterA so that the backup link transmits services when the primary link is faulty.

  4. Configure a default route on the backup link.

  5. Configure association between interface backup and routing on backup interface ATM0/0/0. When the routing entry of the primary link is deleted or becomes inactive, a backup link is started to transmit services.

Procedure

  1. Assign IP addresses to interfaces of the primary link.

    # Assign an IP address to the interface of RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 2.1.1.1 255.255.255.0
    [RouterA-GigabitEthernet1/0/0] quit

    # Assign an IP address to the interface of RouterB.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] interface gigabitethernet1/0/0
    [RouterB-GigabitEthernet1/0/0] ip address 4.1.1.2 255.255.255.0
    [RouterB-GigabitEthernet1/0/0] quit

    # Assign an IP address to the interface of RouterC.

    <Huawei> system-view
    [Huawei] sysname RouterC
    [RouterC] interface gigabitethernet1/0/0
    [RouterC-GigabitEthernet1/0/0] ip address 2.1.1.2 255.255.255.0
    [RouterC-GigabitEthernet1/0/0] quit

    # Assign an IP address to the interface of RouterD.

    [RouterD] interface gigabitethernet1/0/0
    [RouterD-GigabitEthernet1/0/0] ip address 4.1.1.1 255.255.255.0
    [RouterD-GigabitEthernet1/0/0] quit
    

  2. Configure OSPF.

    # Configure RouterA.

    [RouterA] ospf
    [RouterA-ospf-1] area 0
    [RouterA-ospf-1-area-0.0.0.0] network 2.1.1.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] quit

    # Configure RouterB.

    [RouterB] ospf
    [RouterB-ospf-1] area 0
    [RouterB-ospf-1-area-0.0.0.0] network 4.1.1.0 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.0] quit

    # Configure RouterC.

    [RouterC] ospf
    [RouterC-ospf-1] area 0
    [RouterC-ospf-1-area-0.0.0.0] network 2.1.1.0 0.0.0.255
    [RouterC-ospf-1-area-0.0.0.0] quit

    # Configure RouterD.

    [RouterD] ospf
    [RouterD-ospf-1] area 0
    [RouterD-ospf-1-area-0.0.0.0] network 4.1.1.0 0.0.0.255
    [RouterD-ospf-1-area-0.0.0.0] quit

    After the configuration is complete, run the display ospf routing command on RouterA to view OSPF routes.

                                                                                    
             OSPF Process 1 with Router ID 192.168.200.208                          
                      Routing Tables                                                
                                                                                    
     Routing for Network                                                            
     Destination        Cost  Type       NextHop         AdvRouter       Area       
     2.1.1.0/24         1     Transit    2.1.1.1         192.168.200.208 0.0.0.0    
     2.2.2.2/32         0     Stub       2.2.2.2         192.168.200.208 0.0.0.0    
     3.3.3.3/32         1     Stub       2.1.1.2         10.1.1.2        0.0.0.0    
     4.1.1.0/24         3     Transit    2.1.1.2         10.137.217.165  0.0.0.0    
     4.4.4.4/32         3     Stub       2.1.1.2         10.10.10.2      0.0.0.0    
     5.1.1.0/24         2     Transit    2.1.1.2         10.1.1.2        0.0.0.0    
     10.2.1.0/24        53    Stub       2.1.1.2         10.10.10.2      0.0.0.0    
                                                                                    
     Total Nets: 7                                                                  
     Intra Area: 7  Inter Area: 0  ASE: 0  NSSA: 0                                  

  3. Configure RS-DCC on RouterA.

    # Configure a dialer interface.

    [RouterA] dialer-rule
    [RouterA-dialer-rule] dialer-rule 10 ip permit
    [RouterA-dialer-rule] quit
    [RouterA] interface dialer 1
    [RouterA-Dialer1] dialer user u1
    [RouterA-Dialer1] dialer-group 10
    [RouterA-Dialer1] dialer bundle 10
    [RouterA-Dialer1] ip address 3.1.1.1 255.255.255.0
    [RouterA-Dialer1] dialer number 666
    [RouterA-Dialer1] quit
    

    # Configure the ATM interface.

    [RouterA] interface atm 0/0/0
    [RouterA-Atm0/0/0] pvc pppoa 2/40
    [RouterA-atm-pvc-Atm0/0/0-2/40-pppoa] map ppp dialer 1
    [RouterA-atm-pvc-Atm0/0/0-2/40-pppoa] quit
    [RouterA-Atm0/0/0] quit
    # Configure a static route for the backup link.
    [RouterA] ip route-static 0.0.0.0 0.0.0.0 dialer 1
    

  4. Configure the DSLAM.

    See the DSLAM documentation.

  5. Configure the PPPoA server.

    Assign IP address 3.1.1.2 to the PPPoA server.

  6. Configure association between interface backup and routing on backup interface ATM0/0/0.

    [RouterA] interface atm 0/0/0
    [RouterA-Atm0/0/0] standby track ip route 4.1.1.0 255.255.255.0

  7. Verify the configuration.

    After the configuration is complete, RouterA can ping the destination IP address 4.1.1.2/24.

    <RouterA> ping -a 2.1.1.1 4.1.1.2
      PING 4.1.1.2: 56 data bytes, press CTRL_C to break                            
        Reply from 4.1.1.2: bytes=56 Sequence=1 ttl=255 time=1 ms                   
        Reply from 4.1.1.2: bytes=56 Sequence=2 ttl=255 time=5 ms                   
        Reply from 4.1.1.2: bytes=56 Sequence=3 ttl=255 time=1 ms                   
        Reply from 4.1.1.2: bytes=56 Sequence=4 ttl=255 time=2 ms                   
        Reply from 4.1.1.2: bytes=56 Sequence=5 ttl=255 time=1 ms                   
                                                                                    
      --- 4.1.1.2 ping statistics ---                                               
        5 packet(s) transmitted                                                     
        5 packet(s) received                                                        
        0.00% packet loss                                                           
        round-trip min/avg/max = 1/2/5 ms                                           
                                                                                    

    # Check the status of the backup interface and associated route on RouterA. You can see that the route to 4.1.1.0/24 is in OK state, and ATM0/0/0 is in STANDBY state.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
    4.1.1.0/24                OK           Atm0/0/0                   STANDBY       
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             

    Run the shutdown command on GE1/0/0 of RouterA to simulate a link fault.

    Run the display standby state command on RouterA. The command output shows that the status of the route to the destination network segment 4.1.1.0/24 is ERR and the status of Atm0/0/0 is Up, indicating that the backup interface has been started.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
    4.1.1.0/24                ERR           Atm0/0/0                  UP       
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             

    Run the undo shutdown command on GE1/0/0 of RouterA to make GE1/0/0 Up. Run the display standby state command on RouterA. You can see that the status of the route to the destination network segment 4.1.1.0/24 is OK and the status of Atm0/0/0 is STANDBY.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
    4.1.1.0/24                OK           Atm0/0/0                   STANDBY       
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #                                                                               
    interface Dialer1                                                               
     link-protocol ppp                                                              
     ip address 3.1.1.1 255.255.255.0                                              
     dialer user u1                                                                 
     dialer bundle 10                                                               
     dialer number 666                                                              
     dialer-group 10                                                                
    #             
    interface GigabitEthernet1/0/0
     ip address 2.1.1.1 255.255.255.0
    #             
    interface Atm0/0/0                                                              
     pvc pppoa 2/40                                                                 
      map ppp Dialer1                                                               
     standby track ip route 4.1.1.0 255.255.255.0
    #                                                                               
    dialer-rule                                                                     
     dialer-rule 10 ip permit                                                       
    #                                                                               
    ospf 1                                                                          
     area 0.0.0.0                                                                   
      network 2.1.1.0 0.0.0.255                                                     
    #                                                                               
    ip route-static 0.0.0.0 0.0.0.0 dialer 1
    #                                                                               
    return
  • RouterB configuration file

    #
     sysname RouterB
    #
     sysname RouterB
    #
    interface GigabitEthernet1/0/0
     ip address 4.1.1.2 255.255.255.0
    #
    ospf 1                                                                          
     area 0.0.0.0                                                                   
      network 4.1.1.0 0.0.0.255                                                     
    #
    return
  • RouterC configuration file

    #
     sysname RouterC
    #
    interface GigabitEthernet1/0/0
     ip address 2.1.1.2 255.255.255.0
    #                                                                               
    ospf 1                                                                          
     area 0.0.0.0                                                                   
      network 2.1.1.0 0.0.0.255                                                     
    #                                                                               
    return
  • RouterD configuration file

    #
     sysname RouterD
    #
    interface GigabitEthernet1/0/0
     ip address 4.1.1.1 255.255.255.0
    #                                                                               
    ospf 1                                                                          
     area 0.0.0.0                                                                   
      network 4.1.1.0 0.0.0.255                                                     
    #                                                                               
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174116

Views: 51820

Downloads: 19

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next