No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring HSB

Example for Configuring HSB

Networking Requirements

As shown in Figure 5-6, a user network is dual-homed to RouterA and RouterB through Switch. The requirements are as follows:
  • Hosts on the user network use RouterA as the default gateway to access the Internet. Service information on RouterA can be backed up to RouterB in real time and in batches.
  • If RouterA becomes faulty, RouterB takes over services on RouterA to ensure uninterrupted network running.
Figure 5-6  Networking diagram for configuring HSB

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface of devices and configure a routing protocol on each device to ensure network connectivity.
  2. Configure VRRP groups on RouterA and RouterB. Configure a high priority for RouterA as the master device to forward traffic, and a low priority for RouterB as the backup device.
  3. Configure the HSB function so that service information on RouterA is backed up to RouterB in real time and in batches, ensuring smooth service switchover from the master device to the backup device.

Procedure

  1. Configure devices to ensure network connectivity.

    # Assign an IP address to each interface on RouterA. The configuration on RouterB is similar to that on RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 10.1.1.1 24
    [RouterA-GigabitEthernet2/0/0] quit
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 192.168.1.1 24
    [RouterA-GigabitEthernet1/0/0] quit

    # Configure Layer 2 transparent transmission on Switch.

    <Huawei> system-view
    [Huawei] sysname Switch
    [Switch] vlan 100
    [Switch-vlan100] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port hybrid pvid vlan 100
    [Switch-GigabitEthernet0/0/2] port hybrid untagged vlan 100
    [Switch-GigabitEthernet0/0/2] quit
    

  2. Configure VRRP groups.

    # Create VRRP group 1 on RouterA and set the VRRP priority to 120.

    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] vrrp vrid 1 virtual-ip 10.1.1.111
    [RouterA-GigabitEthernet2/0/0] vrrp vrid 1 priority 120
    [RouterA-GigabitEthernet2/0/0] quit

    # Create VRRP group 1 on RouterB and retain the default VRRP priority 100.

    [RouterB] interface gigabitethernet 2/0/0
    [RouterB-GigabitEthernet2/0/0] vrrp vrid 1 virtual-ip 10.1.1.111
    [RouterB-GigabitEthernet2/0/0] quit

  3. Configure the hot standby function.

    # Create HSB service 0 on RouterA and configure the IP addresses and port numbers for the local and peer devices.

    [RouterA] hsb-service 0
    [RouterA-hsb-service-0] service-ip-port local-ip 192.168.1.1 peer-ip 192.168.1.2 local-data-port 10241 peer-data-port 10241

    # Create HSB service 0 on RouterB and configure the IP addresses and port numbers for the local and peer devices.

    [RouterB] hsb-service 0
    [RouterB-hsb-service-0] service-ip-port local-ip 192.168.1.2 peer-ip 192.168.1.1 local-data-port 10241 peer-data-port 10241

    # Create HSB group 0 on RouterA, and bind HSB group 0 to VRRP group 1. The configuration on RouterB is similar to that on RouterA.

    [RouterA] hsb-group 0
    [RouterA-hsb-group-0] bind-service 0
    [RouterA-hsb-group-0] track vrrp vrid 1 interface gigabitethernet 2/0/0

    # Enable HSB group 0 on RouterA to make it take effect. The configuration on RouterB is similar to that on RouterA.

    [RouterA-hsb-group-0] hsb enable

  4. Verify the configuration.

    # Run the display vrrp command on RouterA and RouterB. The command output shows that RouterA is Master and RouterB is Backup in the VRRP group.

    [RouterA] display vrrp
      GigabitEthernet2/0/0 | Virtual Router 1
        State        : Master
        Virtual IP     : 10.1.1.111
        Master IP      : 10.1.1.1
        PriorityRun    : 120
        PriorityConfig : 120                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 0 s                                            
        TimerRun : 1 s                                                              
        TimerConfig : 1 s                                                           
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled                                                   
        Create time : 2012-05-11 11:39:18 UTC-08:00                                 
        Last change time : 2012-05-26 11:38:58 UTC-08:00
    [RouterB] display vrrp
      GigabitEthernet2/0/0 | Virtual Router 1
        State        : Backup
        Virtual IP     : 10.1.1.111
        Master IP      : 10.1.1.1
        PriorityRun    : 100
        PriorityConfig : 100                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 0 s                                            
        TimerRun : 1 s                                                              
        TimerConfig : 1 s                                                           
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled                                                   
        Create time : 2012-05-11 11:39:18 UTC-08:00                                 
        Last change time : 2012-05-26 11:38:58 UTC-08:00

    # Run the display hsb-service service-index command on RouterA and RouterB to check the HSB service status. The value of the Service State field is Connected, indicating that the HSB channel has been established. The command output on RouterA and RouterB is as follows:

    [RouterA] display hsb-service 0
    Hot Standby Service Information:
    ----------------------------------------------------------
      Local IP Address       : 192.168.1.1
      Peer IP Address        : 192.168.1.2
      Source Port            : 10241
      Destination Port       : 10241
      Keep Alive Times       : 5
      Keep Alive Interval    : 3
      Service State          : Connected
      Service Batch Modules  :
    ----------------------------------------------------------
    
    [RouterB] display hsb-service 0
    Hot Standby Service Information:
    ----------------------------------------------------------
      Local IP Address       : 192.168.1.2
      Peer IP Address        : 192.168.1.1
      Source Port            : 10241
      Destination Port       : 10241
      Keep Alive Times       : 5
      Keep Alive Interval    : 3
      Service State          : Connected
      Service Batch Modules  :
    ----------------------------------------------------------
    

    # Run the display hsb-group group-index command on RouterA and RouterB to check the HSB service status. The command output on RouterA and RouterB is as follows:

    [RouterA] display hsb-group 0
    Hot Standby Group Configuration:
    ----------------------------------------------------------
      HSB-group ID                : 0                                
      Vrrp Group ID               : 1                                
      Vrrp Interface              : GigabitEthernet2/0/0
      Service Index               : 0                                
      Group Vrrp Status           : Master                           
      Group Status                : Active                           
      Group Backup Process        : Realtime                         
      Peer Group Device Name      : AR1200-S                     
      Peer Group Software Version : V200R009
      Group Backup Modules        : Firewall                
    [RouterB] display hsb-group 0
    Hot Standby Group Configuration:
    ----------------------------------------------------------
      HSB-group ID                : 0                                
      Vrrp Group ID               : 1                                
      Vrrp Interface              : GigabitEthernet2/0/0                        
      Service Index               : 0                                
      Group Vrrp Status           : Backup                           
      Group Status                : Inactive                         
      Group Backup Process        : Realtime                         
      Peer Group Device Name      : AR1200-S                     
      Peer Group Software Version : V200R009
      Group Backup Modules        : Firewall                

    # Run the shutdown command on GE2/0/0 and GE1/0/0 of RouterA to simulate a fault on RouterA.

    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] shutdown
    [RouterA-GigabitEthernet2/0/0] quit
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] shutdown
    [RouterA-GigabitEthernet1/0/0] quit
    

    # Run the display hsb-group group-index command on RouterB to check the HSB group status. The command output shows that RouterB is Master.

    [RouterB] display hsb-group 0
    Hot Standby Group Configuration:
    ----------------------------------------------------------
      HSB-group ID                : 0                                
      Vrrp Group ID               : 1                                
      Vrrp Interface              : GigabitEthernet2/0/0                        
      Service Index               : 0                                
      Group Vrrp Status           : Master                           
      Group Status                : Independent                      
      Group Backup Process        : Realtime                         
      Peer Group Device Name      : AR1200-S                     
      Peer Group Software Version : V200R009
      Group Backup Modules        : Firewall                

Configuration Files

  • RouterA configuration file

    #
    sysname RouterA
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
     vrrp vrid 1 priority 120
    #
    hsb-service 0
     service-ip-port local-ip 192.168.1.1 peer-ip 192.168.1.2 local-data-port 10241 peer-data-port 10241
    #
    hsb-group 0
     track vrrp vrid 1 interface GigabitEthernet2/0/0
     bind-service 0
     hsb enable
    #
    return
  • RouterB configuration file

    #
    sysname RouterB
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
    #
    hsb-service 0
     service-ip-port local-ip 192.168.1.2 peer-ip 192.168.1.1 local-data-port 10241 peer-data-port 10241
    #
    hsb-group 0
     track vrrp vrid 1 interface GigabitEthernet2/0/0
     bind-service 0
     hsb enable
    #
    return
  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 100
    #
    interface GigabitEthernet0/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet0/0/2
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174116

Views: 54360

Downloads: 19

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next