No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Single-Hop BFD on a VLANIF Interface

Example for Configuring Single-Hop BFD on a VLANIF Interface

Networking Requirements

As shown in Figure 6-22, RouterA connects to RouterB through a VLANIF interface. Faults on the link between RouterA and RouterB need to be fast detected.

Figure 6-22  Networking diagram for configuring single-hop BFD on a VLANIF interface

Configuration Roadmap

The configuration roadmap is as follows:

Configure BFD sessions on RouterA and RouterB to detect faults on the link between RouterA and RouterB.

Procedure

  1. On RouterA and RouterB, create VLANs, configure Eth2/0/0 interfaces as hybrid interfaces, and add Eth2/0/0 interfaces to VLANs. The configuration details are not mentioned here.
  2. Configure IP addresses for GE interfaces so that RouterA and RouterB can communicate at Layer 3. The configuration details are not mentioned here.
  3. Configure single-hop BFD.

    # Enable BFD and create a BFD session on RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] bfd
    [RouterA-bfd] quit
    [RouterA] bfd atob bind peer-ip 10.1.1.6 interface vlanif 100
    [RouterA-bfd-session-atob] discriminator local 1
    [RouterA-bfd-session-atob] discriminator remote 2
    [RouterB-bfd-session-atob] commit
    [RouterA-bfd-session-atob] quit
    

    # Enable BFD and create a BFD session on RouterB.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] bfd
    [RouterB-bfd] quit
    [RouterB] bfd btoa bind peer-ip 10.1.1.5 interface vlanif 100
    [RouterB-bfd-session-btoa] discriminator local 2
    [RouterB-bfd-session-btoa] discriminator remote 1
    [RouterB-bfd-session-btoa] commit
    [RouterB-bfd-session-btoa] quit
    

  4. Verify the configuration.

    # After the configuration is complete, run the display bfd session all verbose command on RouterA and RouterB. You can see that a single-hop BFD session is set up and its status is Up. The display on RouterA is used as an example.

    [RouterA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 64        (One Hop) State : Up        Name : atob              
    --------------------------------------------------------------------------------
      Local Discriminator    : 1               Remote Discriminator   : 2         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(Vlanif100)                                  
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 10.1.1.6                                            
      NextHop Ip Address     : 10.1.1.6                                            
      Bind Interface         : Vlanif100                                             
      FSM Board Id           : 0                TOS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000       
      Local Detect Multi     : 3                Detect Interval (ms)   : 3000       
      Echo Passive           : Disable          Acl Number             : -          
      Destination Port       : 3784             TTL                    : 255        
      Proc Interface Status  : Disable          Process PST            : Disable    
      WTR Interval (ms)      : -                                                    
      Active Multi           : 3                                                    
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : No Application Bind                                  
      Session TX TmrID       : -                Session Detect TmrID   : -          
      Session Init TmrID     : -                Session WTR TmrID      : -          
      Session Echo Tx TmrID  : -                                                    
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    
         Total UP/DOWN Session Number : 1/0

    # Run the shutdown command on Eth2/0/0 of RouterA to simulate a link fault.

    [RouterA] interface ethernet 2/0/0
    [RouterA-Ethernet2/0/0] shutdown
    [RouterA-Ethernet2/0/0] quit

    # After the configuration is complete, run the display bfd session all verbose command on RouterA and RouterB. You can see that a single-hop BFD session is set up and its status is Down. The display on RouterA is used as an example.

    [RouterA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 64        (One Hop) State : Down        Name : atob
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2          
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(Vlanif100)                                 
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 10.1.1.6                                             
      NextHop Ip Address     : 10.1.1.6
      Bind Interface         : Vlanif100                                            
      FSM Board Id           : 0                TOS-EXP                : 7          
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000       
      Actual Tx Interval (ms): 13000            Actual Rx Interval (ms): 13000      
      Local Detect Multi     : 3                Detect Interval (ms)   : 39000      
      Echo Passive           : Disable          Acl Number             : -          
      Destination Port       : 3784             TTL                    : 255        
      Proc Interface Status  : Disable          Process PST            : Disable    
      WTR Interval (ms)      : -                   
      Active Multi           : 3                                                    
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : No Application Bind                                  
      Session TX TmrID       : 16897            Session Detect TmrID   : -          
      Session Init TmrID     : 16898            Session WTR TmrID      : -          
      Session Echo Tx TmrID  : -                                                    
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0                                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    
         Total UP/DOWN Session Number : 0/1 

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ip address 10.1.1.5 255.255.255.0
    #
    interface Ethernet2/0/0
     shutdown
     port hybrid pvid vlan 100 
     port hybrid untagged vlan 100
    #
    bfd atob bind peer-ip 10.1.1.6 interface Vlanif100
     discriminator local 1
     discriminator remote 2
     commit
    #
    return
  • RouterB configuration file

    #
     sysname RouterB
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ip address 10.1.1.6 255.255.255.0
    #
    interface Ethernet2/0/0
     port hybrid pvid vlan 100 
     port hybrid untagged vlan 100
    #
    bfd btoa bind peer-ip 10.1.1.5 interface Vlanif100
     discriminator local 2
     discriminator remote 1
     commit
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174116

Views: 51964

Downloads: 19

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next