No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Interface Backup in Active/Standby Mode on an ISDN Network

Example for Configuring Interface Backup in Active/Standby Mode on an ISDN Network

Networking Requirements

As shown in Figure 2-13, RouterA connects to an ISDN network through an ISDN PRI interface Serial1/0/0:15 and an IP network through GE2/0/0. RouterB connects to an ISDN network through ISDN PRI interfaces Serial1/0/0:15 and Serial2/0/0:15 and an IP network through GE2/0/0.

RouterA is the egress gateway of the headquarters. RouterB is located in a branch.

RouterA communicates with RouterB over an IP network. However, if GE2/0/0 of RouterA is faulty, the headquarters and the branch cannot exchange data. To prevent this fault, the enterprise leases an ISDN line as a backup of the IP network. The ISDN line is used only when faults occur on the IP network. This improves communication reliability.

Figure 2-13  Configuring link backup using the interface backup mode on an ISDN network

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure C-DCC on RouterA and set the dialer numbers to 660210 and 660208 so that RouterA can initiate calls to and receive calls from RouterB. In addition, each configured dialer number acts as a backup to the other.
  2. Configure the PRI interface of RouterA as the backup for GE2/0/0. When GE2/0/0 is faulty, traffic is switched to the PRI interface.

Procedure

  1. Configure RouterA.

    # Configure dialer group 1 and the dialer ACL.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] dialer-rule
    [RouterA-dialer-rule] dialer-rule 1 ip permit
    [RouterA-dialer-rule] quit

    # Configure the physical interface.

    [RouterA] controller e1 1/0/0
    [RouterA-E1 1/0/0] pri-set
    [RouterA-E1 1/0/0] quit

    # Assign an IP address to Serial1/0/0:15, enable C-DCC, and configure the dialer number.

    [RouterA] interface serial 1/0/0:15
    [RouterA-Serial1/0/0:15] ip address 10.1.1.1 24
    [RouterA-Serial1/0/0:15] dialer enable-circular
    [RouterA-Serial1/0/0:15] dialer-group 1
    [RouterA-Serial1/0/0:15] dialer route ip 10.1.1.2 broadcast 660210
    [RouterA-Serial1/0/0:15] dialer route ip 10.1.1.2 broadcast 660208
    [RouterA-Serial1/0/0:15] quit

    # Configure a backup interface for GE2/0/0.

    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] standby interface Serial 1/0/0:15
    [RouterA-GigabitEthernet2/0/0] quit
    

    # Configure a routing protocol.

    [RouterA] rip
    [RouterA-rip-1] network 10.0.0.0
    [RouterA-rip-1] import-route direct
    [RouterA-rip-1] quit

  2. Configure RouterB.

    # Configure dialer group 2 and the dialer ACL.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] dialer-rule
    [RouterB-dialer-rule] dialer-rule 2 ip permit

    # Configure the physical interface.

    [RouterB] controller e1 1/0/0
    [RouterB-E1 1/0/0] pri-set
    [RouterB-E1 1/0/0] quit
    [RouterB] controller e1 2/0/0
    [RouterB-E1 2/0/0] pri-set
    [RouterB-E1 2/0/0] quit

    # Assign an IP address to Dialer0, enable C-DCC, and configure the dialer number.

    [RouterB] interface dialer 0
    [RouterB-Dialer0] ip address 10.1.1.2 24
    [RouterB-Dialer0] dialer enable-circular
    [RouterB-Dialer0] dialer-group 2
    [RouterB-Dialer0] dialer route ip 10.1.1.1 broadcast 660220
    [RouterB-Dialer0] quit

    # Add Serial1/0/0:15 and Serial2/0/0:15 to the dialer circular group.

    [RouterB] interface serial 1/0/0:15
    [RouterB-Serial1/0/0:15] dialer circular-group 0
    [RouterB-Serial1/0/0:15] quit
    [RouterB] interface serial 2/0/0:15
    [RouterB-Serial2/0/0:15] dialer circular-group 0
    [RouterB-Serial2/0/0:15] quit

    # Configure a routing protocol.

    [RouterB] rip
    [RouterB-rip-1] network 10.0.0.0
    [RouterB-rip-1] import-route direct
    [RouterB-rip-1] quit

Configuration Files

  • Configuration file of RouterA
    #
     sysname RouterA
    #
    controller E1 1/0/0
     pri-set
    #
    interface Serial1/0/0:15
     link-protocol ppp
     ip address 10.1.1.1 255.255.255.0
     dialer enable-circular
     dialer-group 1
     dialer route ip 10.1.1.2 broadcast 660210
     dialer route ip 10.1.1.2 broadcast 660208
    #
    interface GigabitEthernet2/0/0
     standby interface Serial1/0/0:15
    #
     dialer-rule
     dialer-rule 1 ip permit
    #
    rip 1
     network 10.0.0.0
     import-route direct
    #
    return   
  • Configuration file of RouterB
    #
     sysname RouterB
    #
    controller E1 1/0/0
     pri-set
    #
    controller E1 2/0/0
     pri-set
    #
    interface Dialer0
     link-protocol ppp
     ip address 10.1.1.2 255.255.255.0
     dialer enable-circular
     dialer-group 2
     dialer route ip 10.1.1.1 broadcast 660220
    #
    interface Serial1/0/0:15
     link-protocol ppp
     dialer circular-group 0
    #
    interface Serial2/0/0:15
     link-protocol ppp
     dialer circular-group 0
    #
     dialer-rule
     dialer-rule 2 ip permit
    #
    rip 1
     network 10.0.0.0
     import-route direct
    #
    return   
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174116

Views: 51280

Downloads: 19

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next