No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Association Between VRRP and Routing to Monitor the Uplink Status

Example for Configuring Association Between VRRP and Routing to Monitor the Uplink Status

Networking Requirements

As shown in Figure 7-17, hosts on a LAN are dual-homed to RouterA and RouterB through the switch. A VRRP group is established on RouterA and RouterB, and RouterA is the master. RouterA functions as the gateway and user traffic is forwarded along the path Switch -> RouterA -> RouterC -> RouterE.

When the route between RouterC and RouterE is withdrawn or becomes inactive, the VRRP group is required to be able to detect the fault. Then an active/standby switchover is performed rapidly and RouterB takes over services. This reduces the impact of the link fault on service forwarding.

Figure 7-17  Association between VRRP and routing to monitor the uplink status

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface and configure a routing protocol to ensure network connectivity.
  2. Configure a VRRP group on RouterA and RouterB, set a higher priority for RouterA so that RouterA functions as the master to forward traffic and set the preemption delay to 20s, and set a lower priority for RouterB so that RouterB functions as the backup.
  3. Configure association between VRRP and routing on RouterA so that an active/standby switchover is performed immediately when the monitored route is withdrawn or becomes inactive.

Procedure

  1. Assign an IP address to each interface. RouterA is used as an example. The configurations of RouterB, RouterC, RouterD, and RouterE are similar to the configuration of RouterA, and are not mentioned here. For details, see the configuration files.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.1.1.1 24
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 192.168.1.1 24
    [RouterA-GigabitEthernet2/0/0] quit
    

  2. Configure Layer 2 transmission on the switch.

    <Huawei> system-view
    [Huawei] sysname Switch
    [Switch] vlan 100
    [Switch-vlan100] quit
    [Switch] interface gigabitethernet1/0/0
    [Switch-GigabitEthernet1/0/0] port link-type trunk
    [Switch-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet1/0/0] port trunk pvid vlan 100
    [Switch-GigabitEthernet1/0/0] undo port trunk allow-pass vlan 1
    [Switch-GigabitEthernet1/0/0] quit
    [Switch] interface gigabitethernet2/0/0
    [Switch-GigabitEthernet2/0/0] port link-type trunk
    [Switch-GigabitEthernet2/0/0] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet2/0/0] port trunk pvid vlan 100
    [Switch-GigabitEthernet2/0/0] undo port trunk allow-pass vlan 1
    [Switch-GigabitEthernet2/0/0] quit

  3. Configure VRRP groups.

    # Configure VRRP group 1 on RouterA, and set the priority of RouterA to 120 and the preemption delay to 20s.

    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] vrrp vrid 1 virtual-ip 10.1.1.10
    [RouterA-GigabitEthernet1/0/0] vrrp vrid 1 priority 120
    [RouterA-GigabitEthernet1/0/0] vrrp vrid 1 preempt-mode timer delay 20
    [RouterA-GigabitEthernet1/0/0] quit

    # Configure VRRP group 1 on RouterB. RouterB uses default priority 100.

    [RouterB] interface gigabitethernet 1/0/0
    [RouterB-GigabitEthernet1/0/0] vrrp vrid 1 virtual-ip 10.1.1.10
    [RouterB-GigabitEthernet1/0/0] quit

  4. Configure IS-IS. RouterA, RouterC, and RouterE are used as an example. The configurations of RouterB and RouterD are similar to the configuration of RouterA, and are not mentioned here. For details, see the configuration files.

    # Set the IS-IS NET of RouterA to 10.0000.0000.0001.00, and set the IS-IS level to 1.

    [RouterA] isis 1
    [RouterA-isis-1] is-level level-1 
    [RouterA-isis-1] network-entity 10.0000.0000.0001.00
    [RouterA-isis-1] quit
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] isis enable 1
    [RouterA-GigabitEthernet2/0/0] quit
    

    # Set the IS-IS NET of RouterC to 10.0000.0000.0002.00, and set the IS-IS level to 1.

    [RouterC] isis 1
    [RouterC-isis-1] is-level level-1 
    [RouterC-isis-1] network-entity 10.0000.0000.0002.00
    [RouterC-isis-1] quit
    [RouterC] interface gigabitethernet 1/0/0
    [RouterC-GigabitEthernet1/0/0] isis enable 1
    [RouterC-GigabitEthernet1/0/0] quit
    [RouterC] interface gigabitethernet 2/0/0
    [RouterC-GigabitEthernet2/0/0] isis enable 1
    [RouterC-GigabitEthernet2/0/0] quit
    

    # Set the IS-IS NET of RouterE to 10.0000.0000.0003.00 and 20.0000.0000.0003.00, and set the IS-IS level to 1.

    [RouterE] isis 1
    [RouterE-isis-1] is-level level-1 
    [RouterE-isis-1] network-entity 10.0000.0000.0003.00
    [RouterE-isis-1] quit
    [RouterE] interface gigabitethernet 1/0/0
    [RouterE-GigabitEthernet1/0/0] isis enable 1
    [RouterE-GigabitEthernet1/0/0] quit
    [RouterE] isis 2
    [RouterE-isis-2] is-level level-1 
    [RouterE-isis-2] network-entity 20.0000.0000.0003.00
    [RouterE-isis-2] quit
    [RouterE] interface gigabitethernet 2/0/0
    [RouterE-GigabitEthernet2/0/0] isis enable 2
    [RouterE-GigabitEthernet2/0/0] quit
    

  5. Configure association between VRRP and routing on RouterA. When the associated route is withdrawn, the priority of RouterA decreases by 40.

    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] vrrp vrid 1 track ip route 172.16.1.0 24 reduced 40
    [RouterA-GigabitEthernet1/0/0] quit

  6. Verify the configuration.

    # After the configuration is complete, run the display isis route command on RouterA. You can see a route to network segment 172.16.1.0/24.

    [RouterA] display isis route
                                                                                    
                             Route information for ISIS(1)                          
                             -----------------------------                          
                                                                                    
                            ISIS(1) Level-1 Forwarding Table                        
                            --------------------------------                        
                                                                                    
    IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags   
    ------------------------------------------------------------------------------- 
    172.16.1.0/24          20         NULL    GE2/0/0         192.168.1.2     A/-/-/- 
    192.168.1.0/24       10         NULL    GE2/0/0         Direct          D/-/L/- 
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,     
                                   U-Up/Down Bit Set                                

    # Run the display vrrp command on RouterA and RouterB. You can see that RouterA is the master, RouterB is the backup, and the associated route is reachable.

    [RouterA] display vrrp
      GigabitEthernet1/0/0 | Virtual Router 1
        State          : Master
        Virtual IP       : 10.1.1.10
        Master IP        : 10.1.1.1
        PriorityRun      : 120
        PriorityConfig   : 120
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 20 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth type        : NONE
        Virtual MAC      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Track IP route : 172.16.1.0/24  Priority reduced : 40                         
        IP route state : Reachable                                                  
        Create time : 2012-05-29 21:25:47                                           
        Last change time : 2012-05-29 21:25:51      
    [RouterB] display vrrp
      GigabitEthernet1/0/0 | Virtual Router 1
        State          : Backup
        Virtual IP       : 10.1.1.10
        Master IP        : 10.1.1.1
        PriorityRun      : 100
        PriorityConfig   : 100
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 0 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth type        : NONE
        Virtual MAC      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time : 2012-05-29 21:25:47                                           
        Last change time : 2012-05-29 21:25:51      

    # Run the shutdown command on GE1/0/0 of RouterE to simulate a link fault.

    [RouterE] interface gigabitethernet 1/0/0
    [RouterE-GigabitEthernet1/0/0] shutdown
    [RouterE-GigabitEthernet1/0/0] quit

    # Run the display isis route command on RouterA. You can see that the route to network segment 172.16.1.0/24 is withdrawn.

    [RouterA] display isis route
                                                                                    
                             Route information for ISIS(1)                          
                             -----------------------------                          
                                                                                    
                            ISIS(1) Level-1 Forwarding Table                        
                            --------------------------------                        
                                                                                    
    IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags   
    ------------------------------------------------------------------------------- 
    192.168.1.0/24       10         NULL    GE2/0/0         Direct          D/-/L/- 
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,     
                                   U-Up/Down Bit Set                                

    # Run the display vrrp command on RouterA and RouterB. You can see that RouterA is in Backup state, RouterB is in Master state, and the associated route is unreachable.

    [RouterA] display vrrp
      GigabitEthernet1/0/0 | Virtual Router 1
        State          : Backup
        Virtual IP       : 10.1.1.10
        Master IP        : 10.1.1.2
        PriorityRun      : 80
        PriorityConfig   : 120
        MasterPriority   : 100
        Preempt          : YES   Delay Time : 20 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth type        : NONE
        Virtual MAC      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Track IP route : 172.16.1.0/24  Priority reduced : 40                         
        IP route state : Unreachable                                                  
        Create time : 2012-05-29 21:25:47                                           
        Last change time : 2012-05-29 21:25:51      
    [RouterB] display vrrp
      GigabitEthernet1/0/0 | Virtual Router 1
        State          : Master
        Virtual IP       : 10.1.1.10
        Master IP        : 10.1.1.2
        PriorityRun      : 100
        PriorityConfig   : 100
        MasterPriority   : 100
        Preempt          : YES   Delay Time : 0 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth type        : NONE
        Virtual MAC      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time : 2012-05-29 21:25:47                                           
        Last change time : 2012-05-29 21:25:51      

    # Run the undo shutdown command on GE1/0/0 of RouterE.

    [RouterE] interface gigabitethernet 1/0/0
    [RouterE-GigabitEthernet1/0/0] undo shutdown
    [RouterE-GigabitEthernet1/0/0] quit

    # After 20s, run the display vrrp command on RouterA and RouterB. You can see that RouterA restores to be the master and RouterB the backup, and the associated route is reachable.

    [RouterA] display vrrp
      GigabitEthernet1/0/0 | Virtual Router 1
        State          : Master
        Virtual IP       : 10.1.1.10
        Master IP        : 10.1.1.1
        PriorityRun      : 120
        PriorityConfig   : 120
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 20 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth type        : NONE
        Virtual MAC      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Track IP route : 172.16.1.0/24  Priority reduced : 40                         
        IP route state : Reachable                                                  
        Create time : 2012-05-29 21:27:47                                           
        Last change time : 2012-05-29 21:27:51      
    [RouterB] display vrrp
      GigabitEthernet1/0/0 | Virtual Router 1
        State          : Backup
        Virtual IP       : 10.1.1.10
        Master IP        : 10.1.1.1
        PriorityRun      : 100
        PriorityConfig   : 100
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 0 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth type        : NONE
        Virtual MAC      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time : 2012-05-29 21:27:47                                           
        Last change time : 2012-05-29 21:27:51      

Configuration Files

  • RouterA configuration file

    #
    sysname RouterA
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0001.00
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.10
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 20
     vrrp vrid 1 track ip route 172.16.1.0 255.255.255.0 reduced 40
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.1.1 255.255.255.0
     isis enable 1
    #
    return
    
  • RouterB configuration file

    #
    sysname RouterB
    #
    isis 2
     is-level level-1
     network-entity 20.0000.0000.0001.00
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.10
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.2.1 255.255.255.0
     isis enable 2
    #
    return
    
  • RouterC configuration file

    #
    sysname RouterC
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0002.00
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     ip address 172.16.1.1 255.255.255.0
     isis enable 1
    #
    return 
  • RouterD configuration file

    #
    sysname RouterD
    #
    isis 2
     is-level level-1
     network-entity 20.0000.0000.0002.00
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.2.2 255.255.255.0
     isis enable 2
    #
    interface GigabitEthernet2/0/0
     ip address 172.16.2.1 255.255.255.0
     isis enable 2
    #
    return 
  • RouterE configuration file

    #
    sysname RouterE
    #
    isis 1
     is-level level-1
     network-entity 10.0000.0000.0003.00
    #
    isis 2
     is-level level-1
     network-entity 20.0000.0000.0003.00
    #
    interface GigabitEthernet1/0/0
     
     ip address 172.16.1.2 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet2/0/0
     
     ip address 172.16.2.2 255.255.255.0
     isis enable 2
    #
    return 
  • Switch configuration file

    #
    sysname Switch 
    #
    vlan batch 100
    #
    interface Ethernet
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    interface Ethernet
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174116

Views: 51743

Downloads: 19

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next