No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Multi-Hop BFD

Example for Configuring Multi-Hop BFD

Networking Requirements

As shown in Figure 6-24, RouterA is indirectly connected to RouterC. Static routes are configured so that RouterA can communicate with RouterC. Faults on the link between RouterA and RouterC need to be fast detected.

Figure 6-24  Networking diagram for configuring multi-hop BFD

Configuration Roadmap

The configuration roadmap is as follows:

Configure BFD sessions on RouterA and RouterC to detect the multi-hop route.

Procedure

  1. Configure a reachable static route between RouterA and RouterC.

    The configuration of RouterC is similar to the configuration of RouterA, and is not mentioned here. For details, see the configuration files.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] ip route-static 10.2.1.0 24 10.1.1.2
    

  2. Configure multi-hop BFD.

    # Create a BFD session between RouterA and RouterC.

    [RouterA] bfd
    [RouterA-bfd] quit
    [RouterA] bfd atoc bind peer-ip 10.2.1.2
    [RouterA-bfd-session-atoc] discriminator local 10
    [RouterA-bfd-session-atoc] discriminator remote 20
    [RouterA-bfd-session-atoc] commit
    [RouterA-bfd-session-atoc] quit

    # Create a BFD session between RouterC and RouterA.

    [RouterC] bfd
    [RouterC-bfd] quit
    [RouterC] bfd ctoa bind peer-ip 10.1.1.1
    [RouterC-bfd-session-ctoa] discriminator local 20
    [RouterC-bfd-session-ctoa] discriminator remote 10
    [RouterC-bfd-session-ctoa] commit
    [RouterC-bfd-session-ctoa] quit

  3. Verify the configuration.

    # After the configuration, run the display bfd session all verbose command on RouterA and RouterC. You can see that a BFD session is set up and is in Up state. Take the display on RouterA as an example.

    [RouterA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 256       (Multi Hop) State :Up        Name : atoc
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Peer Ip Address
      Bind Session Type      : Static
      Bind Peer Ip Address   : 10.2.1.2
      Track Interface        : -     
      FSM Board Id           : 0                TOS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000
      Local Detect Multi     : 3                Detect Interval (ms)   : 3000
      Echo Passive           : Disable          Acl Number             : -
      Destination Port       : 3784             TTL                    : 254
      Proc interface status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                                                   
      Active Multi           : 3
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : No Application Bind
      Session TX TmrID       : -                Session Detect TmrID   : -
      Session Init TmrID     : -                Session WTR TmrID      : -
      Session Echo Tx TmrID  : -                                                    
      PDT Index              : FSM-0|RCV-0|IF-0|TOKEN-0
      Session Description    : -      
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 1/0

    # Run the shutdown command on the GE1/0/0 interface of RouterA to simulate a link fault.

    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] shutdown
    [RouterA-GigabitEthernet1/0/0] quit

    # After the configuration, run the display bfd session all verbose command on RouterA and RouterB. You can see that a multi-hop BFD session is set up and the status is Down. Take the display on RouterA as an example.

    [RouterA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 256       (Multi Hop) State :Down        Name : atoc
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Peer Ip Address
      Bind Session Type      : Static
      Bind Peer Ip Address   : 10.2.1.2
      Bind Interface         : -
      Track Interface        : -     
      FSM Board Id           : 0                TOS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000
      Local Detect Multi     : 3                Detect Interval (ms)   : 3000
      Echo Passive           : Disable          Acl Number             : -
      Destination Port       : 3784             TTL                    : 254
      Proc interface status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                                                   
      Active Multi           : 3
      Last Local Diagnostic  : Control Detection Time Expired
      Bind Application       : No Application Bind
      Session TX TmrID       : -                Session Detect TmrID   : -
      Session Init TmrID     : -                Session WTR TmrID      : -
      Session Echo Tx TmrID  : -                                                    
      PDT Index              : FSM-0|RCV-0|IF-0|TOKEN-0
      Session Description    : -      
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 0/1

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    bfd
    #
    interface GigabitEthernet1/0/0
    shutdown
    ip address 10.1.1.1 255.255.255.0
    #
    bfd atoc bind peer-ip 10.2.1.2
     discriminator local 10
     discriminator remote 20
     commit
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    return
  • RouterB configuration file

    #
     sysname RouterB
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.2.1.1 255.255.255.0
    #
    return
  • RouterC configuration file

    #
     sysname RouterC
    #
    bfd
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.1.2 255.255.255.0
    #
    bfd ctoa bind peer-ip 10.1.1.1
     discriminator local 20
     discriminator remote 10
     commit
    # 
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174116

Views: 51946

Downloads: 19

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next