No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an ADSL Interface as the Backup of an Ethernet Interface

Example for Configuring an ADSL Interface as the Backup of an Ethernet Interface

Networking Requirements

As shown in Figure 2-14, the enterprise egress gateway RouterA connects to the Internet through GE1/0/0.

The enterprise leases an ADSL link as the backup link so that the backup link can be used to connect to the Internet when GE1/0/0 is faulty.

Figure 2-14  Networking diagram of interface backup in active/standby mode

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a dialer interface and an ADSL interface on RouterA so that the backup link transmits services when the primary link is faulty.
  2. Configure static routes for the primary and backup links to implement connectivity at the network layer.
  3. Configure interface backup on GE1/0/0 so that services are switched to the ADSL interface when GE1/0/0 becomes faulty.

Procedure

  1. Configure RouterA.

    # Assign IP addresses to the primary and backup interfaces shown in Figure 2-14. The configuration procedures are not provided here.

    # Configure a dialer interface.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] dialer-rule
    [RouterA-dialer-rule] dialer-rule 10 ip permit
    [RouterA-dialer-rule] quit
    [RouterA] interface dialer 1
    [RouterA-Dialer1] dialer user u1
    [RouterA-Dialer1] dialer-group 10
    [RouterA-Dialer1] dialer bundle 10
    [RouterA-Dialer1] ip address 21.0.0.1 255.255.255.0
    [RouterA-Dialer1] dialer number 666
    [RouterA-Dialer1] quit
    

    # Configure the ADSL interface.

    [RouterA] interface atm 0/0/0
    [RouterA-Atm0/0/0] pvc pppoa 2/40
    [RouterA-atm-pvc-Atm0/0/0-2/40-pppoa] map ppp dialer 1
    [RouterA-atm-pvc-Atm0/0/0-2/40-pppoa] quit
    [RouterA-Atm0/0/0] quit
    # Configure static routes for the primary and backup links.
    [RouterA] ip route-static 0.0.0.0 0.0.0.0 dialer 1 preference 80
    [RouterA] ip route-static 0.0.0.0 0.0.0.0 20.0.0.2 preference 60

    # Configure ATM0/0/0 as the backup of GE1/0/0.

    [RouterA] interface gigabitethernet1/0/0
    [RouterA-GigabitEthernet1/0/0] standby interface atm 0/0/0
    [RouterA-GigabitEthernet1/0/0] quit
    

  2. Configure the DSLAM.

    See the DSLAM documentation.

  3. Configure the PPPoA server.

    Assign IP address 21.0.0.2 to the PPPoA server.

  4. Verify the configuration.

    # Run the display standby state command on RouterA to view the status of primary and backup interfaces. You can see that GigabitEthernet1/0/0 is in Up state and ATM0/0/0 is in standby state.

    <RouterA>display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
    GigabitEthernet1/0/0                   UP         MUP        MU                
    Atm0/0/0                         STANDBY     STANDBY        BU   0            
                                                                                    
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             

    # Run the shutdown command on GE1/0/1 to simulate a link fault. Run the display standby state command on RouterA. You can see that GE1/0/0 is Down and ATM0/0/0 is Up, indicating that the backup interface has been started.

    <RouterA>display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
    GigabitEthernet1/0/0                DOWN       MDOWN         MU                
    Atm0/0/0                              UP          UP         BU   0            
                                                                                    
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             

Configuration File

RouterA configuration file
#
 sysname RouterA
#                                                                               
interface Dialer1                                                               
 link-protocol ppp                                                              
 ip address 21.0.0.1 255.255.255.0                                              
 dialer user u1                                                                 
 dialer bundle 10                                                               
 dialer number 666                                                              
 dialer-group 10                                                                
#                                                                               
interface GigabitEthernet1/0/0                                                         
 ip address 20.0.0.1 255.255.255.0    
 standby interface Atm0/0/0 
#                                                                               
interface Atm0/0/0                                                              
 pvc pppoa 2/40                                                                 
  map ppp Dialer1                                                               
#                                                                               
dialer-rule                                                                     
 dialer-rule 10 ip permit                                                       
#                                                                               
ip route-static 0.0.0.0 0.0.0.0 Dialer1 preference 80                           
ip route-static 0.0.0.0 0.0.0.0 20.0.0.2 preference 60                          
#    
return     
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174116

Views: 52055

Downloads: 19

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next