No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100-S, AR110-S, AR120-S, AR150-S, AR160-S, AR200-S, AR1200-S, AR2200-S, and AR3200-S V200R009

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring VLAN-based Y.1731 Single-ended SLM

Example for Configuring VLAN-based Y.1731 Single-ended SLM

Networking Requirements

As networks continue to rapidly develop and applications become more and more diversified, various value-added services such as IPTV, video conferencing, and VOIP are becoming more widely used. Link connectivity and network performance determine QoS on bearer networks. Therefore, performance monitoring is especially important for service transmission.

On a point-to-multipoint (P2MP) network shown in Figure 10-8, real-time network quality is measured to enable timely adjustment upon deterioration of user communication quality. Carriers want to accurately collect packet loss statistics on the end-to-end link between CE1 and CE2.

Figure 10-8  Networking of VLAN-based Y.1731 single-ended SLM

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure basic CFM functions on the CEs.

  2. Configure CE2 to receive SLM frames.

  3. Configure single-ended SLM for the link between the CEs.

    • Configure on-demand single-ended SLM for the end-to-end link between the CEs to periodically collect statistics about the delay in frame transmission.

    • Configure proactive single-ended SLM for the end-to-end link between the CEs to periodically collect statistics about the delay in frame transmission.

Procedure

  1. Configure basic Ethernet CFM functions on CE1 and CE2. Create an MD named md3 and an MA named ma3, and bind the MA to the VLAN.

    # Configure CE1.

    <Huawei> system-view
    [Huawei] sysname CE1
    [CE1] vlan 2
    [CE1-vlan2] quit
    [CE1] interface GigabitEthernet 1/0/1
    [CE1-GigabitEthernet1/0/1] portswitch
    [CE1-GigabitEthernet1/0/1] port link-type trunk
    [CE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [CE1-GigabitEthernet1/0/1] quit
    [CE1] cfm enable
    [CE1] cfm md md3
    [CE1-md-md3] ma ma3
    [CE1-md-md3-ma-ma3] map vlan 2
    [CE1-md-md3-ma-ma3] mep mep-id 3 interface GigabitEthernet 1/0/1 outward
    [CE1-md-md3-ma-ma3] mep ccm-send mep-id 3 enable
    [CE1-md-md3-ma-ma3] remote-mep mep-id 4 mac 0001-0300-0204
    [CE1-md-md3-ma-ma3] remote-mep ccm-receive mep-id 4 enable
    [CE1-md-md3-ma-ma3] test-id 1 mep 3 remote-mep 4

    # Configure CE2.

    <Huawei> system-view
    [Huawei] sysname CE2
    [CE2] vlan 2
    [CE2-vlan2] quit
    [CE2] interface GigabitEthernet 1/0/1
    [CE2-GigabitEthernet1/0/1] portswitch
    [CE2-GigabitEthernet1/0/1] port link-type trunk
    [CE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [CE2-GigabitEthernet1/0/1] quit
    [CE2] cfm enable
    [CE2] cfm md md3
    [CE2-md-md3] ma ma3
    [CE2-md-md3-ma-ma3] map vlan 2
    [CE2-md-md3-ma-ma3] mep mep-id 4 interface GigabitEthernet 1/0/1 outward
    [CE2-md-md3-ma-ma3] mep ccm-send mep-id 4 enable
    [CE2-md-md3-ma-ma3] remote-mep mep-id 3
    [CE2-md-md3-ma-ma3] remote-mep ccm-receive mep-id 3 enable
    [CE2-md-md3-ma-ma3] test-id 1 mep 4 remote-mep 3

  2. Configure CE2 to receive SLM frames.

    # Configure CE2.

    [CE2-md-md3-ma-ma3] loss-measure single-ended-synthetic receive test-id 1 time-out 300
    [CE2-md-md3-ma-ma3] quit
    [CE2-md-md3] quit

  3. Configure single-ended SLM.

    • Configure on-demand single-ended SLM for the end-to-end link between the CEs.

      # Configure on-demand single-ended SLM on CE1.
      [CE1-md-md3-ma-ma3] loss-measure single-ended-synthetic send test-id 1 interval 1000 sending-count 10 time-out 2
      [CE1-md-md3-ma-ma3] quit
      [CE1-md-md3] quit
    • Configure proactive single-ended SLM for the end-to-end link between the CEs.

      # Configure proactive single-ended SLM on CE1.
      [CE1-md-md3-ma-ma3] loss-measure single-ended-synthetic continual send test-id 1 interval 1000
      [CE1-md-md3-ma-ma3] quit
      [CE1-md-md3] quit
      [CE1] quit

  4. Verify the configuration.

    # After the configurations are complete, run the display y1731 statistic-type single-synthetic-loss test-id 1 command on CE1. You can view packet loss statistics collected using single-ended SLM.

    <CE1> display y1731 statistic-type single-synthetic-loss test-id 1
    --------------------------------------------------------------------------------
    Index       L-send R-send L-recv Unack  L-loss R-loss L-loss-ratio R-loss-ratio 
    --------------------------------------------------------------------------------
    1016        10     10     10     0           0      0      0.0000%      0.0000% 
    1017        10     10     10     0           0      0      0.0000%      0.0000% 
    1018        10     10     10     0           0      0      0.0000%      0.0000% 
    1019        10     10     10     0           0      0      0.0000%      0.0000% 
    1020        10     10     10     0           0      0      0.0000%      0.0000% 
    1021        10     10     10     0           0      0      0.0000%      0.0000% 
    --------------------------------------------------------------------------------
    Average Local-loss  :          0    Average Local-loss Ratio  :         0.0000% 
    Maximum Local-loss  :          0    Maximum Local-loss Ratio  :         0.0000% 
    Minimum Local-loss  :          0    Minimum Local-loss Ratio  :         0.0000% 
    Average Remote-loss :          0    Average Remote-loss Ratio :         0.0000% 
    Maximum Remote-loss :          0    Maximum Remote-loss Ratio :         0.0000% 
    Minimum Remote-loss :          0    Minimum Remote-loss Ratio :         0.0000% 

Configuration Files

  • CE1 configuration file

    #
    sysname CE1
    #
    vlan 2
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    cfm md md3
     ma ma3
      map vlan 2
      mep mep-id 3 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 3 enable
      remote-mep mep-id 4 mac 0001-0300-0204
      remote-mep ccm-receive mep-id 4 enable
      test-id 1 mep 3 remote-mep 4
      loss-measure single-ended-synthetic continual send test-id 1 interval 1000 
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan 2
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    cfm md md3
     ma ma3
      map vlan 2
      mep mep-id 4 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 4 enable
      remote-mep mep-id 3
      remote-mep ccm-receive mep-id 3 enable
      test-id 1 mep 4 remote-mep 3
      loss-measure single-ended-synthetic receive test-id 1 time-out 300
    #
    return
Translation
Download
Updated: 2019-05-17

Document ID: EDOC1000174116

Views: 52092

Downloads: 19

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next