No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Radio Calibration

Example for Configuring Radio Calibration

Networking Requirement

A WLAN containing three APs (AP_1, AP_2, and AP_3) is deployed on the campus network. The three APs interfere with each other, so the WLAN performance is low. The customer requires that three APs automatically adjust their channels and power to reduce interference and achieve optimal WLAN performance.

Figure 11-8  Networking diagram for configuring radio calibration

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the APs and upper-layer network devices to communicate at Layer 2.
  2. Configure the AP as a DHCP server to assign IP addresses to STAs from an IP address pool of an interface.
  3. Configure AP system parameters, including the country code.
  4. Configure a VAP so that STAs can access the WLAN.
  5. Configure radio calibration to ensure that the WLAN works in the optimal state.

Configuration Notes

No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression on switch interfaces connected to APs to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected. For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.

Procedure

  1. Configure the AP to communicate with upper-layer network devices.

    NOTE:

    This example describes how to configure radio calibration on AP_1. The configuration on AP_2 and AP_3 is the same.

    Configure AP uplink interfaces to transparently transmit packets of service VLANs as required and communicate with upstream network devices.

    # Add AP_1's uplink interface GE0/0/1 to VLAN 101.

    <Huawei> system-view
    [Huawei] sysname AP_1
    [AP_1] vlan batch 101
    [AP_1] interface gigabitethernet 0/0/1
    [AP_1-GigabitEthernet0/0/1] port link-type trunk
    [AP_1-GigabitEthernet0/0/1] port trunk allow-pass vlan 101
    [AP_1-GigabitEthernet0/0/1] quit
    

  2. Configure AP_1 as a DHCP server to allocate IP addresses to STAs.

    # Configure the DHCP server to allocate IP addresses to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AP_1] dhcp enable
    [AP_1] interface vlanif 101
    [AP_1-Vlanif101] ip address 10.23.101.1 24
    [AP_1-Vlanif101] dhcp select interface
    [AP_1-Vlanif101] quit
    

  3. Configure system parameters of AP_1.

    # Configure the country code for AP_1.

    [AP_1] wlan
    [AP_1-wlan-view] country-code cn
    

  4. Configure WLAN service parameters.

    # Create the security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AP_1-wlan-view] security-profile name wlan-security
    [AP_1-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AP_1-wlan-sec-prof-wlan-security] quit
    

    # Create the SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AP_1-wlan-view] ssid-profile name wlan-ssid
    [AP_1-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AP_1-wlan-ssid-prof-wlan-ssid] quit
    

    # Create the VAP profile wlan-vap, set the service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AP_1-wlan-view] vap-profile name wlan-vap
    [AP_1-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AP_1-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AP_1-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AP_1-wlan-vap-prof-wlan-vap] quit
    [AP_1-wlan-view] quit
    

  5. Configure a VAP.

    [AP_1] interface wlan-radio0/0/0
    [AP_1-Wlan-Radio0/0/0] vap-profile wlan-vap wlan 2
    [AP_1-Wlan-Radio0/0/0] quit
    

  6. Configure radio calibration.

    # Enable automatic channel selection and automatic transmit power selection. By default, automatic channel selection and automatic transmit power selection are enabled.
    [AP_1] interface wlan-radio0/0/0
    [AP_1-Wlan-Radio0/0/0] undo calibrate auto-channel-select disable 
    [AP_1-Wlan-Radio0/0/0] undo calibrate auto-txpower-select disable
    [AP_1-Wlan-Radio0/0/0] quit 
    [AP_1] wlan

    # Create the air scan profile wlan-airscan and configure the scan channel set, scan interval, and scan duration. By default, an air scan channel set contains all channels supported by the corresponding country code of an AP.

    [AP_1-wlan-view] air-scan-profile name wlan-airscan
    [AP_1-wlan-air-scan-prof-wlan-airscan] scan-channel-set country-channel 
    [AP_1-wlan-air-scan-prof-wlan-airscan] scan-period 80
    [AP_1-wlan-air-scan-prof-wlan-airscan] scan-interval 80000
    [AP_1-wlan-air-scan-prof-wlan-airscan] quit

    # Bind the air scan profile wlan-airscan to the 2G radio profile radio2g.

    [AP_1-wlan-view] radio-2g-profile name default 
    [AP_1-wlan-radio-2g-prof-default] air-scan-profile wlan-airscan
    [AP_1-wlan-radio-2g-prof-default] quit
    [AP_1-wlan-view] quit

    # Set the radio calibration mode to manual and trigger radio calibration.

    [AP_1] wlan
    [AP_1-wlan-view] calibrate enable manual
    [AP_1-wlan-view] calibrate manual startup
    [AP_1-wlan-view] quit

  7. Verify the configuration.

    The configuration automatically takes effect after it is completed. Run the display vap ssid wlan-net command. If Status in the command output is displayed as ON, the VAP has been successfully created on radios of AP_1.

    [AP_1] display vap ssid wlan-net
    WID : WLAN ID
    --------------------------------------------------------------------------------
    AP MAC         RfID WID  BSSID          Status  Auth type  STA    SSID
    --------------------------------------------------------------------------------
    00bc-da3f-e900 0    2    00BC-DA3F-E901 ON      WPA2-PSK   0      wlan-net
    -------------------------------------------------------------------------------
    Total: 1

    Connect STAs to the WLAN with SSID wlan-net and enter the password a1234567. Run the display station all command on AP_1. The command output shows that the STAs are connected to the WLAN wlan-net.

    [AP_1] display station all
    Rf/WLAN: Radio ID/WLAN ID
    Rx/Tx: link receive rate/link transmit rate(Mbps)
    ------------------------------------------------------------------------------
    STA MAC          Ap name        Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address    SSID
    ------------------------------------------------------------------------------
    14cf-9202-13dc   00bc-da3f-e900 0/2      2.4G  11n   19/13      -63   101   10.23.101.254 wlan-net
    ------------------------------------------------------------------------------
    Total: 1 2.4G: 1 5G: 0

    Run the display wlan calibrate statistics radio 0 command on AP_1 to check radio calibration statistics on AP1.

    [AP_1] display wlan calibrate statistics radio 0
    -----------------------------------------------------------------------
    Signal environment deterioration :1
    Power calibration                :0
    Channel calibration              :0
    -----------------------------------------------------------------------
    Radio calibration stops half an hour after it is manually triggered. The following configuration steps are not provided in the configuration file. You can perform either of the following configurations:
    • (Recommended) Set the radio calibration mode to scheduled. Configure the APs to perform radio calibration in off-peak hours, for example, between 00:00 am and 06:00 am.

      [AP_1] wlan
      [AP_1-wlan-view] calibrate enable schedule time 03:00:00 
    • Manually fix the working channels of APs: disable automatic channel selection and automatic transmit power selection. Manually trigger radio calibration when new APs are added to the network.

      [AP_1] interface wlan-radio0/0/0
      [AP_1-Wlan-Radio0/0/0] calibrate auto-channel-select disable 
      [AP_1-Wlan-Radio0/0/0] calibrate auto-txpower-select disable
      [AP_1-Wlan-Radio0/0/0] quit 
      [AP_1] wlan
      [AP_1-wlan-view] calibrate manual startup

Configuration Files

  • AP_1 configuration file

    #
     sysname AP_1
    #
    vlan batch 101
    #
    dhcp enable
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    wlan
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#(yk#Q+M[\CMK]1)AWMX7MjZ)=e`fy@fA+.J\ht3Y%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
     air-scan-profile name wlan-airscan
      scan-period 80
      scan-interval 80000
     radio-2g-profile name default
      air-scan-profile wlan-airscan
    #
    inteface Wlan-Radio0/0/0
     vap-profile wlan-vap wlan 2
    #
    return
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 130335

Downloads: 312

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next