No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

Example for Configuring the STA Blacklist and Whitelist

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile,and WIDS profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. After that, the configuration is automatically delivered to and takes effect on the RUs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Networking Requirements

As shown in Figure 25-36, the central AP and RU are directly connected. An enterprise provides a WLAN with the SSID wlan-net for management personnel to access the enterprise network. STAs automatically obtain IP addresses.

The WLAN with a small number of management personnel can use the STA whitelist. MAC addresses of management personnel's wireless terminals can be added to a STA whitelist, preventing other employees from accessing the WLAN.

The management personnel found that some unauthorized STAs are online. To prevent this situation, management personnel can add MAC addresses of the STAs to a blacklist to prevent these STAs from accessing the WLAN. STAs that are not in the blacklist can access the WLAN.

Figure 25-36  Networking diagram for configuring the STA blacklist and whitelist
Configuration Roadmap
  1. Configure WLAN basic services so that STAs can access the WLAN.
  2. Configure a STA whitelist. Add MAC addresses of management personnel's wireless terminals to the whitelist. To prevent configuration impacts on other VAPs, configure the STA whitelist for a VAP, instead of an RU.
  3. Configure a STA blacklist for an RU. Add MAC addresses of some STAs to the blacklist to prevent the STAs from associating with the RU, ensuing WLAN network security.
NOTE:

The STA whitelist and blacklist cannot be configured simultaneously for a VAP or an RU, that is, the STA whitelist and blacklist cannot take effect at the same time in a VAP profile or an AP system profile.

Table 25-13  Data planning

Item

Data

DHCP server The central AP functions as a DHCP server to assign IP addresses to the STAs and RU.
IP address pool for the RU 10.23.100.2-10.23.100.254/24
IP address pool for STAs 10.23.101.2-10.23.101.254/24
STA whitelist profile
  • Name: sta-whitelist
  • STAs added to the STA whitelist: STA1 and STA2
STA blacklist profile
  • Name: sta-blacklist
  • STAs added to the STA blacklist: STA3 and STA4
AP system profile
  • Name: wlan-system
  • Referenced profile: STA blacklist profile sta-blacklist
AP group
  • Name: ap-group1
  • Referenced profile: VAP profile wlan-vap, AP system profile wlan-system, and regulatory domain profile domain1
Regulatory domain profile
  • Name: domain1
  • Country code: CN
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: open system authentication
VAP profile
  • Name: wlan-vap
  • Service VLAN: VLAN 101
  • Referenced profile: SSID profile wlan-ssid, security profile wlan-security, and STA whitelist profile sta-whitelist
Configuration Notes

Configure port isolation on the interfaces of the device directly connected to RUs. If port isolation is not configured, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

Procedure

  1. Configure the central AP so that the RU and central AP can transmit CAPWAP packets.

    # Configure the central AP: add interface GE0/0/1 to management VLAN 100.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan batch 100 101
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AP-GigabitEthernet0/0/1] quit
    

  2. Configure the central AP to communicate with the upstream device.

    NOTE:

    Configure central AP uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add central AP uplink interface GE0/0/24 to service VLAN 101.

    [AP] interface gigabitethernet 0/0/24
    [AP-GigabitEthernet0/0/24] port link-type trunk
    [AP-GigabitEthernet0/0/24] port trunk allow-pass vlan 101
    [AP-GigabitEthernet0/0/24] quit
    

  3. Configure the central AP as a DHCP server to allocate IP addresses to STAs and the RU.

    # Configure the central AP as the DHCP server to allocate an IP address to the RU from the IP address pool on VLANIF 100, and allocate IP addresses to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AP] dhcp enable
    [AP] interface vlanif 100
    [AP-Vlanif100] ip address 10.23.100.1 24
    [AP-Vlanif100] dhcp select interface
    [AP-Vlanif100] quit
    [AP] interface vlanif 101
    [AP-Vlanif101] ip address 10.23.101.1 24
    [AP-Vlanif101] dhcp select interface
    [AP-Vlanif101] quit
    

  4. Configure the RU to go online.

    # Create an AP group and add the RU to the AP group.

    [AP] wlan
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the central AP country code in the profile, and apply the profile to the AP group.

    [AP-wlan-view] regulatory-domain-profile name domain1
    [AP-wlan-regulate-domain-domain1] country-code cn
    [AP-wlan-regulate-domain-domain1] quit
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AP-wlan-ap-group-ap-group1] quit
    [AP-wlan-view] quit
    

    # Configure the management VLAN for RUs connected to the central AP.

    [AP] management-vlan 100
    
    # Import the RU offline on the central AP and add the RU to AP group ap-group1. Assume that the RU's MAC address is 60de-4476-e360. Configure a name for the RU based on the RU's deployment location, so that you can know where the RU is deployed from its name. For example, name the RU area_1 if it is deployed in Area 1.
    NOTE:

    The default RU authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the R240D is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AP] wlan
    [AP-wlan-view] ap auth-mode mac-auth
    [AP-wlan-view] ap-id 1 ap-mac 60de-4476-e360
    [AP-wlan-ap-1] ap-name area_1
    [AP-wlan-ap-1] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AP-wlan-ap-1] quit
    

    # After the RU is powered on, run the display ap all command to check the RU state. If the State field is displayed as nor, the RU goes online normally.

    [AP-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    1    60de-4476-e360 area_1 ap-group1 10.23.100.254 R240D           nor   0   10S
    -------------------------------------------------------------------------------------
    Total: 1

  5. Configure a STA whitelist in a VAP profile.

    # Create the STA whitelist profile sta-whitelist and add MAC addresses of STA1 and STA2 to the whitelist.

    [AP-wlan-view] sta-whitelist-profile name sta-whitelist
    [AP-wlan-whitelist-prof-sta-whitelist] sta-mac 0011-2233-4455
    [AP-wlan-whitelist-prof-sta-whitelist] sta-mac 0011-2233-4466
    [AP-wlan-whitelist-prof-sta-whitelist] quit

    # Create the VAP profile wlan-vap and bind the STA whitelist profile to the VAP profile.

    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] sta-access-mode whitelist sta-whitelist
    [AP-wlan-vap-prof-wlan-vap] quit
    

  6. Configure a global STA blacklist.

    # Create the STA blacklist profile sta-blacklist and add MAC addresses of STA3 and STA4 to the blacklist.

    [AP-wlan-view] sta-blacklist-profile name sta-blacklist
    [AP-wlan-blacklist-prof-sta-blacklist] sta-mac 0011-2233-4477
    [AP-wlan-blacklist-prof-sta-blacklist] sta-mac 0011-2233-4488
    [AP-wlan-blacklist-prof-sta-blacklist] quit

    # Create the AP system profile wlan-system and bind the STA blacklist profile to the AP system profile.

    [AP-wlan-view] ap-system-profile name wlan-system
    [AP-wlan-ap-system-prof-wlan-system] sta-access-mode blacklist sta-blacklist
    [AP-wlan-ap-system-prof-wlan-system] quit
    

  7. Configure WLAN service parameters.

    # Create the security profile wlan-security.

    [AP-wlan-view] security-profile name wlan-security
    [AP-wlan-sec-prof-wlan-security] quit
    

    # Create the SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AP-wlan-view] ssid-profile name wlan-ssid
    [AP-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AP-wlan-ssid-prof-wlan-ssid] quit
    

    # In the VAP profile wlan-vap, set the service VLAN, and bind the security profile and SSID profile to the VAP profile.

    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AP-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AP-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AP-wlan-vap-prof-wlan-vap] quit
    

    # Bind the VAP profile wlan-vap and AP system profile wlan-system to the AP group.

    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 0
    [AP-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 1
    [AP-wlan-ap-group-ap-group1] ap-system-profile wlan-system
    [AP-wlan-ap-group-ap-group1] quit
    

  8. Set channels and power for the RU radios.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The channel and power configuration for the RU radios in this example is for reference only. In actual scenarios, configure channels and power for RU radios based on country codes of RUs and network planning results.

    # Disable automatic channel and power calibration functions of radio 0, and configure the channel and power for radio 0.
    [AP-wlan-view] ap-id 1
    [AP-wlan-ap-1] radio 0
    [AP-wlan-radio-1/0] calibrate auto-channel-select disable
    [AP-wlan-radio-1/0] calibrate auto-txpower-select disable
    [AP-wlan-radio-1/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-radio-1/0] eirp 127
    [AP-wlan-radio-1/0] quit
    # Disable automatic channel and power calibration functions of radio 1, and configure the channel and power for radio 1.
    [AP-wlan-ap-1] radio 1
    [AP-wlan-radio-1/1] calibrate auto-channel-select disable
    [AP-wlan-radio-1/1] calibrate auto-txpower-select disable
    [AP-wlan-radio-1/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-radio-1/1] eirp 127
    [AP-wlan-radio-1/1] quit
    [AP-wlan-ap-1] quit

  9. Verify the configuration.

    The WLAN with SSID wlan-net is available for STAs connected to the RU.

    STA1 and STA2 can connect to the WLAN. STA3 and STA4 cannot connect to the WLAN.

Configuration Files

Central AP configuration file

#
 sysname AP
#
vlan batch 100 to 101
#
dhcp enable
#
interface Vlanif100
 ip address 10.23.100.1 255.255.255.0
 dhcp select interface
#
interface Vlanif101
 ip address 10.23.101.1 255.255.255.0
 dhcp select interface
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk pvid vlan 100
 port trunk allow-pass vlan 100 to 101
#
interface GigabitEthernet0/0/24
 port link-type trunk
 port trunk allow-pass vlan 101
#
management-vlan 100
#
wlan
 security-profile name wlan-security
 sta-blacklist-profile name sta-blacklist
  sta-mac 0011-2233-4477
  sta-mac 0011-2233-4488
 sta-whitelist-profile name sta-whitelist
  sta-mac 0011-2233-4455
  sta-mac 0011-2233-4466
 ssid-profile name wlan-ssid
  ssid wlan-net
 vap-profile name wlan-vap
  service-vlan vlan-id 101
  sta-access-mode whitelist sta-whitelist
  ssid-profile wlan-ssid
  security-profile wlan-security
 regulatory-domain-profile name domain1
 ap-system-profile name wlan-system
  sta-access-mode blacklist sta-blacklist
 ap-group name ap-group1
  ap-system-profile wlan-system
  regulatory-domain-profile domain1
  radio 0
   vap-profile wlan-vap wlan 1
  radio 1
   vap-profile wlan-vap wlan 1
 ap-id 1 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
  ap-name area_1
  ap-group ap-group1
  radio 0
   channel 20mhz 6
   eirp 127
   calibrate auto-channel-select disable
   calibrate auto-txpower-select disable
  radio 1
   channel 20mhz 149
   eirp 127
   calibrate auto-channel-select disable
   calibrate auto-txpower-select disable
#
return
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 116369

Downloads: 309

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next