No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

Example for Configuring Application Visualization

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile,and WIDS profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. After that, the configuration is automatically delivered to and takes effect on the RUs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Networking Requirements

As shown in Figure 27-39, a WLAN of an enterprise transmits voice, video, and data flows of varied applications, including FaceTime, WeChat, and Skype_VoIP. The enterprise needs to know traffic usage of the applications to plan network capacity and locate problems on the network. In this situation, you can take application traffic control measures, including discarding FaceTime packets, specifying the priority for WeChat packets, and limiting the rate of Skype_VoIP packets.

Figure 27-39  Networking diagram of configuring application visualization
Configuration
The configuration roadmap is as follows:
  1. Configure basic WLAN services to ensure that users can access the WLAN.
  2. Configure application visualization, including specifying the priority for WeChat packets, discarding FaceTime packets, and limiting the rate of Skype_VoIP packets.
Table 27-30  Data planning

Item

Data

DHCP server The central AP functions as a DHCP server to assign IP addresses to the STAs and RUs.
IP address pool for the RUs 10.23.100.2-10.23.100.254/24
IP address pool for the STAs 10.23.101.2-10.23.101.254/24
AP group
  • Name: ap-group1
  • Referenced profile: VAP profile wlan-vap, regulatory domain profile domain1 and SAC profile wlan-sac
Regulatory domain profile
  • Name: domain1
  • Country code: CN
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-vap
  • Service VLAN: VLAN 101
  • Referenced profile: SSID profile wlan-ssid and security profile wlan-security
SAC profile

Name: wlan-sac

Configuration Notes

Configure port isolation on the interfaces of the device directly connected to RUs. If port isolation is not configured, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

Procedure

  1. Configure the central AP so that the RU and central AP can transmit CAPWAP packets.

    # Configure the central AP: add interface GE0/0/1 to management VLAN 100 and service VLAN 101.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan batch 100 101
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [AP-GigabitEthernet0/0/1] quit
    

  2. Configure the central AP to communicate with the upstream device.

    NOTE:

    Configure central AP uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add central AP uplink interface GE0/0/24 to service VLAN 101.

    [AP] interface gigabitethernet 0/0/24
    [AP-GigabitEthernet0/0/24] port link-type trunk
    [AP-GigabitEthernet0/0/24] port trunk allow-pass vlan 101
    [AP-GigabitEthernet0/0/24] quit
    

  3. Configure the central AP as a DHCP server to allocate IP addresses to STAs and the RU.

    # Configure the central AP as the DHCP server to allocate an IP address to the RU from the IP address pool on VLANIF 100, and allocate IP addresses to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AP] dhcp enable
    [AP] interface vlanif 100
    [AP-Vlanif100] ip address 10.23.100.1 24
    [AP-Vlanif100] dhcp select interface
    [AP-Vlanif100] quit
    [AP] interface vlanif 101
    [AP-Vlanif101] ip address 10.23.101.1 24
    [AP-Vlanif101] dhcp select interface
    [AP-Vlanif101] quit
    

  4. Configure the RU to go online.

    # Create an AP group and add the RU to the AP group.

    [AP] wlan
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the central AP country code in the profile, and apply the profile to the AP group.

    [AP-wlan-view] regulatory-domain-profile name domain1
    [AP-wlan-regulate-domain-domain1] country-code cn
    [AP-wlan-regulate-domain-domain1] quit
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AP-wlan-ap-group-ap-group1] quit
    [AP-wlan-view] quit
    

    # Configure the management VLAN for RUs connected to the central AP.

    [AP] management-vlan 100
    
    # Import the RU offline on the central AP and add the RU to AP group ap-group1. Assume that the RU's MAC address is 60de-4476-e360. Configure a name for the RU based on the RU's deployment location, so that you can know where the RU is deployed from its name. For example, name the RU area_1 if it is deployed in Area 1.
    NOTE:

    The default RU authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the R240D is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AP] wlan
    [AP-wlan-view] ap auth-mode mac-auth
    [AP-wlan-view] ap-id 1 ap-mac 60de-4476-e360
    [AP-wlan-ap-1] ap-name area_1
    [AP-wlan-ap-1] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AP-wlan-ap-1] quit
    

    # After the RU is powered on, run the display ap all command to check the RU state. If the State field is displayed as nor, the RU goes online normally.

    [AP-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    1    60de-4476-e360 area_1 ap-group1 10.23.100.254 R240D           nor   0   10S
    -------------------------------------------------------------------------------------
    Total: 1

  5. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AP-wlan-view] security-profile name wlan-security
    [AP-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AP-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AP-wlan-view] ssid-profile name wlan-ssid
    [AP-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profile wlan-vap, set the service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AP-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AP-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AP-wlan-vap-prof-wlan-vap] quit
    

    # Bind VAP profile wlan-vap to the AP group and apply the profile to radio 0 and radio 1 of the AP.

    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio all
    [AP-wlan-ap-group-ap-group1] quit
    

  6. Set channels and power for the RU radios.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The channel and power configuration for the RU radios in this example is for reference only. In actual scenarios, configure channels and power for RU radios based on country codes of RUs and network planning results.

    # Disable automatic channel and power calibration functions of radio 0, and configure the channel and power for radio 0.
    [AP-wlan-view] ap-id 1
    [AP-wlan-ap-1] radio 0
    [AP-wlan-radio-1/0] calibrate auto-channel-select disable
    [AP-wlan-radio-1/0] calibrate auto-txpower-select disable
    [AP-wlan-radio-1/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-radio-1/0] eirp 127
    [AP-wlan-radio-1/0] quit
    # Disable automatic channel and power calibration functions of radio 1, and configure the channel and power for radio 1.
    [AP-wlan-ap-1] radio 1
    [AP-wlan-radio-1/1] calibrate auto-channel-select disable
    [AP-wlan-radio-1/1] calibrate auto-txpower-select disable
    [AP-wlan-radio-1/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-radio-1/1] eirp 127
    [AP-wlan-radio-1/1] quit
    [AP-wlan-ap-1] quit

  7. Configure application visualization.

    # Enable the security engine.
    [AP-wlan-view] quit
    [AP] defence engine enable
    NOTE:
    • After the security engine is enabled, the system automatically loads the default signature database.
    • The signature database contains voice and video protocols supported by the voice and video service optimization function.
    # Create SAC profile wlan-sac and enter the profile view.
    [AP] wlan
    [AP-wlan-view] sac-profile name wlan-sac
    
    # Configure VAP protocol statistics collection.
    [AP-wlan-sac-prof-wlan-sac] vap-protocol-statistic enable
    
    # Configure user protocol statistics collection.
    [AP-wlan-sac-prof-wlan-sac] user-protocol-statistic enable
    
    # Set the DSCP priority of WeChat packets to 40.
    [AP-wlan-sac-prof-wlan-sac] application-group instant_messaging app-protocol weixin_im remark dscp 40
    
    # Configure the central AP to discard FaceTime packets.
    [AP-wlan-sac-prof-wlan-sac] application-group voip app-protocol facetime deny
    # Limit the rate of Skype_VoIP packets to 1000 kbit/s.
    [AP-wlan-sac-prof-wlan-sac] application-group voip app-protocol skype_voip car 1000
    [AP-wlan-sac-prof-wlan-sac] quit
    
    # Bind SAC profile wlan-sac to VAP profile wlan-vap to make the configured policy take effect.
    [AP-wlan-view] vap-profile name wlan-vap 
    [AP-wlan-vap-prof-wlan-vap] sac-profile wlan-sac
    [AP-wlan-vap-prof-wlan-vap] quit
    [AP-wlan-view] quit
    [AP] quit
    

  8. Verify the configuration.

    # Check whether SAC is enabled.
    <AP> display sac information
    ------------------------------------------------------------------------------  
        SAC status            : enabled                                             
        App protocol number   : 1630                                                
        SAC signature status  : loaded                                              
        SAC signature version : 7.2.1059.1                                          
    ------------------------------------------------------------------------------  
    # Check Skype_VoIP packet statistics on VAPs of radio 0 in area_1.
    <AP> display sac protocol-statistic total inbound protocol skype_voip ap-name area_1 radio-id 0 ssid wlan-net
    Protocol statistics:
    
    Protocol       Direction     Packets        Bytes
    --------------------------------------------------------------------------
    skype_voip     inbound       4096           100000
    --------------------------------------------------------------------------
    
    # Check Skype_VoIP packet statistics of the STA with MAC address 286E-D488-BF0B.
    <AP> display sac protocol-statistic total inbound protocol skype_voip user 286E-D488-BF0B
    Protocol statistics:
    
    Protocol       Direction     Packets        Bytes
    --------------------------------------------------------------------------
    skype_voip     inbound       1000           100000
    --------------------------------------------------------------------------
    

Configuration Files
  • Configuration file of the AP

    #
     defence engine enable
     sysname AP
    #
    vlan batch 100 to 101
    #
     management-vlan 100
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet0/0/24
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    wlan
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#Z'(8*=Q-k%k:|I&[!)+39P:g%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     sac-profile name wlan-sac
      vap-protocol-statistic enable
      user-protocol-statistic enable
      application-group instant_messaging app-protocol weixin_im remark dscp 40
      application-group voip app-protocol facetime deny
      application-group voip app-protocol skype_voip car 1000
     vap-profile name wlan-vap
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
      sac-profile wlan-sac
     regulatory-domain-profile name domain1
     ap-group name ap-group1
      regulatory-domain-profile domain1
      radio 0
       vap-profile wlan-vap wlan 1
      radio 1
       vap-profile wlan-vap wlan 1
     ap-id 0 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
      radio 1
       channel 20mhz 149
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
    #
    return
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 117676

Downloads: 309

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next