No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Terminal Location

Example for Configuring Terminal Location

Networking Requirements

In Figure 21-3, the Central AP directly connects to the RUs on an enterprise network.

The administrator requires that the RUs collect Wi-Fi terminal information and report the information to the location server to compute terminal locations so that users can obtain the locations of the Wi-Fi terminals through maps, tables, or reports.

Figure 21-3  Configuring basic WLAN location services

Data preparation

Item

Data

Management VLAN for RUs

VLAN100

Service VLAN for STAs

VLAN101

DHCP server

The Central AP functions as the DHCP server for STAs and APs.

IP address pool for RUs

10.23.100.3-10.23.100.254/24

IP address pool for STAs

10.23.101.2-10.23.101.254/24

AP group

  • Name: ap-group1

  • Referenced profile: regulatory domain profile domain1, VAP profile wlan-vap, 2G radio profile wlan-radio-2g, 5G radio profile wlan-radio-5g, and location profile wlan-location

Regulatory domain profile

  • Name: domain1
  • Country code: CN

SSID profile

  • Name: wlan-ssid

  • SSID name: wlan-net

Security profile

  • Name: wlan-security

  • Security policy: WPA2+PSK+AES

  • Password: a1234567

VAP profile

  • Name: wlan-vap

  • Service VLAN: VLAN101

  • Referenced profile: SSID profile wlan-ssid and security profile wlan-security

Air scan profile

  • Name: wlan-air-scan

  • Probe channel set: channels supported by the country code

2G radio profile

  • Name: wlan-radio-2g

  • Referenced profile: air scan profile wlan-air-scan

5G radio profile

  • Name: wlan-radio-5g

  • Referenced profile: air scan profile wlan-air-scan

Location profile

  • Name: wlan-location

  • Destination IP address/Port number used by the AP to report channel scan information: 10.23.100.2/32180

Configuration Roadmap

The configuration roadmap is as follows:

  • Configure basic WLAN services so that users can connect to the internal network through the WLAN.
  • Configure terminal location so that RUs can periodically scan channels to collect radio signals and report the collected information to the location server.

Configuration Notes

Configure port isolation on the interfaces of the device directly connected to RUs. If port isolation is not configured, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

Procedure

  1. Configure the location server (details are not provided here).
  2. Configure the central AP so that RUs and the central AP can transmit CAPWAP packets.

    # Add interfaces GigabitEthernet0/0/1, GigabitEthernet0/0/2, and GigabitEthernet0/0/3 that connect the central AP to the APs respectively to VLAN 100 (management VLAN).

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan batch 100 101
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [AP-GigabitEthernet0/0/1] quit
    [AP] interface gigabitethernet 0/0/2
    [AP-GigabitEthernet0/0/2] port link-type trunk
    [AP-GigabitEthernet0/0/2] port trunk pvid vlan 100
    [AP-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [AP-GigabitEthernet0/0/2] quit
    [AP] interface gigabitethernet 0/0/3
    [AP-GigabitEthernet0/0/3] port link-type trunk
    [AP-GigabitEthernet0/0/3] port trunk pvid vlan 100
    [AP-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 101
    [AP-GigabitEthernet0/0/3] quit
    

  3. Configure the central AP to communicate with the location server.

    # Add GE0/0/24 that connects the central AP and the location server to VLAN 100.

    [AP] interface gigabitethernet 0/0/24
    [AP-GigabitEthernet0/0/24] port link-type trunk
    [AP-GigabitEthernet0/0/24] port trunk pvid vlan 100
    [AP-GigabitEthernet0/0/24] port trunk allow-pass vlan 100 101
    [AP-GigabitEthernet0/0/24] quit
    

  4. Configure the central AP as a DHCP server to allocate IP addresses to STAs and the RU.

    # Configure the central AP as the DHCP server to allocate an IP address to the RU from the IP address pool on VLANIF 100, and allocate IP addresses to STAs from the IP address pool on VLANIF 101.

    [AP] dhcp enable
    [AP] interface vlanif 100
    [AP-Vlanif100] ip address 10.23.100.1 24
    [AP-Vlanif100] dhcp select interface
    [AP-Vlanif100] quit
    [AP] interface vlanif 101
    [AP-Vlanif101] ip address 10.23.101.1 24
    [AP-Vlanif101] dhcp select interface
    [AP-Vlanif101] quit
    

  5. Configure the RU to go online.

    # Create an AP group and add the RU to the AP group.
    [AP] wlan
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] quit
    
    # Create a regulatory domain profile, configure the central AP country code in the profile, and apply the profile to the AP group.
    [AP-wlan-view] regulatory-domain-profile name domain1
    [AP-wlan-regulatory-domain-prof-domain1] country-code cn
    [AP-wlan-regulatory-domain-prof-domain1] quit
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AP-wlan-ap-group-ap-group1] quit
    [AP-wlan-view] quit
    
    # Configure the central AP's management VLAN.
    [AP] management-vlan 100
    
    # Import the RU offline on the central AP and add the RU to AP group ap-group1. Configure a name for the RU based on the RU's deployment location, so that you can know where the RU is deployed from its name. For example, name the RU area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the R240D is used and has two radios: radio 0 and radio 1.

    [AP] wlan
    [AP-wlan-view] ap auth-mode mac-auth
    [AP-wlan-view] ap-id 1 ap-mac fcb6-9897-c520
    [AP-wlan-ap-1] ap-name area_1
    [AP-wlan-ap-1] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AP-wlan-ap-1] quit
    [AP-wlan-view] ap-id 2 ap-mac fcb6-9897-c9c0
    [AP-wlan-ap-2] ap-name area_2
    [AP-wlan-ap-2] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AP-wlan-ap-2] quit
    [AP-wlan-view] ap-id 3 ap-mac fcb6-9897-ca40
    [AP-wlan-ap-3] ap-name area_3
    [AP-wlan-ap-3] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AP-wlan-ap-3] quit
    # After the RU is powered on, run the display ap all command to check the RU state. If the State field is displayed as nor, the RU goes online normally.
    [AP-wlan-view] display ap all
    Total AP information:
    nor  : normal          [3]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    1    fcb6-9897-c520 area_1 ap-group1 10.23.100.254 R240D           nor   0   25S
    2    fcb6-9897-c9c0 area_2 ap-group1 10.23.100.253 R240D           nor   0   20S
    3    fcb6-9897-ca40 area_3 ap-group1 10.23.100.252 R240D           nor   0   10S
    -------------------------------------------------------------------------------------
    Total: 3

  6. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AP-wlan-view] security-profile name wlan-security
    [AP-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AP-wlan-sec-prof-wlan-security] quit
    
    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.
    [AP-wlan-view] ssid-profile name wlan-ssid
    [AP-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-ssid-prof-wlan-ssid] quit
    
    # Create VAP profile wlan-vap, set the service VLAN, and apply the security profile and SSID profile to the VAP profile.
    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AP-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AP-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AP-wlan-vap-prof-wlan-vap] quit
    
    # Bind VAP profile wlan-vap to the AP group and apply the profile to radio 0 and radio 1 of the RU.
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 0
    [AP-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 1
    [AP-wlan-ap-group-ap-group1] quit
    

  7. Configure the WLAN air scan function.

    # Create an air scan profile named wlan-air-scan and configure an air scan channel set.
    [AP-wlan-view] air-scan-profile name wlan-air-scan
    [AP-wlan-air-scan-prof-wlan-air-scan] scan-channel-set country-channel
    [AP-wlan-air-scan-prof-wlan-air-scan] quit
    
    # Create a 2G radio profile named wlan-radio-2g and bind the air scan profile wlan-air-scan to the 2G radio profile.
    [AP-wlan-view] radio-2g-profile name wlan-radio-2g
    [AP-wlan-radio-2g-prof-wlan-radio-2g] air-scan-profile wlan-air-scan
    [AP-wlan-radio-2g-prof-wlan-radio-2g] quit
    # Create a 5G radio profile named wlan-radio-5g and bind the air scan profile wlan-air-scan to the 5G radio profile.
    [AP-wlan-view] radio-5g-profile name wlan-radio-5g
    [AP-wlan-radio-5g-prof-wlan-radio-5g] air-scan-profile wlan-air-scan
    [AP-wlan-radio-5g-prof-wlan-radio-5g] quit
    # Configure an AP group and bind the radio profile to the AP group.
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] radio-2g-profile wlan-radio-2g radio 0
    [AP-wlan-ap-group-ap-group1] radio-5g-profile wlan-radio-5g radio 1
    [AP-wlan-ap-group-ap-group1] quit

  8. Configure the terminal location function.

    # Create a location profile named wlan-location. Enable the terminal location function. Configure the target and port number to report location information.
    [AP-wlan-view] location-profile name wlan-location
    [AP-wlan-location-prof-wlan-location] private mu-enable
    [AP-wlan-location-prof-wlan-location] private server ip-address 10.23.100.2 port 32180
    [AP-wlan-location-prof-wlan-location] quit
    # Configure an AP group and bind the location profile to the AP group.
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] location-profile wlan-location radio all
    [AP-wlan-ap-group-ap-group1] quit

  9. Verify the configuration.

    The central AP automatically delivers WLAN service configuration to the RU. After the service configuration is complete, run the display vap ssid wlan-net command. If Status in the command output is displayed as ON, the VAPs have been successfully created on RU radios.

    [AP-wlan-view] display vap ssid wlan-net
    WID : WLAN ID
    ------------------------------------------------------------------------------------
    AP ID AP name        RfID WID  BSSID          Status  Auth type     STA   SSID     
    ------------------------------------------------------------------------------------
    1     area_1         0    1    FCB6-9897-C520 ON      WPA2-PSK      1     wlan-net
    1     area_1         1    1    FCB6-9897-C530 ON      WPA2-PSK      0     wlan-net
    2     area_2         0    1    FCB6-9897-C9C0 ON      WPA2-PSK      0     wlan-net
    2     area_2         1    1    FCB6-9897-C9D0 ON      WPA2-PSK      0     wlan-net
    3     area_3         0    1    FCB6-9897-CA40 ON      WPA2-PSK      0     wlan-net
    4     area_3         1    1    FCB6-9897-CA50 ON      WPA2-PSK      0     wlan-net
    ------------------------------------------------------------------------------------
    Total: 6

Configuration File

  • Central AP configuration file

    #
     sysname AP
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 101
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 101
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 101
    #
    interface GigabitEthernet0/0/24
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 101
    #
    management-vlan 100
    #
    wlan
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#_b"h2cpaO$9bZ-;`-_;CN5)k,_\UP3[!AJE6Vtg3%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
     location-profile name wlan-location
      private mu-enable
      private server ip-address 10.23.100.2 port 32180
     regulatory-domain-profile name domain1
     air-scan-profile name wlan-air-scan
     radio-2g-profile name wlan-radio-2g
      air-scan-profile wlan-air-scan
     radio-5g-profile name wlan-radio-5g
      air-scan-profile wlan-air-scan
     ap-group name ap-group1
      regulatory-domain-profile domain1
      location-profile wlan-location radio all
      radio 0
       radio-2g-profile wlan-radio-2g
       vap-profile wlan-vap wlan 1
      radio 1
       radio-5g-profile wlan-radio-5g
       vap-profile wlan-vap wlan 1
     ap-id 1 type-id 55 ap-mac fcb6-9897-c520 ap-sn 21500826402SF4900166
      ap-name area_1
      ap-group ap-group1
     ap-id 2 type-id 55 ap-mac fcb6-9897-c9c0 ap-sn 21500826402SF4900203
      ap-name area_2
      ap-group ap-group1
     ap-id 3 type-id 55 ap-mac fcb6-9897-ca40 ap-sn 21500826402SF4900207
      ap-name area_3
      ap-group ap-group1
    #
    return
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 115742

Downloads: 309

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next