No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

Example for Configuring Multicast CAC Based on Multicast Bandwidth

Networking Requirements

As shown in Figure 7-109, enterprise users can access the Internet through the WLAN to meet the basic requirement of mobile office.

Video conference multicast sources are deployed on the WLAN to specially provide video conference services. The multicast source IP address ranges from 225.1.1.1 to 225.1.1.5. The administrator wants to configure multicast connection admission control (CAC) based on multicast bandwidth to deny access of employees when the multicast bandwidth reaches the upper limit, ensuring access quality of video conferences.

Figure 7-109  Networking for configuring multicast CAC based on multicast bandwidth
Configuration Roadmap
  1. Configure basic WLAN services to ensure that users can access the WLAN.

  2. Configure the multicast-to-unicast function to convert multicast data packets to unicast data packets, improving multicast data transmission efficiency.

  3. Configure multicast CAC based on the multicast bandwidth to control access of multicast users.

Table 7-63  Data planning

Item

Data

DHCP server

The AP functions as a DHCP server to assign IP addresses to STAs.

IP address pool for STAs 10.23.101.2-10.23.101.254/24
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-vap
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-ssid, security profile wlan-security, and traffic profile wlan-traffic
Traffic profile
  • Name: wlan-traffic
  • Maximum multicast bandwidth of a VAP: 40 Mbit/s (40,960 kbit/s)
IP address segment of multicast groups

225.1.1.1-225.1.1.5

Bandwidth of multicast groups

2 Mbit/s (2048 kbit/s)

Configuration Notes

No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression on switch interfaces connected to APs to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected. For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.

Procedure

  1. Configure the AP to communicate with the upstream device.

    NOTE:

    Configure AP uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add AP uplink interface GE0/0/1 to VLAN 101.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan batch 101
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 101
    [AP-GigabitEthernet0/0/1] quit
    

  2. Configure the AP as a DHCP server to allocate IP addresses to STAs.

    # Configure the AP as the DHCP server to allocate an IP address to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AP] dhcp enable
    [AP] interface vlanif 101
    [AP-Vlanif101] ip address 10.23.101.1 24
    [AP-Vlanif101] dhcp select interface
    [AP-Vlanif101] quit
    

  3. Configure AP system parameters.

    # Configure the country code.

    [AP] wlan
    [AP-wlan-view] country-code cn
    

  4. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AP-wlan-view] security-profile name wlan-security
    [AP-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AP-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AP-wlan-view] ssid-profile name wlan-ssid
    [AP-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AP-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profile wlan-vap, set the service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AP-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AP-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AP-wlan-vap-prof-wlan-vap] quit
    

  5. Configure a VAP and set channels and power for the AP radios.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The channel and power configuration for the AP radios in this example is for reference only. In actual scenarios, configure channels and power for AP radios based on country codes of APs and network planning results.

    # Disable automatic channel and power calibration functions of the radio, and configure the channel and power for the radio.
    [AP-wlan-view] quit
    [AP] interface wlan-radio0/0/0
    [AP-Wlan-Radio0/0/0] vap-profile wlan-vap wlan 2
    [AP-Wlan-Radio0/0/0] calibrate auto-channel-select disable
    [AP-Wlan-Radio0/0/0] calibrate auto-txpower-select disable
    [AP-Wlan-Radio0/0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-Wlan-Radio0/0/0] eirp 127
    [AP-Wlan-Radio0/0/0] quit
    

  6. Configure the multicast-to-unicast function.

    # Create traffic profile wlan-traffic, and enable the Internet Group Management Protocol (IGMP) snooping and multicast-to-unicast functions in the traffic profile.
    [AP] wlan
    [AP-wlan-view] traffic-profile name wlan-traffic
    [AP-wlan-traffic-prof-wlan-traffic] igmp-snooping enable
    [AP-wlan-traffic-prof-wlan-traffic] traffic-optimize multicast-unicast enable
    

  7. Configure broadcast CAC based on broadcast bandwidth.

    # Configure the maximum multicast bandwidth to 40960 kbit/s for a VAP.

    [AP-wlan-traffic-prof-wlan-traffic] igmp-snooping max-bandwidth 40960
    [AP-wlan-traffic-prof-wlan-traffic] quit
    

    # Bind traffic profile wlan-traffic to VAP profile wlan-vap.

    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] traffic-profile wlan-traffic
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-vap-prof-wlan-vap] quit
    [AP-wlan-view] quit
    

    # Configure the range of multicast group IP addresses to 225.1.1.1 to 225.1.1.5, and bandwidth of multicast groups to 2048 kbit/s.

    [AP] igmp-snooping group-bandwidth start-group-address 225.1.1.1 end-group-address 225.1.1.5 bandwidth 2048
    

  8. Verify the configuration.

    Run the display wlan igmp-snooping vap-cac command on the AP to check the multicast CAC configuration and statistics on the VAP. When the difference between the CurBw and MaxBw values is smaller than the configured bandwidth of a multicast group, new users cannot join the multicast group.

    [AP] display wlan igmp-snooping vap-cac ap-id 0
    Info: This operation may take a few seconds, please wait.done.
    Rf            : Radio ID                  WID             : WLAN ID
    CurBw         : Current bandwidth(kbps)   MaxBw           : Max bandwidth(kbps)
    CurUser       : Current user number       MaxUser         : Max user number
    BwUtilization : Bandwidth utilization     UserUtilization : User utilization
    --------------------------------------------------------------------------------
    Rf  WID  CurBw/MaxBw        BwUtilization  CurUser/MaxUser  UserUtilization
    --------------------------------------------------------------------------------
    0   1    0/40960            0%             0/0              0%
    --------------------------------------------------------------------------------
    Total: 1

Configuration Files
  • AP configuration file

    #
     sysname AP
    #
    igmp-snooping group-bandwidth start-group-address 225.1.1.1 end-group-address 225.1.1.5 bandwidth 2048
    #
    vlan batch 101
    #
    dhcp enable
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    wlan
     traffic-profile name wlan-traffic 
      igmp-snooping enable
      igmp-snooping max-bandwidth 40960
      traffic-optimize multicast-unicast enable
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
      traffic-profile wlan-traffic
    #
    interface Wlan-Radio0/0/0
     vap-profile wlan-vap wlan 2
     channel 20mhz 6
     calibrate auto-channel-select disable
     calibrate auto-txpower-select disable
    #
    return

Example for Configuring Multicast CAC Based on the Number of Multicast Group Memberships

Networking Requirements

As shown in Figure 7-110, enterprise users can access the Internet through the WLAN to meet the basic requirement of mobile office.

Video conference multicast sources are deployed on the WLAN to specially provide video conference services. The multicast source IP address ranges from 225.1.1.1 to 225.1.1.5. The administrator wants to configure multicast connection admission control (CAC) based on the number of multicast group memberships to deny access of employees when the number of multicast group memberships reaches the upper limit, ensuring access quality of video conferences.

Figure 7-110  Networking for configuring multicast CAC based on the number of multicast group memberships
Configuration Roadmap
  1. Configure basic WLAN services to ensure that users can access the WLAN.

  2. Configure the multicast-to-unicast function to convert multicast data packets to unicast data packets, improving multicast data transmission efficiency.

  3. Configure multicast CAC based on the number of multicast group memberships to control access of multicast users.

Table 7-64  Data planning

Item

Data

DHCP server

The AP functions as a DHCP server to assign IP addresses to STAs.

IP address pool for STAs 10.23.101.2-10.23.101.254/24
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-vap
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-ssid, security profile wlan-security, and traffic profile wlan-traffic
Traffic profile
  • Name: wlan-traffic
  • Maximum number of multicast group memberships on a VAP: 20
Configuration Notes

No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression on switch interfaces connected to APs to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected. For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.

Procedure

  1. Configure the AP to communicate with the upstream device.

    NOTE:

    Configure AP uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add AP uplink interface GE0/0/1 to VLAN 101.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan batch 101
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 101
    [AP-GigabitEthernet0/0/1] quit
    

  2. Configure the AP as a DHCP server to allocate IP addresses to STAs.

    # Configure the AP as the DHCP server to allocate an IP address to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AP] dhcp enable
    [AP] interface vlanif 101
    [AP-Vlanif101] ip address 10.23.101.1 24
    [AP-Vlanif101] dhcp select interface
    [AP-Vlanif101] quit
    

  3. Configure AP system parameters.

    # Configure the country code.

    [AP] wlan
    [AP-wlan-view] country-code cn
    

  4. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AP-wlan-view] security-profile name wlan-security
    [AP-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AP-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AP-wlan-view] ssid-profile name wlan-ssid
    [AP-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AP-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profile wlan-vap, set the service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AP-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AP-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AP-wlan-vap-prof-wlan-vap] quit
    

  5. Configure a VAP and set channels and power for the AP radios.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The channel and power configuration for the AP radios in this example is for reference only. In actual scenarios, configure channels and power for AP radios based on country codes of APs and network planning results.

    # Disable automatic channel and power calibration functions of the radio, and configure the channel and power for the radio.
    [AP-wlan-view] quit
    [AP] interface wlan-radio0/0/0
    [AP-Wlan-Radio0/0/0] vap-profile wlan-vap wlan 2
    [AP-Wlan-Radio0/0/0] calibrate auto-channel-select disable
    [AP-Wlan-Radio0/0/0] calibrate auto-txpower-select disable
    [AP-Wlan-Radio0/0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-Wlan-Radio0/0/0] eirp 127
    [AP-Wlan-Radio0/0/0] quit
    

  6. Configure the multicast-to-unicast function.

    # Create traffic profile wlan-traffic, and enable the Internet Group Management Protocol (IGMP) snooping and multicast-to-unicast functions in the traffic profile.
    [AP] wlan
    [AP-wlan-view] traffic-profile name wlan-traffic
    [AP-wlan-traffic-prof-wlan-traffic] igmp-snooping enable
    [AP-wlan-traffic-prof-wlan-traffic] traffic-optimize multicast-unicast enable
    

  7. Configure multicast CAC based on the number of multicast group memberships.

    # Configure the maximum number of multicast group memberships to 20 for a VAP.
    [AP-wlan-traffic-prof-wlan-traffic] igmp-snooping max-user 20
    [AP-wlan-traffic-prof-wlan-traffic] quit
    

    # Bind traffic profile wlan-traffic to VAP profile wlan-vap.

    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] traffic-profile wlan-traffic
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-vap-prof-wlan-vap] quit
    

  8. Verify the configuration.

    Run the display wlan igmp-snooping vap-cac command on the AP to check the multicast CAC configuration and statistics on the VAP. When the CurUser value is equal to the MaxUser value, new users cannot join the multicast group.

    [AP-wlan-view] display wlan igmp-snooping vap-cac ap-id 0
    Info: This operation may take a few seconds, please wait.done.
    Rf            : Radio ID                  WID             : WLAN ID
    CurBw         : Current bandwidth(kbps)   MaxBw           : Max bandwidth(kbps)
    CurUser       : Current user number       MaxUser         : Max user number
    BwUtilization : Bandwidth utilization     UserUtilization : User utilization
    --------------------------------------------------------------------------------
    Rf  WID  CurBw/MaxBw        BwUtilization  CurUser/MaxUser  UserUtilization
    --------------------------------------------------------------------------------
    0   1    0/0                0%             0/20             0%
    --------------------------------------------------------------------------------
    Total: 1

Configuration Files
  • AP configuration file

    #
     sysname AP
    #
    vlan batch 101
    #
    dhcp enable
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    wlan
     traffic-profile name wlan-traffic 
      igmp-snooping enable
      igmp-snooping max-user 20
      traffic-optimize multicast-unicast enable
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
      traffic-profile wlan-traffic
    #
    interface Wlan-Radio0/0/0
     vap-profile wlan-vap wlan 2
     channel 20mhz 6
     calibrate auto-channel-select disable
     calibrate auto-txpower-select disable
    #
    return
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 114403

Downloads: 309

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next