No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples for WLAN Security Policies

Configuration Examples for WLAN Security Policies

Example for Configuring a WPA2-802.1X-AES Security Policy

Networking Requirements

As shown in Figure 25-11, the enterprise's AP connects to the egress gateway (Router) and RADIUS server. The WLAN with the SSID of wlan-net is available for employees to access network resources. The gateway also functions as a DHCP server to provide IP addresses on the 10.23.101.0/24 network segment for STAs. The AP controls and manages STAs.

Because the WLAN is open to users, there are potential security risks to enterprise information if no security policy is configured for the WLAN. The enterprise requires high information security, so a WPA2 security policy using 802.1X authentication and AES encryption can be configured. The RADIUS server authenticates STA identities. The AP must be configured to function as an EAP relay, so the AP supports 802.1X authentication.

Figure 25-11  Networking diagram for configuring 802.1X authentication
Configuration Roadmap
  1. Configure the AP and upper-layer devices to communicate with each other.
  2. Configure the Router to assign IP addresses to STAs.
  3. Configure RADIUS authentication parameters.
  4. Configure an 802.1X access profile to manage 802.1X access control parameters.
  5. Configure an authentication profile, and apply the 802.1X access profile, authentication scheme, and RADIUS server template to the authentication profile.
  6. Configure WLAN service parameters, set the security policy to WPA2-802.1X-AES, and bind the security profile and authentication profile to the VAP profile to control access from STAs.
  7. Bound the VAP profile to the radio.
NOTE:

Ensure that the RADIUS server IP address, port number, and shared key are correct and consistent with the RADIUS server. When the AP functions as an EAP relay, ensure that the RADIUS server supports the EAP protocol. Otherwise, the RADIUS server cannot process 802.1X authentication requests.

Table 25-3  Data planning

Item

Data

Service VLAN

VLAN101

DHCP server

  • IP addresses that Router assigns to STAs: 10.23.101.2-10.23.101.254/24

  • IP address of DNS server: 8.8.8.8

Gateway for STAs

VLANIF101: 10.23.101.1/24

RADIUS authentication parameters

  • Name of a RADIUS server template: radius_huawei
  • IP address: 10.23.103.1
  • Authentication port number: 1812
  • Shared key: huawei@123
  • Authentication scheme: radius_huawei

User name and password of STAs

  • User name: test
  • Password: 123456

802.1X access profile

  • Name: wlan-dot1x
  • Authentication mode: EAP

Authentication profile

  • Name: wlan-authentication
  • Referenced profile, authentication scheme, and template: 802.1X access profile wlan-dot1x, authentication scheme radius_huawei, and RADIUS server template radius_huawei
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2-802.1X-AES
VAP profile
  • Name: wlan-net
  • Service VLAN: VLAN 101
  • Referenced profile: SSID profile wlan-ssid, security profile wlan-security, and authentication profile wlan-authentication
Configuration Notes

No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression on switch interfaces connected to APs to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected. For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.

Procedure

  1. Configure SwitchA and the AP can communicate with the upstream device.

    # Add GE0/0/1 that connects SwitchA to the AP to VLAN 101, VLAN 102, and VLAN 103. Add GE0/0/2 that connects SwitchA to the router to VLAN 102. Add GE0/0/3 that connects SwitchA to the RADIUS server to VLAN 103.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 101 102 103
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 101 102 103
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 102
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type trunk
    [SwitchA-GigabitEthernet0/0/3] port trunk pvid vlan 103
    [SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 103
    [SwitchA-GigabitEthernet0/0/3] quit
    

  2. Configure the AP to communicate with the upstream device.

    # Configure VLANIF 101 (service VLAN), VLANIF 102, and VLANIF 103.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan batch 101 102 103
    [AP] interface vlanif 101
    [AP-Vlanif101] ip address 10.23.101.1 24
    [AP-Vlanif101] quit
    [AP] interface vlanif 102
    [AP-Vlanif102] ip address 10.23.102.2 24
    [AP-Vlanif102] quit
    [AP] interface vlanif 103
    [AP-Vlanif103] ip address 10.23.103.2 24
    [AP-Vlanif103] quit
    

    # Add GE0/0/1 that connects the AP to the SwitchA to VLAN 101, VLAN 102, and VLAN 103.

    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 101 102 103
    [AP-GigabitEthernet0/0/1] quit

    # On the AP, configure a static route.

    [AP] ip route-static 0.0.0.0 0.0.0.0 10.23.102.1

  3. Configure the Router to assign IP addresses to STAs.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.

    # Configure the AP as a DHCP relay agent, enable user entry detection on the AP, and specify the DHCP server IP address on the DHCP relay agent.

    [AP] dhcp enable
    [AP] dhcp relay detect enable
    [AP] interface vlanif 101
    [AP-Vlanif101] dhcp select relay
    [AP-Vlanif101] dhcp relay server-ip 10.23.102.1
    [AP-Vlanif101] quit

    # Configure the Router as a DHCP server to assign IP addresses to STAs from a global address pool. The egress gateway address of the DHCP client is 10.23.101.1, and the network segment of the global address pool is 10.23.101.0/24.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] dhcp enable
    [Router] ip pool sta
    [Router-ip-pool-sta] gateway-list 10.23.101.1
    [Router-ip-pool-sta] dns-list 8.8.8.8
    [Router-ip-pool-sta] network 10.23.101.0 mask 24
    [Router-ip-pool-sta] quit
    [Router] vlan batch 102
    [Router] interface vlanif 102
    [Router-Vlanif102] ip address 10.23.102.1 24
    [Router-Vlanif102] dhcp select global
    [Router-Vlanif102] quit
    [Router] interface gigabitethernet 2/0/0
    [Router-GigabitEthernet2/0/0] port link-type trunk
    [Router-GigabitEthernet2/0/0] port trunk allow-pass vlan 102
    [Router-GigabitEthernet2/0/0] quit
    [Router] ip route-static 10.23.101.0 24 10.23.102.2
    

  4. Configure RADIUS authentication parameters.

    NOTE:
    Configure the same shared key for the AP and RADIUS server.

    # Create a RADIUS server template.

    [AP] radius-server template radius_huawei
    [AP-radius-radius_huawei] radius-server authentication 10.23.103.1 1812
    [AP-radius-radius_huawei] radius-server shared-key cipher huawei@123
    [AP-radius-radius_huawei] quit
    

    # Configure a RADIUS authentication scheme.

    [AP] aaa
    [AP-aaa] authentication-scheme radius_huawei
    [AP-aaa-authen-radius_huawei] authentication-mode radius
    [AP-aaa-authen-radius_huawei] quit
    [AP-aaa] quit
    

    # Test whether a STA can be authenticated using RADIUS authentication. A user name test and password 123456 have been configured on the RADIUS server.

    [AP] test-aaa test 123456 radius-template radius_huawei
    Info: Account test succeed.
    

  5. Configure an 802.1X access profile to manage 802.1X access control parameters.

    # Create the 802.1X access profile wlan-dot1x.

    [AP] dot1x-access-profile name wlan-dot1x
    

    # Set the authentication mode to EAP relay.

    [AP-dot1x-access-profile-wlan-dot1x] dot1x authentication-method eap
    [AP-dot1x-access-profile-wlan-dot1x] quit
    

  6. Create the authentication profile wlan-authentication, and apply the 802.1X access profile, authentication scheme, and RADIUS server template to the authentication profile.

    [AP] authentication-profile name wlan-authentication
    [AP-authentication-profile-wlan-authentication] dot1x-access-profile wlan-dot1x
    [AP-authentication-profile-wlan-authentication] authentication-scheme radius_huawei
    [AP-authentication-profile-wlan-authentication] radius-server radius_huawei
    [AP-authentication-profile-wlan-authentication] quit

  7. Configure AP system parameters.

    # Configure the country code.

    [AP] wlan
    [AP-wlan-view] country-code cn
    

  8. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.

    [AP-wlan-view] security-profile name wlan-security
    [AP-wlan-sec-prof-wlan-security] security wpa2 dot1x aes
    [AP-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AP-wlan-view] ssid-profile name wlan-ssid
    [AP-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AP-wlan-ssid-prof-wlan-ssid] quit
    

    # Create the VAP profile wlan-net, set the service VLAN, and apply the security profile, SSID profile, and authentication profile to the VAP profile.

    [AP-wlan-view] vap-profile name wlan-net
    [AP-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
    [AP-wlan-vap-prof-wlan-net] security-profile wlan-security
    [AP-wlan-vap-prof-wlan-net] authentication-profile wlan-authentication
    [AP-wlan-vap-prof-wlan-net] ssid-profile wlan-ssid
    [AP-wlan-vap-prof-wlan-net] quit
    [AP-wlan-view] quit
    

  9. Bound the VAP profile to the radio.

    [AP] interface wlan-radio 0/0/0
    [AP-Wlan-Radio0/0/0] vap-profile wlan-net wlan 1
    [AP-Wlan-Radio0/0/0] quit
    

  10. Configure radio parameters for the VAP and AP.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The settings of the AP channel and power in this example are for reference only. You need to configure the AP channel and power based on the actual country code and network planning.

    # Disable automatic channel and power calibration functions of the radio, and configure the channel and power for the radio.
    [AP-wlan-view] quit
    [AP] interface wlan-radio0/0/0
    [AP-Wlan-Radio0/0/0] vap-profile wlan-net wlan 2
    [AP-Wlan-Radio0/0/0] calibrate auto-channel-select disable
    [AP-Wlan-Radio0/0/0] calibrate auto-txpower-select disable
    [AP-Wlan-Radio0/0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-Wlan-Radio0/0/0] eirp 127
    [AP-Wlan-Radio0/0/0] quit
    [AP] interface wlan-radio0/0/1
    [AP-Wlan-Radio0/0/1] vap-profile wlan-net wlan 2
    [AP-Wlan-Radio0/0/1] calibrate auto-channel-select disable
    [AP-Wlan-Radio0/0/1] calibrate auto-txpower-select disable
    [AP-Wlan-Radio0/0/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-Wlan-Radio0/0/1] eirp 127
    [AP-Wlan-Radio0/0/1] quit
    

  11. Verify the configuration.

    • The WLAN with SSID wlan-net is available for STAs connected to the AP.
    • The wireless PC obtains an IP address after it associates with the WLAN.
    • Use the 802.1X authentication client on a STA and enter the correct user name and password. The STA is authenticated and can access the WLAN. You must configure the client for PEAP authentication.
      • Configuration on the Windows XP operating system:

        1. On the Association tab page of the Wireless network properties dialog box, add SSID wlan-net, set the authentication mode to WPA2, and encryption algorithm to AES.
        2. On the Authentication tab page, set EAP type to PEAP and click Properties. In the Protected EAP Properties dialog box, deselect Validate server certificate and click Configure. In the displayed dialog box, deselect Automatically use my Windows logon name and password and click OK.
      • Configuration on the Windows 7 operating system:

        1. Access the Manage wireless networks page, click Add, and select Manually create a network profile. Add SSID wlan-net. Set the authentication mode to WPA2-Enterprise, and encryption algorithm to AES. Click Next.
        2. Click Change connection settings. On the Wireless Network Properties page that is displayed, select the Security tab page and click Settings. On the Protected EAP Properties page, deselect Validate server certificate and click Configure. On the dialog box that is displayed, deselect Automatically use my Windows logon name and password and click OK.
        3. On the Wireless Network Properties page, click Advanced settings. On the Advanced settings page that is displayed, select Specify authentication mode, set the identity authentication mode to User authentication, and click OK.

Configuration Files
  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 101 to 103
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 101 to 103
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk pvid vlan 103
     port trunk allow-pass vlan 103
    #
    return
  • Router configuration file

    #
    sysname Router
    #
    vlan batch 102
    #
    dhcp enable
    #
    ip pool sta
     gateway-list 10.23.101.1
     network 10.23.101.0 mask 255.255.255.0
     dns-list 8.8.8.8
    #
    interface Vlanif102
     ip address 10.23.102.1 255.255.255.0
     dhcp select global
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    ip route-static 10.23.101.0 255.255.255.0 10.23.102.2
    #
    return
    
  • AP configuration file

    #
     sysname AP
    #
    vlan batch 101 to 103
    #
    authentication-profile name wlan-authentication
     dot1x-access-profile wlan-dot1x
     authentication-scheme radius_huawei
     radius-server radius_huawei
    #
    dot1x-access-profile name wlan-dot1x
    #
    dhcp enable
    #
    dhcp relay detect enable
    #
    radius-server template radius_huawei
     radius-server shared-key cipher %^%#*7d1;XNof/|Q0:DsP!,W51DIYPx}`AARBdJ'0B^$%^%#
     radius-server authentication 10.23.103.1 1812 weight 80
    #
    aaa
     authentication-scheme radius_huawei
      authentication-mode radius
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.23.102.1
    #
    interface Vlanif102
     ip address 10.23.102.2 255.255.255.0
    #
    interface Vlanif103
     ip address 10.23.103.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 101 to 103
    #
    ip route-static 0.0.0.0 0.0.0.0 10.23.102.1
    #
    wlan
     security-profile name wlan-security
      security wpa2 dot1x aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
      authentication-profile wlan-authentication
    #
    interface Wlan-Radio0/0/0
     vap-profile wlan-net wlan 2
     channel 20mhz 6
     calibrate auto-channel-select disable
     calibrate auto-txpower-select disable
    #
    return
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 130333

Downloads: 312

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next