No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Attack Detection

Example for Configuring Attack Detection

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile,and WIDS profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. After that, the configuration is automatically delivered to and takes effect on the RUs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Networking Requirements

As shown in Figure 20-8, the central AP directly connects to the RU. The enterprise branch has deployed WLAN services for mobile office applications. To protect the network against flood attacks and PSK cracking, configure the attack detection and dynamic blacklist functions and add the attacking devices to the blacklist. Packets from the attacking devices are discarded to ensure network stability and security.

Figure 20-8  Networking diagram for configuring attack detection

Configuration Roadmap

  1. Configure basic WLAN services to enable STAs to connect to the WLAN.
  2. Configure detection of brute force key cracking attacks for WPA2-PSK authentication and detection of flood attacks so that the device can detect information about the attacking devices.
  3. Configure the dynamic blacklist function and add devices that initiate attacks to the dynamic blacklist so that packets from the devices are discarded during the configured aging time.
NOTE:

The following example configures attack detection on the 2.4G radio. The configuration on the 5G radio is similar.

Table 20-3  Data planning

Item

Data

DHCP server The central AP functions as a DHCP server to assign IP addresses to the STAs and RU.
IP address pool for the RU 10.23.100.2-10.23.100.254/24
IP address pool for STAs 10.23.101.2-10.23.101.254/24
AP group
  • Name: ap-group1
  • Referenced profile: VAP profile wlan-vap, regulatory domain profile domain1, and WIDS profile wlan-wids
  • Attack detection mode on radio 0 in an AP group: detection of brute force key cracking attacks for WPA2-PSK authentication and detection of flood attacks
Regulatory domain profile
  • Name: domain1
  • Country code: CN
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2-PSK-AES
  • Password: a1234567
VAP profile
  • Name: wlan-vap
  • Service VLAN: VLAN 101
  • Referenced profile: SSID profile wlan-ssid and security profile wlan-security
WIDS profile
  • Name: wlan-wids
  • Interval for brute force PSK cracking attack detection: 70s
  • Quiet time for brute force PSK cracking attack detection: 700s
  • Maximum number of key negotiation failures allowed within a brute force PSK cracking attack detection period: 25
  • Flood attack detection interval: 70s
  • Quiet time for flood attack detection: 700s
  • Flood attack detection threshold: 350
  • Dynamic blacklist: enabled
AP system profile
  • Name: wlan-system
  • Aging time of a dynamic blacklist: 200s

Configuration Notes

Configure port isolation on the interfaces of the device directly connected to RUs. If port isolation is not configured, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

Procedure

  1. Configure the central AP so that the RU and central AP can transmit CAPWAP packets.

    # Configure the central AP: add interface GE0/0/1 to management VLAN 100.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan batch 100 101
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AP-GigabitEthernet0/0/1] quit
    

  2. Configure the central AP to communicate with the upstream device.

    NOTE:

    Configure central AP uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add central AP uplink interface GE0/0/24 to service VLAN 101.

    [AP] interface gigabitethernet 0/0/24
    [AP-GigabitEthernet0/0/24] port link-type trunk
    [AP-GigabitEthernet0/0/24] port trunk allow-pass vlan 101
    [AP-GigabitEthernet0/0/24] quit
    

  3. Configure the central AP as a DHCP server to allocate IP addresses to STAs and the RU.

    # Configure the central AP as the DHCP server to allocate an IP address to the RU from the IP address pool on VLANIF 100, and allocate IP addresses to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AP] dhcp enable
    [AP] interface vlanif 100
    [AP-Vlanif100] ip address 10.23.100.1 24
    [AP-Vlanif100] dhcp select interface
    [AP-Vlanif100] quit
    [AP] interface vlanif 101
    [AP-Vlanif101] ip address 10.23.101.1 24
    [AP-Vlanif101] dhcp select interface
    [AP-Vlanif101] quit
    

  4. Configure the RU to go online.

    # Create an AP group and add the RU to the AP group.

    [AP] wlan
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the central AP country code in the profile, and apply the profile to the AP group.

    [AP-wlan-view] regulatory-domain-profile name domain1
    [AP-wlan-regulate-domain-domain1] country-code cn
    [AP-wlan-regulate-domain-domain1] quit
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AP-wlan-ap-group-ap-group1] quit
    [AP-wlan-view] quit
    

    # Configure the management VLAN for RUs connected to the central AP.

    [AP] management-vlan 100
    
    # Import the RU offline on the central AP and add the RU to AP group ap-group1. Assume that the RU's MAC address is 60de-4476-e360. Configure a name for the RU based on the RU's deployment location, so that you can know where the RU is deployed from its name. For example, name the RU area_1 if it is deployed in Area 1.
    NOTE:

    The default RU authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the R240D is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AP] wlan
    [AP-wlan-view] ap auth-mode mac-auth
    [AP-wlan-view] ap-id 1 ap-mac 60de-4476-e360
    [AP-wlan-ap-1] ap-name area_1
    [AP-wlan-ap-1] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AP-wlan-ap-1] quit
    

    # After the RU is powered on, run the display ap all command to check the RU state. If the State field is displayed as nor, the RU goes online normally.

    [AP-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    1    60de-4476-e360 area_1 ap-group1 10.23.100.254 R240D           nor   0   10S
    -------------------------------------------------------------------------------------
    Total: 1

  5. Configure attack detection.

    # Enable brute force attack detection for WPA2-PSK authentication and flood attack detection.

    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] radio 0
    [AP-wlan-group-radio-ap-group1/0] wids attack detect enable wpa2-psk
    [AP-wlan-group-radio-ap-group1/0] wids attack detect enable flood
    [AP-wlan-group-radio-ap-group1/0] quit
    [AP-wlan-ap-group-ap-group1] quit
    

    # Create the WIDS profile wlan-wids.

    [AP-wlan-view] wids-profile name wlan-wids
    

    # Set the interval for brute force attack detection to 70 seconds in WPA2-PSK authentication, the maximum number of key negotiation failures allowed within the detection period to 25, and quiet time to 700s.

    [AP-wlan-wids-prof-wlan-wids] brute-force-detect interval 70
    [AP-wlan-wids-prof-wlan-wids] brute-force-detect threshold 25
    [AP-wlan-wids-prof-wlan-wids] brute-force-detect quiet-time 700
    

    # Set the interval for flood attack detection to 70 seconds, flood attack detection threshold to 350, and quiet time to 700s.

    [AP-wlan-wids-prof-wlan-wids] flood-detect interval 70
    [AP-wlan-wids-prof-wlan-wids] flood-detect threshold 350
    [AP-wlan-wids-prof-wlan-wids] flood-detect quiet-time 700
    

    # Enable the dynamic blacklist function.

    [AP-wlan-wids-prof-wlan-wids] dynamic-blacklist enable
    [AP-wlan-wids-prof-wlan-wids] quit
    

    # Create the AP system profile wlan-system and set the aging time of dynamic blacklist to 200s.

    [AP-wlan-view] ap-system-profile name wlan-system
    [AP-wlan-ap-system-prof-wlan-system] dynamic-blacklist aging-time 200
    [AP-wlan-ap-system-prof-wlan-system] quit
    

  6. Configure WLAN service parameters.

    # Create the security profile wlan-security and set the security policy in the profile.

    [AP-wlan-view] security-profile name wlan-security
    [AP-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AP-wlan-sec-prof-wlan-security] quit
    

    # Create the SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AP-wlan-view] ssid-profile name wlan-ssid
    [AP-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AP-wlan-ssid-prof-wlan-ssid] quit
    

    # Create the VAP profile wlan-vap, set the service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AP-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AP-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AP-wlan-vap-prof-wlan-vap] quit
    

    # Bind the VAP profile wlan-vap, WIDS profile wlan-wids, and AP system profile wlan-system to the AP group.

    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 0
    [AP-wlan-ap-group-ap-group1] vap-profile wlan-vap wlan 1 radio 1
    [AP-wlan-ap-group-ap-group1] wids-profile wlan-wids
    [AP-wlan-ap-group-ap-group1] ap-system-profile wlan-system
    [AP-wlan-ap-group-ap-group1] quit
    

  7. Verify the configuration.

    After the configuration is complete, run the display wlan ids attack-detected all command to check the detected attacking devices.

    [AP-wlan-view] display wlan ids attack-detected all
    #AP: Number of monitor APs that have detected the device
    AT: Last detected attack type
    CH: Channel number
    act: Action frame            asr: Association request
    aur: Authentication request  daf: Deauthentication frame
    dar: Disassociation request  wiv: Weak IV detected
    pbr: Probe request           rar: Reassociation request
    eaps: EAPOL start frame      eapl: EAPOL logoff frame
    saf: Spoofed disassociation frame
    sdf: Spoofed deauthentication frame
    otsf: Other types of spoofing frames
    -------------------------------------------------------------------------------
    MAC address     AT     CH   RSSI(dBm)  Last detected time     #AP
    -------------------------------------------------------------------------------
    000b-c002-9c81  pbr    165  -87        2014-11-20/15:51:13    1
    0024-2376-03e9  pbr    165  -84        2014-11-20/15:51:13    1
    0046-4b74-691f  act    165  -67        2014-11-20/15:51:13    1
    -------------------------------------------------------------------------------
    Total: 3, printed: 3

    Run the display wlan dynamic-blacklist all command to check devices on the blacklist.

    [AP-wlan-view] display wlan dynamic-blacklist all
    #AP: Number of monitor APs that have detected the device
    act: Action frame            asr: Association request
    aur: Authentication request  daf: Deauthentication frame
    dar: Disassociation request  eapl: EAPOL logoff frame
    pbr: Probe request           rar: Reassociation request
    eaps: EAPOL start frame
    -------------------------------------------------------------------------------
    MAC address       Last detected time    Reason   #AP
    -------------------------------------------------------------------------------
    000b-c002-9c81    2014-11-20/16:15:53   pbr      1   
    0024-2376-03e9    2014-11-20/16:15:53   pbr      1   
    0046-4b74-691f    2014-11-20/16:15:53   act      1   
    -------------------------------------------------------------------------------
    Total: 3, printed: 3
    

Configuration Files

Central AP configuration file

#
 sysname AP
#
vlan batch 100 to 101
#
dhcp enable
#
interface Vlanif100
 ip address 10.23.100.1 255.255.255.0
 dhcp select interface
#
interface Vlanif101
 ip address 10.23.101.1 255.255.255.0
 dhcp select interface
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk pvid vlan 100
 port trunk allow-pass vlan 100 to 101
#
interface GigabitEthernet0/0/24
 port link-type trunk
 port trunk allow-pass vlan 101
#
management-vlan 100
#
wlan
 security-profile name wlan-security
  security wpa2 psk pass-phrase %^%#4R-.UpLuaWW`dGKS3R':Hg.h4g.hh:ygc7*P$q("%^%# aes
 ssid-profile name wlan-ssid
  ssid wlan-net
 vap-profile name wlan-vap
  service-vlan vlan-id 101
  ssid-profile wlan-ssid
  security-profile wlan-security
 regulatory-domain-profile name domain1
 wids-profile name wlan-wids
  flood-detect interval 70
  flood-detect threshold 350
  flood-detect quiet-time 700
  brute-force-detect interval 70
  brute-force-detect threshold 25
  brute-force-detect quiet-time 700
  dynamic-blacklist enable
 ap-system-profile name wlan-system
  dynamic-blacklist aging-time 200
 ap-group name ap-group1
  ap-system-profile wlan-system
  regulatory-domain-profile domain1
  wids-profile wlan-wids
  radio 0
   vap-profile wlan-vap wlan 1
   wids attack detect enable flood
   wids attack detect enable wpa2-psk
  radio 1
   vap-profile wlan-vap wlan 1
 ap-id 1 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
  ap-name area_1
  ap-group ap-group1
#
return
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 119094

Downloads: 309

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next