No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides configuration examples of static routes. Configuration examples explain networking requirements, networking diagram, configuration notes, configuration roadmap, and configuration procedure.

Example for Configuring IPv4 Static Routes

Networking Requirements

As shown in Figure 7-105, STA1, STA2, and PC1 belong to different network segments. STA1 and STA2 go online respectively on AP1 and AP2. It is required that static routes be configured to allow PC1 to communicate with STA1 and STA2.

Figure 7-105  Networking diagram of configuring IPv4 static routes

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create VLANs, add interfaces to the VLANs, and assign IPv4 addresses to VLANIF interfaces so that the adjacent devices can communicate with each other.
  2. Configure the default IP gateway on PC1, and configure IPv4 static routes and default routes on AP1, AP2, and SwitchA so that PC1 can communicate with STA1 and STA2.

Procedure

  1. Configure STA1 and STA2 to go online respectively on AP1 and AP2.

    Configure VLAN 30 as AP1's service VLAN and configure STA1 to go online on AP1. STA1 obtains the IP address 1.1.1.254/24. For details, see Example for Configuring Fat AP Layer 2 Networking.

    Configure STA2 to go online on AP2. (The configuration procedure is not provided here.)

  2. On AP1, create VLANs and add interfaces to the VLANs.

    <Huawei> system-view
    [Huawei] sysname AP1
    [AP1] vlan batch 10 30
    [AP1] interface gigabitethernet 0/0/1
    [AP1-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [AP1-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [AP1-GigabitEthernet0/0/1] quit
    

    The configuration of AP2 is similar to that of AP1, and is not provided here.

    Add interfaces of SwitchA to VLANs. (The configuration procedure is not provided here.)

  3. Assign IPv4 addresses to the VLANIF interfaces on AP1.

    [AP1] interface vlanif 10
    [AP1-Vlanif10] ip address 1.1.4.1 30
    [AP1-Vlanif10] quit
    [AP1] interface vlanif 30
    [AP1-Vlanif30] ip address 1.1.1.1 24
    [AP1-Vlanif30] quit

    The configuration of AP2 is similar to that of AP1, and is not provided here.

    Configure IP addresses for VLANIF interfaces on SwitchA. (The configuration procedure is not provided here.)

  4. Configure PC1 and STAs.

    Configure 1.1.2.1 as the default gateway of PC1. STA1 and STA2 go online respectively on AP1 and AP2; therefore, the gateways of STA1 and STA2 are respectively 1.1.1.1 and 1.1.3.1.

  5. Configure static routes.

    # Configure a default IPv4 route on AP1.

    [APA] ip route-static 0.0.0.0 0.0.0.0 1.1.4.2

    # Configure two IPv4 static routes on SwitchA.

    [SwitchA] ip route-static 1.1.1.0 255.255.255.0 1.1.4.1
    [SwitchA] ip route-static 1.1.3.0 255.255.255.0 1.1.4.6

    # Configure a default IPv4 route on AP2.

    [AP2] ip route-static 0.0.0.0 0.0.0.0 1.1.4.5

  6. Verify the configurations.

    # Check the routing table on AP1.

    [AP1] display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 10       Routes : 10                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
            0.0.0.0/0   Static  60   0          RD   1.1.4.2         Vlanif10       
            1.1.1.0/24  Direct  0    0           D   1.1.1.1         Vlanif30       
            1.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif30       
          1.1.1.255/32  Direct  0    0           D   127.0.0.1       Vlanif30       
            1.1.4.0/30  Direct  0    0           D   1.1.4.1         Vlanif10       
            1.1.4.1/32  Direct  0    0           D   127.0.0.1       Vlanif10       
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0 

    # Run the ping command to verify the connectivity.

    [AP1] ping 1.1.3.1
      PING 1.1.3.1: 56  data bytes, press CTRL_C to break
        Reply from 1.1.3.1: bytes=56 Sequence=1 ttl=254 time=62 ms
        Reply from 1.1.3.1: bytes=56 Sequence=2 ttl=254 time=63 ms
        Reply from 1.1.3.1: bytes=56 Sequence=3 ttl=254 time=63 ms
        Reply from 1.1.3.1: bytes=56 Sequence=4 ttl=254 time=62 ms
        Reply from 1.1.3.1: bytes=56 Sequence=5 ttl=254 time=62 ms
     
      --- 1.1.3.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 62/62/63 ms

    # Run the tracert command to verify the connectivity.

    [AP1] tracert 1.1.3.1
     traceroute to  1.1.3.1(1.1.3.1), max hops: 30 ,packet length: 40, press CTRL_C to break
     1 1.1.4.2 31 ms  32 ms  31 ms
     2 1.1.4.6 62 ms  63 ms  62 ms

Configuration Files
  • Configuration file of AP1

    #
    sysname AP1
    #
    vlan batch 10 30
    #
    interface Vlanif10
     ip address 1.1.4.1 255.255.255.252
    #
    interface Vlanif30
     ip address 1.1.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    ip route-static 0.0.0.0 0.0.0.0 1.1.4.2
    #
    return
  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20 40
    #
    interface Vlanif10
     ip address 1.1.4.2 255.255.255.252
    #
    interface Vlanif20
     ip address 1.1.4.5 255.255.255.252
    #
    interface Vlanif40
     ip address 1.1.2.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet0/0/2
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface GigabitEthernet0/0/3
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    ip route-static 1.1.1.0 255.255.255.0 1.1.4.1
    ip route-static 1.1.3.0 255.255.255.0 1.1.4.6
    #
    return
  • Configuration file of AP2

    #
    sysname AP2
    #
    vlan batch 20 50
    #
    interface Vlanif20
     ip address 1.1.4.6 255.255.255.252
    #
    interface Vlanif50
     ip address 1.1.3.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    ip route-static 0.0.0.0 0.0.0.0 1.1.4.5
    #
    return
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 116120

Downloads: 309

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next