No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides examples for the BFD configuration, including networking requirements, configuration notes, and configuration roadmap.

Example for Configuring Single-hop BFD for Detecting Faults on a Layer 2 Link

Networking Requirements

As shown in Figure 24-9, AP and Switch are connected through a Layer 2 interface. Faults on the link between AP and Switch need to be fast detected.

Figure 24-9  Single-hop BFD for detecting faults on a Layer 2 link
Configuration Roadmap

The configuration roadmap is as follows:

Configure BFD sessions on AP and Switch to detect faults on the link between AP and Switch.

Procedure

  1. Configure single-hop BFD on AP.

    # Enable BFD on AP.

    [AP] bfd
    [AP-bfd] quit

    # Create a BFD session on AP.

    [AP] bfd atob bind peer-ip default-ip interface gigabitethernet 0/0/1
    [AP-bfd-session-atob] discriminator local 1
    [AP-bfd-session-atob] discriminator remote 2
    [AP-bfd-session-atob] commit
    [AP-bfd-session-atob] quit
    

  2. Configure single-hop BFD on Switch.

    The configuration of Switch is similar to that of AP. The local and remote discriminators of the BFD session must be respectively set to 2 and 1.

  3. Configure interfaces that connect the AP and switch to ensure transmission of BFD packets at Layer 2.

    # Configure the AP.

    [AP] vlan 10
    [AP-vlan10] quit
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [AP-GigabitEthernet0/0/1] undo port trunk allow-pass vlan 1
    [AP-GigabitEthernet0/0/1] port trunk pvid vlan 10
    [AP-GigabitEthernet0/0/1] quit
    

    # Configure the interface on the switch. The configuration method is the same as that on the AP.

  4. Verify the configuration.

    After the configuration is complete, run the display bfd session all verbose command on AP and Switch. You can see that a single-hop BFD session is set up and its status is Up.

    The display on AP is used as an example.

    [AP] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 16        (One Hop) State : Up        Name : atob
    --------------------------------------------------------------------------------
      Local Discriminator    : 1              Remote Discriminator   : 2
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Interface(GigabitEthernet0/0/1)
      Bind Session Type      : Static
      Bind Peer IP Address   : 224.0.0.184
      NextHop Ip Address     : 224.0.0.184
      Bind Interface         : GigabitEthernet0/0/1
      FSM Board Id           : 0                TOS-EXP                : 7
      Min Tx Interval (ms)   : 30               Min Rx Interval (ms)   : 30  
      Actual Tx Interval (ms): 30               Actual Rx Interval (ms): 30  
      Local Detect Multi     : 3                Detect Interval (ms)   : 90  
      Echo Passive           : Disable          Acl Number             : -
      Destination Port       : 3784             TTL                    : 255 
      Proc Interface Status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                  
      Active Multi           : 3                DSCP                   : - 
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : No Application Bind
      Session TX TmrID       : -                Session Detect TmrID   : -
      Session Init TmrID     : -                Session WTR TmrID      : -
      Session Echo Tx TmrID  : -
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0
      Session Description    : -
    --------------------------------------------------------------------------------
     
         Total UP/DOWN Session Number : 1/0

    # Run the shutdown command on GE0/0/1 of AP to simulate a link fault.

    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] shutdown
    [AP-GigabitEthernet0/0/1] quit

    After the configuration is complete, run the display bfd session all verbose command on AP and Switch. You can see that a single-hop BFD session is set up and its status is Down. The display on AP is used as an example.

    [AP] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 16        (One Hop) State : Down        Name : atob
    --------------------------------------------------------------------------------
      Local Discriminator    : 1              Remote Discriminator   : 2
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Interface(GigabitEthernet0/0/1)
      Bind Session Type      : Static
      Bind Peer IP Address   : 224.0.0.184
      NextHop Ip Address     : 224.0.0.184
      Bind Interface         : GigabitEthernet0/0/1
      FSM Board Id           : 0                TOS-EXP                : 7
      Min Tx Interval (ms)   : 30               Min Rx Interval (ms)   : 30  
      Actual Tx Interval (ms): 13000            Actual Rx Interval (ms): 13000
      Local Detect Multi     : 3                Detect Interval (ms)   : -
      Echo Passive           : Disable          Acl Number             : -
      Destination Port       : 3784             TTL                    : 255 
      Proc Interface Status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                  
      Active Multi           : 3                DSCP                   : - 
      Last Local Diagnostic  : Control Detection Time Expired
      Bind Application       : No Application Bind
      Session TX TmrID       : 16402            Session Detect TmrID   : -
      Session Init TmrID     : -                Session WTR TmrID      : -
      Session Echo Tx TmrID  : -
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0
      Session Description    : -
    --------------------------------------------------------------------------------
     
         Total UP/DOWN Session Number : 0/1

Configuration Files
  • Configuration file of AP

    #
     sysname AP
    #
    bfd
    #
    interface GigabitEthernet0/0/1
     shutdown
     port link-type trunk
     port trunk pvid vlan 10
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
    #
    bfd atob bind peer-ip default-ip interface GigabitEthernet0/0/1
     discriminator local 1
     discriminator remote 2
     commit
    #
    return

Example for Configuring Single-Hop BFD on a VLANIF Interface

Networking Requirements

As shown in Figure 24-10, the AP connects to the switch through a VLANIF interface. Faults on the link between the AP and switch need to be fast detected.

Figure 24-10  Networking diagram for configuring single-hop BFD on a VLANIF interface
Configuration Roadmap

The configuration roadmap is as follows:

Configure BFD sessions on the AP and switch to detect faults on the link between the AP and switch.

Procedure

  1. On the AP and switch, create VLANs, configure GE0/0/1 interfaces as hybrid interfaces, and add GE0/0/1 interfaces to VLANs. The configuration details are not mentioned here.
  2. Configure IP addresses for VLANIF interfaces so that the AP and switch can communicate at Layer 3. The configuration details are not mentioned here.
  3. Configure single-hop BFD.

    # Enable BFD and create a BFD session on the AP.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] bfd
    [AP-bfd] quit
    [AP] bfd atob bind peer-ip 10.1.1.6 interface vlanif 100
    [AP-bfd-session-atob] discriminator local 1
    [AP-bfd-session-atob] discriminator remote 2
    [AP-bfd-session-atob] commit
    [AP-bfd-session-atob] quit
    

    # Enable BFD and create a BFD session on the switch. The configuration of the switch is similar to that of the AP. The peer IP address of the BFD session must be set to 10.1.1.5, and the local and remote discriminators of the BFD session must be respectively set to 2 and 1.

  4. Verify the configuration.

    After the configuration is complete, run the display bfd session all verbose command on the AP and switch, and you can find that a single-hop BFD session is set up and its status is Up. The command output on the AP is used as an example.

    <AP> display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 16        (One Hop) State : Up        Name : atob              
    --------------------------------------------------------------------------------
      Local Discriminator    : 1               Remote Discriminator   : 2         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(Vlanif100)                                  
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 10.1.1.6                                            
      NextHop Ip Address     : 10.1.1.6                                            
      Bind Interface         : Vlanif100                                             
      FSM Board Id           : 0                TOS-EXP                : 7          
      Min Tx Interval (ms)   : 30               Min Rx Interval (ms)   : 30         
      Actual Tx Interval (ms): 30               Actual Rx Interval (ms): 30         
      Local Detect Multi     : 3                Detect Interval (ms)   : 90   
      Echo Passive           : Disable          Acl Number             : -          
      Destination Port       : 3784             TTL                    : 255        
      Proc Interface Status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                                                    
      Active Multi           : 3                DSCP                   : -
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : No Application Bind                                  
      Session TX TmrID       : -                Session Detect TmrID   : -          
      Session Init TmrID     : -                Session WTR TmrID      : -          
      Session Echo Tx TmrID  : -                                                    
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    
         Total UP/DOWN Session Number : 1/0

    # Run the shutdown command on GE0/0/1 of AP to simulate a link fault.

    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] shutdown
    [AP-GigabitEthernet0/0/1] quit

    After the configuration is complete, run the display bfd session all verbose command on the AP and switch, and you can find that a single-hop BFD session is set up and its status is Down. The command output on the AP is used as an example.

    <AP> display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 16        (One Hop) State : Down        Name : atob
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2          
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(Vlanif100)                                 
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 10.1.1.6                                             
      NextHop Ip Address     : 10.1.1.6
      Bind Interface         : Vlanif100                                            
      FSM Board Id           : 0                TOS-EXP                : 7          
      Min Tx Interval (ms)   : 30               Min Rx Interval (ms)   : 30         
      Actual Tx Interval (ms): 13000            Actual Rx Interval (ms): 13000      
      Local Detect Multi     : 3                Detect Interval (ms)   : -      
      Echo Passive           : Disable          Acl Number             : -          
      Destination Port       : 3784             TTL                    : 255        
      Proc Interface Status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                   
      Active Multi           : 3                DSCP                   : -
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : No Application Bind                                  
      Session TX TmrID       : 16897            Session Detect TmrID   : -          
      Session Init TmrID     : 16898            Session WTR TmrID      : -          
      Session Echo Tx TmrID  : -                                                    
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0                                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    
         Total UP/DOWN Session Number : 0/1 

Configuration Files
  • Configuration file of the AP

    #
     sysname AP
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ip address 10.1.1.5 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     shutdown
     port hybrid pvid vlan 100 
     port hybrid untagged vlan 100
    #
    bfd atob bind peer-ip 10.1.1.6 interface Vlanif100
     discriminator local 1
     discriminator remote 2
     commit
    #
    return

Example for Configuring Multi-Hop BFD

Networking Requirements

As shown in Figure 24-11, AP is indirectly connected to SwitchC. Static routes are configured so that AP can communicate with SwitchC. Faults on the link between AP and SwitchC need to be fast detected.

Figure 24-11  Networking diagram for configuring multi-hop BFD
Configuration Roadmap

The configuration roadmap is as follows:

Configure BFD sessions on AP and SwitchC to detect the multi-hop route.

Procedure

  1. Add interfaces to VLANs, create VLANIF interfaces, and assign IP addresses to VLANIF interfaces. The configuration details are not mentioned here.
  2. Configure a reachable static route between AP and SwitchC.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] ip route-static 10.2.0.0 16 10.1.1.2
    

    The configuration of SwitchC is similar to the configuration of AP, and is not mentioned here.

  3. Configure multi-hop BFD.

    # Create a BFD session between AP and SwitchC.

    [AP] bfd
    [AP-bfd] quit
    [AP] bfd atoc bind peer-ip 10.2.1.2
    [AP-bfd-session-atoc] discriminator local 10
    [AP-bfd-session-atoc] discriminator remote 20
    [AP-bfd-session-atoc] commit
    [AP-bfd-session-atoc] quit

    # Create a BFD session between SwitchC and AP.

    The configuration of SwitchC is similar to that of AP. The peer IP address of the BFD session must be set to 10.1.1.1, and the local and remote discriminators of the BFD session must be respectively set to 20 and 10.

  4. Verify the configuration.

    After the configuration, run the display bfd session all verbose command on AP and SwitchC. You can see that a BFD session is set up and is in Up state. Take the display on APas an example.

    <AP> display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 68        (Multi Hop) State : Up        Name : atoc            
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Peer IP Address                                      
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 10.2.1.2                                             
      Bind Interface         : -                                                    
      Track Interface        : -                                                    
      FSM Board Id           : 0                TOS-EXP                : 7          
      Min Tx Interval (ms)   : 30               Min Rx Interval (ms)   : 30         
      Actual Tx Interval (ms): 30               Actual Rx Interval (ms): 30         
      Local Detect Multi     : 3                Detect Interval (ms)   : 90         
      Echo Passive           : Disable          Acl Number             : -          
      Destination Port       : 3784             TTL                    : 254        
      Proc Interface Status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                                                    
      Active Multi           : 3                DSCP                   : -          
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : No Application Bind                                  
      Session TX TmrID       : -                Session Detect TmrID   : -          
      Session Init TmrID     : -                Session WTR TmrID      : -          
      Session Echo Tx TmrID  : -                                                    
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    
         Total UP/DOWN Session Number : 1/0                                         
    

    # Run the shutdown command on the GE0/0/1 interface of APto simulate a link fault.

    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] shutdown
    [AP-GigabitEthernet0/0/1] quit

    After the configuration, run the display bfd session all verbose command on AP and SwitchC. You can see that a multi-hop BFD session is set up and the status is Down. Take the display on APas an example.

    <AP> display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 68        (Multi Hop) State : Down      Name : atoc            
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Peer IP Address                                      
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 10.2.1.2                                             
      Bind Interface         : -                                                    
      Track Interface        : -                                                    
      FSM Board Id           : 0                TOS-EXP                : 7          
      Min Tx Interval (ms)   : 30               Min Rx Interval (ms)   : 30         
      Actual Tx Interval (ms): 11500            Actual Rx Interval (ms): 11500      
      Local Detect Multi     : 3                Detect Interval (ms)   : -          
      Echo Passive           : Disable          Acl Number             : -          
      Destination Port       : 3784             TTL                    : 254        
      Proc Interface Status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                                                    
      Active Multi           : 3                DSCP                   : -          
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : No Application Bind                                  
      Session TX TmrID       : 534              Session Detect TmrID   : -          
      Session Init TmrID     : -                Session WTR TmrID      : -          
      Session Echo Tx TmrID  : -                                                    
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    
         Total UP/DOWN Session Number : 0/1 
    

Configuration Files
  • Configuration file of APA

    #
     sysname AP
    #
    vlan batch 10
    #
    bfd
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    bfd atoc bind peer-ip 10.2.1.2
     discriminator local 10
     discriminator remote 20
     commit
    #
     ip route-static 10.2.0.0 255.255.0.0 10.1.1.2
    #
    return

Example for Configuring Association Between the BFD Status and the Interface Status

Networking Requirements

As shown in Figure 24-12, the AP and SwitchC connect to each other at the network layer. SwitchA and SwitchB are Layer 2 transmission devices and are deployed between the AP and SwitchC. Users expect that devices on both ends can rapidly detect the fault, triggering fast route convergence.

Figure 24-12  Networking diagram of configuring association between the BFD session status and the interface status
Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure BFD sessions on the AP and SwitchC to detect link status.

  2. Configure association between BFD status and interface status on the AP and SwitchC after the BFD session is Up.

Procedure

  1. Configure the interfaces connecting the AP and SwitchC.

    # Configure the AP.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan 10
    [AP-vlan10] quit
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [AP-GigabitEthernet0/0/1] undo port trunk allow-pass vlan 1
    [AP-GigabitEthernet0/0/1] port trunk pvid vlan 10
    [AP-GigabitEthernet0/0/1] quit
    

    # Configure the interface of SwitchC connecting to the AP. The configuration procedure is similar to that of the AP.

    NOTE:

    Configure a PVID on interfaces of SwitchA and SwitchB where BFD packets pass through so that BFD packets can be transmitted at Layer 2.

  2. Configure single-hop BFD.

    # On the AP, enable BFD and create a BFD session with SwitchC.

    [AP] bfd
    [AP-bfd] quit
    [AP] bfd atob bind peer-ip default-ip interface gigabitethernet 0/0/1
    [AP-bfd-session-atob] discriminator local 10
    [AP-bfd-session-atob] discriminator remote 20
    [AP-bfd-session-atob] commit
    [AP-bfd-session-atob] quit

    # On SwitchC, enable BFD and create a BFD session with the AP. The configuration of SwitchC is similar to that of the AP. The local and remote discriminators of the BFD session must be respectively set to 20 and 10.

    # Run the display bfd session all verbose command on the AP and SwitchC, and you can find that a single-hop BFD session is set up and is in Up state. The command output on the AP is used as an example.

    [AP] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 67        (One Hop) State : Up        Name : atob             
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(GigabitEthernet0/0/1)                      
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 224.0.0.184                                          
      NextHop Ip Address     : 224.0.0.184                                          
      Bind Interface         : GigabitEthernet0/0/1                                 
      FSM Board Id           : 0                TOS-EXP                : 7          
      Min Tx Interval (ms)   : 30               Min Rx Interval (ms)   : 30         
      Actual Tx Interval (ms): 30               Actual Rx Interval (ms): 30         
      Local Detect Multi     : 3                Detect Interval (ms)   : 90         
      Echo Passive           : Disable          Acl Number             : -          
      Destination Port       : 3784             TTL                    : 255        
      Proc Interface Status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                                                    
      Active Multi           : 3                DSCP                   : -          
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : No Application Bind                                  
      Session TX TmrID       : -                Session Detect TmrID   : -          
      Session Init TmrID     : -                Session WTR TmrID      : -          
      Session Echo Tx TmrID  : -                                                    
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    
         Total UP/DOWN Session Number : 1/0 
    

  3. Configure association between BFD session status and interface status.

    # Configure association between the BFD session status and the interface status on the AP.

    [AP] bfd atob 
    [AP-bfd-session-atob] process-interface-status
    [AP-bfd-session-atob] quit

    # Configure association between BFD session status and interface status on SwitchC. The configuration of SwitchC is similar to that of the AP.

  4. Verify the configuration.

    After the configuration is complete, run the display bfd session all verbose command on the AP and SwitchC, and you can find that the Proc Interface Status field is Enable.

    The command output on the AP is used as an example.

    [AP] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 67        (One Hop) State : Up        Name : atob             
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(GigabitEthernet0/0/1)                      
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 224.0.0.184                                          
      NextHop Ip Address     : 224.0.0.184                                          
      Bind Interface         : GigabitEthernet0/0/1                                 
      FSM Board Id           : 0                TOS-EXP                : 7          
      Min Tx Interval (ms)   : 30               Min Rx Interval (ms)   : 30         
      Actual Tx Interval (ms): 30               Actual Rx Interval (ms): 30         
      Local Detect Multi     : 3                Detect Interval (ms)   : 90         
      Echo Passive           : Disable          Acl Number             : -          
      Destination Port       : 3784             TTL                    : 255        
      Proc Interface Status  : Enable           Process PST            : Disable
      WTR Interval (ms)      : -                                                    
      Active Multi           : 3                DSCP                   : -          
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : IFNET                                                
      Session TX TmrID       : -                Session Detect TmrID   : -          
      Session Init TmrID     : -                Session WTR TmrID      : -          
      Session Echo Tx TmrID  : -                                                    
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    
         Total UP/DOWN Session Number : 1/0 
    

    Run the shutdown command on GE0/0/1 of SwitchB to have the BFD session Down.

    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] shutdown
    [SwitchB-GigabitEthernet0/0/1] quit

    Run the display bfd session all verbose and display interface gigabitethernet 0/0/1 commands on the AP, and you can find that the status of the BFD session is Down, and the status of GE0/0/1 is Up.

    [AP] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 67        (One Hop) State : Down      Name : atob             
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20         
      Session Detect Mode    : Asynchronous Mode Without Echo Function              
      BFD Bind Type          : Interface(GigabitEthernet0/0/1)                      
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 224.0.0.184                                          
      NextHop Ip Address     : 224.0.0.184                                          
      Bind Interface         : GigabitEthernet0/0/1                                 
      FSM Board Id           : 0                TOS-EXP                : 7          
      Min Tx Interval (ms)   : 30               Min Rx Interval (ms)   : 30         
      Actual Tx Interval (ms): 12500            Actual Rx Interval (ms): 12500      
      Local Detect Multi     : 3                Detect Interval (ms)   : -          
      Echo Passive           : Disable          Acl Number             : -          
      Destination Port       : 3784             TTL                    : 255        
      Proc Interface Status  : Enable           Process PST            : Disable
      WTR Interval (ms)      : -                                                    
      Active Multi           : 3                DSCP                   : -          
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : IFNET                                                
      Session TX TmrID       : 430              Session Detect TmrID   : -          
      Session Init TmrID     : -                Session WTR TmrID      : -          
      Session Echo Tx TmrID  : -                                                    
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    
         Total UP/DOWN Session Number : 0/1
    [AP] display interface gigabitethernet 0/0/1
    GigabitEthernet0/0/1 current state : UP                                         
    Line protocol current state : UP(BFD status down)                               
    Description:HUAWEI, AP Series, GigabitEthernet0/0/1 Interface                   
    Switch Port, PVID :   10, TPID : 8100(Hex), The Maximum Frame Length is 9216    
    IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is dcd2-fcf9-b5ca 
    Last physical up time   : 2013-08-06 14:02:50 UTC+08:00                         
    Last physical down time : 2013-08-06 14:02:33 UTC+08:00                         
    Current system time: 2013-08-06 21:05:10+08:00                                  
    Port Mode: COMMON COPPER                                                        
    Speed : 1000,  Loopback: NONE                                                   
    Duplex: FULL,  Negotiation: ENABLE                                              
    Mdi   : AUTO                                                                    
    Last 300 seconds input rate 0 bits/sec, 0 packets/sec                           
    Last 300 seconds output rate 0 bits/sec, 0 packets/sec                          
    Input peak rate 22704 bits/sec,Record time: 2013-08-06 14:03:46                 
    Output peak rate 53960 bits/sec,Record time: 2013-08-06 14:03:46                
                                                                                    
    Input:  19108 packets, 2480594 bytes                                            
      Unicast:               6284,  Multicast:                2890                  
      Broadcast:             9934,  Jumbo:                       0                  
      Discard:                  0,  Total Error:                 0                  
                                                                                    
      CRC:                      0,  Giants:                      0                  
      Jabbers:                  0,  Throttles:                   0                  
      Runts:                    0,  Alignments:                  0                  
      Symbols:                  0,  Ignoreds:                    0                  
      Frames:                   0                                                   
                                                                                    
    Output:  13634 packets, 1278722 bytes                                           
      Unicast:               5227,  Multicast:                2574                  
      Broadcast:             5833,  Jumbo:                       0                  
      Discard:                  0,  Total Error:                 0                  
                                                                                    
      Collisions:               0,  ExcessiveCollisions:         0                  
      Late Collisions:          0,  Deferreds:                   0                  
      Buffers Purged:           0                                                   
                                                                                    
        Input bandwidth utilization threshold : 100.00%                             
        Output bandwidth utilization threshold: 100.00%                             
        Input bandwidth utilization  :    0%                                        
        Output bandwidth utilization :    0% 

Configuration Files
  • Configuration file of the AP

    #
     sysname AP
    #
    vlan 10
    #
    bfd
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 10
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
    #
    bfd atob bind peer-ip default-ip interface GigabitEthernet0/0/1
     discriminator local 10
     discriminator remote 20
     process-interface-status
     commit
    #
    return

Example for Configuring the BFD Echo Function

Networking Requirements

As shown in Figure 24-13, the AP and switch directly connect to each other. The AP supports the BFD function but the switch does not. Users expect that faults on the link can be fast detected.

Figure 24-13  Networking diagram of configuring the BFD echo function
Configuration Roadmap

The configuration roadmap is as follows:

  • Configure the BFD echo function on the AP to detect the link between the AP and switch.

Procedure

  1. Create a VLAN on both the AP and switch, configure GE0/0/1 as a trunk interface, and add it to the VLAN.

    # Configure the AP.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan 13
    [AP-vlan13] quit
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 13
    [AP-GigabitEthernet0/0/1] quit

    # Configure the switch. The configuration of the switch is similar to that of the AP.

  2. Configure IP addresses for the VLANIF interfaces so that the AP can communicate with the switch at Layer 3.

    # Configure the AP.

    [AP] interface vlanif13
    [AP-Vlanif13] ip address 10.1.1.5 24
    [AP-Vlanif13] quit

    # Configure the switch. The configuration of the switch is similar to that of the AP.

  3. Configure the BFD echo function.

    # Configure the AP.

    [AP] bfd
    [AP-bfd] quit
    [AP] bfd atob bind peer-ip 10.1.1.6 interface vlanif13 source-ip 10.1.1.5 one-arm-echo
    [AP-bfd-session-atob] discriminator local 1
    [AP-bfd-session-atob] commit
    [AP-bfd-session-atob] quit

  4. Verify the configuration.

    After the configuration is complete, run the display bfd session all verbose command on AP, and you can find that a single-hop BFD session is set up and is in Up state.

    <AP> display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 515       (One Hop) State : Up        Name : atob              
    --------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : -          
      Session Detect Mode    : Asynchronous One-arm-echo Mode                       
      BFD Bind Type          : Interface(Vlanif13)                                  
      Bind Session Type      : Static                                               
      Bind Peer IP Address   : 10.1.1.6                                             
      NextHop Ip Address     : 10.1.1.6                                             
      Bind Interface         : Vlanif13                                             
      Bind Source IP Address : 10.1.1.5                                             
      FSM Board Id           : 0                TOS-EXP                : 7          
      Echo Rx Interval (ms)  : 30                                                   
      Actual Tx Interval (ms): 30               Actual Rx Interval (ms): 30         
      Local Detect Multi     : 3                Detect Interval (ms)   : 90         
      Echo Passive           : Disable          Acl Number             : -          
      Destination Port       : 3784             TTL                    : 255        
      Proc Interface Status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                                                    
      Active Multi           : 3                DSCP                   : -          
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : No Application Bind                                  
      Session TX TmrID       : -                Session Detect TmrID   : -          
      Session Init TmrID     : -                Session WTR TmrID      : -          
      Session Echo Tx TmrID  : -                                                    
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0                       
      Session Description    : -                                                    
    --------------------------------------------------------------------------------
                                                                                    
         Total UP/DOWN Session Number : 1/0  

Configuration Files
  • Configuration file of the AP

    #
     sysname AP
    #
    vlan batch 13
    #
    bfd
    #
    interface Vlanif13
     ip address 10.1.1.5 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 13  
    #
    bfd atob bind peer-ip 10.1.1.6 interface Vlanif13 source-ip 10.1.1.5 one-arm-echo
     discriminator local 1
     commit
    #
    return
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 116113

Downloads: 309

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next