No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

This section provides several configuration examples of VRRP, including networking requirements, configuration roadmap, and configuration procedure.

Example for Configuring Vehicle-Ground Fast Link Handover (VRRP Backup for Vehicle-Mounted APs)

Service Requirements

To reduce network deployment costs and better serve passengers, a rail transportation enterprise wants to use WLAN technology to implement vehicle-ground communications. If a vehicle-mounted AP is faulty, the network is faulty and vehicle-ground communication is affected. To prevent such problem, the customer requires two vehicle-mounted APs to support redundancy. The VRRP function is recommended.

Networking Requirements
  • AC networking mode: Layer 2 bypass mode
  • Wireless backhaul mode: Mesh-based vehicle-ground fast link handover
  • Backhaul radio: 5 GHz radio
Figure 24-24  Networking for configuring vehicle-ground fast link handover
Data Planning
Table 24-8  AP planning

AP

Model

MAC Address

Trackside AP (L1_001)

AP8030DN

0046-4b59-1d10

Trackside AP (L1_003)

AP8030DN

0046-4b59-1d20

Trackside AP (L1_010)

AP8030DN

0046-4b59-1d30

Trackside AP (L1_150)

AP8030DN

0046-4b59-1d40

Trackside AP (L1_160)

AP8030DN

0046-4b59-1d50

Trackside AP (L1_170)

AP8030DN

0046-4b59-1d60

......

Vehicle-mounted AP (in the front)

AP9132DN

0046-4b59-2e10

Vehicle-mounted AP (in the rear)

AP9132DN

0046-4b59-2e20

.......
Table 24-9  Data planning

Item

Data

Management VLAN VLAN 100
VLAN for vehicle-mounted APs VLAN 200
DHCP server
  • Configure the AC as a DHCP server to assign IP addresses to trackside APs.
  • Configure a vehicle-mounted AP as a DHCP server to assign IP addresses to vehicle-mounted terminals.
AC's source interface address VLANIF 100: 10.23.100.1/24
Gateway address VRRP IP address for vehicle-mounted APs: 10.23.161.1/24
IP address pool for trackside APs 10.23.100.2 to 10.23.100.254/24
IP address pool for vehicle-mounted terminals 10.23.161.4 to 10.23.161.254/24
AP group to which trackside APs belong Name: mesh-mpp
IDs of trackside APs
  • Trackside AP (L1_001): 1
  • Trackside AP (L1_003): 2
  • Trackside AP (L1_010): 3
  • Trackside AP (L1_150): 101
  • Trackside AP (L1_160): 102
  • Trackside AP (L1_170): 103
AP wired port profile
  • Name: wired-port
Security profile
  • Name: sp01
  • Security policy: WPA2+PSK+AES
  • Password type: PASS-PHRASE
  • Authentication key: a1234567
AP system profile
  • Name: mesh-sys
  • Mesh role: Mesh-portal
Mesh profile
Radio 0 of trackside APs:
  • Name: mesh-net
  • Identifier: mesh-net
Radio 1 of trackside APs:
  • Name: mesh-net2
  • Identifier: mesh-net2
Vehicle-mounted AP (in the front):
  • Name: mesh-net
  • Identifier: mesh-net
Vehicle-mounted AP (in the rear):
  • Name: mesh-net2
  • Identifier: mesh-net2
Mesh handover profile

Trackside APs:

  • Name: hand-over

Vehicle-mounted APs:

  • Name: hand-over
Mesh whitelist on trackside APs Name: whitelist01

Add MAC addresses of all vehicle-mounted APs on trains running on the rail to the whitelist according to actual situations.

Mesh whitelist on vehicle-mounted APs Name: whitelist01

Add MAC addresses of all trackside APs along the rail line to the whitelist according to actual situations.

MAC address of the proxied ground device
  • Gateway: 707b-e8e9-d328
MAC address of the proxied vehicle-mounted device
  • Vehicle-mounted terminal_1: 286e-d488-d359
  • Vehicle-mounted terminal_2: 286e-d488-d270
Virtual IP address of the management VRRP group 10.23.161.1
Virtual IP address of the service VRRP group 10.23.200.1
Configuration Roadmap
  1. Configure the ground network to enable Layer 2 communications between trackside APs and the AC.
  2. Configure the vehicle-ground fast link handover function on trackside and vehicle-mounted APs so that the vehicle-mounted APs can set up Mesh links with the trackside APs.
  3. Configure the vehicle-mounted network to enable intra-network data communication, and configure VRRP and BFD between the vehicle-mounted APs.
NOTE:
  • This example uses Huawei AP8030DNs in Fit AP mode as the trackside APs and AP9132DNs in Fat AP mode as the vehicle-mounted APs.
  • The switches and router used in this example are all Huawei products.
Configuration Notes

No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression on switch interfaces connected to APs to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected. For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.

Procedure

  • Configure ground network devices.
    1. Create VLAN 100 and VLAN 200 on Switch_A, and add GE0/0/1 and GE0/0/2 to VLAN 100 and VLAN 200, and GE0/0/3 to VLAN 100.

      <HUAWEI> system-view
      [HUAWEI] sysname Switch_A
      [Switch_A] vlan batch 100 200
      [Switch_A] interface gigabitEthernet 0/0/1
      [Switch_A-GigabitEthernet0/0/1] port link-type trunk
      [Switch_A-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 200
      [Switch_A-GigabitEthernet0/0/1] quit
      [Switch_A] interface gigabitEthernet 0/0/2
      [Switch_A-GigabitEthernet0/0/2] port link-type trunk
      [Switch_A-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 200
      [Switch_A-GigabitEthernet0/0/2] quit
      [Switch_A] interface gigabitEthernet 0/0/3
      [Switch_A-GigabitEthernet0/0/3] port link-type trunk
      [Switch_A-GigabitEthernet0/0/3] port trunk allow-pass vlan 100
      [Switch_A-GigabitEthernet0/0/3] quit
      

    2. Configure an IP address for VLANIF 200 on Switch_A.

      NOTE:

      Configure a route to Router based on the actual networking so that packets destined for the public network are forwarded from the ground network to Router.

      [Switch_A] interface vlanif 200
      [Switch_A-Vlanif200] ip address 10.23.200.2 24
      [Switch_A-Vlanif200] quit
      

    3. Configure the IP address 10.23.200.1 as the next-hop address of the route for packets from Switch_A to be forwarded to vehicle-mounted terminals.

      [Switch_A] ip route-static 10.23.161.0 24 10.23.200.1
      

    4. Configure Switch_B and Switch_C to enable Layer 2 communication between trackside APs and the ground network.

      # On Switch_B, create VLAN 100 and VLAN 200, configure GE0/0/2 and GE0/0/1 to allow packets from VLAN 100 and VLAN 200 to pass through, and set the PVID of GE0/0/1 to VLAN 100 (management VLAN for trackside APs).

      # Configure other interfaces on Switch_B connected to trackside APs according to the configuration for GE0/0/1. Configure these interfaces to allow packets from VLAN 100 and VLAN 200 to pass through, and set their PVIDs to VLAN 100.
      <HUAWEI> system-view
      [HUAWEI] sysname Switch_B
      [Switch_B] vlan batch 100 200
      [Switch_B] interface gigabitEthernet 0/0/2
      [Switch_B-GigabitEthernet0/0/2] port link-type trunk
      [Switch_B-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 200
      [Switch_B-GigabitEthernet0/0/2] quit
      [Switch_B] interface gigabitEthernet 0/0/1
      [Switch_B-GigabitEthernet0/0/1] port link-type trunk
      [Switch_B-GigabitEthernet0/0/1] port trunk pvid vlan 100
      [Switch_B-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 200
      [Switch_B-GigabitEthernet0/0/1] quit

      # On Switch_C, create VLAN 100 and VLAN 200, configure GE0/0/2 and GE0/0/1 to allow packets from VLAN 100 and VLAN 200 to pass through, and set the PVID of GE0/0/1 to VLAN 100.

      # Configure other interfaces on Switch_C connected to trackside APs according to the configuration for GE0/0/1. Configure these interfaces to allow packets from VLAN 100 and VLAN 200 to pass through, and set their PVIDs to VLAN 100.
      <HUAWEI> system-view
      [HUAWEI] sysname Switch_C
      [Switch_C] vlan batch 100 200
      [Switch_C] interface gigabitEthernet 0/0/2
      [Switch_C-GigabitEthernet0/0/2] port link-type trunk
      [Switch_C-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 200
      [Switch_C-GigabitEthernet0/0/2] quit
      [Switch_C] interface gigabitEthernet 0/0/1
      [Switch_C-GigabitEthernet0/0/1] port link-type trunk
      [Switch_C-GigabitEthernet0/0/1] port trunk pvid vlan 100
      [Switch_C-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 200
      [Switch_C-GigabitEthernet0/0/1] quit

    5. Configure the AC to enable it to communicate with trackside APs at Layer 2.

      # Create VLAN 100 and VLAN 200 on the AC and configure GE0/0/1 to allow packets from VLAN 100 to pass through.

      <AC6605> system-view
      [AC6605] sysname AC
      [AC] vlan batch 100 200
      [AC] interface gigabitEthernet 0/0/1
      [AC-GigabitEthernet0/0/1] port link-type trunk
      [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
      [AC-GigabitEthernet0/0/1] quit
      

      # Configure the AC as a DHCP server to assign IP addresses to trackside APs.

      [AC] dhcp enable
      [AC] interface vlanif 100
      [AC-Vlanif100] ip address 10.23.100.1 24
      [AC-Vlanif100] dhcp select interface
      [AC-Vlanif100] quit
      

    6. Configure the AP group, country code, and AC's source interface.

      # Create the AP group mesh-mpp and add trackside APs that require the same configuration to the group.

      [AC] wlan
      [AC-wlan-view] ap-group name mesh-mpp
      [AC-wlan-ap-group-mesh-mpp] quit
      

      # Create a regulatory domain profile, configure the AC country code in the profile, and bind the profile to the AP group.

      [AC-wlan-view] regulatory-domain-profile name default
      [AC-wlan-regulate-domain-default] country-code cn
      [AC-wlan-regulate-domain-default] quit
      [AC-wlan-view] ap-group name mesh-mpp
      [AC-wlan-ap-group-mesh-mpp] regulatory-domain-profile default
      Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
      e?[Y/N]:y 
      [AC-wlan-ap-group-mesh-mpp] quit
      
      [AC-wlan-view] quit
      

      # Configure the AC's source interface.

      [AC] capwap source interface vlanif 100
      
      # Add trackside APs to the AP group mesh-mpp.
      NOTE:

      The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

      [AC] wlan
      [AC-wlan-view] ap auth-mode mac-auth
      [AC-wlan-view] ap-id 1 ap-mac 0046-4b59-1d10
      [AC-wlan-ap-1] ap-name L1_001
      [AC-wlan-ap-1] ap-group mesh-mpp
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC-wlan-ap-1] quit
      [AC-wlan-view] ap-id 2 ap-mac 0046-4b59-1d20
      [AC-wlan-ap-2] ap-name L1_003
      [AC-wlan-ap-2] ap-group mesh-mpp
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC-wlan-ap-2] quit
      [AC-wlan-view] ap-id 3 ap-mac 0046-4b59-1d30
      [AC-wlan-ap-3] ap-name L1_010
      [AC-wlan-ap-3] ap-group mesh-mpp
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC-wlan-ap-3] quit
      [AC-wlan-view] ap-id 101 ap-mac 0046-4b59-1d40
      [AC-wlan-ap-101] ap-name L1_150
      [AC-wlan-ap-101] ap-group mesh-mpp
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC-wlan-ap-101] quit
      [AC-wlan-view] ap-id 102 ap-mac 0046-4b59-1d50
      [AC-wlan-ap-102] ap-name L1_160
      [AC-wlan-ap-102] ap-group mesh-mpp
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC-wlan-ap-102] quit
      [AC-wlan-view] ap-id 103 ap-mac 0046-4b59-1d60
      [AC-wlan-ap-103] ap-name L1_170
      [AC-wlan-ap-103] ap-group mesh-mpp
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC-wlan-ap-103] quit
      

    7. Configure uplink wired interfaces on trackside APs to allow packets from VLAN 200 to pass through.

      # Configure the wired port profile wired-port and add the wired interfaces to VLAN 200 in tagged mode.

      [AC-wlan-view] wired-port-profile name wired-port
      [AC-wlan-wired-port-wired-port] vlan tagged 200
      [AC-wlan-wired-port-wired-port] quit
      

      # Bind the wired port profile wired-port to the AP group mesh-mpp.

      [AC-wlan-view] ap-group name mesh-mpp
      [AC-wlan-ap-group-mesh-mpp] wired-port-profile wired-port gigabitethernet 0
      [AC-wlan-ap-group-mesh-mpp] quit
      

    8. Configure Mesh parameters.

      # Create the Mesh whitelist whitelist01 and add MAC addresses of vehicle-mounted APs to the Mesh whitelist.

      [AC-wlan-view] mesh-whitelist name whitelist01
      [AC-wlan-mesh-whitelist-whitelist01] peer-ap mac 0046-4b59-2e10
      [AC-wlan-mesh-whitelist-whitelist01] peer-ap mac 0046-4b59-2e20
      [AC-wlan-mesh-whitelist-whitelist01] quit
      

      # Add MAC addresses of vehicle-mounted APs on other trains to the Mesh whitelist whitelist01 according to the preceding procedure.

      # Configure the security profile sp01 used by Mesh links. Set the security policy to WPA2+PSK+AES in the security profile.

      [AC-wlan-view] security-profile name sp01
      [AC-wlan-sec-prof-sp01] security wpa2 psk pass-phrase a1234567 aes
      [AC-wlan-sec-prof-sp01] quit
      

      # Configure the Mesh role. Set the Mesh role of trackside APs to Mesh-portal in the AP system profile.

      [AC-wlan-view] ap-system-profile name mesh-sys
      [AC-wlan-ap-system-prof-mesh-sys] mesh-role Mesh-portal
      [AC-wlan-ap-system-prof-mesh-sys] quit
      

      # Configure the Mesh handover profile hand-over and enable the location-based fast link handover algorithm.

      [AC-wlan-view] mesh-handover-profile name hand-over
      [AC-wlan-mesh-handover-hand-over] location-based-algorithm enable
      [AC-wlan-mesh-handover-hand-over] quit
      

      # Configure Mesh profiles. Set the IDs of the Mesh networks to mesh-net and mesh-net2, and bind the security profile and Mesh handover profile to the Mesh profiles.

      [AC-wlan-view] mesh-profile name mesh-net
      [AC-wlan-mesh-prof-mesh-net] mesh-id mesh-net
      [AC-wlan-mesh-prof-mesh-net] security-profile sp01
      [AC-wlan-mesh-prof-mesh-net] mesh-handover-profile hand-over
      [AC-wlan-mesh-prof-mesh-net] quit
      [AC-wlan-view] mesh-profile name mesh-net2
      [AC-wlan-mesh-prof-mesh-net2] mesh-id mesh-net2
      [AC-wlan-mesh-prof-mesh-net2] security-profile sp01
      [AC-wlan-mesh-prof-mesh-net2] mesh-handover-profile hand-over
      [AC-wlan-mesh-prof-mesh-net2] quit
      

    9. Apply the Mesh parameters to radios of trackside APs.

      # Configure the radio and channel used by trackside APs, and apply the Mesh whitelist, Mesh profiles, and AP system profile.

      [AC-wlan-view] ap-group name mesh-mpp
      [AC-wlan-ap-group-mesh-mpp] ap-system-profile mesh-sys
      [AC-wlan-ap-group-mesh-mpp] radio 0
      [AC-wlan-group-radio-mesh-mpp/0] frequency 5g
      Warning: Modifying the frequency band will delete the channel, power, and antenna gain configurations of the current radio in the AP
       group and reboot the AP. Continue?[Y/N]:y
      [AC-wlan-group-radio-mesh-mpp/0] channel 40mhz-plus 149
      Warning: This action may cause service interruption. Continue?[Y/N]y
      [AC-wlan-group-radio-mesh-mpp/0] mesh-whitelist-profile whitelist01
      [AC-wlan-group-radio-mesh-mpp/0] mesh-profile mesh-net
      [AC-wlan-group-radio-mesh-mpp/0] quit
      [AC-wlan-ap-group-mesh-mpp] radio 1
      [AC-wlan-group-radio-mesh-mpp/1] channel 40mhz-plus 157
      Warning: This action may cause service interruption. Continue?[Y/N]y
      [AC-wlan-group-radio-mesh-mpp/1] mesh-whitelist-profile whitelist01
      [AC-wlan-group-radio-mesh-mpp/1] mesh-profile mesh-net2
      [AC-wlan-group-radio-mesh-mpp/1] quit
      [AC-wlan-ap-group-mesh-mpp] quit
      [AC-wlan-view] quit
      [AC] quit

    10. Configure Switch_D.

      # Configure Switch_D to communicate with other devices.
      <HUAWEI> system-view
      [HUAWEI] sysname Switch_D
      [Switch_D] vlan batch 161
      [Switch_D] interface gigabitethernet 0/0/1
      [Switch_D-GigabitEthernet0/0/1] port trunk allow-pass vlan 161
      [Switch_D-GigabitEthernet0/0/1] port link-type trunk
      [Switch_D-GigabitEthernet0/0/1] quit
      [Switch_D] interface gigabitethernet 0/0/2
      [Switch_D-GigabitEthernet0/0/2] port link-type trunk
      [Switch_D-GigabitEthernet0/0/2] port trunk allow-pass vlan 161
      [Switch_D-GigabitEthernet0/0/2] quit
      [Switch_D] interface gigabitethernet 0/0/3
      [Switch_D-GigabitEthernet0/0/3] port link-type trunk
      [Switch_D-GigabitEthernet0/0/3] port trunk pvid vlan 161
      [Switch_D-GigabitEthernet0/0/3] port trunk allow-pass vlan 161
      [Switch_D-GigabitEthernet0/0/3] quit
      [Switch_D] interface gigabitethernet 0/0/4
      [Switch_D-GigabitEthernet0/0/4] port link-type trunk
      [Switch_D-GigabitEthernet0/0/4] port trunk pvid vlan 161
      [Switch_D-GigabitEthernet0/0/4] port trunk allow-pass vlan 161
      [Switch_D-GigabitEthernet0/0/4] quit
      

  • Configure vehicle-mounted network devices.

    NOTE:
    This example provides the detailed procedure for configuring the vehicle-mounted AP in the front of the train. The procedure for configuring the vehicle-mounted AP in the rear is similar. The configuration differences are described in the subsequent steps.

    1. Configure system parameters for the vehicle-mounted AP.

      # Configure the AP's country code.

      <Huawei> system-view
      <Huawei> sysname AP
      [AP] wlan
      [AP-wlan-view] country-code cn
      

    2. Configure vehicle-ground fast link handover parameters.

      # Create the Mesh whitelist whitelist01 and add MAC addresses of all trackside APs along the rail line to the Mesh whitelist.

      [AP-wlan-view] mesh-whitelist-profile name whitelist01
      [AP-wlan-mesh-whitelist-whitelist01] peer-ap mac 0046-4b59-1d10
      [AP-wlan-mesh-whitelist-whitelist01] peer-ap mac 0046-4b59-1d20
      [AP-wlan-mesh-whitelist-whitelist01] peer-ap mac 0046-4b59-1d30
      [AP-wlan-mesh-whitelist-whitelist01] peer-ap mac 0046-4b59-1d40
      [AP-wlan-mesh-whitelist-whitelist01] peer-ap mac 0046-4b59-1d50
      [AP-wlan-mesh-whitelist-whitelist01] peer-ap mac 0046-4b59-1d60
      [AP-wlan-mesh-whitelist-whitelist01] quit
      

      # Add MAC addresses of all trackside APs along the rail line to the Mesh whitelist of vehicle-mounted APs on the other trains according to the preceding configuration procedure.

      # Configure the security profile sp01 used by Mesh links. Set the security policy to WPA2+PSK+AES in the profile.

      [AP-wlan-view] security-profile name sp01
      [AP-wlan-sec-prof-sp01] security wpa2 psk pass-phrase a1234567 aes
      [AP-wlan-sec-prof-sp01] quit
      
      NOTE:

      The preceding configurations for the two vehicle-mounted APs are the same except the AP name. Name the vehicle-mounted AP in the rear AP2. Configurations for the two vehicle-mounted APs are different from this step.

      # On the vehicle-mounted AP (in the front), configure the Mesh handover profile hand-over, enable the location-based fast link handover algorithm, and set the moving direction of the vehicle-mounted AP to forward.

      [AP-wlan-view] mesh-handover-profile name hand-over
      [AP-wlan-mesh-handover-hand-over] location-based-algorithm enable moving-direction forward 
      [AP-wlan-mesh-handover-hand-over] quit
      

      # On the vehicle-mounted AP (in the rear), configure the Mesh handover profile hand-over, enable the location-based fast link handover algorithm, and set the moving direction of the vehicle-mounted AP to backward.

      [AP2-wlan-view] mesh-handover-profile name hand-over
      [AP2-wlan-mesh-handover-hand-over] location-based-algorithm enable moving-direction backward
      [AP2-wlan-mesh-handover-hand-over] quit
      

      # On the vehicle-mounted AP (in the front), configure the Mesh profile. Set the ID of the Mesh network to mesh-net, and bind the security profile and Mesh handover profile to the Mesh profile.

      [AP-wlan-view] mesh-profile name mesh-net
      [AP-wlan-mesh-prof-mesh-net] mesh-id mesh-net
      [AP-wlan-mesh-prof-mesh-net] security-profile sp01
      [AP-wlan-mesh-prof-mesh-net] mesh-handover-profile hand-over
      [AP-wlan-mesh-prof-mesh-net] quit
      [AP-wlan-view] quit
      

      # On the vehicle-mounted AP (in the rear), configure the Mesh profile. Set the ID of the Mesh network to mesh-net2, and bind the security profile and Mesh handover profile to the Mesh profile.

      [AP2-wlan-view] mesh-profile name mesh-net2
      [AP2-wlan-mesh-prof-mesh-net] mesh-id mesh-net2
      [AP2-wlan-mesh-prof-mesh-net] security-profile sp01
      [AP2-wlan-mesh-prof-mesh-net] mesh-handover-profile hand-over
      [AP2-wlan-mesh-prof-mesh-net] quit
      [AP2-wlan-view] quit
      

    3. Apply the Mesh parameters to radios of the vehicle-mounted APs.

      # Configure the radio and channel used by the vehicle-mounted AP (in the front), and bind the Mesh whitelist and Mesh profile.

      [AP] interface wlan-radio 0/0/1
      [AP-Wlan-Radio0/0/1] channel 40mhz-plus 149
      Warning: This action may cause service interruption. Continue?[Y/N]y
      [AP-Wlan-Radio0/0/1] mesh-whitelist-profile whitelist01
      [AP-Wlan-Radio0/0/1] mesh-profile mesh-net
      [AP-Wlan-Radio0/0/1] quit
      

      # Configure the radio and channel used by the vehicle-mounted AP (in the rear) and bind the Mesh whitelist and Mesh profile.

      [AP2] interface wlan-radio 0/0/1
      [AP2-Wlan-Radio0/0/1] channel 40mhz-plus 157 
      Warning: This action may cause service interruption. Continue?[Y/N]y
      [AP2-Wlan-Radio0/0/1] mesh-whitelist-profile whitelist01
      [AP2-Wlan-Radio0/0/1] mesh-profile mesh-net2
      [AP2-Wlan-Radio0/0/1] quit
      

    4. Add proxied devices on the vehicle-mounted APs.

      # Add proxied ground devices. Add MAC addresses of Switch_A on the vehicle-mounted APs.

      [AP] wlan
      [AP-wlan-view] mesh-proxy trackside-equip mac-address 707b-e8e9-d328 vlan 200
      

      # Add proxied vehicle-mounted devices. Add MAC addresses of the vehicle-mounted terminals on the vehicle-mounted APs.

      [AP-wlan-view] mesh-proxy onboard-equip mac-address 286e-d488-d359 vlan 161
      [AP-wlan-view] mesh-proxy onboard-equip mac-address 286e-d488-d270 vlan 161
      [AP-wlan-view] quit
      

      # Configure the vehicle-mounted AP (in the rear) in the same way.

    5. Configure VRRP and BFD on the vehicle-mounted AP in the front.

      # Create VLANs and configure IP addresses for the VLANIF interfaces.
      [AP] vlan batch 161 200
      [AP] interface gigabitethernet 0/0/0
      [AP-GigabitEthernet0/0/0] port link-type trunk
      [AP-GigabitEthernet0/0/0] port trunk allow-pass vlan 161 200
      [AP-GigabitEthernet0/0/0] quit
      [AP] dhcp enable
      [AP] interface vlanif 161
      [AP-Vlanif161] ip address 10.23.161.2 24
      [AP-Vlanif161] dhcp select interface
      [AP-Vlanif161] dhcp server excluded-ip-address 10.23.161.1 10.23.161.3
      [AP-Vlanif161] quit
      [AP] interface vlanif 200
      [AP-Vlanif200] ip address 10.23.200.3 24
      [AP-Vlanif200] quit
      
      # Configure VRRP.
      [AP] interface Vlanif 161
      [AP-Vlanif161] vrrp vrid 1 virtual-ip 10.23.161.1
      [AP-Vlanif161] admin-vrrp vrid 1
      [AP-Vlanif161] vrrp vrid 1 priority 120
      [AP-Vlanif161] quit
      [AP] interface Vlanif 200
      [AP-Vlanif200] vrrp vrid 2 virtual-ip 10.23.200.1
      [AP-Vlanif200] vrrp vrid 2 track admin-vrrp interface vlanif 161 vrid 1 unflowdown
      [AP-Vlanif200] vrrp vrid 2 priority 120
      [AP-Vlanif200] quit
      
      # Configure BFD.
      [AP] bfd
      [AP-bfd] quit
      [AP] bfd atob bind peer-ip 10.23.161.3 interface vlanif161
      [AP-bfd-session-atob] discriminator local 1
      [AP-bfd-session-atob] discriminator remote 2
      [AP-bfd-session-atob] min-rx-interval 50
      [AP-bfd-session-atob] min-tx-interval 50
      [AP-bfd-session-atob] commit
      [AP-bfd-session-atob] quit
      [AP] interface Vlanif 161
      [AP-Vlanif161] vrrp vrid 1 track bfd-session 1 reduced 50
      [AP-Vlanif161] quit
      
      # Configure an uplink route.
      [AP] ip route-static 0.0.0.0 0 10.23.200.2
      

    6. Configure VRRP and BFD on the vehicle-mounted AP in the rear.

      # Create VLANs and configure IP addresses for the VLANIF interfaces.
      [AP2] vlan batch 161 200
      [AP2] interface gigabitethernet 0/0/0
      [AP2-GigabitEthernet0/0/0] port link-type trunk
      [AP2-GigabitEthernet0/0/0] port trunk allow-pass vlan 161 200
      [AP2-GigabitEthernet0/0/0] quit
      [AP2] interface vlanif 161
      [AP2-Vlanif161] ip address 10.23.161.3 24
      [AP2-Vlanif161] dhcp select interface
      [AP2-Vlanif161] dhcp server excluded-ip-address 10.23.161.1 10.23.161.3
      [AP2-Vlanif161] quit
      [AP2] interface vlanif 200
      [AP2-Vlanif200] ip address 10.23.200.4 24
      [AP2-Vlanif200] quit
      
      # Configure VRRP.
      [AP2] interface Vlanif 161
      [AP2-Vlanif161] vrrp vrid 1 virtual-ip 10.23.161.1
      [AP2-Vlanif161] admin-vrrp vrid 1
      [AP2-Vlanif161] vrrp vrid 1 priority 110
      [AP2-Vlanif161] quit
      [AP2] interface Vlanif 200
      [AP2-Vlanif200] vrrp vrid 2 virtual-ip 10.23.200.1
      [AP2-Vlanif200] vrrp vrid 2 track admin-vrrp interface vlanif 161 vrid 1 unflowdown
      [AP2-Vlanif200] vrrp vrid 2 priority 110
      [AP2-Vlanif200] quit
      
      # Configure BFD.
      [AP2] bfd
      [AP2-bfd] quit
      [AP2] bfd btoa bind peer-ip 10.23.161.2 interface vlanif161
      [AP2-bfd-session-atob] discriminator local 2
      [AP2-bfd-session-atob] discriminator remote 1
      [AP2-bfd-session-atob] min-rx-interval 50
      [AP2-bfd-session-atob] min-tx-interval 50
      [AP2-bfd-session-atob] commit
      [AP2-bfd-session-atob] quit
      
      # Configure an uplink route.
      [AP] ip route-static 0.0.0.0 0 10.23.200.2
      

  • Verify the configuration.

    # After vehicle-ground fast link handover configuration is complete, run the display wlan mesh link all command on the AC to view Mesh links between trackside and vehicle-mounted APs.

    <AC> display wlan mesh link all
    Rf   : radio ID             Dis  : coverage distance(100m)                      
    Ch   : channel              Per  : drop percent(%)                              
    TSNR : total SNR(dB)        P-   : peer                                         
    Mesh : Mesh mode            Re   : retry ratio(%)                               
    RSSI : RSSI(dBm)            MaxR : max RSSI(dBm)                                
    --------------------------------------------------------------------------------
    -----------------                                                               
    APName  P-APName  Rf Dis   Ch   Mesh    P-Status        RSSI  MaxR  Per  Re   TS
    NR  SNR(Ch0~2:dB)
    --------------------------------------------------------------------------------
    -----------------                                                               
    L1_001            0  3     149  portal  -               -51   -38   0    0    47
       39/47/-
    L1_001            1  3     157  portal  -               -51   -38   0    0    47
       39/47/-
    L1_003            0  3     149  portal  -               -59   -7    0    0    50
       19/14/37
    L1_003            1  3     157  portal  -               -59   -7    0    0    50
       19/14/37
    L1_010            0  3     149  portal  -               -45   -33   0    0    37
       20/17/17
    L1_010            1  3     157  portal  -               -45   -33   0    0    37
       20/17/17
    L1_150            0  3     149  portal  -               -54   -39   0    0    46
       34/43/-
    L1_150            1  3     157  portal  -               -54   -39   0    0    46
       34/43/-
    L1_160            0  3     149  portal  -               -52   -7    0    0    32
       21/18/35
    L1_160            1  3     157  portal  -               -52   -7    0    0    32
       21/18/35
    L1_170            0  3     149  portal  -               -42   -33   0    0    29
       26/14/19
    L1_170            1  3     157  portal  -               -42   -33   0    0    29
       26/14/19
    --------------------------------------------------------------------------------
    -----------------                                                               
    Total: 12
    

    # Run the display mesh-neighbor-rssi command on the AC to view RSSI information about trackside APs.

    <AC> display mesh-neighbor-rssi
    Info: This operation may take a few seconds, please wait.done.   
    AP name/MAC/Radio/Location-ID  Neighbor AP/MAC/Location-ID  RSSI  Update Time   
    ------------------------------------------------------------------------------  
    L1_001/0046-4b59-1d10/0/1         -/0046-4b59-2e10/-           -44   18:08:21    
    L1_001/0046-4b59-1d10/1/1         -/0046-4b59-2e20/-           -44   18:08:21    
    L1_003/0046-4b59-1d20/0/3         -/0046-4b59-2e10/-           -50   18:08:20    
    L1_003/0046-4b59-1d20/1/3         -/0046-4b59-2e20/-           -50   18:08:20    
    L1_010/0046-4b59-1d30/0/10        -/0046-4b59-2e10/-           -28   18:08:21    
    L1_010/0046-4b59-1d30/1/10        -/0046-4b59-2e20/-           -28   18:08:21    
    L1_150/0046-4b59-1d40/0/150       -/0046-4b59-2e10/-           -43   18:08:20    
    L1_150/0046-4b59-1d40/1/150       -/0046-4b59-2e20/-           -43   18:08:20    
    L1_160/0046-4b59-1d50/0/160       -/0046-4b59-2e10/-           -47   18:08:21    
    L1_160/0046-4b59-1d50/1/160       -/0046-4b59-2e20/-           -47   18:08:21    
    L1_170/0046-4b59-1d6s0/0/170      -/0046-4b59-2e10/-           -38   18:08:21    
    L1_170/0046-4b59-1d6s0/1/170      -/0046-4b59-2e20/-           -38   18:08:21    
    ------------------------------------------------------------------------------  
    Total: 6

    # Run the display mesh-handover-trace command on the vehicle-mounted AP to view roaming traces of the vehicle-mounted AP.

    <AP> display mesh-handover-trace
      Info: This operation may take a few seconds, please wait.done.   
      Index  Timestamp  From AP MAC/RSSI/Location-ID   To AP MAC/RSSI/Location-ID
      ------------------------------------------------------------------------------
      1      18:52:27   0046-4b59-1d50/-95/160         0046-4b59-1d60/-15/170
      2      18:50:46   0046-4b59-1d40/-95/150         0046-4b59-1d50/-34/160
      3      18:49:25   0046-4b59-1d30/-95/10          0046-4b59-1d40/-11/150
      4      18:48:56   0046-4b59-1d20/-95/3           0046-4b59-1d30/-40/10
      5      18:47:39   0046-4b59-1d10/-47/1           0046-4b59-1d20/-36/3
      ------------------------------------------------------------------------------
    # Check information about BFD sessions.
    <AP> display bfd session all
    --------------------------------------------------------------------------------
    Local Remote     PeerIpAddr      State     Type         InterfaceName
    --------------------------------------------------------------------------------
    1     2          10.23.161.3     Up        S_IP_IF      Vlanif161               
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 1/0

Configuration Files
  • Ground network devices

    • Switch_A configuration file

      #
      sysname Switch_A
      #
       vlan batch 100 200
      #
      interface Vlanif200
       ip address 10.23.200.2 255.255.255.0
      #
      interface GigabitEthernet0/0/1
       port link-type trunk
       port trunk allow-pass vlan 100 200
      #
      interface GigabitEthernet0/0/2
       port link-type trunk
       port trunk allow-pass vlan 100 200
      #
      interface GigabitEthernet0/0/3
       port link-type trunk
       port trunk allow-pass vlan 100
      #
      ip route-static 10.23.161.0 255.255.255.0 10.23.200.1
      #
      return
      
    • Switch_B configuration file

      #
      sysname Switch_B
      #
       vlan batch 100 200
      #
      interface GigabitEthernet0/0/1
       port link-type trunk
       port trunk pvid vlan 100
       port trunk allow-pass vlan 100 200
      #
      interface GigabitEthernet0/0/2
       port link-type trunk
       port trunk allow-pass vlan 100 200
      #
      interface GigabitEthernet0/0/3
       port link-type trunk
       port trunk pvid vlan 100
       port trunk allow-pass vlan 100 200
      #
      interface GigabitEthernet0/0/4
       port link-type trunk
       port trunk pvid vlan 100
       port trunk allow-pass vlan 100 200
      #
      return
      
    • Switch_C configuration file

      #
      sysname Switch_C
      #
       vlan batch 100 200
      #
      interface GigabitEthernet0/0/1
       port link-type trunk
       port trunk pvid vlan 100
       port trunk allow-pass vlan 100 200
      #
      interface GigabitEthernet0/0/2
       port link-type trunk
       port trunk allow-pass vlan 100 200
      #
      interface GigabitEthernet0/0/3
       port link-type trunk
       port trunk pvid vlan 100
       port trunk allow-pass vlan 100 200
      #
      interface GigabitEthernet0/0/4
       port link-type trunk
       port trunk pvid vlan 100
       port trunk allow-pass vlan 100 200
      #
      return
      
    • Switch_D configuration file

      #
      sysname Switch_D
      #
      vlan batch 161
      #
      interface GigabitEthernet0/0/1
       port link-type trunk
       port trunk allow-pass vlan 161
      #
      interface GigabitEthernet0/0/2
       port link-type trunk
       port trunk allow-pass vlan 161
      #
      interface GigabitEthernet0/0/3
       port link-type trunk
       port trunk pvid vlan 161
       port trunk allow-pass vlan 161
      #
      interface GigabitEthernet0/0/4
       port link-type trunk
       port trunk pvid vlan 161
       port trunk allow-pass vlan 161
      #
      return
      
    • AC configuration file

      #
       sysname AC
       #
      vlan batch 100 200
      #
      dhcp enable
      #
      interface Vlanif100
       ip address 10.23.100.1 255.255.255.0
       dhcp select interface
      #
      interface GigabitEthernet0/0/1
       port link-type trunk
       port trunk allow-pass vlan 100
      #
      capwap source interface vlanif100
      #
      wlan
       security-profile name sp01
        security wpa2 psk pass-phrase %^%#yUrI$*AU}-T<aI*$21X8,wdZ>"Q%NVibT@S@ITs<%^%# aes 
       mesh-handover-profile name hand-over 
        location-based-algorithm enable 
       mesh-whitelist-profile name whitelist01
        peer-ap mac 0046-4b59-2e10
        peer-ap mac 0046-4b59-2e20
       mesh-profile name mesh-net
        mesh-handover-profile hand-over
        security-profile sp01
        mesh-id mesh-net
       mesh-profile name mesh-net2
        mesh-handover-profile hand-over
        security-profile sp01
        mesh-id mesh-net2
       regulatory-domain-profile name default
       ap-system-profile name mesh-sys
        mesh-role Mesh-portal
       wired-port-profile name wired-port
        vlan tagged 200
       ap-group name mesh-mpp
        ap-system-profile mesh-sys
        wired-port-profile wired-port gigabitethernet 0
        radio 0
         mesh-profile mesh-net
         mesh-whitelist-profile whitelist01
         frequency 5g 
         channel 40mhz-plus 149
        radio 1
         mesh-profile mesh-net2
         mesh-whitelist-profile whitelist01
         channel 40mhz-plus 157
       ap-id 1 type-id 48 ap-mac 0046-4b59-1d10 ap-sn 210235554710CB000042
        ap-name L1_001
        ap-group mesh-mpp
       ap-id 2 type-id 48 ap-mac 0046-4b59-1d20 ap-sn 210235555310CC000094
        ap-name L1_003
        ap-group mesh-mpp
       ap-id 3 type-id 48 ap-mac 0046-4b59-1d30 ap-sn 210235419610CB002287
        ap-name L1_010
        ap-group mesh-mpp
       ap-id 101 type-id 48 ap-mac 0046-4b59-1d40 ap-sn 210235555310CC00AC69
        ap-name L1_150
        ap-group mesh-mpp
       ap-id 102 type-id 48 ap-mac 0046-4b59-1d50 ap-sn 210235555310CC003587
        ap-name L1_160
        ap-group mesh-mpp
       ap-id 103 type-id 48 ap-mac 0046-4b59-1d60 ap-sn 210235449210CB000011
        ap-name L1_170
        ap-group mesh-mpp#
      return
      
  • Vehicle-mounted network devices

    • Vehicle-mounted AP (in the front) configuration file

      #
       sysname AP
      #
      vlan batch 161 200
      #
      dhcp enable
      #
      interface Vlanif161
       ip address 10.23.161.2 255.255.255.0
       vrrp vrid 1 virtual-ip 10.23.161.1
       admin-vrrp vrid 1
       vrrp vrid 1 priority 120
       vrrp vrid 1 track bfd-session 1 reduced 50
       dhcp select interface
       dhcp server excluded-ip-address 10.23.161.1 10.23.161.3
      #
      interface Vlanif200
       ip address 10.23.200.3 255.255.255.0
       vrrp vrid 2 virtual-ip 10.23.200.1
       vrrp vrid 2 priority 120
       vrrp vrid 2 track admin-vrrp interface Vlanif161 vrid 1 unflowdown
      #
      interface GigabitEthernet0/0/0
       port link-type trunk
       port trunk allow-pass vlan 161 200
      #
      bfd atob bind peer-ip 10.23.161.3 interface Vlanif161
       discriminator local 1
       discriminator remote 2
       min-tx-interval 50
       min-rx-interval 50
       commit
      #
      ip route-static 0.0.0.0 0.0.0.0 10.23.200.2
      #
      wlan
       security-profile name sp01
        security wpa2 psk pass-phrase %^%#yUrI$*AU}-T<aI*$21X8,wdZ>"Q%NVibT@S@ITs<%^%# aes 
       mesh-handover-profile name hand-over
        location-based-algorithm enable moving-direction forward
       mesh-whitelist-profile name whitelist01
        peer-ap mac 0046-4b59-1d10
        peer-ap mac 0046-4b59-1d20
        peer-ap mac 0046-4b59-1d30
        peer-ap mac 0046-4b59-1d40
        peer-ap mac 0046-4b59-1d50
        peer-ap mac 0046-4b59-1d60
       mesh-proxy trackside-equip mac-address 707b-e8e9-d328 vlan 200
       mesh-proxy onboard-equip mac-address 286e-d488-d359 vlan 161
       mesh-proxy onboard-equip mac-address 286e-d488-d270 vlan 161
       mesh-profile name mesh-net
        mesh-handover-profile hand-over
        security-profile sp01 
        mesh-id mesh-net
      #
      interface Wlan-Radio0/0/1
       mesh-profile mesh-net
       mesh-whitelist-profile whitelist01 
       channel 40mhz-plus 149  
      #
      return
      
    • Vehicle-mounted AP (in the rear) configuration file

      #
       sysname AP2
      #
      vlan batch 161 200
      #
      dhcp enable
      #
      interface Vlanif161
       ip address 10.23.161.3 255.255.255.0
       vrrp vrid 1 virtual-ip 10.23.161.1
       admin-vrrp vrid 1
       vrrp vrid 1 priority 110
       dhcp select interface
       dhcp server excluded-ip-address 10.23.161.1 10.23.161.3
      #
      interface Vlanif200
       ip address 10.23.200.4 255.255.255.0
       vrrp vrid 2 virtual-ip 10.23.200.1
       vrrp vrid 2 priority 110
       vrrp vrid 2 track admin-vrrp interface Vlanif161 vrid 1 unflowdown
      #
      interface GigabitEthernet0/0/0
       port link-type trunk
       port trunk allow-pass vlan 161 200
      #
      bfd btoa bind peer-ip 10.23.161.2 interface Vlanif161
       discriminator local 2
       discriminator remote 1
       min-tx-interval 50
       min-rx-interval 50
       commit
      #
      ip route-static 0.0.0.0 0.0.0.0 10.23.200.2
      #
      wlan
       security-profile name sp01
        security wpa2 psk pass-phrase %^%#yUrI$*AU}-T<aI*$21X8,wdZ>"Q%NVibT@S@ITs<%^%# aes 
       mesh-handover-profile name hand-over
        location-based-algorithm enable moving-direction backward
       mesh-whitelist-profile name whitelist01
        peer-ap mac 0046-4b59-1d10
        peer-ap mac 0046-4b59-1d20
        peer-ap mac 0046-4b59-1d30
        peer-ap mac 0046-4b59-1d40
        peer-ap mac 0046-4b59-1d50
        peer-ap mac 0046-4b59-1d60
       mesh-proxy trackside-equip mac-address 707b-e8e9-d328 vlan 200
       mesh-proxy onboard-equip mac-address 286e-d488-d359 vlan 161
       mesh-proxy onboard-equip mac-address 286e-d488-d270 vlan 161
       mesh-profile name mesh-net2
        mesh-handover-profile hand-over
        security-profile sp01 
        mesh-id mesh-net2
      #
      interface Wlan-Radio0/0/1
       mesh-profile mesh-net2
       mesh-whitelist-profile whitelist01 
       channel 40mhz-plus 157  
      #
      return
      
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 130278

Downloads: 312

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next