No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Band Steering

Example for Configuring Band Steering

Networking Requirements

An enterprise branch needs to deploy WLAN services for mobile office so that branch users can access the enterprise internal network anywhere and anytime. A Fat AP is connected to the Internet in wired mode and connects to STAs in wireless mode. To improve user experience and reduce burden on the 2.4 GHz frequency band, the enterprise requires that STAs preferentially connect to the 5 GHz frequency band.
Figure 11-9  Networking diagram for configuring band steering

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the AP and upper-layer network devices to communicate at Layer 2.
  2. Configure the AP as a DHCP server to assign IP addresses to STAs from an IP address pool of an interface.
  3. Configure AP system parameters, including the country code.
  4. Configure a VAP so that STAs can access the WLAN.
  5. Configure the band steering function and proper band steering parameters so that STAs can preferentially access the 5 GHz frequency band.
NOTE:

Configuration Notes

No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression on switch interfaces connected to APs to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected. For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.

Procedure

  1. Configure the AP to communicate with the upstream device.

    NOTE:

    Configure AP uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add AP uplink interface GE0/0/1 to VLAN 101.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan batch 101
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 101
    [AP-GigabitEthernet0/0/1] quit
    

  2. Configure the AP as a DHCP server to allocate IP addresses to STAs.

    # Configure the AP as the DHCP server to allocate an IP address to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AP] dhcp enable
    [AP] interface vlanif 101
    [AP-Vlanif101] ip address 10.23.101.1 24
    [AP-Vlanif101] dhcp select interface
    [AP-Vlanif101] quit
    

  3. Configure AP system parameters.

    # Configure the country code.

    [AP] wlan
    [AP-wlan-view] country-code cn
    

  4. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AP-wlan-view] security-profile name wlan-security
    [AP-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AP-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AP-wlan-view] ssid-profile name wlan-ssid
    [AP-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AP-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profile wlan-vap, set the service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AP-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AP-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AP-wlan-vap-prof-wlan-vap] quit
    

  5. Configure a VAP and set channels and power for the AP radios.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The channel and power configuration for the AP radios in this example is for reference only. In actual scenarios, configure channels and power for AP radios based on country codes of APs and network planning results.

    # Disable automatic channel and power calibration functions of the radio, and configure the channel and power for the radio.
    [AP-wlan-view] quit
    [AP] interface wlan-radio0/0/0
    [AP-Wlan-Radio0/0/0] vap-profile wlan-vap wlan 2
    [AP-Wlan-Radio0/0/0] calibrate auto-channel-select disable
    [AP-Wlan-Radio0/0/0] calibrate auto-txpower-select disable
    [AP-Wlan-Radio0/0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-Wlan-Radio0/0/0] eirp 127
    [AP-Wlan-Radio0/0/0] quit
    

  6. Configure the band steering function.

    # Enable the band steering function in the VAP profile wlan-vap. By default, the band steering function is enabled.
    NOTE:

    When band steering is enabled on one radio of an AP, the function takes effect on the SSID of the AP. If different VAP profiles are applied to two radios of the AP, you only need to enable the band steering function in the VAP profile of one radio.

    [AP] wlan
    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] undo band-steer disable 
    [AP-wlan-vap-prof-wlan-vap] quit
    

    # Configure load balancing between radios in the profile to prevent heavy load on a single radio. Set the start threshold for load balancing between radios to 15 and the load difference threshold to 25%.

    [AP-wlan-view] rrm-profile name default
    [AP-wlan-rrm-prof-default] band-steer balance start-threshold 15 
    [AP-wlan-rrm-prof-default] band-steer balance gap-threshold 25
    [AP-wlan-rrm-prof-default] quit

  7. Verify the configuration.

    • The configuration automatically takes effect after it is completed. Run the display vap ssid wlan-net command. If Status in the command output is displayed as ON, the VAP has been successfully created on the AP radios.

      [AP] display vap ssid wlan-net
      WID : WLAN ID
      --------------------------------------------------------------------------------
      AP MAC         RfID WID   BSSID          Status  Auth type  STA    SSID
      --------------------------------------------------------------------------------
      00bc-da3f-e900 0    2     00BC-DA3F-E901 ON      WPA2-PSK   0      wlan-net
      -------------------------------------------------------------------------------
      Total: 1
    • Connect STAs to the WLAN with SSID wlan-net and enter the password a1234567. Run the display station all command on the AP. The command output shows that the STAs are connected to the WLAN wlan-net.

      [AP] display station all
      Rf/WLAN: Radio ID/WLAN ID
      Rx/Tx: link receive rate/link transmit rate(Mbps)
      ------------------------------------------------------------------------------
      STA MAC          Ap name        Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address    SSID
      ------------------------------------------------------------------------------
      14cf-9202-13dc   00bc-da3f-e900 0/2      2.4G  11n   19/13      -63   101   10.23.101.254 wlan-net
      ------------------------------------------------------------------------------
      Total: 1 2.4G: 1 5G: 0
    • Run the display vap-profile name wlan-vap command on the AP. The command output shows that the band steering function is enabled in the VAP profile.

      [AP] display vap-profile name wlan-vap
      --------------------------------------------------------------------------------
      ...
      Band steer                       : enable
      ...
      --------------------------------------------------------------------------------
    • Run the display rrm-profile name default command on the AP to check the band steering configuration.

      [AP] display rrm-profile name default
      ------------------------------------------------------------
      ...
      Band steer deny threshold                              : 2
      Band balance start threshold                           : 15
      Band balance gap threshold(%)                          : 25
      ...
      ------------------------------------------------------------   
    • Most STAs in the enterprise branch connect to the 5 GHz frequency band, and users enjoy good service experience.

Configuration Files

  • AP configuration file

    #
     sysname AP
    #
    vlan batch 101
    #
    dhcp enable
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    wlan
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#(yk#Q+M[\CMK]1)AWMX7MjZ)=e`fy@fA+.J\ht3Y%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
     rrm-profile name default
      band-steer balance start-threshold 15
      band-steer balance gap-threshold 25
    #
    inteface Wlan-Radio0/0/0
     vap-profile wlan-vap wlan 2
    #
    return
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 118871

Downloads: 309

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next